oxidized 0.30.1 → 0.31.0
Sign up to get free protection for your applications and to get access to all the features.
- checksums.yaml +4 -4
- data/.github/workflows/ruby.yml +2 -2
- data/.github/workflows/stale.yml +4 -2
- data/.rubocop.yml +18 -2
- data/.rubocop_todo.yml +5 -12
- data/CHANGELOG.md +61 -1
- data/CONTRIBUTING.md +5 -0
- data/Dockerfile +82 -21
- data/README.md +5 -21
- data/Rakefile +3 -2
- data/docs/Configuration.md +36 -12
- data/docs/Creating-Models.md +45 -4
- data/docs/Hooks.md +34 -0
- data/docs/Issues.md +91 -0
- data/docs/Model-Notes/Cumulus.md +5 -0
- data/docs/Model-Notes/FSOS.md +5 -0
- data/docs/Model-Notes/FortiOS.md +21 -5
- data/docs/Model-Notes/HPEAruba.md +31 -0
- data/docs/Model-Notes/OS6.md +10 -0
- data/docs/Model-Notes/RouterOS.md +15 -0
- data/docs/Model-Notes/SikluMHTG.md +7 -0
- data/docs/Outputs.md +2 -0
- data/docs/Release.md +18 -15
- data/docs/Sources.md +21 -0
- data/docs/Supported-OS-Types.md +11 -5
- data/docs/Troubleshooting.md +35 -0
- data/examples/device-simulation/README.md +173 -0
- data/examples/device-simulation/cmdsets/aoscx +9 -0
- data/examples/device-simulation/cmdsets/arubainstant +5 -0
- data/examples/device-simulation/cmdsets/asa +7 -0
- data/examples/device-simulation/cmdsets/ios +7 -0
- data/examples/device-simulation/cmdsets/nxos +5 -0
- data/examples/device-simulation/cmdsets/routeros +5 -0
- data/examples/device-simulation/cmdsets/srosmd +11 -0
- data/examples/device-simulation/device2yaml.rb +225 -0
- data/examples/device-simulation/yaml/aoscx_R0X25A-6410_FL.10.10.1100.yaml +2281 -0
- data/examples/device-simulation/yaml/aoscx_R8N85A-C6000-48G-CL4_PL.10.08.1010.yaml +451 -0
- data/examples/device-simulation/yaml/arubainstant_IAP515_8.10.0.6_VWLC.yaml +213 -0
- data/examples/device-simulation/yaml/asa_5512_9.12-4-67_single-context.yaml +531 -0
- data/examples/device-simulation/yaml/asr920_16.8.1b.yaml +1122 -0
- data/examples/device-simulation/yaml/garderos_R7709_003_006_068.yaml +101 -0
- data/examples/device-simulation/yaml/iosxe_C9200L-24P-4G_17.09.04a.yaml +514 -0
- data/examples/device-simulation/yaml/iosxe_C9800-L-F-K9_17.06.05.yaml +417 -0
- data/examples/device-simulation/yaml/riverbed_915.yaml +123 -0
- data/examples/device-simulation/yaml/routeros_CHR_7.10.1.yaml +145 -0
- data/examples/device-simulation/yaml/routeros_CHR_7.16.yaml +79 -0
- data/examples/device-simulation/yaml/routeros_L009UiGS_7.15.2.yaml +353 -0
- data/examples/podman-compose/Makefile +60 -17
- data/examples/podman-compose/README.md +63 -27
- data/examples/podman-compose/docker-compose.yml +11 -2
- data/examples/podman-compose/gitserver/.gitignore +1 -0
- data/examples/podman-compose/gitserver/Dockerfile +14 -0
- data/examples/podman-compose/model-simulation/Dockerfile-model +1 -1
- data/examples/podman-compose/model-simulation/asternos.sh +2 -0
- data/examples/podman-compose/oxidized-config/.gitignore +2 -0
- data/examples/podman-compose/oxidized-config/config +1 -1
- data/examples/podman-compose/oxidized-config/config_csv-file +46 -0
- data/examples/podman-compose/oxidized-config/config_csv-gitserver +56 -0
- data/examples/podman-compose/oxidized-ssh/.gitignore +1 -0
- data/lib/oxidized/config.rb +7 -1
- data/lib/oxidized/hook/githubrepo.rb +37 -7
- data/lib/oxidized/hook/slackdiff.rb +29 -7
- data/lib/oxidized/input/http.rb +1 -0
- data/lib/oxidized/input/telnet.rb +1 -1
- data/lib/oxidized/manager.rb +17 -16
- data/lib/oxidized/model/aoscx.rb +16 -2
- data/lib/oxidized/model/aosw.rb +7 -1
- data/lib/oxidized/model/arubainstant.rb +90 -0
- data/lib/oxidized/model/audiocodes.rb +2 -2
- data/lib/oxidized/model/cnos.rb +13 -10
- data/lib/oxidized/model/cumulus.rb +3 -0
- data/lib/oxidized/model/dlink.rb +1 -0
- data/lib/oxidized/model/dlinknextgen.rb +3 -0
- data/lib/oxidized/model/edgecos.rb +2 -1
- data/lib/oxidized/model/eos.rb +2 -0
- data/lib/oxidized/model/f5os.rb +17 -0
- data/lib/oxidized/model/firewareos.rb +10 -1
- data/lib/oxidized/model/fortios.rb +24 -1
- data/lib/oxidized/model/garderos.rb +43 -0
- data/lib/oxidized/model/h3c.rb +1 -1
- data/lib/oxidized/model/ibos.rb +1 -0
- data/lib/oxidized/model/ios.rb +20 -12
- data/lib/oxidized/model/iosxr.rb +1 -1
- data/lib/oxidized/model/lenovonos.rb +2 -0
- data/lib/oxidized/model/linuxgeneric.rb +1 -1
- data/lib/oxidized/model/netgear.rb +1 -1
- data/lib/oxidized/model/nodegrid.rb +1 -1
- data/lib/oxidized/model/nsxdfw.rb +30 -0
- data/lib/oxidized/model/nxos.rb +2 -1
- data/lib/oxidized/model/os6.rb +48 -0
- data/lib/oxidized/model/rgos.rb +1 -1
- data/lib/oxidized/model/riverbed.rb +104 -0
- data/lib/oxidized/model/routeros.rb +2 -2
- data/lib/oxidized/model/saos.rb +18 -1
- data/lib/oxidized/model/siklumhtg.rb +22 -0
- data/lib/oxidized/model/uplinkolt.rb +46 -0
- data/lib/oxidized/model/vyatta.rb +2 -2
- data/lib/oxidized/model/xos.rb +7 -0
- data/lib/oxidized/node.rb +30 -18
- data/lib/oxidized/nodes.rb +13 -5
- data/lib/oxidized/output/file.rb +45 -42
- data/lib/oxidized/output/git.rb +185 -160
- data/lib/oxidized/output/gitcrypt.rb +188 -186
- data/lib/oxidized/output/http.rb +53 -51
- data/lib/oxidized/output/output.rb +6 -4
- data/lib/oxidized/source/csv.rb +44 -49
- data/lib/oxidized/source/http.rb +63 -81
- data/lib/oxidized/source/jsonfile.rb +63 -0
- data/lib/oxidized/source/source.rb +43 -18
- data/lib/oxidized/source/sql.rb +66 -59
- data/lib/oxidized/version.rb +2 -2
- data/oxidized.gemspec +22 -16
- metadata +111 -15
@@ -0,0 +1,101 @@
|
|
1
|
+
---
|
2
|
+
# Trailing white spaces are coded as \x20 because some editors automatically remove trailing white spaces
|
3
|
+
init_prompt: |-
|
4
|
+
\e[4m\rLAB-R1234_Garderos#\e[m\x20
|
5
|
+
commands:
|
6
|
+
show system version: |-
|
7
|
+
show system version
|
8
|
+
grs-gwuz-armel/003_005_068 (Garderos; 2021-04-30 16:19:35)
|
9
|
+
\e[4m\rLAB-R1234_Garderos#\e[m\x20
|
10
|
+
show system serial: |-
|
11
|
+
show system serial
|
12
|
+
Serial : R77079012345
|
13
|
+
Hardware: Model R-7700, Board GWUZ, Ethernet
|
14
|
+
\e[4m\rLAB-R1234_Garderos#\e[m\x20
|
15
|
+
show hardware wwan wwan0 sim: |-
|
16
|
+
show hardware wwan wwan0 sim
|
17
|
+
Unknown command 'wwan'.
|
18
|
+
\e[4m\rLAB-R1234_Garderos#\e[m\x20
|
19
|
+
# This is a not working configuration - but it shows everything we need to make unit tests
|
20
|
+
show configuration running: |-
|
21
|
+
show configuration running
|
22
|
+
acl.ipv4.input.1.action=ACCEPT
|
23
|
+
acl.ipv4.input.1.description=allow ssh from management
|
24
|
+
acl.ipv4.input.1.dest-ports=22
|
25
|
+
acl.ipv4.input.1.protocol=tcp
|
26
|
+
acl.ipv4.input.1.source-network=10.42.0.0/24
|
27
|
+
acl.ipv4.input.999.action=DROP
|
28
|
+
hardware.rs-232.1.enable=true
|
29
|
+
hardware.rs-232.1.name=ttyS0
|
30
|
+
interface.eth.1.description=WAN
|
31
|
+
interface.eth.1.ip-assignment=static
|
32
|
+
interface.eth.1.ipv4=10.42.101.5/24
|
33
|
+
interface.eth.1.name=eth1
|
34
|
+
route.ipv4.1.gateway=10.42.101.1
|
35
|
+
route.ipv4.1.network=10.0.0.0/8
|
36
|
+
service.console.0.authenticate.0.client-ref=TACACS-1
|
37
|
+
service.console.0.authenticate.0.type=tacacs+
|
38
|
+
service.console.0.authenticate.1.client-ref=TACACS-2
|
39
|
+
service.console.0.authenticate.1.type=tacacs+
|
40
|
+
service.console.0.authenticate.2.type=local
|
41
|
+
service.console.0.hardware-ref=ttyS0
|
42
|
+
service.snmp.query-agent.enable=true
|
43
|
+
service.snmp.query-agent.server.0.community.0.name=SECRET
|
44
|
+
service.tacacs.client.0.name=TACACS-1
|
45
|
+
service.tacacs.client.0.server.1.key={enc2}AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDD
|
46
|
+
service.tacacs.client.0.server.1.name=10.42.0.42
|
47
|
+
service.tacacs.client.1.name=TACACS-2
|
48
|
+
service.tacacs.client.1.server.1.key={enc2}AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDD
|
49
|
+
service.tacacs.client.1.server.1.name=10.42.0.43
|
50
|
+
system.name=LAB-R1234_Garderos
|
51
|
+
system.secret={enc2}AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDDDDDDDD
|
52
|
+
system.timezone=Europe/Berlin
|
53
|
+
tunnel.ipsec.2.auth.psk.psk={enc2}AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDD
|
54
|
+
user.account.0.level=15
|
55
|
+
user.account.0.name=oxidized
|
56
|
+
user.account.0.password={sha256}AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDDDDDDDD
|
57
|
+
user.enable.0.password={sha256}AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDDDDDDDD
|
58
|
+
\e[4m\rLAB-R1234_Garderos#\e[m\x20
|
59
|
+
exit: ""
|
60
|
+
oxidized_output: |-
|
61
|
+
# grs-gwuz-armel/003_005_068 (Garderos; 2021-04-30 16:19:35)
|
62
|
+
#\x20
|
63
|
+
# Serial : R77079012345
|
64
|
+
# Hardware: Model R-7700, Board GWUZ, Ethernet
|
65
|
+
#\x20
|
66
|
+
acl.ipv4.input.1.action=ACCEPT
|
67
|
+
acl.ipv4.input.1.description=allow ssh from management
|
68
|
+
acl.ipv4.input.1.dest-ports=22
|
69
|
+
acl.ipv4.input.1.protocol=tcp
|
70
|
+
acl.ipv4.input.1.source-network=10.42.0.0/24
|
71
|
+
acl.ipv4.input.999.action=DROP
|
72
|
+
hardware.rs-232.1.enable=true
|
73
|
+
hardware.rs-232.1.name=ttyS0
|
74
|
+
interface.eth.1.description=WAN
|
75
|
+
interface.eth.1.ip-assignment=static
|
76
|
+
interface.eth.1.ipv4=10.42.101.5/24
|
77
|
+
interface.eth.1.name=eth1
|
78
|
+
route.ipv4.1.gateway=10.42.101.1
|
79
|
+
route.ipv4.1.network=10.0.0.0/8
|
80
|
+
service.console.0.authenticate.0.client-ref=TACACS-1
|
81
|
+
service.console.0.authenticate.0.type=tacacs+
|
82
|
+
service.console.0.authenticate.1.client-ref=TACACS-2
|
83
|
+
service.console.0.authenticate.1.type=tacacs+
|
84
|
+
service.console.0.authenticate.2.type=local
|
85
|
+
service.console.0.hardware-ref=ttyS0
|
86
|
+
service.snmp.query-agent.enable=true
|
87
|
+
service.snmp.query-agent.server.0.community.0.name=SECRET
|
88
|
+
service.tacacs.client.0.name=TACACS-1
|
89
|
+
service.tacacs.client.0.server.1.key={enc2}AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDD
|
90
|
+
service.tacacs.client.0.server.1.name=10.42.0.42
|
91
|
+
service.tacacs.client.1.name=TACACS-2
|
92
|
+
service.tacacs.client.1.server.1.key={enc2}AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDD
|
93
|
+
service.tacacs.client.1.server.1.name=10.42.0.43
|
94
|
+
system.name=LAB-R1234_Garderos
|
95
|
+
system.secret={enc2}AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDDDDDDDD
|
96
|
+
system.timezone=Europe/Berlin
|
97
|
+
tunnel.ipsec.2.auth.psk.psk={enc2}AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDD
|
98
|
+
user.account.0.level=15
|
99
|
+
user.account.0.name=oxidized
|
100
|
+
user.account.0.password={sha256}AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDDDDDDDD
|
101
|
+
user.enable.0.password={sha256}AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDDDDDDDD\n
|
@@ -0,0 +1,514 @@
|
|
1
|
+
---
|
2
|
+
init_prompt: |-
|
3
|
+
|
4
|
+
### EXAMPLE IOS-XE 17.09.04a config on a C9200L-24P-4G ###
|
5
|
+
Retrieved 2024-09-09 by @robertcheramy
|
6
|
+
### ###
|
7
|
+
LAB-SW123_9200L#
|
8
|
+
commands:
|
9
|
+
terminal length 0: |-
|
10
|
+
terminal length 0
|
11
|
+
LAB-SW123_9200L#
|
12
|
+
terminal width 0: |-
|
13
|
+
terminal width 0
|
14
|
+
LAB-SW123_9200L#
|
15
|
+
show version: |-
|
16
|
+
show version
|
17
|
+
Cisco IOS XE Software, Version 17.09.04a
|
18
|
+
Cisco IOS Software [Cupertino], Catalyst L3 Switch Software (CAT9K_LITE_IOSXE), Version 17.9.4a, RELEASE SOFTWARE (fc3)
|
19
|
+
Technical Support: http://www.cisco.com/techsupport
|
20
|
+
Copyright (c) 1986-2023 by Cisco Systems, Inc.
|
21
|
+
Compiled Fri 20-Oct-23 10:33 by mcpre
|
22
|
+
|
23
|
+
|
24
|
+
Cisco IOS-XE software, Copyright (c) 2005-2023 by cisco Systems, Inc.
|
25
|
+
All rights reserved. Certain components of Cisco IOS-XE software are
|
26
|
+
licensed under the GNU General Public License (\"GPL\") Version 2.0. The
|
27
|
+
software code licensed under GPL Version 2.0 is free software that comes
|
28
|
+
with ABSOLUTELY NO WARRANTY. You can redistribute and/or modify such
|
29
|
+
GPL code under the terms of GPL Version 2.0. For more details, see the
|
30
|
+
documentation or \"License Notice\" file accompanying the IOS-XE software,
|
31
|
+
or the applicable URL provided on the flyer accompanying the IOS-XE
|
32
|
+
software.
|
33
|
+
|
34
|
+
|
35
|
+
ROM: IOS-XE ROMMON
|
36
|
+
BOOTLDR: System Bootstrap, Version 17.9.1r [FC13], RELEASE SOFTWARE (P)\x20
|
37
|
+
|
38
|
+
LAB-SW123_9200L uptime is 44 weeks, 4 days, 1 hour, 16 minutes
|
39
|
+
Uptime for this control processor is 44 weeks, 4 days, 1 hour, 17 minutes
|
40
|
+
System returned to ROM by Reload Command at 11:29:34 CET Thu Nov 2 2023
|
41
|
+
System restarted at 11:41:27 CET Thu Nov 2 2023
|
42
|
+
System image file is \"flash:cat9k_lite_iosxe.17.09.04a.SPA.bin\"
|
43
|
+
Last reload reason: Reload Command
|
44
|
+
|
45
|
+
|
46
|
+
|
47
|
+
This product contains cryptographic features and is subject to United
|
48
|
+
States and local country laws governing import, export, transfer and
|
49
|
+
use. Delivery of Cisco cryptographic products does not imply
|
50
|
+
third-party authority to import, export, distribute or use encryption.
|
51
|
+
Importers, exporters, distributors and users are responsible for
|
52
|
+
compliance with U.S. and local country laws. By using this product you
|
53
|
+
agree to comply with applicable laws and regulations. If you are unable
|
54
|
+
to comply with U.S. and local laws, return this product immediately.
|
55
|
+
|
56
|
+
A summary of U.S. laws governing Cisco cryptographic products may be found at:
|
57
|
+
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
|
58
|
+
|
59
|
+
If you require further assistance please contact us by sending email to
|
60
|
+
export@cisco.com.
|
61
|
+
|
62
|
+
|
63
|
+
Technology Package License Information:\x20
|
64
|
+
|
65
|
+
------------------------------------------------------------------------------
|
66
|
+
Technology-package Technology-package
|
67
|
+
Current Type Next reboot \x20
|
68
|
+
------------------------------------------------------------------------------
|
69
|
+
network-essentials \tSmart License \t network-essentials \x20
|
70
|
+
dna-essentials \tSubscription Smart License \t dna-essentials \x20
|
71
|
+
|
72
|
+
|
73
|
+
Smart Licensing Status: Smart Licensing Using Policy
|
74
|
+
|
75
|
+
cisco C9200L-24P-4G (ARM64) processor with 519464K/3071K bytes of memory.
|
76
|
+
Processor board ID JAE24FFFFFF
|
77
|
+
2 Virtual Ethernet interfaces
|
78
|
+
28 Gigabit Ethernet interfaces
|
79
|
+
2048K bytes of non-volatile configuration memory.
|
80
|
+
1973320K bytes of physical memory.
|
81
|
+
819200K bytes of Crash Files at crashinfo:.
|
82
|
+
1941504K bytes of Flash at flash:.
|
83
|
+
|
84
|
+
Base Ethernet MAC Address : 40:f0:78:00:00:00
|
85
|
+
Motherboard Assembly Number : 77-22222-00
|
86
|
+
Motherboard Serial Number : JAE24FFFFFF
|
87
|
+
Model Revision Number : L0
|
88
|
+
Motherboard Revision Number : A0
|
89
|
+
Model Number : C9200L-24P-4G
|
90
|
+
System Serial Number : JAE24FFFFFF
|
91
|
+
CLEI Code Number : INM6000000
|
92
|
+
|
93
|
+
|
94
|
+
Switch Ports Model SW Version SW Image Mode \x20
|
95
|
+
------ ----- ----- ---------- ---------- ---- \x20
|
96
|
+
* 1 28 C9200L-24P-4G 17.09.04a CAT9K_LITE_IOSXE BUNDLE\x20
|
97
|
+
|
98
|
+
|
99
|
+
Configuration register is 0x102
|
100
|
+
|
101
|
+
LAB-SW123_9200L#
|
102
|
+
show vtp status: |-
|
103
|
+
show vtp status
|
104
|
+
VTP Version capable : 1 to 3
|
105
|
+
VTP version running : 1
|
106
|
+
VTP Domain Name : Oxidized
|
107
|
+
VTP Pruning Mode : Disabled (Operationally Disabled)
|
108
|
+
VTP Traps Generation : Disabled
|
109
|
+
Device ID : 40f0.7800.0000
|
110
|
+
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
|
111
|
+
|
112
|
+
Feature VLAN:
|
113
|
+
--------------
|
114
|
+
VTP Operating Mode : Transparent
|
115
|
+
Maximum VLANs supported locally : 1005
|
116
|
+
Number of existing VLANs : 10
|
117
|
+
Configuration Revision : 0
|
118
|
+
MD5 digest : 0x35 0x00 0x00 0x00 0x00 0x00 0x7F 0xB4\x20
|
119
|
+
0x07 0x00 0x00 0x00 0x00 0x00 0x09 0x6D\x20
|
120
|
+
LAB-SW123_9200L#
|
121
|
+
show inventory: |-
|
122
|
+
show inventory
|
123
|
+
NAME: \"c92xxL Stack\", DESCR: \"c92xxL Stack\"
|
124
|
+
PID: C9200L-24P-4G , VID: V01 , SN: JAE24FFFFFF
|
125
|
+
|
126
|
+
NAME: \"Switch 1\", DESCR: \"C9200L-24P-4G\"
|
127
|
+
PID: C9200L-24P-4G , VID: V01 , SN: JAE24FFFFFF
|
128
|
+
|
129
|
+
NAME: \"Switch 1 - Power Supply A\", DESCR: \"Switch 1 - Power Supply A\"
|
130
|
+
PID: PWR-C5-600WAC , VID: V02 , SN: QCS24XXXXXX
|
131
|
+
|
132
|
+
|
133
|
+
LAB-SW123_9200L#
|
134
|
+
show running-config: |-
|
135
|
+
show running-config
|
136
|
+
Building configuration...
|
137
|
+
|
138
|
+
Current configuration : 20546 bytes
|
139
|
+
!
|
140
|
+
! Last configuration change at 09:37:40 CEST Tue Aug 20 2024 by oxidized
|
141
|
+
! NVRAM config last updated at 09:37:37 CEST Tue Aug 20 2024 by oxidized
|
142
|
+
!
|
143
|
+
version 17.9
|
144
|
+
service timestamps debug datetime localtime show-timezone year
|
145
|
+
service timestamps log datetime localtime show-timezone year
|
146
|
+
service password-encryption
|
147
|
+
!
|
148
|
+
hostname LAB-SW123_9200L
|
149
|
+
!
|
150
|
+
!
|
151
|
+
vrf definition Mgmt-vrf
|
152
|
+
!
|
153
|
+
address-family ipv4
|
154
|
+
exit-address-family
|
155
|
+
!
|
156
|
+
address-family ipv6
|
157
|
+
exit-address-family
|
158
|
+
!
|
159
|
+
logging buffered 65536 informational
|
160
|
+
no logging console
|
161
|
+
aaa new-model
|
162
|
+
!
|
163
|
+
!
|
164
|
+
aaa authentication login default group tacacs+ local
|
165
|
+
aaa authentication enable default group tacacs+ enable
|
166
|
+
aaa authorization exec default group tacacs+ if-authenticated\x20
|
167
|
+
! ...
|
168
|
+
no aaa accounting system guarantee-first
|
169
|
+
!
|
170
|
+
!
|
171
|
+
aaa session-id common
|
172
|
+
!
|
173
|
+
!
|
174
|
+
!
|
175
|
+
clock timezone CET 1 0
|
176
|
+
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 2:00
|
177
|
+
boot system switch all flash:cat9k_lite_iosxe.17.09.05.SPA.bin
|
178
|
+
switch 1 provision c9200l-24p-4g
|
179
|
+
!
|
180
|
+
!
|
181
|
+
!
|
182
|
+
!
|
183
|
+
!
|
184
|
+
ip name-server 10.42.0.1 10.42.0.2
|
185
|
+
no ip domain lookup
|
186
|
+
ip domain name oxidized.local
|
187
|
+
!
|
188
|
+
!
|
189
|
+
!
|
190
|
+
login on-success log
|
191
|
+
vtp domain Oxidized
|
192
|
+
vtp mode transparent
|
193
|
+
vtp version 1
|
194
|
+
!
|
195
|
+
!
|
196
|
+
spanning-tree mode rapid-pvst
|
197
|
+
spanning-tree logging
|
198
|
+
spanning-tree portfast bpduguard default
|
199
|
+
spanning-tree extend system-id
|
200
|
+
!
|
201
|
+
!
|
202
|
+
errdisable recovery cause udld
|
203
|
+
errdisable recovery cause bpduguard
|
204
|
+
errdisable recovery cause security-violation
|
205
|
+
errdisable recovery cause dhcp-rate-limit
|
206
|
+
errdisable recovery cause arp-inspection
|
207
|
+
errdisable recovery cause loopback
|
208
|
+
!
|
209
|
+
enable secret 9 $9$xxxSECRET_ENABLExxxxxxxxxxxxxx
|
210
|
+
!
|
211
|
+
username oxidized secret 9 $9$xxxxxxxxxxSECRET_OXIDIZEDxxxxxxxxx
|
212
|
+
username rocks secret 9 $9$xxxxxxxxxxSECRET_OXIDIZEDxxxxxxxxx
|
213
|
+
!
|
214
|
+
transceiver type all
|
215
|
+
monitoring
|
216
|
+
!
|
217
|
+
vlan 2
|
218
|
+
name two
|
219
|
+
!
|
220
|
+
vlan 3
|
221
|
+
name three
|
222
|
+
!
|
223
|
+
!
|
224
|
+
interface GigabitEthernet0/0
|
225
|
+
vrf forwarding Mgmt-vrf
|
226
|
+
no ip address
|
227
|
+
!
|
228
|
+
interface GigabitEthernet1/0/1
|
229
|
+
description oxidized test one
|
230
|
+
switchport access vlan 2
|
231
|
+
switchport mode access
|
232
|
+
no snmp trap link-status
|
233
|
+
spanning-tree portfast
|
234
|
+
!
|
235
|
+
interface GigabitEthernet1/0/2
|
236
|
+
description oxidized two
|
237
|
+
switchport access vlan 3
|
238
|
+
switchport mode access
|
239
|
+
!
|
240
|
+
! ...
|
241
|
+
!
|
242
|
+
interface GigabitEthernet1/0/24
|
243
|
+
description oxodized trunk
|
244
|
+
switchport trunk allowed vlan 2,3
|
245
|
+
switchport mode trunk
|
246
|
+
switchport nonegotiate
|
247
|
+
!
|
248
|
+
interface GigabitEthernet1/1/1
|
249
|
+
!
|
250
|
+
interface GigabitEthernet1/1/2
|
251
|
+
!
|
252
|
+
interface GigabitEthernet1/1/3
|
253
|
+
!
|
254
|
+
interface GigabitEthernet1/1/4
|
255
|
+
!
|
256
|
+
interface Vlan1
|
257
|
+
no ip address
|
258
|
+
shutdown
|
259
|
+
!
|
260
|
+
interface Vlan2
|
261
|
+
description network management
|
262
|
+
ip address 10.42.11.42 255.255.255.0
|
263
|
+
!
|
264
|
+
ip default-gateway 10.41.11.1
|
265
|
+
no ip http server
|
266
|
+
no ip http secure-server
|
267
|
+
ip ftp source-interface Vlan2
|
268
|
+
ip tftp source-interface Vlan2
|
269
|
+
ip tacacs source-interface Vlan2\x20
|
270
|
+
ip ssh version 2
|
271
|
+
!
|
272
|
+
!
|
273
|
+
ip access-list standard 5
|
274
|
+
10 permit 10.0.0.0 0.0.0.255
|
275
|
+
20 deny any
|
276
|
+
!
|
277
|
+
snmp-server community public RW 5
|
278
|
+
snmp-server location Here and there
|
279
|
+
snmp-server host 10.42.0.33 version 2c AAAAAAAAAABBBBBBBBBB\x20
|
280
|
+
snmp-server host 10.42.0.34 version 2c AAAAAAAAAABBBBBBBBBB\x20
|
281
|
+
snmp-server host 10.42.0.35 vrf Mgmt-vrf informs version 2c AAAAAAAAAABBBBBBBBBB tty vtp
|
282
|
+
snmp-server host 10.42.0.36 vrf Mgmt-vrf informs version 3 auth oxidized bfd bridge transceiver
|
283
|
+
!
|
284
|
+
snmp mib expression owner nat name 1
|
285
|
+
expression 42
|
286
|
+
snmp mib expression owner oxidized name rocks
|
287
|
+
expression 42
|
288
|
+
!
|
289
|
+
!
|
290
|
+
!
|
291
|
+
banner exec ^C
|
292
|
+
### EXAMPLE IOS-XE 17.09.04a config on a C9200L-24P-4G ###
|
293
|
+
Retrieved 2024-09-09 by @robertcheramy
|
294
|
+
### ###
|
295
|
+
^C
|
296
|
+
banner login ^C
|
297
|
+
.
|
298
|
+
Login banner.
|
299
|
+
.
|
300
|
+
^C
|
301
|
+
!
|
302
|
+
!
|
303
|
+
!
|
304
|
+
!
|
305
|
+
!
|
306
|
+
end
|
307
|
+
|
308
|
+
LAB-SW123_9200L#
|
309
|
+
exit: |-
|
310
|
+
oxidized_output: |
|
311
|
+
! Cisco IOS XE Software, Version 17.09.04a
|
312
|
+
!\x20
|
313
|
+
! Image: Software: CAT9K_LITE_IOSXE, 17.9.4a, RELEASE SOFTWARE (fc3)
|
314
|
+
! Image: Compiled: Fri 20-Oct-23 10:33 by mcpre
|
315
|
+
! Image: flash:cat9k_lite_iosxe.17.09.04a.SPA.bin
|
316
|
+
! Chassis type: C9200L-24P-4G
|
317
|
+
! Memory: main 519464K/3071K
|
318
|
+
! Processor ID: JAE24FFFFFF
|
319
|
+
! CPU: ARM64
|
320
|
+
! Memory: nvram 2048K
|
321
|
+
!\x20
|
322
|
+
! VTP: VTP Version capable : 1 to 3
|
323
|
+
! VTP: VTP version running : 1
|
324
|
+
! VTP: VTP Domain Name : Oxidized
|
325
|
+
! VTP: VTP Pruning Mode : Disabled (Operationally Disabled)
|
326
|
+
! VTP: VTP Traps Generation : Disabled
|
327
|
+
! VTP: Device ID : 40f0.7800.0000
|
328
|
+
! VTP: Feature VLAN:
|
329
|
+
! VTP: --------------
|
330
|
+
! VTP: VTP Operating Mode : Transparent
|
331
|
+
! VTP: Maximum VLANs supported locally : 1005
|
332
|
+
! VTP: Number of existing VLANs : 10
|
333
|
+
! VTP: Configuration Revision : 0
|
334
|
+
! VTP: MD5 digest : 0x35 0x00 0x00 0x00 0x00 0x00 0x7F 0xB4\x20
|
335
|
+
! VTP: 0x07 0x00 0x00 0x00 0x00 0x00 0x09 0x6D\x20
|
336
|
+
!\x20
|
337
|
+
! NAME: \"c92xxL Stack\", DESCR: \"c92xxL Stack\"
|
338
|
+
! PID: C9200L-24P-4G , VID: V01 , SN: JAE24FFFFFF
|
339
|
+
!\x20
|
340
|
+
! NAME: \"Switch 1\", DESCR: \"C9200L-24P-4G\"
|
341
|
+
! PID: C9200L-24P-4G , VID: V01 , SN: JAE24FFFFFF
|
342
|
+
!\x20
|
343
|
+
! NAME: \"Switch 1 - Power Supply A\", DESCR: \"Switch 1 - Power Supply A\"
|
344
|
+
! PID: PWR-C5-600WAC , VID: V02 , SN: QCS24XXXXXX
|
345
|
+
!\x20
|
346
|
+
!\x20
|
347
|
+
!
|
348
|
+
! Last configuration change at 09:37:40 CEST Tue Aug 20 2024 by oxidized
|
349
|
+
! NVRAM config last updated at 09:37:37 CEST Tue Aug 20 2024 by oxidized
|
350
|
+
!
|
351
|
+
version 17.9
|
352
|
+
service timestamps debug datetime localtime show-timezone year
|
353
|
+
service timestamps log datetime localtime show-timezone year
|
354
|
+
service password-encryption
|
355
|
+
!
|
356
|
+
hostname LAB-SW123_9200L
|
357
|
+
!
|
358
|
+
!
|
359
|
+
vrf definition Mgmt-vrf
|
360
|
+
!
|
361
|
+
address-family ipv4
|
362
|
+
exit-address-family
|
363
|
+
!
|
364
|
+
address-family ipv6
|
365
|
+
exit-address-family
|
366
|
+
!
|
367
|
+
logging buffered 65536 informational
|
368
|
+
no logging console
|
369
|
+
aaa new-model
|
370
|
+
!
|
371
|
+
!
|
372
|
+
aaa authentication login default group tacacs+ local
|
373
|
+
aaa authentication enable default group tacacs+ enable
|
374
|
+
aaa authorization exec default group tacacs+ if-authenticated\x20
|
375
|
+
! ...
|
376
|
+
no aaa accounting system guarantee-first
|
377
|
+
!
|
378
|
+
!
|
379
|
+
aaa session-id common
|
380
|
+
!
|
381
|
+
!
|
382
|
+
!
|
383
|
+
clock timezone CET 1 0
|
384
|
+
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 2:00
|
385
|
+
boot system switch all flash:cat9k_lite_iosxe.17.09.05.SPA.bin
|
386
|
+
switch 1 provision c9200l-24p-4g
|
387
|
+
!
|
388
|
+
!
|
389
|
+
!
|
390
|
+
!
|
391
|
+
!
|
392
|
+
ip name-server 10.42.0.1 10.42.0.2
|
393
|
+
no ip domain lookup
|
394
|
+
ip domain name oxidized.local
|
395
|
+
!
|
396
|
+
!
|
397
|
+
!
|
398
|
+
login on-success log
|
399
|
+
vtp domain Oxidized
|
400
|
+
vtp mode transparent
|
401
|
+
vtp version 1
|
402
|
+
!
|
403
|
+
!
|
404
|
+
spanning-tree mode rapid-pvst
|
405
|
+
spanning-tree logging
|
406
|
+
spanning-tree portfast bpduguard default
|
407
|
+
spanning-tree extend system-id
|
408
|
+
!
|
409
|
+
!
|
410
|
+
errdisable recovery cause udld
|
411
|
+
errdisable recovery cause bpduguard
|
412
|
+
errdisable recovery cause security-violation
|
413
|
+
errdisable recovery cause dhcp-rate-limit
|
414
|
+
errdisable recovery cause arp-inspection
|
415
|
+
errdisable recovery cause loopback
|
416
|
+
!
|
417
|
+
enable secret 9 $9$xxxSECRET_ENABLExxxxxxxxxxxxxx
|
418
|
+
!
|
419
|
+
username oxidized secret 9 $9$xxxxxxxxxxSECRET_OXIDIZEDxxxxxxxxx
|
420
|
+
username rocks secret 9 $9$xxxxxxxxxxSECRET_OXIDIZEDxxxxxxxxx
|
421
|
+
!
|
422
|
+
transceiver type all
|
423
|
+
monitoring
|
424
|
+
!
|
425
|
+
vlan 2
|
426
|
+
name two
|
427
|
+
!
|
428
|
+
vlan 3
|
429
|
+
name three
|
430
|
+
!
|
431
|
+
!
|
432
|
+
interface GigabitEthernet0/0
|
433
|
+
vrf forwarding Mgmt-vrf
|
434
|
+
no ip address
|
435
|
+
!
|
436
|
+
interface GigabitEthernet1/0/1
|
437
|
+
description oxidized test one
|
438
|
+
switchport access vlan 2
|
439
|
+
switchport mode access
|
440
|
+
no snmp trap link-status
|
441
|
+
spanning-tree portfast
|
442
|
+
!
|
443
|
+
interface GigabitEthernet1/0/2
|
444
|
+
description oxidized two
|
445
|
+
switchport access vlan 3
|
446
|
+
switchport mode access
|
447
|
+
!
|
448
|
+
! ...
|
449
|
+
!
|
450
|
+
interface GigabitEthernet1/0/24
|
451
|
+
description oxodized trunk
|
452
|
+
switchport trunk allowed vlan 2,3
|
453
|
+
switchport mode trunk
|
454
|
+
switchport nonegotiate
|
455
|
+
!
|
456
|
+
interface GigabitEthernet1/1/1
|
457
|
+
!
|
458
|
+
interface GigabitEthernet1/1/2
|
459
|
+
!
|
460
|
+
interface GigabitEthernet1/1/3
|
461
|
+
!
|
462
|
+
interface GigabitEthernet1/1/4
|
463
|
+
!
|
464
|
+
interface Vlan1
|
465
|
+
no ip address
|
466
|
+
shutdown
|
467
|
+
!
|
468
|
+
interface Vlan2
|
469
|
+
description network management
|
470
|
+
ip address 10.42.11.42 255.255.255.0
|
471
|
+
!
|
472
|
+
ip default-gateway 10.41.11.1
|
473
|
+
no ip http server
|
474
|
+
no ip http secure-server
|
475
|
+
ip ftp source-interface Vlan2
|
476
|
+
ip tftp source-interface Vlan2
|
477
|
+
ip tacacs source-interface Vlan2\x20
|
478
|
+
ip ssh version 2
|
479
|
+
!
|
480
|
+
!
|
481
|
+
ip access-list standard 5
|
482
|
+
10 permit 10.0.0.0 0.0.0.255
|
483
|
+
20 deny any
|
484
|
+
!
|
485
|
+
snmp-server community public RW 5
|
486
|
+
snmp-server location Here and there
|
487
|
+
snmp-server host 10.42.0.33 version 2c AAAAAAAAAABBBBBBBBBB\x20
|
488
|
+
snmp-server host 10.42.0.34 version 2c AAAAAAAAAABBBBBBBBBB\x20
|
489
|
+
snmp-server host 10.42.0.35 vrf Mgmt-vrf informs version 2c AAAAAAAAAABBBBBBBBBB tty vtp
|
490
|
+
snmp-server host 10.42.0.36 vrf Mgmt-vrf informs version 3 auth oxidized bfd bridge transceiver
|
491
|
+
!
|
492
|
+
snmp mib expression owner nat name 1
|
493
|
+
expression <value removed>
|
494
|
+
snmp mib expression owner oxidized name rocks
|
495
|
+
expression <value removed>
|
496
|
+
!
|
497
|
+
!
|
498
|
+
!
|
499
|
+
banner exec ^C
|
500
|
+
### EXAMPLE IOS-XE 17.09.04a config on a C9200L-24P-4G ###
|
501
|
+
Retrieved 2024-09-09 by @robertcheramy
|
502
|
+
### ###
|
503
|
+
^C
|
504
|
+
banner login ^C
|
505
|
+
.
|
506
|
+
Login banner.
|
507
|
+
.
|
508
|
+
^C
|
509
|
+
!
|
510
|
+
!
|
511
|
+
!
|
512
|
+
!
|
513
|
+
!
|
514
|
+
end\n
|