oxidized 0.30.1 → 0.31.0
Sign up to get free protection for your applications and to get access to all the features.
- checksums.yaml +4 -4
- data/.github/workflows/ruby.yml +2 -2
- data/.github/workflows/stale.yml +4 -2
- data/.rubocop.yml +18 -2
- data/.rubocop_todo.yml +5 -12
- data/CHANGELOG.md +61 -1
- data/CONTRIBUTING.md +5 -0
- data/Dockerfile +82 -21
- data/README.md +5 -21
- data/Rakefile +3 -2
- data/docs/Configuration.md +36 -12
- data/docs/Creating-Models.md +45 -4
- data/docs/Hooks.md +34 -0
- data/docs/Issues.md +91 -0
- data/docs/Model-Notes/Cumulus.md +5 -0
- data/docs/Model-Notes/FSOS.md +5 -0
- data/docs/Model-Notes/FortiOS.md +21 -5
- data/docs/Model-Notes/HPEAruba.md +31 -0
- data/docs/Model-Notes/OS6.md +10 -0
- data/docs/Model-Notes/RouterOS.md +15 -0
- data/docs/Model-Notes/SikluMHTG.md +7 -0
- data/docs/Outputs.md +2 -0
- data/docs/Release.md +18 -15
- data/docs/Sources.md +21 -0
- data/docs/Supported-OS-Types.md +11 -5
- data/docs/Troubleshooting.md +35 -0
- data/examples/device-simulation/README.md +173 -0
- data/examples/device-simulation/cmdsets/aoscx +9 -0
- data/examples/device-simulation/cmdsets/arubainstant +5 -0
- data/examples/device-simulation/cmdsets/asa +7 -0
- data/examples/device-simulation/cmdsets/ios +7 -0
- data/examples/device-simulation/cmdsets/nxos +5 -0
- data/examples/device-simulation/cmdsets/routeros +5 -0
- data/examples/device-simulation/cmdsets/srosmd +11 -0
- data/examples/device-simulation/device2yaml.rb +225 -0
- data/examples/device-simulation/yaml/aoscx_R0X25A-6410_FL.10.10.1100.yaml +2281 -0
- data/examples/device-simulation/yaml/aoscx_R8N85A-C6000-48G-CL4_PL.10.08.1010.yaml +451 -0
- data/examples/device-simulation/yaml/arubainstant_IAP515_8.10.0.6_VWLC.yaml +213 -0
- data/examples/device-simulation/yaml/asa_5512_9.12-4-67_single-context.yaml +531 -0
- data/examples/device-simulation/yaml/asr920_16.8.1b.yaml +1122 -0
- data/examples/device-simulation/yaml/garderos_R7709_003_006_068.yaml +101 -0
- data/examples/device-simulation/yaml/iosxe_C9200L-24P-4G_17.09.04a.yaml +514 -0
- data/examples/device-simulation/yaml/iosxe_C9800-L-F-K9_17.06.05.yaml +417 -0
- data/examples/device-simulation/yaml/riverbed_915.yaml +123 -0
- data/examples/device-simulation/yaml/routeros_CHR_7.10.1.yaml +145 -0
- data/examples/device-simulation/yaml/routeros_CHR_7.16.yaml +79 -0
- data/examples/device-simulation/yaml/routeros_L009UiGS_7.15.2.yaml +353 -0
- data/examples/podman-compose/Makefile +60 -17
- data/examples/podman-compose/README.md +63 -27
- data/examples/podman-compose/docker-compose.yml +11 -2
- data/examples/podman-compose/gitserver/.gitignore +1 -0
- data/examples/podman-compose/gitserver/Dockerfile +14 -0
- data/examples/podman-compose/model-simulation/Dockerfile-model +1 -1
- data/examples/podman-compose/model-simulation/asternos.sh +2 -0
- data/examples/podman-compose/oxidized-config/.gitignore +2 -0
- data/examples/podman-compose/oxidized-config/config +1 -1
- data/examples/podman-compose/oxidized-config/config_csv-file +46 -0
- data/examples/podman-compose/oxidized-config/config_csv-gitserver +56 -0
- data/examples/podman-compose/oxidized-ssh/.gitignore +1 -0
- data/lib/oxidized/config.rb +7 -1
- data/lib/oxidized/hook/githubrepo.rb +37 -7
- data/lib/oxidized/hook/slackdiff.rb +29 -7
- data/lib/oxidized/input/http.rb +1 -0
- data/lib/oxidized/input/telnet.rb +1 -1
- data/lib/oxidized/manager.rb +17 -16
- data/lib/oxidized/model/aoscx.rb +16 -2
- data/lib/oxidized/model/aosw.rb +7 -1
- data/lib/oxidized/model/arubainstant.rb +90 -0
- data/lib/oxidized/model/audiocodes.rb +2 -2
- data/lib/oxidized/model/cnos.rb +13 -10
- data/lib/oxidized/model/cumulus.rb +3 -0
- data/lib/oxidized/model/dlink.rb +1 -0
- data/lib/oxidized/model/dlinknextgen.rb +3 -0
- data/lib/oxidized/model/edgecos.rb +2 -1
- data/lib/oxidized/model/eos.rb +2 -0
- data/lib/oxidized/model/f5os.rb +17 -0
- data/lib/oxidized/model/firewareos.rb +10 -1
- data/lib/oxidized/model/fortios.rb +24 -1
- data/lib/oxidized/model/garderos.rb +43 -0
- data/lib/oxidized/model/h3c.rb +1 -1
- data/lib/oxidized/model/ibos.rb +1 -0
- data/lib/oxidized/model/ios.rb +20 -12
- data/lib/oxidized/model/iosxr.rb +1 -1
- data/lib/oxidized/model/lenovonos.rb +2 -0
- data/lib/oxidized/model/linuxgeneric.rb +1 -1
- data/lib/oxidized/model/netgear.rb +1 -1
- data/lib/oxidized/model/nodegrid.rb +1 -1
- data/lib/oxidized/model/nsxdfw.rb +30 -0
- data/lib/oxidized/model/nxos.rb +2 -1
- data/lib/oxidized/model/os6.rb +48 -0
- data/lib/oxidized/model/rgos.rb +1 -1
- data/lib/oxidized/model/riverbed.rb +104 -0
- data/lib/oxidized/model/routeros.rb +2 -2
- data/lib/oxidized/model/saos.rb +18 -1
- data/lib/oxidized/model/siklumhtg.rb +22 -0
- data/lib/oxidized/model/uplinkolt.rb +46 -0
- data/lib/oxidized/model/vyatta.rb +2 -2
- data/lib/oxidized/model/xos.rb +7 -0
- data/lib/oxidized/node.rb +30 -18
- data/lib/oxidized/nodes.rb +13 -5
- data/lib/oxidized/output/file.rb +45 -42
- data/lib/oxidized/output/git.rb +185 -160
- data/lib/oxidized/output/gitcrypt.rb +188 -186
- data/lib/oxidized/output/http.rb +53 -51
- data/lib/oxidized/output/output.rb +6 -4
- data/lib/oxidized/source/csv.rb +44 -49
- data/lib/oxidized/source/http.rb +63 -81
- data/lib/oxidized/source/jsonfile.rb +63 -0
- data/lib/oxidized/source/source.rb +43 -18
- data/lib/oxidized/source/sql.rb +66 -59
- data/lib/oxidized/version.rb +2 -2
- data/oxidized.gemspec +22 -16
- metadata +111 -15
@@ -0,0 +1,531 @@
|
|
1
|
+
---
|
2
|
+
init_prompt: |-
|
3
|
+
.
|
4
|
+
Sample asa configuration with single context
|
5
|
+
Provided by @robertcheramy
|
6
|
+
.
|
7
|
+
User oxidzed logged in to LAB-ASA12-Oxidized-IPv6
|
8
|
+
Logins over the last 91 days: 21. Last login: 20:01:14 CEST Oct 21 2024 from 10.42.0.17
|
9
|
+
Failed logins since the last login: 0. \x20
|
10
|
+
Type help or '?' for a list of available commands.
|
11
|
+
\rLAB-ASA12-Oxidized-IPv6>\x20
|
12
|
+
commands:
|
13
|
+
enable: |-
|
14
|
+
enable
|
15
|
+
Password: ******************
|
16
|
+
\rLAB-ASA12-Oxidized-IPv6#\x20
|
17
|
+
terminal pager 0: |-
|
18
|
+
terminal pager 0
|
19
|
+
\rLAB-ASA12-Oxidized-IPv6#\x20
|
20
|
+
show mode: |-
|
21
|
+
show mode
|
22
|
+
Security context mode: single\x20
|
23
|
+
\rLAB-ASA12-Oxidized-IPv6#\x20
|
24
|
+
show version: |-
|
25
|
+
show version
|
26
|
+
|
27
|
+
Cisco Adaptive Security Appliance Software Version 9.12(4)67\x20
|
28
|
+
SSP Operating System Version 2.6(1.272)
|
29
|
+
|
30
|
+
Compiled on Thu 14-Mar-24 18:01 GMT by builders
|
31
|
+
System image file is \"disk0:/asa9-12-4-67-smp-k8.bin\"
|
32
|
+
Config file at boot was \"startup-config\"
|
33
|
+
|
34
|
+
LAB-ASA12-Oxidized-IPv6 up 173 days 16 hours
|
35
|
+
|
36
|
+
Hardware: ASA5512, 4096 MB RAM, CPU Clarkdale 2800 MHz, 1 CPU (2 cores)
|
37
|
+
ASA: 1666 MB RAM, 1 CPU (1 core)
|
38
|
+
Internal ATA Compact Flash, 4096MB
|
39
|
+
BIOS Flash MX25EEEEEE @ 0xffbb0000, 8192KB
|
40
|
+
|
41
|
+
Encryption hardware device : Cisco ASA Crypto on-board accelerator (revision 0x1)
|
42
|
+
Boot microcode : CNPx-MC-BOOT-2.00
|
43
|
+
SSL/IKE microcode : CNPx-MC-SSL-SB-PLUS-0005
|
44
|
+
IPSec microcode : CNPx-MC-IPSEC-MAIN-0026
|
45
|
+
Number of accelerators: 1
|
46
|
+
Baseboard Management Controller (revision 0x1) Firmware Version: 2.4
|
47
|
+
|
48
|
+
|
49
|
+
0: Int: Internal-Data0/0 : address is c08c.cafe.7303, irq 11
|
50
|
+
1: Ext: GigabitEthernet0/0 : address is c08c.cafe.7307, irq 10
|
51
|
+
2: Ext: GigabitEthernet0/1 : address is c08c.cafe.7304, irq 10
|
52
|
+
3: Ext: GigabitEthernet0/2 : address is c08c.cafe.7308, irq 5
|
53
|
+
4: Ext: GigabitEthernet0/3 : address is c08c.cafe.7305, irq 5
|
54
|
+
5: Ext: GigabitEthernet0/4 : address is c08c.cafe.7309, irq 10
|
55
|
+
6: Ext: GigabitEthernet0/5 : address is c08c.cafe.7306, irq 10
|
56
|
+
7: Int: Internal-Data0/1 : address is 0000.0001.0002, irq 0
|
57
|
+
8: Int: Internal-Control0/0 : address is 0000.0001.0001, irq 0
|
58
|
+
9: Int: Internal-Data0/2 : address is 0000.0001.0003, irq 0
|
59
|
+
10: Ext: Management0/0 : address is c08c.cafe.7303, irq 0
|
60
|
+
11: Int: Internal-Data0/3 : address is 0000.0100.0001, irq 0
|
61
|
+
|
62
|
+
Licensed features for this platform:
|
63
|
+
Maximum Physical Interfaces : Unlimited perpetual
|
64
|
+
Maximum VLANs : 50 perpetual
|
65
|
+
Inside Hosts : Unlimited perpetual
|
66
|
+
Failover : Disabled perpetual
|
67
|
+
Encryption-DES : Enabled perpetual
|
68
|
+
Encryption-3DES-AES : Enabled perpetual
|
69
|
+
Security Contexts : 2 perpetual
|
70
|
+
Carrier : Disabled perpetual
|
71
|
+
AnyConnect Premium Peers : 2 perpetual
|
72
|
+
AnyConnect Essentials : Disabled perpetual
|
73
|
+
Other VPN Peers : 250 perpetual
|
74
|
+
Total VPN Peers : 250 perpetual
|
75
|
+
AnyConnect for Mobile : Disabled perpetual
|
76
|
+
AnyConnect for Cisco VPN Phone : Disabled perpetual
|
77
|
+
Advanced Endpoint Assessment : Disabled perpetual
|
78
|
+
Shared License : Disabled perpetual
|
79
|
+
Total TLS Proxy Sessions : 2 perpetual
|
80
|
+
Botnet Traffic Filter : Disabled perpetual
|
81
|
+
IPS Module : Disabled perpetual
|
82
|
+
Cluster : Disabled perpetual
|
83
|
+
|
84
|
+
This platform has a Base license.
|
85
|
+
|
86
|
+
Serial Number: FCH17AAAAAA
|
87
|
+
Running Permanent Activation Key: 0x12345678 0x9f012345 0x00000000 0x11111111 0x22222222\x20
|
88
|
+
Configuration register is 0x1
|
89
|
+
|
90
|
+
Image type : Release
|
91
|
+
Key version : A
|
92
|
+
|
93
|
+
Configuration has not been modified since last system restart.
|
94
|
+
\rLAB-ASA12-Oxidized-IPv6# \x20
|
95
|
+
show inventory: |-
|
96
|
+
show inventory
|
97
|
+
Name: \"Chassis\", DESCR: \"ASA 5512-X with SW, 6 GE Data, 1 GE Mgmt, AC\"
|
98
|
+
PID: ASA5512 , VID: V01 , SN: FGL17AAAAAA
|
99
|
+
|
100
|
+
\rLAB-ASA12-Oxidized-IPv6#\x20
|
101
|
+
'more system:running-config': |-
|
102
|
+
more system:running-config
|
103
|
+
: Saved
|
104
|
+
|
105
|
+
:\x20
|
106
|
+
: Serial Number: FCH17AAAAAA
|
107
|
+
: Hardware: ASA5512, 4096 MB RAM, CPU Clarkdale 2800 MHz, 1 CPU (2 cores)
|
108
|
+
: Written by oxidzed at 20:03:32.236 CEST Mon Oct 21 2024
|
109
|
+
!
|
110
|
+
ASA Version 9.12(4)67\x20
|
111
|
+
!
|
112
|
+
hostname LAB-ASA12-Oxidized-IPv6
|
113
|
+
domain-name lab
|
114
|
+
enable password $sha512$5000$AAAAAAAAAABBBBBBBBBBCCCCCCCCCC pbkdf2
|
115
|
+
service-module 0 keepalive-timeout 4
|
116
|
+
service-module 0 keepalive-counter 6
|
117
|
+
service-module ips keepalive-timeout 4
|
118
|
+
service-module ips keepalive-counter 6
|
119
|
+
service-module cxsc keepalive-timeout 4
|
120
|
+
service-module cxsc keepalive-counter 6
|
121
|
+
xlate per-session deny tcp any4 any4
|
122
|
+
xlate per-session deny tcp any4 any6
|
123
|
+
xlate per-session deny tcp any6 any4
|
124
|
+
xlate per-session deny tcp any6 any6
|
125
|
+
xlate per-session deny udp any4 any4 eq domain
|
126
|
+
xlate per-session deny udp any4 any6 eq domain
|
127
|
+
xlate per-session deny udp any6 any4 eq domain
|
128
|
+
xlate per-session deny udp any6 any6 eq domain
|
129
|
+
passwd AAAAAAAAAABBBBBBBBBBCCCCCCCCCC encrypted
|
130
|
+
names
|
131
|
+
no mac-address auto
|
132
|
+
|
133
|
+
!
|
134
|
+
interface GigabitEthernet0/0
|
135
|
+
nameif RZ
|
136
|
+
security-level 90
|
137
|
+
no ip address
|
138
|
+
ipv6 address 2001:db8:0000:4200::12/64
|
139
|
+
ipv6 nd suppress-ra
|
140
|
+
!
|
141
|
+
interface GigabitEthernet0/1
|
142
|
+
nameif WAN
|
143
|
+
security-level 10
|
144
|
+
no ip address
|
145
|
+
ipv6 address 2001:db8:0000:4203::12/64
|
146
|
+
ipv6 nd suppress-ra
|
147
|
+
!
|
148
|
+
interface GigabitEthernet0/2
|
149
|
+
description IPv4 DMZ NAT64
|
150
|
+
nameif NAT64
|
151
|
+
security-level 95
|
152
|
+
ip address 10.42.1.2 255.255.255.240\x20
|
153
|
+
!
|
154
|
+
interface GigabitEthernet0/3
|
155
|
+
description Oxidized
|
156
|
+
nameif OXIDIZED
|
157
|
+
security-level 20
|
158
|
+
no ip address
|
159
|
+
ipv6 address 2001:db8:0000:4201::12/64
|
160
|
+
!
|
161
|
+
interface GigabitEthernet0/4
|
162
|
+
shutdown
|
163
|
+
no nameif
|
164
|
+
no security-level
|
165
|
+
no ip address
|
166
|
+
!
|
167
|
+
interface GigabitEthernet0/5
|
168
|
+
shutdown
|
169
|
+
no nameif
|
170
|
+
no security-level
|
171
|
+
no ip address
|
172
|
+
!
|
173
|
+
interface Management0/0
|
174
|
+
description Management
|
175
|
+
management-only
|
176
|
+
nameif management
|
177
|
+
security-level 100
|
178
|
+
ip address 10.42.2.12 255.255.255.0\x20
|
179
|
+
!
|
180
|
+
banner motd .
|
181
|
+
banner motd Sample asa configuration with single context
|
182
|
+
banner motd Provided by @robertcheramy
|
183
|
+
banner motd .
|
184
|
+
boot system disk0:/asa9-12-4-67-smp-k8.bin
|
185
|
+
ftp mode passive
|
186
|
+
clock timezone MET 1
|
187
|
+
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 2:00
|
188
|
+
dns server-group DefaultDNS
|
189
|
+
domain-name oxidized
|
190
|
+
object network OXIDIZED
|
191
|
+
subnet 10.42.3.64 255.255.255.224
|
192
|
+
object network ROCKS
|
193
|
+
host 2001:db8:0000:4202::4:4
|
194
|
+
object network SOME_OBJECT
|
195
|
+
host 10.42.0.12
|
196
|
+
pager lines 24
|
197
|
+
logging enable
|
198
|
+
logging buffer-size 65000
|
199
|
+
logging monitor debugging
|
200
|
+
logging buffered notifications
|
201
|
+
mtu RZ 1500
|
202
|
+
mtu WAN 1500
|
203
|
+
mtu NAT64 1500
|
204
|
+
mtu OXIDIZED 1500
|
205
|
+
mtu management 1500
|
206
|
+
icmp unreachable rate-limit 1 burst-size 1
|
207
|
+
no asdm history enable
|
208
|
+
arp timeout 14400
|
209
|
+
no arp permit-nonconnected
|
210
|
+
arp rate-limit 8192
|
211
|
+
ipv6 route WAN 2001:db8:0000:4200::/56 2001:db8:0000:4203::801
|
212
|
+
ipv6 route WAN 2001:db8:0000:4203::/64 2001:db8:0000:4203::801
|
213
|
+
aaa-server TACACS protocol tacacs+
|
214
|
+
aaa-server TACACS (management) host 10.42.0.12
|
215
|
+
key AAAAAAAAAABBBBBBBBBBCCCCCCCCCC
|
216
|
+
aaa-server TACACS (management) host 10.42.0.13
|
217
|
+
key AAAAAAAAAABBBBBBBBBBCCCCCCCCCC
|
218
|
+
user-identity default-domain LOCAL
|
219
|
+
aaa authentication http console TACACS LOCAL
|
220
|
+
aaa authentication enable console TACACS LOCAL
|
221
|
+
aaa authentication serial console TACACS LOCAL
|
222
|
+
aaa authentication ssh console TACACS LOCAL
|
223
|
+
aaa authentication telnet console TACACS LOCAL
|
224
|
+
aaa authentication login-history
|
225
|
+
no snmp-server location
|
226
|
+
no snmp-server contact
|
227
|
+
ssh scopy enable
|
228
|
+
ssh stricthostkeycheck
|
229
|
+
ssh timeout 60
|
230
|
+
ssh version 2
|
231
|
+
ssh 10.42.0.0 255.255.0.0 management
|
232
|
+
console timeout 0
|
233
|
+
threat-detection basic-threat
|
234
|
+
threat-detection statistics access-list
|
235
|
+
no threat-detection statistics tcp-intercept
|
236
|
+
ntp server 10.42.42.11 source management prefer
|
237
|
+
username oxidized password $sha512$5000$AAAAAAAAAABBBBBBBBBBCCCCCCCCCC== pbkdf2
|
238
|
+
!
|
239
|
+
class-map inspection_default
|
240
|
+
match default-inspection-traffic
|
241
|
+
!
|
242
|
+
!
|
243
|
+
policy-map type inspect dns preset_dns_map
|
244
|
+
parameters
|
245
|
+
message-length maximum client auto
|
246
|
+
message-length maximum 512
|
247
|
+
no tcp-inspection
|
248
|
+
policy-map global_policy
|
249
|
+
class inspection_default
|
250
|
+
inspect dns preset_dns_map\x20
|
251
|
+
inspect ftp\x20
|
252
|
+
inspect h323 h225\x20
|
253
|
+
inspect h323 ras\x20
|
254
|
+
inspect ip-options\x20
|
255
|
+
inspect netbios\x20
|
256
|
+
inspect rsh\x20
|
257
|
+
inspect rtsp\x20
|
258
|
+
inspect skinny \x20
|
259
|
+
inspect esmtp\x20
|
260
|
+
inspect sqlnet\x20
|
261
|
+
inspect sunrpc\x20
|
262
|
+
inspect tftp\x20
|
263
|
+
inspect sip \x20
|
264
|
+
inspect xdmcp\x20
|
265
|
+
inspect icmp\x20
|
266
|
+
!
|
267
|
+
service-policy global_policy global
|
268
|
+
prompt hostname context\x20
|
269
|
+
no call-home reporting anonymous
|
270
|
+
call-home
|
271
|
+
profile CiscoTAC-1
|
272
|
+
no active
|
273
|
+
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
|
274
|
+
destination address email callhome@cisco.com
|
275
|
+
destination transport-method http
|
276
|
+
subscribe-to-alert-group diagnostic
|
277
|
+
subscribe-to-alert-group environment
|
278
|
+
subscribe-to-alert-group inventory periodic monthly 1
|
279
|
+
subscribe-to-alert-group configuration periodic monthly 1
|
280
|
+
subscribe-to-alert-group telemetry periodic daily
|
281
|
+
password encryption aes
|
282
|
+
Cryptochecksum:dddddddddffffffffffffffeeeeeeeee
|
283
|
+
: end
|
284
|
+
|
285
|
+
\rLAB-ASA12-Oxidized-IPv6# \x20
|
286
|
+
exit: |-
|
287
|
+
oxidized_output: |
|
288
|
+
!\x20
|
289
|
+
! Cisco Adaptive Security Appliance Software Version 9.12(4)67\x20
|
290
|
+
! SSP Operating System Version 2.6(1.272)
|
291
|
+
!\x20
|
292
|
+
! Compiled on Thu 14-Mar-24 18:01 GMT by builders
|
293
|
+
! System image file is \"disk0:/asa9-12-4-67-smp-k8.bin\"
|
294
|
+
! Config file at boot was \"startup-config\"
|
295
|
+
!\x20
|
296
|
+
!\x20
|
297
|
+
! Hardware: ASA5512, 4096 MB RAM, CPU Clarkdale 2800 MHz, 1 CPU (2 cores)
|
298
|
+
! ASA: 1666 MB RAM, 1 CPU (1 core)
|
299
|
+
! Internal ATA Compact Flash, 4096MB
|
300
|
+
! BIOS Flash MX25EEEEEE @ 0xffbb0000, 8192KB
|
301
|
+
!\x20
|
302
|
+
! Encryption hardware device : Cisco ASA Crypto on-board accelerator (revision 0x1)
|
303
|
+
! Boot microcode : CNPx-MC-BOOT-2.00
|
304
|
+
! SSL/IKE microcode : CNPx-MC-SSL-SB-PLUS-0005
|
305
|
+
! IPSec microcode : CNPx-MC-IPSEC-MAIN-0026
|
306
|
+
! Number of accelerators: 1
|
307
|
+
! Baseboard Management Controller (revision 0x1) Firmware Version: 2.4
|
308
|
+
!\x20
|
309
|
+
!\x20
|
310
|
+
! 0: Int: Internal-Data0/0 : address is c08c.cafe.7303, irq 11
|
311
|
+
! 1: Ext: GigabitEthernet0/0 : address is c08c.cafe.7307, irq 10
|
312
|
+
! 2: Ext: GigabitEthernet0/1 : address is c08c.cafe.7304, irq 10
|
313
|
+
! 3: Ext: GigabitEthernet0/2 : address is c08c.cafe.7308, irq 5
|
314
|
+
! 4: Ext: GigabitEthernet0/3 : address is c08c.cafe.7305, irq 5
|
315
|
+
! 5: Ext: GigabitEthernet0/4 : address is c08c.cafe.7309, irq 10
|
316
|
+
! 6: Ext: GigabitEthernet0/5 : address is c08c.cafe.7306, irq 10
|
317
|
+
! 7: Int: Internal-Data0/1 : address is 0000.0001.0002, irq 0
|
318
|
+
! 8: Int: Internal-Control0/0 : address is 0000.0001.0001, irq 0
|
319
|
+
! 9: Int: Internal-Data0/2 : address is 0000.0001.0003, irq 0
|
320
|
+
! 10: Ext: Management0/0 : address is c08c.cafe.7303, irq 0
|
321
|
+
! 11: Int: Internal-Data0/3 : address is 0000.0100.0001, irq 0
|
322
|
+
!\x20
|
323
|
+
! Licensed features for this platform:
|
324
|
+
! Maximum Physical Interfaces : Unlimited perpetual
|
325
|
+
! Maximum VLANs : 50 perpetual
|
326
|
+
! Inside Hosts : Unlimited perpetual
|
327
|
+
! Failover : Disabled perpetual
|
328
|
+
! Encryption-DES : Enabled perpetual
|
329
|
+
! Encryption-3DES-AES : Enabled perpetual
|
330
|
+
! Security Contexts : 2 perpetual
|
331
|
+
! Carrier : Disabled perpetual
|
332
|
+
! AnyConnect Premium Peers : 2 perpetual
|
333
|
+
! AnyConnect Essentials : Disabled perpetual
|
334
|
+
! Other VPN Peers : 250 perpetual
|
335
|
+
! Total VPN Peers : 250 perpetual
|
336
|
+
! AnyConnect for Mobile : Disabled perpetual
|
337
|
+
! AnyConnect for Cisco VPN Phone : Disabled perpetual
|
338
|
+
! Advanced Endpoint Assessment : Disabled perpetual
|
339
|
+
! Shared License : Disabled perpetual
|
340
|
+
! Total TLS Proxy Sessions : 2 perpetual
|
341
|
+
! Botnet Traffic Filter : Disabled perpetual
|
342
|
+
! IPS Module : Disabled perpetual
|
343
|
+
! Cluster : Disabled perpetual
|
344
|
+
!\x20
|
345
|
+
! This platform has a Base license.
|
346
|
+
!\x20
|
347
|
+
! Serial Number: FCH17AAAAAA
|
348
|
+
! Running Permanent Activation Key: 0x12345678 0x9f012345 0x00000000 0x11111111 0x22222222\x20
|
349
|
+
! Configuration register is 0x1
|
350
|
+
!\x20
|
351
|
+
! Image type : Release
|
352
|
+
! Key version : A
|
353
|
+
!\x20
|
354
|
+
! Name: \"Chassis\", DESCR: \"ASA 5512-X with SW, 6 GE Data, 1 GE Mgmt, AC\"
|
355
|
+
! PID: ASA5512 , VID: V01 , SN: FGL17AAAAAA
|
356
|
+
!\x20
|
357
|
+
!
|
358
|
+
ASA Version 9.12(4)67\x20
|
359
|
+
!
|
360
|
+
hostname LAB-ASA12-Oxidized-IPv6
|
361
|
+
domain-name lab
|
362
|
+
enable password $sha512$5000$AAAAAAAAAABBBBBBBBBBCCCCCCCCCC pbkdf2
|
363
|
+
service-module 0 keepalive-timeout 4
|
364
|
+
service-module 0 keepalive-counter 6
|
365
|
+
service-module ips keepalive-timeout 4
|
366
|
+
service-module ips keepalive-counter 6
|
367
|
+
service-module cxsc keepalive-timeout 4
|
368
|
+
service-module cxsc keepalive-counter 6
|
369
|
+
xlate per-session deny tcp any4 any4
|
370
|
+
xlate per-session deny tcp any4 any6
|
371
|
+
xlate per-session deny tcp any6 any4
|
372
|
+
xlate per-session deny tcp any6 any6
|
373
|
+
xlate per-session deny udp any4 any4 eq domain
|
374
|
+
xlate per-session deny udp any4 any6 eq domain
|
375
|
+
xlate per-session deny udp any6 any4 eq domain
|
376
|
+
xlate per-session deny udp any6 any6 eq domain
|
377
|
+
passwd AAAAAAAAAABBBBBBBBBBCCCCCCCCCC encrypted
|
378
|
+
names
|
379
|
+
no mac-address auto
|
380
|
+
|
381
|
+
!
|
382
|
+
interface GigabitEthernet0/0
|
383
|
+
nameif RZ
|
384
|
+
security-level 90
|
385
|
+
no ip address
|
386
|
+
ipv6 address 2001:db8:0000:4200::12/64
|
387
|
+
ipv6 nd suppress-ra
|
388
|
+
!
|
389
|
+
interface GigabitEthernet0/1
|
390
|
+
nameif WAN
|
391
|
+
security-level 10
|
392
|
+
no ip address
|
393
|
+
ipv6 address 2001:db8:0000:4203::12/64
|
394
|
+
ipv6 nd suppress-ra
|
395
|
+
!
|
396
|
+
interface GigabitEthernet0/2
|
397
|
+
description IPv4 DMZ NAT64
|
398
|
+
nameif NAT64
|
399
|
+
security-level 95
|
400
|
+
ip address 10.42.1.2 255.255.255.240\x20
|
401
|
+
!
|
402
|
+
interface GigabitEthernet0/3
|
403
|
+
description Oxidized
|
404
|
+
nameif OXIDIZED
|
405
|
+
security-level 20
|
406
|
+
no ip address
|
407
|
+
ipv6 address 2001:db8:0000:4201::12/64
|
408
|
+
!
|
409
|
+
interface GigabitEthernet0/4
|
410
|
+
shutdown
|
411
|
+
no nameif
|
412
|
+
no security-level
|
413
|
+
no ip address
|
414
|
+
!
|
415
|
+
interface GigabitEthernet0/5
|
416
|
+
shutdown
|
417
|
+
no nameif
|
418
|
+
no security-level
|
419
|
+
no ip address
|
420
|
+
!
|
421
|
+
interface Management0/0
|
422
|
+
description Management
|
423
|
+
management-only
|
424
|
+
nameif management
|
425
|
+
security-level 100
|
426
|
+
ip address 10.42.2.12 255.255.255.0\x20
|
427
|
+
!
|
428
|
+
banner motd .
|
429
|
+
banner motd Sample asa configuration with single context
|
430
|
+
banner motd Provided by @robertcheramy
|
431
|
+
banner motd .
|
432
|
+
boot system disk0:/asa9-12-4-67-smp-k8.bin
|
433
|
+
ftp mode passive
|
434
|
+
clock timezone MET 1
|
435
|
+
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 2:00
|
436
|
+
dns server-group DefaultDNS
|
437
|
+
domain-name oxidized
|
438
|
+
object network OXIDIZED
|
439
|
+
subnet 10.42.3.64 255.255.255.224
|
440
|
+
object network ROCKS
|
441
|
+
host 2001:db8:0000:4202::4:4
|
442
|
+
object network SOME_OBJECT
|
443
|
+
host 10.42.0.12
|
444
|
+
pager lines 24
|
445
|
+
logging enable
|
446
|
+
logging buffer-size 65000
|
447
|
+
logging monitor debugging
|
448
|
+
logging buffered notifications
|
449
|
+
mtu RZ 1500
|
450
|
+
mtu WAN 1500
|
451
|
+
mtu NAT64 1500
|
452
|
+
mtu OXIDIZED 1500
|
453
|
+
mtu management 1500
|
454
|
+
icmp unreachable rate-limit 1 burst-size 1
|
455
|
+
no asdm history enable
|
456
|
+
arp timeout 14400
|
457
|
+
no arp permit-nonconnected
|
458
|
+
arp rate-limit 8192
|
459
|
+
ipv6 route WAN 2001:db8:0000:4200::/56 2001:db8:0000:4203::801
|
460
|
+
ipv6 route WAN 2001:db8:0000:4203::/64 2001:db8:0000:4203::801
|
461
|
+
aaa-server TACACS protocol tacacs+
|
462
|
+
aaa-server TACACS (management) host 10.42.0.12
|
463
|
+
key AAAAAAAAAABBBBBBBBBBCCCCCCCCCC
|
464
|
+
aaa-server TACACS (management) host 10.42.0.13
|
465
|
+
key AAAAAAAAAABBBBBBBBBBCCCCCCCCCC
|
466
|
+
user-identity default-domain LOCAL
|
467
|
+
aaa authentication http console TACACS LOCAL
|
468
|
+
aaa authentication enable console TACACS LOCAL
|
469
|
+
aaa authentication serial console TACACS LOCAL
|
470
|
+
aaa authentication ssh console TACACS LOCAL
|
471
|
+
aaa authentication telnet console TACACS LOCAL
|
472
|
+
aaa authentication login-history
|
473
|
+
no snmp-server location
|
474
|
+
no snmp-server contact
|
475
|
+
ssh scopy enable
|
476
|
+
ssh stricthostkeycheck
|
477
|
+
ssh timeout 60
|
478
|
+
ssh version 2
|
479
|
+
ssh 10.42.0.0 255.255.0.0 management
|
480
|
+
console timeout 0
|
481
|
+
threat-detection basic-threat
|
482
|
+
threat-detection statistics access-list
|
483
|
+
no threat-detection statistics tcp-intercept
|
484
|
+
ntp server 10.42.42.11 source management prefer
|
485
|
+
username oxidized password $sha512$5000$AAAAAAAAAABBBBBBBBBBCCCCCCCCCC== pbkdf2
|
486
|
+
!
|
487
|
+
class-map inspection_default
|
488
|
+
match default-inspection-traffic
|
489
|
+
!
|
490
|
+
!
|
491
|
+
policy-map type inspect dns preset_dns_map
|
492
|
+
parameters
|
493
|
+
message-length maximum client auto
|
494
|
+
message-length maximum 512
|
495
|
+
no tcp-inspection
|
496
|
+
policy-map global_policy
|
497
|
+
class inspection_default
|
498
|
+
inspect dns preset_dns_map\x20
|
499
|
+
inspect ftp\x20
|
500
|
+
inspect h323 h225\x20
|
501
|
+
inspect h323 ras\x20
|
502
|
+
inspect ip-options\x20
|
503
|
+
inspect netbios\x20
|
504
|
+
inspect rsh\x20
|
505
|
+
inspect rtsp\x20
|
506
|
+
inspect skinny \x20
|
507
|
+
inspect esmtp\x20
|
508
|
+
inspect sqlnet\x20
|
509
|
+
inspect sunrpc\x20
|
510
|
+
inspect tftp\x20
|
511
|
+
inspect sip \x20
|
512
|
+
inspect xdmcp\x20
|
513
|
+
inspect icmp\x20
|
514
|
+
!
|
515
|
+
service-policy global_policy global
|
516
|
+
prompt hostname context\x20
|
517
|
+
no call-home reporting anonymous
|
518
|
+
call-home
|
519
|
+
profile CiscoTAC-1
|
520
|
+
no active
|
521
|
+
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
|
522
|
+
destination address email callhome@cisco.com
|
523
|
+
destination transport-method http
|
524
|
+
subscribe-to-alert-group diagnostic
|
525
|
+
subscribe-to-alert-group environment
|
526
|
+
subscribe-to-alert-group inventory periodic monthly 1
|
527
|
+
subscribe-to-alert-group configuration periodic monthly 1
|
528
|
+
subscribe-to-alert-group telemetry periodic daily
|
529
|
+
password encryption aes
|
530
|
+
Cryptochecksum:dddddddddffffffffffffffeeeeeeeee\n
|
531
|
+
# End of YAML
|