oxidized 0.30.1 → 0.31.0
Sign up to get free protection for your applications and to get access to all the features.
- checksums.yaml +4 -4
- data/.github/workflows/ruby.yml +2 -2
- data/.github/workflows/stale.yml +4 -2
- data/.rubocop.yml +18 -2
- data/.rubocop_todo.yml +5 -12
- data/CHANGELOG.md +61 -1
- data/CONTRIBUTING.md +5 -0
- data/Dockerfile +82 -21
- data/README.md +5 -21
- data/Rakefile +3 -2
- data/docs/Configuration.md +36 -12
- data/docs/Creating-Models.md +45 -4
- data/docs/Hooks.md +34 -0
- data/docs/Issues.md +91 -0
- data/docs/Model-Notes/Cumulus.md +5 -0
- data/docs/Model-Notes/FSOS.md +5 -0
- data/docs/Model-Notes/FortiOS.md +21 -5
- data/docs/Model-Notes/HPEAruba.md +31 -0
- data/docs/Model-Notes/OS6.md +10 -0
- data/docs/Model-Notes/RouterOS.md +15 -0
- data/docs/Model-Notes/SikluMHTG.md +7 -0
- data/docs/Outputs.md +2 -0
- data/docs/Release.md +18 -15
- data/docs/Sources.md +21 -0
- data/docs/Supported-OS-Types.md +11 -5
- data/docs/Troubleshooting.md +35 -0
- data/examples/device-simulation/README.md +173 -0
- data/examples/device-simulation/cmdsets/aoscx +9 -0
- data/examples/device-simulation/cmdsets/arubainstant +5 -0
- data/examples/device-simulation/cmdsets/asa +7 -0
- data/examples/device-simulation/cmdsets/ios +7 -0
- data/examples/device-simulation/cmdsets/nxos +5 -0
- data/examples/device-simulation/cmdsets/routeros +5 -0
- data/examples/device-simulation/cmdsets/srosmd +11 -0
- data/examples/device-simulation/device2yaml.rb +225 -0
- data/examples/device-simulation/yaml/aoscx_R0X25A-6410_FL.10.10.1100.yaml +2281 -0
- data/examples/device-simulation/yaml/aoscx_R8N85A-C6000-48G-CL4_PL.10.08.1010.yaml +451 -0
- data/examples/device-simulation/yaml/arubainstant_IAP515_8.10.0.6_VWLC.yaml +213 -0
- data/examples/device-simulation/yaml/asa_5512_9.12-4-67_single-context.yaml +531 -0
- data/examples/device-simulation/yaml/asr920_16.8.1b.yaml +1122 -0
- data/examples/device-simulation/yaml/garderos_R7709_003_006_068.yaml +101 -0
- data/examples/device-simulation/yaml/iosxe_C9200L-24P-4G_17.09.04a.yaml +514 -0
- data/examples/device-simulation/yaml/iosxe_C9800-L-F-K9_17.06.05.yaml +417 -0
- data/examples/device-simulation/yaml/riverbed_915.yaml +123 -0
- data/examples/device-simulation/yaml/routeros_CHR_7.10.1.yaml +145 -0
- data/examples/device-simulation/yaml/routeros_CHR_7.16.yaml +79 -0
- data/examples/device-simulation/yaml/routeros_L009UiGS_7.15.2.yaml +353 -0
- data/examples/podman-compose/Makefile +60 -17
- data/examples/podman-compose/README.md +63 -27
- data/examples/podman-compose/docker-compose.yml +11 -2
- data/examples/podman-compose/gitserver/.gitignore +1 -0
- data/examples/podman-compose/gitserver/Dockerfile +14 -0
- data/examples/podman-compose/model-simulation/Dockerfile-model +1 -1
- data/examples/podman-compose/model-simulation/asternos.sh +2 -0
- data/examples/podman-compose/oxidized-config/.gitignore +2 -0
- data/examples/podman-compose/oxidized-config/config +1 -1
- data/examples/podman-compose/oxidized-config/config_csv-file +46 -0
- data/examples/podman-compose/oxidized-config/config_csv-gitserver +56 -0
- data/examples/podman-compose/oxidized-ssh/.gitignore +1 -0
- data/lib/oxidized/config.rb +7 -1
- data/lib/oxidized/hook/githubrepo.rb +37 -7
- data/lib/oxidized/hook/slackdiff.rb +29 -7
- data/lib/oxidized/input/http.rb +1 -0
- data/lib/oxidized/input/telnet.rb +1 -1
- data/lib/oxidized/manager.rb +17 -16
- data/lib/oxidized/model/aoscx.rb +16 -2
- data/lib/oxidized/model/aosw.rb +7 -1
- data/lib/oxidized/model/arubainstant.rb +90 -0
- data/lib/oxidized/model/audiocodes.rb +2 -2
- data/lib/oxidized/model/cnos.rb +13 -10
- data/lib/oxidized/model/cumulus.rb +3 -0
- data/lib/oxidized/model/dlink.rb +1 -0
- data/lib/oxidized/model/dlinknextgen.rb +3 -0
- data/lib/oxidized/model/edgecos.rb +2 -1
- data/lib/oxidized/model/eos.rb +2 -0
- data/lib/oxidized/model/f5os.rb +17 -0
- data/lib/oxidized/model/firewareos.rb +10 -1
- data/lib/oxidized/model/fortios.rb +24 -1
- data/lib/oxidized/model/garderos.rb +43 -0
- data/lib/oxidized/model/h3c.rb +1 -1
- data/lib/oxidized/model/ibos.rb +1 -0
- data/lib/oxidized/model/ios.rb +20 -12
- data/lib/oxidized/model/iosxr.rb +1 -1
- data/lib/oxidized/model/lenovonos.rb +2 -0
- data/lib/oxidized/model/linuxgeneric.rb +1 -1
- data/lib/oxidized/model/netgear.rb +1 -1
- data/lib/oxidized/model/nodegrid.rb +1 -1
- data/lib/oxidized/model/nsxdfw.rb +30 -0
- data/lib/oxidized/model/nxos.rb +2 -1
- data/lib/oxidized/model/os6.rb +48 -0
- data/lib/oxidized/model/rgos.rb +1 -1
- data/lib/oxidized/model/riverbed.rb +104 -0
- data/lib/oxidized/model/routeros.rb +2 -2
- data/lib/oxidized/model/saos.rb +18 -1
- data/lib/oxidized/model/siklumhtg.rb +22 -0
- data/lib/oxidized/model/uplinkolt.rb +46 -0
- data/lib/oxidized/model/vyatta.rb +2 -2
- data/lib/oxidized/model/xos.rb +7 -0
- data/lib/oxidized/node.rb +30 -18
- data/lib/oxidized/nodes.rb +13 -5
- data/lib/oxidized/output/file.rb +45 -42
- data/lib/oxidized/output/git.rb +185 -160
- data/lib/oxidized/output/gitcrypt.rb +188 -186
- data/lib/oxidized/output/http.rb +53 -51
- data/lib/oxidized/output/output.rb +6 -4
- data/lib/oxidized/source/csv.rb +44 -49
- data/lib/oxidized/source/http.rb +63 -81
- data/lib/oxidized/source/jsonfile.rb +63 -0
- data/lib/oxidized/source/source.rb +43 -18
- data/lib/oxidized/source/sql.rb +66 -59
- data/lib/oxidized/version.rb +2 -2
- data/oxidized.gemspec +22 -16
- metadata +111 -15
@@ -0,0 +1,1122 @@
|
|
1
|
+
---
|
2
|
+
init_prompt: |-
|
3
|
+
|
4
|
+
*******************************************************************************
|
5
|
+
\x204. The information contained in this computer network is confidential and
|
6
|
+
\x20 must not be disclosed to unauthorised persons. Unauthorised disclosure,
|
7
|
+
\x20 system disruption or any unauthorised modification may lead to prosecution.
|
8
|
+
\x205. Details of all transactions and accesses including user-ids, are
|
9
|
+
\x20 automatically recorded by the computer network and can be retrieved for
|
10
|
+
\x20 audit purposes. By accessing and using this computer network you are
|
11
|
+
\x20 consenting to security monitoring.
|
12
|
+
********************************************************************************
|
13
|
+
hostname#
|
14
|
+
commands:
|
15
|
+
terminal length 0: |-
|
16
|
+
terminal length 0
|
17
|
+
hostname#
|
18
|
+
terminal width 0: |-
|
19
|
+
terminal width 0
|
20
|
+
hostname#
|
21
|
+
show version: |-
|
22
|
+
show version
|
23
|
+
Cisco IOS XE Software, Version 16.08.01b
|
24
|
+
Cisco IOS Software [Fuji], ASR920 Software (PPC_LINUX_IOSD-UNIVERSALK9_NPE-M), Version 16.8.1b, RELEASE SOFTWARE (fc1)
|
25
|
+
Technical Support: http://www.cisco.com/techsupport
|
26
|
+
Copyright (c) 1986-2018 by Cisco Systems, Inc.
|
27
|
+
Compiled Sat 14-Apr-18 12:07 by mcpre
|
28
|
+
|
29
|
+
|
30
|
+
Cisco IOS-XE software, Copyright (c) 2005-2018 by cisco Systems, Inc.
|
31
|
+
All rights reserved. Certain components of Cisco IOS-XE software are
|
32
|
+
licensed under the GNU General Public License (\"GPL\") Version 2.0. The
|
33
|
+
software code licensed under GPL Version 2.0 is free software that comes
|
34
|
+
with ABSOLUTELY NO WARRANTY. You can redistribute and/or modify such
|
35
|
+
GPL code under the terms of GPL Version 2.0. For more details, see the
|
36
|
+
documentation or \"License Notice\" file accompanying the IOS-XE software,
|
37
|
+
or the applicable URL provided on the flyer accompanying the IOS-XE
|
38
|
+
software.
|
39
|
+
|
40
|
+
|
41
|
+
ROM: IOS-XE ROMMON
|
42
|
+
|
43
|
+
hostname uptime is 20 weeks, 1 day, 1 hour, 40 minutes
|
44
|
+
Uptime for this control processor is 20 weeks, 1 day, 1 hour, 44 minutes
|
45
|
+
System returned to ROM by reload
|
46
|
+
System restarted at 12:47:37 UTC Mon Jun 17 2024
|
47
|
+
System image file is \"bootflash:/asr920-universalk9_npe.16.08.01b.SPA.bin\"
|
48
|
+
Last reload reason: OPS-51606
|
49
|
+
|
50
|
+
|
51
|
+
|
52
|
+
This product contains cryptographic features and is subject to United
|
53
|
+
States and local country laws governing import, export, transfer and
|
54
|
+
use. Delivery of Cisco cryptographic products does not imply
|
55
|
+
third-party authority to import, export, distribute or use encryption.
|
56
|
+
Importers, exporters, distributors and users are responsible for
|
57
|
+
compliance with U.S. and local country laws. By using this product you
|
58
|
+
agree to comply with applicable laws and regulations. If you are unable
|
59
|
+
to comply with U.S. and local laws, return this product immediately.
|
60
|
+
|
61
|
+
A summary of U.S. laws governing Cisco cryptographic products may be found at:
|
62
|
+
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
|
63
|
+
|
64
|
+
If you require further assistance please contact us by sending email to
|
65
|
+
export@cisco.com.
|
66
|
+
|
67
|
+
License Level: advancedmetroipaccess
|
68
|
+
License Type: Permanent
|
69
|
+
Next reload license Level: advancedmetroipaccess
|
70
|
+
|
71
|
+
cisco ASR-920-24TZ-M (Freescale P2020) processor (revision 1.2 GHz) with 900278K/6147K bytes of memory.
|
72
|
+
Processor board ID CAT12345699
|
73
|
+
24 Gigabit Ethernet interfaces
|
74
|
+
4 Ten Gigabit Ethernet interfaces
|
75
|
+
32768K bytes of non-volatile configuration memory.
|
76
|
+
3670016K bytes of physical memory.
|
77
|
+
1231647K bytes of SD flash at bootflash:.
|
78
|
+
|
79
|
+
Configuration register is 0x2102
|
80
|
+
|
81
|
+
hostname#
|
82
|
+
show vtp status: |-
|
83
|
+
show vtp status
|
84
|
+
show vtp status
|
85
|
+
\x20 ^
|
86
|
+
% Invalid input detected at '^' marker.
|
87
|
+
|
88
|
+
hostname#
|
89
|
+
show inventory: |-
|
90
|
+
show inventory
|
91
|
+
NAME: \"Chassis\", DESCR: \"Cisco ASR920 Series - 24GE Copper and 4-10GE - Modular PSU\"
|
92
|
+
PID: ASR-920-24TZ-M , VID: V01 , SN: abcdefgh
|
93
|
+
|
94
|
+
NAME: \"Power Supply Module 0\", DESCR: \"ASR 920 250W DC Power Supply\"
|
95
|
+
PID: ASR-920-PWR-D , VID: V01 , SN: abcdefgh
|
96
|
+
|
97
|
+
NAME: \"Power Supply Module 1\", DESCR: \"ASR 920 250W DC Power Supply\"
|
98
|
+
PID: ASR-920-PWR-D , VID: V01 , SN: abcdefgh
|
99
|
+
|
100
|
+
NAME: \"Fan Tray\", DESCR: \"ASR 920 Fan tray\"
|
101
|
+
PID: ASR-920-FAN-F , VID: V01 , SN: ab12cdefgh
|
102
|
+
|
103
|
+
|
104
|
+
hostname#
|
105
|
+
show running-config: |-
|
106
|
+
show running-config
|
107
|
+
Building configuration...
|
108
|
+
|
109
|
+
Current configuration : 16734 bytes
|
110
|
+
!
|
111
|
+
! Last configuration change at 11:54:34 UTC Thu Aug 29 2024 by 123456
|
112
|
+
!
|
113
|
+
version 16.8
|
114
|
+
no service pad
|
115
|
+
service tcp-keepalives-in
|
116
|
+
service tcp-keepalives-out
|
117
|
+
service timestamps debug datetime msec localtime show-timezone
|
118
|
+
service timestamps log datetime msec localtime show-timezone
|
119
|
+
service password-encryption
|
120
|
+
service sequence-numbers
|
121
|
+
no platform punt-keepalive disable-kernel-core
|
122
|
+
platform bfd-debug-trace 1
|
123
|
+
platform xconnect load-balance-hash-algo mac-ip-instanceid
|
124
|
+
platform tcam-parity-error enable
|
125
|
+
platform tcam-threshold alarm-frequency 1
|
126
|
+
!
|
127
|
+
hostname hostname
|
128
|
+
!
|
129
|
+
boot-start-marker
|
130
|
+
boot-end-marker
|
131
|
+
!
|
132
|
+
!
|
133
|
+
vrf definition Mgmt-intf
|
134
|
+
\x20!
|
135
|
+
\x20address-family ipv4
|
136
|
+
\x20exit-address-family
|
137
|
+
\x20!
|
138
|
+
\x20address-family ipv6
|
139
|
+
\x20exit-address-family
|
140
|
+
!
|
141
|
+
security passwords min-length 8
|
142
|
+
logging buffered 200000
|
143
|
+
enable secret 5 password
|
144
|
+
!
|
145
|
+
aaa new-model
|
146
|
+
!
|
147
|
+
!
|
148
|
+
aaa group server tacacs+ DES_ACS_GROUP
|
149
|
+
\x20server-private 111.111.111.111 key 7 ABCDEFGH1234
|
150
|
+
\x20server-private 111.111.111.111 key 7 ABCDEFGH1234
|
151
|
+
\x20server-private 111.111.111.111 key 7 ABCDEFGH1234
|
152
|
+
\x20ip tacacs source-interface Loopback9
|
153
|
+
!
|
154
|
+
aaa authentication login default local group DES_ACS_GROUP
|
155
|
+
aaa authentication login console local group DES_ACS_GROUP
|
156
|
+
aaa authentication enable default group DES_ACS_GROUP enable
|
157
|
+
aaa authorization console
|
158
|
+
aaa authorization config-commands
|
159
|
+
aaa authorization exec default local group DES_ACS_GROUP none\x20
|
160
|
+
aaa authorization commands 0 default group DES_ACS_GROUP none\x20
|
161
|
+
aaa authorization commands 1 default group DES_ACS_GROUP none\x20
|
162
|
+
aaa authorization commands 15 default local group DES_ACS_GROUP none\x20
|
163
|
+
aaa accounting exec default
|
164
|
+
\x20action-type start-stop
|
165
|
+
\x20group DES_ACS_GROUP
|
166
|
+
!
|
167
|
+
aaa accounting commands 0 default
|
168
|
+
\x20action-type start-stop
|
169
|
+
\x20group DES_ACS_GROUP
|
170
|
+
!
|
171
|
+
aaa accounting commands 1 default
|
172
|
+
\x20action-type start-stop
|
173
|
+
\x20group DES_ACS_GROUP
|
174
|
+
!
|
175
|
+
aaa accounting commands 15 default
|
176
|
+
\x20action-type start-stop
|
177
|
+
\x20group DES_ACS_GROUP
|
178
|
+
!
|
179
|
+
aaa accounting network default start-stop group DES_ACS_GROUP
|
180
|
+
!
|
181
|
+
!
|
182
|
+
!
|
183
|
+
!
|
184
|
+
!
|
185
|
+
aaa session-id common
|
186
|
+
clock timezone UTC 10 0
|
187
|
+
no ip source-route
|
188
|
+
!
|
189
|
+
!
|
190
|
+
!
|
191
|
+
!
|
192
|
+
!
|
193
|
+
!
|
194
|
+
!
|
195
|
+
no ip bootp server
|
196
|
+
ip name-server 111.111.111.111 111.111.111.111
|
197
|
+
no ip domain lookup
|
198
|
+
ip domain name abcd.abcd
|
199
|
+
ip multicast-routing distributed
|
200
|
+
ip dhcp smart-relay
|
201
|
+
!
|
202
|
+
!
|
203
|
+
!
|
204
|
+
login block-for 15 attempts 3 within 15
|
205
|
+
!
|
206
|
+
!
|
207
|
+
!
|
208
|
+
!
|
209
|
+
!
|
210
|
+
!
|
211
|
+
!
|
212
|
+
!
|
213
|
+
!
|
214
|
+
multilink bundle-name authenticated
|
215
|
+
!
|
216
|
+
!
|
217
|
+
!
|
218
|
+
license udi pid ASR-920-24TZ-M sn 12334456
|
219
|
+
no license smart enable
|
220
|
+
archive
|
221
|
+
\x20log config
|
222
|
+
\x20 hidekeys
|
223
|
+
!
|
224
|
+
!
|
225
|
+
spanning-tree extend system-id
|
226
|
+
sdm prefer default\x20
|
227
|
+
diagnostic bootup level minimal
|
228
|
+
!
|
229
|
+
!
|
230
|
+
username root secret 5 password
|
231
|
+
!
|
232
|
+
redundancy
|
233
|
+
!
|
234
|
+
!
|
235
|
+
!
|
236
|
+
!
|
237
|
+
!
|
238
|
+
transceiver type all
|
239
|
+
\x20monitoring
|
240
|
+
!
|
241
|
+
lldp run
|
242
|
+
!
|
243
|
+
!
|
244
|
+
class-map match-any RoIP-RTP-Class-In
|
245
|
+
\x20 description: test 123
|
246
|
+
\x20match access-group name RoIP-RTP-Class
|
247
|
+
class-map match-all RoIP-RTP-Class-Out
|
248
|
+
\x20 description: test 123
|
249
|
+
\x20match dscp 45\x20
|
250
|
+
class-map match-all Routing-and-Control
|
251
|
+
\x20 description: test 123
|
252
|
+
\x20match dscp cs6\x20
|
253
|
+
!
|
254
|
+
!
|
255
|
+
!
|
256
|
+
!
|
257
|
+
interface Loopback9
|
258
|
+
\x20description: test 123
|
259
|
+
\x20ip address 111.111.111.111 111.111.111.111
|
260
|
+
!
|
261
|
+
interface GigabitEthernet0/0/0
|
262
|
+
\x20no ip address
|
263
|
+
\x20shutdown
|
264
|
+
\x20negotiation auto
|
265
|
+
!
|
266
|
+
interface GigabitEthernet0/0/1
|
267
|
+
\x20description: test 123
|
268
|
+
\x20bandwidth 100000
|
269
|
+
\x20no ip address
|
270
|
+
\x20negotiation auto
|
271
|
+
\x20service-policy output shape-all
|
272
|
+
\x20service instance 2 ethernet
|
273
|
+
\x20 encapsulation untagged
|
274
|
+
\x20 bridge-domain 2
|
275
|
+
\x20!
|
276
|
+
!
|
277
|
+
interface GigabitEthernet0/0/2
|
278
|
+
\x20description: test 123
|
279
|
+
\x20bandwidth 100000
|
280
|
+
\x20no ip address
|
281
|
+
\x20negotiation auto
|
282
|
+
\x20service-policy output shape-all
|
283
|
+
\x20service instance 3 ethernet
|
284
|
+
\x20 encapsulation untagged
|
285
|
+
\x20 bridge-domain 3
|
286
|
+
\x20!
|
287
|
+
!
|
288
|
+
interface GigabitEthernet0/0/3
|
289
|
+
\x20description: test 123
|
290
|
+
\x20bandwidth 100000
|
291
|
+
\x20no ip address
|
292
|
+
\x20negotiation auto
|
293
|
+
\x20service-policy output shape-all
|
294
|
+
\x20service instance 4 ethernet
|
295
|
+
\x20 encapsulation untagged
|
296
|
+
\x20 bridge-domain 4
|
297
|
+
\x20!
|
298
|
+
!
|
299
|
+
interface GigabitEthernet0/0/4
|
300
|
+
\x20no ip address
|
301
|
+
\x20shutdown
|
302
|
+
\x20negotiation auto
|
303
|
+
!
|
304
|
+
interface GigabitEthernet0/0/5
|
305
|
+
\x20no ip address
|
306
|
+
\x20shutdown
|
307
|
+
\x20negotiation auto
|
308
|
+
!
|
309
|
+
interface GigabitEthernet0/0/6
|
310
|
+
\x20description: test 123
|
311
|
+
\x20no ip address
|
312
|
+
\x20negotiation auto
|
313
|
+
\x20service-policy input Classification-Marking-In
|
314
|
+
\x20service instance 99 ethernet
|
315
|
+
\x20 encapsulation untagged
|
316
|
+
\x20 bridge-domain 99
|
317
|
+
\x20!
|
318
|
+
!
|
319
|
+
interface GigabitEthernet0/0/7
|
320
|
+
\x20no ip address
|
321
|
+
\x20shutdown
|
322
|
+
\x20negotiation auto
|
323
|
+
!
|
324
|
+
interface GigabitEthernet0/0/8
|
325
|
+
\x20no ip address
|
326
|
+
\x20shutdown
|
327
|
+
\x20negotiation auto
|
328
|
+
!
|
329
|
+
interface GigabitEthernet0/0/9
|
330
|
+
\x20no ip address
|
331
|
+
\x20shutdown
|
332
|
+
\x20negotiation auto
|
333
|
+
!
|
334
|
+
interface GigabitEthernet0/0/10
|
335
|
+
\x20description: test 123
|
336
|
+
\x20no ip address
|
337
|
+
\x20negotiation auto
|
338
|
+
\x20service-policy input Classification-Marking-In
|
339
|
+
\x20service instance 99 ethernet
|
340
|
+
\x20 encapsulation untagged
|
341
|
+
\x20 bridge-domain 99
|
342
|
+
\x20!
|
343
|
+
!
|
344
|
+
interface GigabitEthernet0/0/11
|
345
|
+
\x20no ip address
|
346
|
+
\x20shutdown
|
347
|
+
\x20negotiation auto
|
348
|
+
!
|
349
|
+
interface GigabitEthernet0/0/12
|
350
|
+
\x20no ip address
|
351
|
+
\x20shutdown
|
352
|
+
\x20negotiation auto
|
353
|
+
!
|
354
|
+
interface GigabitEthernet0/0/13
|
355
|
+
\x20no ip address
|
356
|
+
\x20shutdown
|
357
|
+
\x20negotiation auto
|
358
|
+
!
|
359
|
+
interface GigabitEthernet0/0/14
|
360
|
+
\x20no ip address
|
361
|
+
\x20negotiation auto
|
362
|
+
\x20service-policy input Classification-Marking-In
|
363
|
+
\x20service instance 99 ethernet
|
364
|
+
\x20 description: test 123
|
365
|
+
\x20 encapsulation untagged
|
366
|
+
\x20 bridge-domain 99
|
367
|
+
\x20!
|
368
|
+
!
|
369
|
+
interface GigabitEthernet0/0/15
|
370
|
+
\x20no ip address
|
371
|
+
\x20shutdown
|
372
|
+
\x20negotiation auto
|
373
|
+
!
|
374
|
+
interface GigabitEthernet0/0/16
|
375
|
+
\x20no ip address
|
376
|
+
\x20shutdown
|
377
|
+
\x20negotiation auto
|
378
|
+
!
|
379
|
+
interface GigabitEthernet0/0/17
|
380
|
+
\x20description: test 123
|
381
|
+
\x20no ip address
|
382
|
+
\x20negotiation auto
|
383
|
+
\x20service-policy input Classification-Marking-In
|
384
|
+
\x20service instance 99 ethernet
|
385
|
+
\x20 encapsulation untagged
|
386
|
+
\x20 bridge-domain 99
|
387
|
+
\x20!
|
388
|
+
!
|
389
|
+
interface GigabitEthernet0/0/18
|
390
|
+
\x20description: test 123
|
391
|
+
\x20no ip address
|
392
|
+
\x20negotiation auto
|
393
|
+
\x20service-policy input Classification-Marking-In
|
394
|
+
\x20service instance 99 ethernet
|
395
|
+
\x20 encapsulation untagged
|
396
|
+
\x20 bridge-domain 99
|
397
|
+
\x20!
|
398
|
+
!
|
399
|
+
interface GigabitEthernet0/0/19
|
400
|
+
\x20no ip address
|
401
|
+
\x20shutdown
|
402
|
+
\x20negotiation auto
|
403
|
+
!
|
404
|
+
interface GigabitEthernet0/0/20
|
405
|
+
\x20no ip address
|
406
|
+
\x20shutdown
|
407
|
+
\x20negotiation auto
|
408
|
+
!
|
409
|
+
interface GigabitEthernet0/0/21
|
410
|
+
\x20no ip address
|
411
|
+
\x20shutdown
|
412
|
+
\x20negotiation auto
|
413
|
+
!
|
414
|
+
interface GigabitEthernet0/0/22
|
415
|
+
\x20description: test 123
|
416
|
+
\x20no ip address
|
417
|
+
\x20shutdown
|
418
|
+
\x20negotiation auto
|
419
|
+
\x20service instance 99 ethernet
|
420
|
+
\x20 encapsulation untagged
|
421
|
+
\x20 bridge-domain 99
|
422
|
+
\x20!
|
423
|
+
!
|
424
|
+
interface GigabitEthernet0/0/23
|
425
|
+
\x20description: test 123
|
426
|
+
\x20no ip address
|
427
|
+
\x20negotiation auto
|
428
|
+
\x20service instance 99 ethernet
|
429
|
+
\x20 encapsulation untagged
|
430
|
+
\x20 bridge-domain 99
|
431
|
+
\x20!
|
432
|
+
!
|
433
|
+
interface TenGigabitEthernet0/0/24
|
434
|
+
\x20no ip address
|
435
|
+
\x20shutdown
|
436
|
+
!
|
437
|
+
interface TenGigabitEthernet0/0/25
|
438
|
+
\x20no ip address
|
439
|
+
\x20shutdown
|
440
|
+
!
|
441
|
+
interface TenGigabitEthernet0/0/26
|
442
|
+
\x20no ip address
|
443
|
+
\x20shutdown
|
444
|
+
!
|
445
|
+
interface TenGigabitEthernet0/0/27
|
446
|
+
\x20no ip address
|
447
|
+
\x20shutdown
|
448
|
+
!
|
449
|
+
interface GigabitEthernet0
|
450
|
+
\x20vrf forwarding Mgmt-intf
|
451
|
+
\x20no ip address
|
452
|
+
\x20shutdown
|
453
|
+
\x20negotiation auto
|
454
|
+
!
|
455
|
+
!
|
456
|
+
ip access-list standard auth-SNMP
|
457
|
+
\x20permit 111.111.111.111
|
458
|
+
\x20permit 111.111.111.111
|
459
|
+
\x20permit 111.111.111.111 111.111.111.111
|
460
|
+
\x20deny any log
|
461
|
+
ip access-list standard auth-SNMPV2
|
462
|
+
\x20permit 111.111.111.111
|
463
|
+
\x20permit 111.111.111.111
|
464
|
+
\x20permit 111.111.111.111 111.111.111.111
|
465
|
+
\x20deny any log
|
466
|
+
ip access-list standard auth-SSH
|
467
|
+
\x20permit 111.111.111.111
|
468
|
+
\x20permit 111.111.111.111
|
469
|
+
\x20permit 111.111.111.111 111.111.111.111
|
470
|
+
\x20permit 111.111.111.111 111.111.111.111
|
471
|
+
\x20permit 111.111.111.111 111.111.111.111
|
472
|
+
\x20deny any log
|
473
|
+
!
|
474
|
+
!
|
475
|
+
logging origin-id hostname
|
476
|
+
logging facility local6
|
477
|
+
logging source-interface Loopback9
|
478
|
+
logging host 111.111.111.111
|
479
|
+
!
|
480
|
+
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
|
481
|
+
snmp-server enable traps vrrp
|
482
|
+
snmp-server enable traps ds1
|
483
|
+
snmp-server enable traps ds3
|
484
|
+
snmp-server enable traps call-home message-send-fail server-fail
|
485
|
+
snmp-server enable traps tty
|
486
|
+
snmp-server enable traps eigrp
|
487
|
+
snmp-server enable traps ospf state-change
|
488
|
+
snmp-server enable traps ospf errors
|
489
|
+
snmp-server enable traps ospf retransmit
|
490
|
+
snmp-server enable traps ospf lsa
|
491
|
+
snmp-server enable traps ospf cisco-specific state-change nssa-trans-change
|
492
|
+
snmp-server enable traps ospf cisco-specific state-change shamlink interface
|
493
|
+
snmp-server enable traps ospf cisco-specific state-change shamlink neighbor
|
494
|
+
snmp-server enable traps ospf cisco-specific errors
|
495
|
+
snmp-server enable traps ospf cisco-specific retransmit
|
496
|
+
snmp-server enable traps ospf cisco-specific lsa
|
497
|
+
snmp-server enable traps license
|
498
|
+
snmp-server enable traps smart-license
|
499
|
+
snmp-server enable traps ike policy add
|
500
|
+
snmp-server enable traps ike policy delete
|
501
|
+
snmp-server enable traps ike tunnel start
|
502
|
+
snmp-server enable traps ike tunnel stop
|
503
|
+
snmp-server enable traps ipsec cryptomap add
|
504
|
+
snmp-server enable traps ipsec cryptomap delete
|
505
|
+
snmp-server enable traps ipsec cryptomap attach
|
506
|
+
snmp-server enable traps ipsec cryptomap detach
|
507
|
+
snmp-server enable traps ipsec tunnel start
|
508
|
+
snmp-server enable traps ipsec tunnel stop
|
509
|
+
snmp-server enable traps ipsec too-many-sas
|
510
|
+
snmp-server enable traps atm subif
|
511
|
+
snmp-server enable traps bfd
|
512
|
+
snmp-server enable traps bgp cbgp2
|
513
|
+
snmp-server enable traps config-copy
|
514
|
+
snmp-server enable traps config
|
515
|
+
snmp-server enable traps config-ctid
|
516
|
+
snmp-server enable traps dhcp
|
517
|
+
snmp-server enable traps otn
|
518
|
+
snmp-server enable traps event-manager
|
519
|
+
snmp-server enable traps hsrp
|
520
|
+
snmp-server enable traps pimstdmib neighbor-loss invalid-register invalid-join-prune rp-mapping-change interface-election
|
521
|
+
snmp-server enable traps ipmulticast
|
522
|
+
snmp-server enable traps isis
|
523
|
+
snmp-server enable traps msdp
|
524
|
+
snmp-server enable traps ospfv3 state-change
|
525
|
+
snmp-server enable traps ospfv3 errors
|
526
|
+
snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message
|
527
|
+
snmp-server enable traps ipsla
|
528
|
+
snmp-server enable traps bridge newroot topologychange
|
529
|
+
snmp-server enable traps stpx inconsistency root-inconsistency loop-inconsistency
|
530
|
+
snmp-server enable traps syslog
|
531
|
+
snmp-server enable traps pki
|
532
|
+
snmp-server enable traps adslline
|
533
|
+
snmp-server enable traps vdsl2line
|
534
|
+
snmp-server enable traps ether-oam
|
535
|
+
snmp-server enable traps ethernet cfm cc mep-up mep-down cross-connect loop config
|
536
|
+
snmp-server enable traps ethernet cfm crosscheck mep-missing mep-unknown service-up
|
537
|
+
snmp-server enable traps memory bufferpeak
|
538
|
+
snmp-server enable traps entity-state
|
539
|
+
snmp-server enable traps fru-ctrl
|
540
|
+
snmp-server enable traps entity
|
541
|
+
snmp-server enable traps cpu threshold
|
542
|
+
snmp-server enable traps rep
|
543
|
+
snmp-server enable traps vtp
|
544
|
+
snmp-server enable traps vlancreate
|
545
|
+
snmp-server enable traps vlandelete
|
546
|
+
snmp-server enable traps sonet
|
547
|
+
snmp-server enable traps cef resource-failure peer-state-change peer-fib-state-change inconsistency
|
548
|
+
snmp-server enable traps lisp
|
549
|
+
snmp-server enable traps entity-sensor
|
550
|
+
snmp-server enable traps resource-policy
|
551
|
+
snmp-server enable traps flash insertion removal lowspace
|
552
|
+
snmp-server enable traps netsync
|
553
|
+
snmp-server enable traps rsvp
|
554
|
+
snmp-server enable traps cnpd
|
555
|
+
!
|
556
|
+
tacacs-server timeout 3
|
557
|
+
!
|
558
|
+
!
|
559
|
+
!
|
560
|
+
control-plane
|
561
|
+
!
|
562
|
+
banner motd ^C
|
563
|
+
*******************************************************************************
|
564
|
+
\x204. The information contained in this computer network is confidential and
|
565
|
+
\x20 must not be disclosed to unauthorised persons. Unauthorised disclosure,
|
566
|
+
\x20 system disruption or any unauthorised modification may lead to prosecution.
|
567
|
+
\x205. Details of all transactions and accesses including user-ids, are
|
568
|
+
\x20 automatically recorded by the computer network and can be retrieved for
|
569
|
+
\x20 audit purposes. By accessing and using this computer network you are
|
570
|
+
\x20 consenting to security monitoring.
|
571
|
+
********************************************************************************
|
572
|
+
^C
|
573
|
+
!
|
574
|
+
line con 0
|
575
|
+
\x20exec-timeout 20 0
|
576
|
+
\x20logging synchronous
|
577
|
+
\x20history size 50
|
578
|
+
\x20transport preferred none
|
579
|
+
\x20transport output none
|
580
|
+
\x20stopbits 1
|
581
|
+
line aux 0
|
582
|
+
\x20no exec
|
583
|
+
\x20stopbits 1
|
584
|
+
line vty 0 4
|
585
|
+
\x20exec-timeout 20 0
|
586
|
+
\x20logging synchronous
|
587
|
+
\x20history size 50
|
588
|
+
\x20transport input ssh
|
589
|
+
line vty 5 15
|
590
|
+
\x20exec-timeout 20 0
|
591
|
+
\x20logging synchronous
|
592
|
+
\x20history size 50
|
593
|
+
\x20transport input ssh
|
594
|
+
!
|
595
|
+
ntp server 111.111.111.111
|
596
|
+
ntp server 111.111.111.111
|
597
|
+
!
|
598
|
+
|
599
|
+
!
|
600
|
+
end
|
601
|
+
|
602
|
+
hostname#
|
603
|
+
exit: |-
|
604
|
+
oxidized_output: |
|
605
|
+
! Cisco IOS XE Software, Version 16.08.01b
|
606
|
+
!\x20
|
607
|
+
! Image: Software: PPC_LINUX_IOSD-UNIVERSALK9_NPE-M, 16.8.1b, RELEASE SOFTWARE (fc1)
|
608
|
+
! Image: Compiled: Sat 14-Apr-18 12:07 by mcpre
|
609
|
+
! Image: bootflash:/asr920-universalk9_npe.16.08.01b.SPA.bin
|
610
|
+
! Chassis type: ASR-920-24TZ-M
|
611
|
+
! Memory: main 900278K/6147K
|
612
|
+
! Processor ID: CAT12345699
|
613
|
+
! CPU: Freescale P2020
|
614
|
+
! Memory: nvram 32768K
|
615
|
+
!\x20
|
616
|
+
! VTP: show vtp status
|
617
|
+
!\x20
|
618
|
+
! NAME: \"Chassis\", DESCR: \"Cisco ASR920 Series - 24GE Copper and 4-10GE - Modular PSU\"
|
619
|
+
! PID: ASR-920-24TZ-M , VID: V01 , SN: abcdefgh
|
620
|
+
!\x20
|
621
|
+
! NAME: \"Power Supply Module 0\", DESCR: \"ASR 920 250W DC Power Supply\"
|
622
|
+
! PID: ASR-920-PWR-D , VID: V01 , SN: abcdefgh
|
623
|
+
!\x20
|
624
|
+
! NAME: \"Power Supply Module 1\", DESCR: \"ASR 920 250W DC Power Supply\"
|
625
|
+
! PID: ASR-920-PWR-D , VID: V01 , SN: abcdefgh
|
626
|
+
!\x20
|
627
|
+
! NAME: \"Fan Tray\", DESCR: \"ASR 920 Fan tray\"
|
628
|
+
! PID: ASR-920-FAN-F , VID: V01 , SN: ab12cdefgh
|
629
|
+
!\x20
|
630
|
+
!\x20
|
631
|
+
!
|
632
|
+
! Last configuration change at 11:54:34 UTC Thu Aug 29 2024 by 123456
|
633
|
+
!
|
634
|
+
version 16.8
|
635
|
+
no service pad
|
636
|
+
service tcp-keepalives-in
|
637
|
+
service tcp-keepalives-out
|
638
|
+
service timestamps debug datetime msec localtime show-timezone
|
639
|
+
service timestamps log datetime msec localtime show-timezone
|
640
|
+
service password-encryption
|
641
|
+
service sequence-numbers
|
642
|
+
no platform punt-keepalive disable-kernel-core
|
643
|
+
platform bfd-debug-trace 1
|
644
|
+
platform xconnect load-balance-hash-algo mac-ip-instanceid
|
645
|
+
platform tcam-parity-error enable
|
646
|
+
platform tcam-threshold alarm-frequency 1
|
647
|
+
!
|
648
|
+
hostname hostname
|
649
|
+
!
|
650
|
+
boot-start-marker
|
651
|
+
boot-end-marker
|
652
|
+
!
|
653
|
+
!
|
654
|
+
vrf definition Mgmt-intf
|
655
|
+
!
|
656
|
+
address-family ipv4
|
657
|
+
exit-address-family
|
658
|
+
!
|
659
|
+
address-family ipv6
|
660
|
+
exit-address-family
|
661
|
+
!
|
662
|
+
security passwords min-length 8
|
663
|
+
logging buffered 200000
|
664
|
+
enable secret 5 password
|
665
|
+
!
|
666
|
+
aaa new-model
|
667
|
+
!
|
668
|
+
!
|
669
|
+
aaa group server tacacs+ DES_ACS_GROUP
|
670
|
+
server-private 111.111.111.111 key 7 ABCDEFGH1234
|
671
|
+
server-private 111.111.111.111 key 7 ABCDEFGH1234
|
672
|
+
server-private 111.111.111.111 key 7 ABCDEFGH1234
|
673
|
+
ip tacacs source-interface Loopback9
|
674
|
+
!
|
675
|
+
aaa authentication login default local group DES_ACS_GROUP
|
676
|
+
aaa authentication login console local group DES_ACS_GROUP
|
677
|
+
aaa authentication enable default group DES_ACS_GROUP enable
|
678
|
+
aaa authorization console
|
679
|
+
aaa authorization config-commands
|
680
|
+
aaa authorization exec default local group DES_ACS_GROUP none\x20
|
681
|
+
aaa authorization commands 0 default group DES_ACS_GROUP none\x20
|
682
|
+
aaa authorization commands 1 default group DES_ACS_GROUP none\x20
|
683
|
+
aaa authorization commands 15 default local group DES_ACS_GROUP none\x20
|
684
|
+
aaa accounting exec default
|
685
|
+
action-type start-stop
|
686
|
+
group DES_ACS_GROUP
|
687
|
+
!
|
688
|
+
aaa accounting commands 0 default
|
689
|
+
action-type start-stop
|
690
|
+
group DES_ACS_GROUP
|
691
|
+
!
|
692
|
+
aaa accounting commands 1 default
|
693
|
+
action-type start-stop
|
694
|
+
group DES_ACS_GROUP
|
695
|
+
!
|
696
|
+
aaa accounting commands 15 default
|
697
|
+
action-type start-stop
|
698
|
+
group DES_ACS_GROUP
|
699
|
+
!
|
700
|
+
aaa accounting network default start-stop group DES_ACS_GROUP
|
701
|
+
!
|
702
|
+
!
|
703
|
+
!
|
704
|
+
!
|
705
|
+
!
|
706
|
+
aaa session-id common
|
707
|
+
clock timezone UTC 10 0
|
708
|
+
no ip source-route
|
709
|
+
!
|
710
|
+
!
|
711
|
+
!
|
712
|
+
!
|
713
|
+
!
|
714
|
+
!
|
715
|
+
!
|
716
|
+
no ip bootp server
|
717
|
+
ip name-server 111.111.111.111 111.111.111.111
|
718
|
+
no ip domain lookup
|
719
|
+
ip domain name abcd.abcd
|
720
|
+
ip multicast-routing distributed
|
721
|
+
ip dhcp smart-relay
|
722
|
+
!
|
723
|
+
!
|
724
|
+
!
|
725
|
+
login block-for 15 attempts 3 within 15
|
726
|
+
!
|
727
|
+
!
|
728
|
+
!
|
729
|
+
!
|
730
|
+
!
|
731
|
+
!
|
732
|
+
!
|
733
|
+
!
|
734
|
+
!
|
735
|
+
multilink bundle-name authenticated
|
736
|
+
!
|
737
|
+
!
|
738
|
+
!
|
739
|
+
license udi pid ASR-920-24TZ-M sn 12334456
|
740
|
+
no license smart enable
|
741
|
+
archive
|
742
|
+
log config
|
743
|
+
hidekeys
|
744
|
+
!
|
745
|
+
!
|
746
|
+
spanning-tree extend system-id
|
747
|
+
sdm prefer default\x20
|
748
|
+
diagnostic bootup level minimal
|
749
|
+
!
|
750
|
+
!
|
751
|
+
username root secret 5 password
|
752
|
+
!
|
753
|
+
redundancy
|
754
|
+
!
|
755
|
+
!
|
756
|
+
!
|
757
|
+
!
|
758
|
+
!
|
759
|
+
transceiver type all
|
760
|
+
monitoring
|
761
|
+
!
|
762
|
+
lldp run
|
763
|
+
!
|
764
|
+
!
|
765
|
+
class-map match-any RoIP-RTP-Class-In
|
766
|
+
description: test 123
|
767
|
+
match access-group name RoIP-RTP-Class
|
768
|
+
class-map match-all RoIP-RTP-Class-Out
|
769
|
+
description: test 123
|
770
|
+
match dscp 45\x20
|
771
|
+
class-map match-all Routing-and-Control
|
772
|
+
description: test 123
|
773
|
+
match dscp cs6\x20
|
774
|
+
!
|
775
|
+
!
|
776
|
+
!
|
777
|
+
!
|
778
|
+
interface Loopback9
|
779
|
+
description: test 123
|
780
|
+
ip address 111.111.111.111 111.111.111.111
|
781
|
+
!
|
782
|
+
interface GigabitEthernet0/0/0
|
783
|
+
no ip address
|
784
|
+
shutdown
|
785
|
+
negotiation auto
|
786
|
+
!
|
787
|
+
interface GigabitEthernet0/0/1
|
788
|
+
description: test 123
|
789
|
+
bandwidth 100000
|
790
|
+
no ip address
|
791
|
+
negotiation auto
|
792
|
+
service-policy output shape-all
|
793
|
+
service instance 2 ethernet
|
794
|
+
encapsulation untagged
|
795
|
+
bridge-domain 2
|
796
|
+
!
|
797
|
+
!
|
798
|
+
interface GigabitEthernet0/0/2
|
799
|
+
description: test 123
|
800
|
+
bandwidth 100000
|
801
|
+
no ip address
|
802
|
+
negotiation auto
|
803
|
+
service-policy output shape-all
|
804
|
+
service instance 3 ethernet
|
805
|
+
encapsulation untagged
|
806
|
+
bridge-domain 3
|
807
|
+
!
|
808
|
+
!
|
809
|
+
interface GigabitEthernet0/0/3
|
810
|
+
description: test 123
|
811
|
+
bandwidth 100000
|
812
|
+
no ip address
|
813
|
+
negotiation auto
|
814
|
+
service-policy output shape-all
|
815
|
+
service instance 4 ethernet
|
816
|
+
encapsulation untagged
|
817
|
+
bridge-domain 4
|
818
|
+
!
|
819
|
+
!
|
820
|
+
interface GigabitEthernet0/0/4
|
821
|
+
no ip address
|
822
|
+
shutdown
|
823
|
+
negotiation auto
|
824
|
+
!
|
825
|
+
interface GigabitEthernet0/0/5
|
826
|
+
no ip address
|
827
|
+
shutdown
|
828
|
+
negotiation auto
|
829
|
+
!
|
830
|
+
interface GigabitEthernet0/0/6
|
831
|
+
description: test 123
|
832
|
+
no ip address
|
833
|
+
negotiation auto
|
834
|
+
service-policy input Classification-Marking-In
|
835
|
+
service instance 99 ethernet
|
836
|
+
encapsulation untagged
|
837
|
+
bridge-domain 99
|
838
|
+
!
|
839
|
+
!
|
840
|
+
interface GigabitEthernet0/0/7
|
841
|
+
no ip address
|
842
|
+
shutdown
|
843
|
+
negotiation auto
|
844
|
+
!
|
845
|
+
interface GigabitEthernet0/0/8
|
846
|
+
no ip address
|
847
|
+
shutdown
|
848
|
+
negotiation auto
|
849
|
+
!
|
850
|
+
interface GigabitEthernet0/0/9
|
851
|
+
no ip address
|
852
|
+
shutdown
|
853
|
+
negotiation auto
|
854
|
+
!
|
855
|
+
interface GigabitEthernet0/0/10
|
856
|
+
description: test 123
|
857
|
+
no ip address
|
858
|
+
negotiation auto
|
859
|
+
service-policy input Classification-Marking-In
|
860
|
+
service instance 99 ethernet
|
861
|
+
encapsulation untagged
|
862
|
+
bridge-domain 99
|
863
|
+
!
|
864
|
+
!
|
865
|
+
interface GigabitEthernet0/0/11
|
866
|
+
no ip address
|
867
|
+
shutdown
|
868
|
+
negotiation auto
|
869
|
+
!
|
870
|
+
interface GigabitEthernet0/0/12
|
871
|
+
no ip address
|
872
|
+
shutdown
|
873
|
+
negotiation auto
|
874
|
+
!
|
875
|
+
interface GigabitEthernet0/0/13
|
876
|
+
no ip address
|
877
|
+
shutdown
|
878
|
+
negotiation auto
|
879
|
+
!
|
880
|
+
interface GigabitEthernet0/0/14
|
881
|
+
no ip address
|
882
|
+
negotiation auto
|
883
|
+
service-policy input Classification-Marking-In
|
884
|
+
service instance 99 ethernet
|
885
|
+
description: test 123
|
886
|
+
encapsulation untagged
|
887
|
+
bridge-domain 99
|
888
|
+
!
|
889
|
+
!
|
890
|
+
interface GigabitEthernet0/0/15
|
891
|
+
no ip address
|
892
|
+
shutdown
|
893
|
+
negotiation auto
|
894
|
+
!
|
895
|
+
interface GigabitEthernet0/0/16
|
896
|
+
no ip address
|
897
|
+
shutdown
|
898
|
+
negotiation auto
|
899
|
+
!
|
900
|
+
interface GigabitEthernet0/0/17
|
901
|
+
description: test 123
|
902
|
+
no ip address
|
903
|
+
negotiation auto
|
904
|
+
service-policy input Classification-Marking-In
|
905
|
+
service instance 99 ethernet
|
906
|
+
encapsulation untagged
|
907
|
+
bridge-domain 99
|
908
|
+
!
|
909
|
+
!
|
910
|
+
interface GigabitEthernet0/0/18
|
911
|
+
description: test 123
|
912
|
+
no ip address
|
913
|
+
negotiation auto
|
914
|
+
service-policy input Classification-Marking-In
|
915
|
+
service instance 99 ethernet
|
916
|
+
encapsulation untagged
|
917
|
+
bridge-domain 99
|
918
|
+
!
|
919
|
+
!
|
920
|
+
interface GigabitEthernet0/0/19
|
921
|
+
no ip address
|
922
|
+
shutdown
|
923
|
+
negotiation auto
|
924
|
+
!
|
925
|
+
interface GigabitEthernet0/0/20
|
926
|
+
no ip address
|
927
|
+
shutdown
|
928
|
+
negotiation auto
|
929
|
+
!
|
930
|
+
interface GigabitEthernet0/0/21
|
931
|
+
no ip address
|
932
|
+
shutdown
|
933
|
+
negotiation auto
|
934
|
+
!
|
935
|
+
interface GigabitEthernet0/0/22
|
936
|
+
description: test 123
|
937
|
+
no ip address
|
938
|
+
shutdown
|
939
|
+
negotiation auto
|
940
|
+
service instance 99 ethernet
|
941
|
+
encapsulation untagged
|
942
|
+
bridge-domain 99
|
943
|
+
!
|
944
|
+
!
|
945
|
+
interface GigabitEthernet0/0/23
|
946
|
+
description: test 123
|
947
|
+
no ip address
|
948
|
+
negotiation auto
|
949
|
+
service instance 99 ethernet
|
950
|
+
encapsulation untagged
|
951
|
+
bridge-domain 99
|
952
|
+
!
|
953
|
+
!
|
954
|
+
interface TenGigabitEthernet0/0/24
|
955
|
+
no ip address
|
956
|
+
shutdown
|
957
|
+
!
|
958
|
+
interface TenGigabitEthernet0/0/25
|
959
|
+
no ip address
|
960
|
+
shutdown
|
961
|
+
!
|
962
|
+
interface TenGigabitEthernet0/0/26
|
963
|
+
no ip address
|
964
|
+
shutdown
|
965
|
+
!
|
966
|
+
interface TenGigabitEthernet0/0/27
|
967
|
+
no ip address
|
968
|
+
shutdown
|
969
|
+
!
|
970
|
+
interface GigabitEthernet0
|
971
|
+
vrf forwarding Mgmt-intf
|
972
|
+
no ip address
|
973
|
+
shutdown
|
974
|
+
negotiation auto
|
975
|
+
!
|
976
|
+
!
|
977
|
+
ip access-list standard auth-SNMP
|
978
|
+
permit 111.111.111.111
|
979
|
+
permit 111.111.111.111
|
980
|
+
permit 111.111.111.111 111.111.111.111
|
981
|
+
deny any log
|
982
|
+
ip access-list standard auth-SNMPV2
|
983
|
+
permit 111.111.111.111
|
984
|
+
permit 111.111.111.111
|
985
|
+
permit 111.111.111.111 111.111.111.111
|
986
|
+
deny any log
|
987
|
+
ip access-list standard auth-SSH
|
988
|
+
permit 111.111.111.111
|
989
|
+
permit 111.111.111.111
|
990
|
+
permit 111.111.111.111 111.111.111.111
|
991
|
+
permit 111.111.111.111 111.111.111.111
|
992
|
+
permit 111.111.111.111 111.111.111.111
|
993
|
+
deny any log
|
994
|
+
!
|
995
|
+
!
|
996
|
+
logging origin-id hostname
|
997
|
+
logging facility local6
|
998
|
+
logging source-interface Loopback9
|
999
|
+
logging host 111.111.111.111
|
1000
|
+
!
|
1001
|
+
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
|
1002
|
+
snmp-server enable traps vrrp
|
1003
|
+
snmp-server enable traps ds1
|
1004
|
+
snmp-server enable traps ds3
|
1005
|
+
snmp-server enable traps call-home message-send-fail server-fail
|
1006
|
+
snmp-server enable traps tty
|
1007
|
+
snmp-server enable traps eigrp
|
1008
|
+
snmp-server enable traps ospf state-change
|
1009
|
+
snmp-server enable traps ospf errors
|
1010
|
+
snmp-server enable traps ospf retransmit
|
1011
|
+
snmp-server enable traps ospf lsa
|
1012
|
+
snmp-server enable traps ospf cisco-specific state-change nssa-trans-change
|
1013
|
+
snmp-server enable traps ospf cisco-specific state-change shamlink interface
|
1014
|
+
snmp-server enable traps ospf cisco-specific state-change shamlink neighbor
|
1015
|
+
snmp-server enable traps ospf cisco-specific errors
|
1016
|
+
snmp-server enable traps ospf cisco-specific retransmit
|
1017
|
+
snmp-server enable traps ospf cisco-specific lsa
|
1018
|
+
snmp-server enable traps license
|
1019
|
+
snmp-server enable traps smart-license
|
1020
|
+
snmp-server enable traps ike policy add
|
1021
|
+
snmp-server enable traps ike policy delete
|
1022
|
+
snmp-server enable traps ike tunnel start
|
1023
|
+
snmp-server enable traps ike tunnel stop
|
1024
|
+
snmp-server enable traps ipsec cryptomap add
|
1025
|
+
snmp-server enable traps ipsec cryptomap delete
|
1026
|
+
snmp-server enable traps ipsec cryptomap attach
|
1027
|
+
snmp-server enable traps ipsec cryptomap detach
|
1028
|
+
snmp-server enable traps ipsec tunnel start
|
1029
|
+
snmp-server enable traps ipsec tunnel stop
|
1030
|
+
snmp-server enable traps ipsec too-many-sas
|
1031
|
+
snmp-server enable traps atm subif
|
1032
|
+
snmp-server enable traps bfd
|
1033
|
+
snmp-server enable traps bgp cbgp2
|
1034
|
+
snmp-server enable traps config-copy
|
1035
|
+
snmp-server enable traps config
|
1036
|
+
snmp-server enable traps config-ctid
|
1037
|
+
snmp-server enable traps dhcp
|
1038
|
+
snmp-server enable traps otn
|
1039
|
+
snmp-server enable traps event-manager
|
1040
|
+
snmp-server enable traps hsrp
|
1041
|
+
snmp-server enable traps pimstdmib neighbor-loss invalid-register invalid-join-prune rp-mapping-change interface-election
|
1042
|
+
snmp-server enable traps ipmulticast
|
1043
|
+
snmp-server enable traps isis
|
1044
|
+
snmp-server enable traps msdp
|
1045
|
+
snmp-server enable traps ospfv3 state-change
|
1046
|
+
snmp-server enable traps ospfv3 errors
|
1047
|
+
snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message
|
1048
|
+
snmp-server enable traps ipsla
|
1049
|
+
snmp-server enable traps bridge newroot topologychange
|
1050
|
+
snmp-server enable traps stpx inconsistency root-inconsistency loop-inconsistency
|
1051
|
+
snmp-server enable traps syslog
|
1052
|
+
snmp-server enable traps pki
|
1053
|
+
snmp-server enable traps adslline
|
1054
|
+
snmp-server enable traps vdsl2line
|
1055
|
+
snmp-server enable traps ether-oam
|
1056
|
+
snmp-server enable traps ethernet cfm cc mep-up mep-down cross-connect loop config
|
1057
|
+
snmp-server enable traps ethernet cfm crosscheck mep-missing mep-unknown service-up
|
1058
|
+
snmp-server enable traps memory bufferpeak
|
1059
|
+
snmp-server enable traps entity-state
|
1060
|
+
snmp-server enable traps fru-ctrl
|
1061
|
+
snmp-server enable traps entity
|
1062
|
+
snmp-server enable traps cpu threshold
|
1063
|
+
snmp-server enable traps rep
|
1064
|
+
snmp-server enable traps vtp
|
1065
|
+
snmp-server enable traps vlancreate
|
1066
|
+
snmp-server enable traps vlandelete
|
1067
|
+
snmp-server enable traps sonet
|
1068
|
+
snmp-server enable traps cef resource-failure peer-state-change peer-fib-state-change inconsistency
|
1069
|
+
snmp-server enable traps lisp
|
1070
|
+
snmp-server enable traps entity-sensor
|
1071
|
+
snmp-server enable traps resource-policy
|
1072
|
+
snmp-server enable traps flash insertion removal lowspace
|
1073
|
+
snmp-server enable traps netsync
|
1074
|
+
snmp-server enable traps rsvp
|
1075
|
+
snmp-server enable traps cnpd
|
1076
|
+
!
|
1077
|
+
tacacs-server timeout 3
|
1078
|
+
!
|
1079
|
+
!
|
1080
|
+
!
|
1081
|
+
control-plane
|
1082
|
+
!
|
1083
|
+
banner motd ^C
|
1084
|
+
*******************************************************************************
|
1085
|
+
4. The information contained in this computer network is confidential and
|
1086
|
+
must not be disclosed to unauthorised persons. Unauthorised disclosure,
|
1087
|
+
system disruption or any unauthorised modification may lead to prosecution.
|
1088
|
+
5. Details of all transactions and accesses including user-ids, are
|
1089
|
+
automatically recorded by the computer network and can be retrieved for
|
1090
|
+
audit purposes. By accessing and using this computer network you are
|
1091
|
+
consenting to security monitoring.
|
1092
|
+
********************************************************************************
|
1093
|
+
^C
|
1094
|
+
!
|
1095
|
+
line con 0
|
1096
|
+
exec-timeout 20 0
|
1097
|
+
logging synchronous
|
1098
|
+
history size 50
|
1099
|
+
transport preferred none
|
1100
|
+
transport output none
|
1101
|
+
stopbits 1
|
1102
|
+
line aux 0
|
1103
|
+
no exec
|
1104
|
+
stopbits 1
|
1105
|
+
line vty 0 4
|
1106
|
+
exec-timeout 20 0
|
1107
|
+
logging synchronous
|
1108
|
+
history size 50
|
1109
|
+
transport input ssh
|
1110
|
+
line vty 5 15
|
1111
|
+
exec-timeout 20 0
|
1112
|
+
logging synchronous
|
1113
|
+
history size 50
|
1114
|
+
transport input ssh
|
1115
|
+
!
|
1116
|
+
ntp server 111.111.111.111
|
1117
|
+
ntp server 111.111.111.111
|
1118
|
+
!
|
1119
|
+
|
1120
|
+
!
|
1121
|
+
end\n
|
1122
|
+
# End of YAML file
|