@maxim_mazurok/gapi.client.compute-alpha 0.0.20240430 → 0.0.20240519

This diff represents the content of publicly available package versions that have been released to one of the supported registries. The information contained in this diff is provided for informational purposes only and reflects changes between package versions as they appear in their respective public registries.
Files changed (3) hide show
  1. package/index.d.ts +14 -14
  2. package/package.json +1 -1
  3. package/readme.md +1 -1
package/index.d.ts CHANGED
@@ -9,7 +9,7 @@
9
9
  // This file was generated by https://github.com/Maxim-Mazurok/google-api-typings-generator. Please do not edit it manually.
10
10
  // In case of any problems please post issue to https://github.com/Maxim-Mazurok/google-api-typings-generator
11
11
  // Generated from: https://www.googleapis.com/discovery/v1/apis/compute/alpha/rest
12
- // Revision: 20240430
12
+ // Revision: 20240519
13
13
 
14
14
  /// <reference types="gapi.client" />
15
15
 
@@ -359,7 +359,7 @@ declare namespace gapi.client {
359
359
  boot?: boolean;
360
360
  /** Specifies a unique device name of your choice that is reflected into the /dev/disk/by-id/google-* tree of a Linux operating system running within the instance. This name can be used to reference the device for mounting, resizing, and so on, from within the instance. If not specified, the server chooses a default device name to apply to this disk, in the form persistent-disk-x, where x is a number assigned by Google Compute Engine. This field is only applicable for persistent disks. */
361
361
  deviceName?: string;
362
- /** Encrypts or decrypts a disk using a customer-supplied encryption key. If you are creating a new disk, this field encrypts the new disk using an encryption key that you provide. If you are attaching an existing disk that is already encrypted, this field decrypts the disk using the customer-supplied encryption key. If you encrypt a disk using a customer-supplied key, you must provide the same key again when you attempt to use this resource at a later time. For example, you must provide the key when you create a snapshot or an image from the disk or when you attach the disk to a virtual machine instance. If you do not provide an encryption key, then the disk will be encrypted using an automatically generated key and you do not need to provide a key to use the disk later. Instance templates do not store customer-supplied encryption keys, so you cannot use your own keys to encrypt disks in a managed instance group. */
362
+ /** Encrypts or decrypts a disk using a customer-supplied encryption key. If you are creating a new disk, this field encrypts the new disk using an encryption key that you provide. If you are attaching an existing disk that is already encrypted, this field decrypts the disk using the customer-supplied encryption key. If you encrypt a disk using a customer-supplied key, you must provide the same key again when you attempt to use this resource at a later time. For example, you must provide the key when you create a snapshot or an image from the disk or when you attach the disk to a virtual machine instance. If you do not provide an encryption key, then the disk will be encrypted using an automatically generated key and you do not need to provide a key to use the disk later. Note: Instance templates do not store customer-supplied encryption keys, so you cannot use your own keys to encrypt disks in a managed instance group. You cannot create VMs that have disks with customer-supplied keys using the bulk insert method. */
363
363
  diskEncryptionKey?: CustomerEncryptionKey;
364
364
  /** The size of the disk in GB. */
365
365
  diskSizeGb?: string;
@@ -472,10 +472,6 @@ declare namespace gapi.client {
472
472
  /** List of RbacPolicies. */
473
473
  policies?: RbacPolicy[];
474
474
  }
475
- interface AuthorizationLoggingOptions {
476
- /** This is deprecated and has no effect. Do not use. */
477
- permissionType?: string;
478
- }
479
475
  interface Autoscaler {
480
476
  /** The configuration parameters for the autoscaling algorithm. You can define one or more signals for an autoscaler: cpuUtilization, customMetricUtilizations, and loadBalancingUtilization. If none of these are specified, the default will be to autoscale based on cpuUtilization to 0.6 or 60%. */
481
477
  autoscalingPolicy?: AutoscalingPolicy;
@@ -877,6 +873,8 @@ declare namespace gapi.client {
877
873
  serviceLbPolicy?: string;
878
874
  /** Type of session affinity to use. The default is NONE. Only NONE and HEADER_FIELD are supported when the backend service is referenced by a URL map that is bound to target gRPC proxy that has validateForProxyless field set to true. For more details, see: [Session Affinity](https://cloud.google.com/load-balancing/docs/backend-service#session_affinity). */
879
875
  sessionAffinity?: string;
876
+ /** Describes the HTTP cookie used for stateful session affinity. This field is applicable and required if the sessionAffinity is set to STRONG_COOKIE_AFFINITY. */
877
+ strongSessionAffinityCookie?: BackendServiceHttpCookie;
880
878
  subsetting?: Subsetting;
881
879
  /** The backend service timeout has a different meaning depending on the type of load balancer. For more information see, Backend service settings. The default is 30 seconds. The full range of timeout values allowed goes from 1 through 2,147,483,647 seconds. This value can be overridden in the PathMatcher configuration of the UrlMap that references this backend service. Not supported when the backend service is referenced by a URL map that is bound to target gRPC proxy that has validateForProxyless field set to true. Instead, use maxStreamDuration. */
882
880
  timeoutSec?: number;
@@ -990,6 +988,14 @@ declare namespace gapi.client {
990
988
  /** Specifying the instance name of a leader is not supported. */
991
989
  instance?: string;
992
990
  }
991
+ interface BackendServiceHttpCookie {
992
+ /** Name of the cookie. */
993
+ name?: string;
994
+ /** Path to set for the cookie. */
995
+ path?: string;
996
+ /** Lifetime of the cookie. */
997
+ ttl?: Duration;
998
+ }
993
999
  interface BackendServiceIAP {
994
1000
  /** Whether the serving infrastructure will authenticate and authorize all incoming requests. */
995
1001
  enabled?: boolean;
@@ -4392,7 +4398,7 @@ declare namespace gapi.client {
4392
4398
  keyRevocationActionType?: string;
4393
4399
  /** Labels to apply to instances that are created from these properties. */
4394
4400
  labels?: {[P in string]: string};
4395
- /** The machine type to use for instances that are created from these properties. */
4401
+ /** The machine type to use for instances that are created from these properties. This field only accept machine types name. e.g. n2-standard-4 and does not accept machine type full or partial url. e.g. projects/my-l7ilb-project/zones/us-central1-a/machineTypes/n2-standard-4 will throw INTERNAL_ERROR. */
4396
4402
  machineType?: string;
4397
4403
  /** The metadata key/value pairs to assign to instances that are created from these properties. These pairs can consist of custom metadata or predefined keys. See Project and instance metadata for more information. */
4398
4404
  metadata?: Metadata;
@@ -5572,8 +5578,6 @@ declare namespace gapi.client {
5572
5578
  dataAccess?: LogConfigDataAccessOptions;
5573
5579
  }
5574
5580
  interface LogConfigCloudAuditOptions {
5575
- /** This is deprecated and has no effect. Do not use. */
5576
- authorizationLoggingOptions?: AuthorizationLoggingOptions;
5577
5581
  /** This is deprecated and has no effect. Do not use. */
5578
5582
  logName?: string;
5579
5583
  }
@@ -8032,15 +8036,11 @@ declare namespace gapi.client {
8032
8036
  };
8033
8037
  }
8034
8038
  interface QueuedResourceStatus {
8035
- /** Additional status detail for the FAILED state. */
8036
8039
  failedData?: QueuedResourceStatusFailedData;
8037
- /** [Output only] Fully qualified URL of the provisioning GCE operation to track the provisioning along with provisioning errors. The referenced operation may not exist after having been deleted or expired. */
8038
8040
  provisioningOperations?: string[];
8039
- /** Constraints for the time when the resource(s) start provisioning. Always exposed as absolute times. */
8040
8041
  queuingPolicy?: QueuingPolicy;
8041
8042
  }
8042
8043
  interface QueuedResourceStatusFailedData {
8043
- /** The error(s) that caused the QueuedResource to enter the FAILED state. */
8044
8044
  error?: {
8045
8045
  /** [Output Only] The array of errors encountered while processing this operation. */
8046
8046
  errors?: Array<{
@@ -44638,7 +44638,7 @@ declare namespace gapi.client {
44638
44638
  /** Legacy name for parameter that has been superseded by `quotaUser`. */
44639
44639
  userIp?: string;
44640
44640
  }): Request<Region>;
44641
- /** Retrieves the list of region resources available to the specified project. To decrease latency for this method, you can optionally omit any unneeded information from the response by using a field mask. This practice is especially recommended for unused quota information (the `items.quotas` field). To exclude one or more fields, set your request's `fields` query parameter to only include the fields you need. For example, to only include the `id` and `selfLink` fields, add the query parameter `?fields=id,selfLink` to your request. */
44641
+ /** Retrieves the list of region resources available to the specified project. To decrease latency for this method, you can optionally omit any unneeded information from the response by using a field mask. This practice is especially recommended for unused quota information (the `items.quotas` field). To exclude one or more fields, set your request's `fields` query parameter to only include the fields you need. For example, to only include the `id` and `selfLink` fields, add the query parameter `?fields=id,selfLink` to your request. This method fails if the quota information is unavailable for the region and if the organization policy constraint compute.requireBasicQuotaInResponse is enforced. This constraint, when enforced, disables the fail-open behaviour when quota information (the `items.quotas` field) is unavailable for the region. It is recommended to use the default setting for the constraint unless your application requires the fail-closed behaviour for this method. */
44642
44642
  list(request?: {
44643
44643
  /** V1 error format. */
44644
44644
  '$.xgafv'?: string;
package/package.json CHANGED
@@ -1,6 +1,6 @@
1
1
  {
2
2
  "name": "@maxim_mazurok/gapi.client.compute-alpha",
3
- "version": "0.0.20240430",
3
+ "version": "0.0.20240519",
4
4
  "description": "TypeScript typings for Compute Engine API alpha",
5
5
  "repository": {
6
6
  "type": "git",
package/readme.md CHANGED
@@ -3281,7 +3281,7 @@ Returns the specified Region resource. To decrease latency for this method, you
3281
3281
  await gapi.client.compute.regions.get({ project: "project", region: "region", });
3282
3282
 
3283
3283
  /*
3284
- Retrieves the list of region resources available to the specified project. To decrease latency for this method, you can optionally omit any unneeded information from the response by using a field mask. This practice is especially recommended for unused quota information (the `items.quotas` field). To exclude one or more fields, set your request's `fields` query parameter to only include the fields you need. For example, to only include the `id` and `selfLink` fields, add the query parameter `?fields=id,selfLink` to your request.
3284
+ Retrieves the list of region resources available to the specified project. To decrease latency for this method, you can optionally omit any unneeded information from the response by using a field mask. This practice is especially recommended for unused quota information (the `items.quotas` field). To exclude one or more fields, set your request's `fields` query parameter to only include the fields you need. For example, to only include the `id` and `selfLink` fields, add the query parameter `?fields=id,selfLink` to your request. This method fails if the quota information is unavailable for the region and if the organization policy constraint compute.requireBasicQuotaInResponse is enforced. This constraint, when enforced, disables the fail-open behaviour when quota information (the `items.quotas` field) is unavailable for the region. It is recommended to use the default setting for the constraint unless your application requires the fail-closed behaviour for this method.
3285
3285
  */
3286
3286
  await gapi.client.compute.regions.list({ project: "project", });
3287
3287