@leverege/build-tools 2.21.14 → 2.22.0

This diff represents the content of publicly available package versions that have been released to one of the supported registries. The information contained in this diff is provided for informational purposes only and reflects changes between package versions as they appear in their respective public registries.
@@ -0,0 +1,15 @@
1
+ #!/bin/bash
2
+ #
3
+ showInstalling "Prometheus"
4
+
5
+ createNamespaceIfNeeded monitoring
6
+
7
+ addHelmRepo prometheus-community https://prometheus-community.github.io/helm-charts
8
+
9
+ [ -z "$PROMETHEUS_HELM_CHART" ] && PROMETHEUS_HELM_CHART="15"
10
+ helm upgrade --install prometheus prometheus-community/prometheus \
11
+ --namespace monitoring \
12
+ --values prometheus/values.yaml \
13
+ --version $PROMETHEUS_HELM_CHART
14
+
15
+ removeHelmRepo prometheus-community
@@ -0,0 +1,62 @@
1
+ global:
2
+ storageClass: ssd
3
+
4
+ auth:
5
+ enabled: false
6
+ sentinel: false
7
+
8
+ master:
9
+ affinity:
10
+ nodeAffinity:
11
+ requiredDuringSchedulingIgnoredDuringExecution:
12
+ nodeSelectorTerms:
13
+ - matchExpressions:
14
+ - key: target-env
15
+ operator: In
16
+ values:
17
+ - database
18
+
19
+ tolerations:
20
+ - key: "database"
21
+ operator: "Equal"
22
+ value: "true"
23
+ effect: "NoSchedule"
24
+
25
+ persistence:
26
+ size: 1Gi # 8Gi is default
27
+
28
+ replica:
29
+ affinity:
30
+ nodeAffinity:
31
+ requiredDuringSchedulingIgnoredDuringExecution:
32
+ nodeSelectorTerms:
33
+ - matchExpressions:
34
+ - key: target-env
35
+ operator: In
36
+ values:
37
+ - database
38
+
39
+ tolerations:
40
+ - key: "database"
41
+ operator: "Equal"
42
+ value: "true"
43
+ effect: "NoSchedule"
44
+
45
+ persistence:
46
+ size: 8Gi # 8Gi is default
47
+
48
+ architecture: replication
49
+
50
+ sentinel:
51
+ enabled: false
52
+
53
+ networkPolicy:
54
+ enabled: true
55
+ allowExternal: false
56
+ ingressNSMatchLabels:
57
+ redis: external
58
+ ingressNSPodMatchLabels:
59
+ redis-client: true
60
+
61
+ metrics:
62
+ enabled: true
@@ -0,0 +1,12 @@
1
+ #!/bin/bash
2
+
3
+ showInstalling "Redis"
4
+
5
+ addBitnamiRepo latest
6
+
7
+ [ -z "$REDIS_HELM_CHART" ] && REDIS_HELM_CHART="17" # latest chart 17 is redis v7
8
+ helm upgrade --install redis bitnami/redis \
9
+ --values redis/redis-local.yaml \
10
+ --version $REDIS_HELM_CHART
11
+
12
+ removeHelmRepo bitnami
@@ -0,0 +1,44 @@
1
+ postgresql:
2
+ postgresqlExtendedConf:
3
+ maxWorkerProcesses: 8
4
+ maxParallelWorkers: 8
5
+ maxConnections: 500
6
+ sharedBuffers: 2GB
7
+ effectiveCacheSize: 6GB
8
+ maintenanceWorkMem: 1GB
9
+ workMem: 20MB
10
+ idle_in_transaction_session_timeout: 30000 # 30ms timeout
11
+ maxWalSize: 2GB
12
+ walKeepSegments: 64
13
+
14
+ resources:
15
+ requests:
16
+ memory: 4Gi
17
+ cpu: 1000m
18
+
19
+ persistence:
20
+ size: 200Gi
21
+
22
+ livenessProbe:
23
+ enabled: true # false for repairs
24
+ initialDelaySeconds: 30
25
+ periodSeconds: 10
26
+ timeoutSeconds: 5
27
+ failureThreshold: 6
28
+ successThreshold: 1
29
+
30
+ readinessProbe:
31
+ enabled: true
32
+ successThreshold: 1
33
+ initialDelaySeconds: 5
34
+ timeoutSeconds: 5
35
+ periodSeconds: 10
36
+ failureThreshold: 6
37
+ # These values should be used when attempting to rebuild the slave VPCs
38
+ # following a failure, typically caused by WAL problems. The failure
39
+ # threshold of 240 with a period of 30 seconds should allow the recovery
40
+ # process 2 hours of time for each slave VPC - lengthen as necessary.
41
+ # initialDelaySeconds: 60
42
+ # timeoutSeconds: 15
43
+ # periodSeconds: 30
44
+ # failureThreshold: 240
@@ -0,0 +1,10 @@
1
+ #!/bin/bash
2
+ #
3
+ showInstalling "Timescale Database (Leverege chart)"
4
+
5
+ checkTimescalePassword
6
+
7
+ [ -z "$TIMESCALE_HELM_CHART" ] && TIMESCALE_HELM_CHART="2"
8
+ helm upgrade --install timescale-db leverege/timescale-db \
9
+ --values timescale-db/timescale-db-local.yaml \
10
+ --version $TIMESCALE_HELM_CHART
Binary file