@hot-updater/cli-tools 1.0.0-rc.44 → 1.0.0-rc.45

This diff represents the content of publicly available package versions that have been released to one of the supported registries. The information contained in this diff is provided for informational purposes only and reflects changes between package versions as they appear in their respective public registries.
Files changed (2) hide show
  1. package/dist/index.mjs +2 -1
  2. package/package.json +5 -5
package/dist/index.mjs CHANGED
@@ -44805,7 +44805,8 @@ const renderServerSettings = (scaffold) => {
44805
44805
  const PLUGINS_FILE_PATH = "hotUpdater.plugins.ts";
44806
44806
  /**
44807
44807
  * Whether `text` is the plugins file an older init wrote: comments and a
44808
- * re-export of a provider package's `plugins`, which the config imports now.
44808
+ * re-export of a provider package's former `plugins`, which the config's
44809
+ * `plugins` list replaces.
44809
44810
  */
44810
44811
  const isGeneratedPluginsFile = (text) => /^export\{plugins\}from(["'])@hot-updater\/[\w-]+\1;?$/u.test(text.replace(/^\s*\/\/.*$/gmu, "").replace(/\s+/gu, ""));
44811
44812
  /**
package/package.json CHANGED
@@ -1,6 +1,6 @@
1
1
  {
2
2
  "name": "@hot-updater/cli-tools",
3
- "version": "1.0.0-rc.44",
3
+ "version": "1.0.0-rc.45",
4
4
  "type": "module",
5
5
  "engines": {
6
6
  "node": ">=20.19.0"
@@ -49,9 +49,9 @@
49
49
  "oxc-parser": "0.141.0",
50
50
  "oxc-transform": "0.141.0",
51
51
  "unconfig": "7.5.0",
52
- "@hot-updater/protocol": "1.0.0-rc.44",
53
- "@hot-updater/plugin-core": "1.0.0-rc.44",
54
- "@hot-updater/server": "1.0.0-rc.44"
52
+ "@hot-updater/protocol": "1.0.0-rc.45",
53
+ "@hot-updater/plugin-core": "1.0.0-rc.45",
54
+ "@hot-updater/server": "1.0.0-rc.45"
55
55
  },
56
56
  "devDependencies": {
57
57
  "@clack/prompts": "1.7.0",
@@ -65,7 +65,7 @@
65
65
  "tar": "^7.5.16",
66
66
  "verkit": "0.4.0",
67
67
  "workspace-tools": "^0.41.7",
68
- "@hot-updater/test-utils": "1.0.0-rc.44"
68
+ "@hot-updater/test-utils": "1.0.0-rc.45"
69
69
  },
70
70
  "inlinedDependencies": {
71
71
  "@babel/code-frame": "7.29.0",