smartermeter 0.4.5 → 0.4.6

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA1:
3
- metadata.gz: a6009000178456bc32b248ef9ffac37ab66cd8e1
4
- data.tar.gz: a32c6a13f7efb1278855125a38bad0639c8a06ee
3
+ metadata.gz: bd5a437a39d1ea28b305a51a7c884aad1a54fc1d
4
+ data.tar.gz: 20b4d9d11886b2fee42c963895fd9e60268f5a2b
5
5
  SHA512:
6
- metadata.gz: e3fb9d042a57f7fa2f8b44f5ebe7f9badcc7520f22eda50e24dcb597151ab13b889f658ce7d83d721128aaae1702f30e5733a546f20f4f42e0121047f39c8081
7
- data.tar.gz: 36a0c29010218b815b79cb010834d98efbe245d09d583c76ca69e46c6af7ba2d433801f3da50ff42cb4b0af36101b56d4d7b8b056effe173170837b63d4c4e62
6
+ metadata.gz: 67e27814066c40d67b88fb7ff74d4d110944c55a222239002e63cb202ace7c1658961e527f0ba28e563589e9c19b9ab39d98cb435c797fa94eee701f1f8f3c7a
7
+ data.tar.gz: 0ed2ddea753258b2259db07bf65e6dc54ee53999fab388e6bebe1fc4734174b3f1fa16d205421e0d81dd04a096081bce99e03e0d7ffd865fadb12c801e2f4393
@@ -1,5 +1,8 @@
1
1
  # Changelog
2
2
 
3
+ ## 0.4.6 (Aug 27, 2019)
4
+ * Updated out of date gems
5
+
3
6
  ## 0.4.4 (May 17, 2014)
4
7
  * Fixed an issue with downloading data from PG&E.
5
8
 
data/README.md CHANGED
@@ -1,8 +1,6 @@
1
1
  SmarterMeter - the smarter way to read your PG&E SmartMeter
2
2
  =========================================================
3
3
 
4
- [![Build Status](https://travis-ci.org/mcolyer/smartermeter.png?branch=master)](https://travis-ci.org/mcolyer/smartermeter)
5
-
6
4
  So I have PG&E SmartMeter and I like playing with data. However I didn't
7
5
  really want to jump through 37 hoops to see the data on PG&E's website.
8
6
  So I made this.
@@ -7,5 +7,5 @@ require 'smartermeter/services/brighterplanet'
7
7
  require 'smartermeter/interfaces/cli'
8
8
 
9
9
  module SmarterMeter
10
- VERSION = "0.4.5"
10
+ VERSION = "0.4.6"
11
11
  end
@@ -13,8 +13,8 @@ Gem::Specification.new do |s|
13
13
  ## If your rubyforge_project name is different, then edit it and comment out
14
14
  ## the sub! line in the Rakefile
15
15
  s.name = 'smartermeter'
16
- s.version = '0.4.5'
17
- s.date = '2017-11-18'
16
+ s.version = '0.4.6'
17
+ s.date = '2019-08-28'
18
18
  s.rubyforge_project = 'smartermeter'
19
19
 
20
20
  ## Make sure your summary is short. The description may be as long
@@ -50,17 +50,17 @@ Gem::Specification.new do |s|
50
50
  ## that are needed for an end user to actually USE your code.
51
51
  s.add_dependency('mechanize', ["= 2.6.0"])
52
52
  s.add_dependency('crypt19-rb', ["= 1.3.1"])
53
- s.add_dependency('rest-client', ["= 1.7.3"])
53
+ s.add_dependency('rest-client', ["= 2.1.0"])
54
54
  s.add_dependency('json_pure', ["= 1.7.7"])
55
- s.add_dependency('rubyzip', ["= 1.2.1"])
55
+ s.add_dependency('rubyzip', ["= 1.2.2"])
56
56
  s.add_dependency('trollop', ["= 2.0"])
57
57
 
58
58
  ## List your development dependencies here. Development dependencies are
59
59
  ## those that are only needed during development
60
60
  s.add_development_dependency('rake', ["~> 10.0.0"])
61
61
  s.add_development_dependency('rspec', ["~> 2.13.0"])
62
- s.add_development_dependency('vcr', ["~> 2.4.0"])
63
- s.add_development_dependency('webmock', ["~> 1.9.0"])
62
+ s.add_development_dependency('vcr', ["~> 5.0.0"])
63
+ s.add_development_dependency('webmock', ["~> 3.7.0"])
64
64
  s.add_development_dependency('minitar', ["~> 0.6.0"])
65
65
 
66
66
  ## Leave this section as-is. It will be automatically generated from the
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: smartermeter
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.4.5
4
+ version: 0.4.6
5
5
  platform: ruby
6
6
  authors:
7
7
  - Matt Colyer
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2017-11-18 00:00:00.000000000 Z
11
+ date: 2019-08-28 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: mechanize
@@ -44,14 +44,14 @@ dependencies:
44
44
  requirements:
45
45
  - - '='
46
46
  - !ruby/object:Gem::Version
47
- version: 1.7.3
47
+ version: 2.1.0
48
48
  type: :runtime
49
49
  prerelease: false
50
50
  version_requirements: !ruby/object:Gem::Requirement
51
51
  requirements:
52
52
  - - '='
53
53
  - !ruby/object:Gem::Version
54
- version: 1.7.3
54
+ version: 2.1.0
55
55
  - !ruby/object:Gem::Dependency
56
56
  name: json_pure
57
57
  requirement: !ruby/object:Gem::Requirement
@@ -72,14 +72,14 @@ dependencies:
72
72
  requirements:
73
73
  - - '='
74
74
  - !ruby/object:Gem::Version
75
- version: 1.2.1
75
+ version: 1.2.2
76
76
  type: :runtime
77
77
  prerelease: false
78
78
  version_requirements: !ruby/object:Gem::Requirement
79
79
  requirements:
80
80
  - - '='
81
81
  - !ruby/object:Gem::Version
82
- version: 1.2.1
82
+ version: 1.2.2
83
83
  - !ruby/object:Gem::Dependency
84
84
  name: trollop
85
85
  requirement: !ruby/object:Gem::Requirement
@@ -128,28 +128,28 @@ dependencies:
128
128
  requirements:
129
129
  - - "~>"
130
130
  - !ruby/object:Gem::Version
131
- version: 2.4.0
131
+ version: 5.0.0
132
132
  type: :development
133
133
  prerelease: false
134
134
  version_requirements: !ruby/object:Gem::Requirement
135
135
  requirements:
136
136
  - - "~>"
137
137
  - !ruby/object:Gem::Version
138
- version: 2.4.0
138
+ version: 5.0.0
139
139
  - !ruby/object:Gem::Dependency
140
140
  name: webmock
141
141
  requirement: !ruby/object:Gem::Requirement
142
142
  requirements:
143
143
  - - "~>"
144
144
  - !ruby/object:Gem::Version
145
- version: 1.9.0
145
+ version: 3.7.0
146
146
  type: :development
147
147
  prerelease: false
148
148
  version_requirements: !ruby/object:Gem::Requirement
149
149
  requirements:
150
150
  - - "~>"
151
151
  - !ruby/object:Gem::Version
152
- version: 1.9.0
152
+ version: 3.7.0
153
153
  - !ruby/object:Gem::Dependency
154
154
  name: minitar
155
155
  requirement: !ruby/object:Gem::Requirement