sasso-rails 0.1.7 → 0.1.8
This diff represents the content of publicly available package versions that have been released to one of the supported registries. The information contained in this diff is provided for informational purposes only and reflects changes between package versions as they appear in their respective public registries.
- checksums.yaml +4 -4
- data/CHANGELOG.md +36 -0
- data/README.md +10 -1
- data/lib/sasso/rails/version.rb +1 -1
- metadata +2 -2
checksums.yaml
CHANGED
|
@@ -1,7 +1,7 @@
|
|
|
1
1
|
---
|
|
2
2
|
SHA256:
|
|
3
|
-
metadata.gz:
|
|
4
|
-
data.tar.gz:
|
|
3
|
+
metadata.gz: 73d0547c3d8d12c8781a672098800fba93d8518c51fcd98a8065f0e8d4249768
|
|
4
|
+
data.tar.gz: aad074d78f43edb67b1f8ea43012d855afb35652d8e1e9514464a862725bc251
|
|
5
5
|
SHA512:
|
|
6
|
-
metadata.gz:
|
|
7
|
-
data.tar.gz:
|
|
6
|
+
metadata.gz: 358ba16009d6ab754d9b8c50ca3e9c061ca88c9b51431b898aafbbfb09075896880ad75c2f9b4cb266400e6352d9339124253ed09d2beb679915e1697e341c21
|
|
7
|
+
data.tar.gz: 47334488762747b64da86a8da675d20dbfb0a15022750169a2135daecc830e262e9d5220723175e22a181de0706d698657e7db42f3d95b10bb8587d544944248
|
data/CHANGELOG.md
CHANGED
|
@@ -8,6 +8,42 @@ the engine-gem version range it requires.
|
|
|
8
8
|
|
|
9
9
|
## [Unreleased]
|
|
10
10
|
|
|
11
|
+
## [0.1.8] - 2026-10-30
|
|
12
|
+
|
|
13
|
+
Requires the `sasso` gem **>= 0.14.0** (unchanged); works with **0.21.0**, which a
|
|
14
|
+
fresh `bundle install` or `bundle update sasso` now resolves.
|
|
15
|
+
|
|
16
|
+
### Added
|
|
17
|
+
|
|
18
|
+
- **Ruby 4.0** in CI. It needs `sasso` **>= 0.14.1**, the first engine-gem
|
|
19
|
+
release with a precompiled 4.0 binary (0.14.0's source gem does not build on
|
|
20
|
+
4.0); Bundler picks one automatically unless your app pins `sasso` 0.14.0.
|
|
21
|
+
|
|
22
|
+
### Changed
|
|
23
|
+
|
|
24
|
+
- **Upgrading to `sasso` 0.21.0 can break `sasso:build`.** It adopts core 0.15.0
|
|
25
|
+
through 0.21.0, and some stylesheets that compiled under 0.14.0 now raise
|
|
26
|
+
`Sasso::CompileError` — and so fail `assets:precompile` on deploy. The likely
|
|
27
|
+
ones in a Rails app: a built-in called with an argument name it does not
|
|
28
|
+
declare (`math.max(1, 2, $x: 999)`), an argument passed both by position and
|
|
29
|
+
by name, and selectors that dart-sass's grammar rejects (`[a=1]`, `a^b`). Some
|
|
30
|
+
output also changes meaning, not only bytes (compressed `color()`, a quoted
|
|
31
|
+
attribute value's whitespace, a non-ASCII space in a selector), and asset
|
|
32
|
+
digests change once again. Run `bin/rails sasso:build` after the upgrade, and
|
|
33
|
+
read the engine gem's
|
|
34
|
+
[CHANGELOG](https://github.com/momiji-rs/sasso-ruby/blob/main/CHANGELOG.md)
|
|
35
|
+
(section `0.21.0`) for the full list. Pin `gem "sasso", "~> 0.14.0"` in your
|
|
36
|
+
Gemfile to stay on the old compiler while you fix stylesheets.
|
|
37
|
+
- **A new `bogus-combinators` deprecation warning** may appear in `sasso:build`
|
|
38
|
+
/ `sasso:watch` output, for a rule whose selector has a repeated or leading
|
|
39
|
+
combinator (`a > + b`). The compiler already dropped those rules silently; the
|
|
40
|
+
warning is the only sign the CSS lost them. This gem does not expose
|
|
41
|
+
`silence_deprecations:`, so fix the selector to clear it.
|
|
42
|
+
- The `sasso` floor stays at **>= 0.14.0**: this gem uses none of 0.21.0's new
|
|
43
|
+
options, and raising it would force the breakage above onto apps that pinned
|
|
44
|
+
the older compiler. No change to this gem's own API, generators, or rake
|
|
45
|
+
tasks. Verified green against `sasso` 0.21.0 (23 runs, 70 assertions).
|
|
46
|
+
|
|
11
47
|
## [0.1.7] - 2026-09-17
|
|
12
48
|
|
|
13
49
|
Requires the `sasso` gem **>= 0.14.0** (was `>= 0.2.7`), and **Ruby >= 3.2**.
|
data/README.md
CHANGED
|
@@ -19,7 +19,9 @@ Why this gem over the alternatives:
|
|
|
19
19
|
|
|
20
20
|
## Compatibility
|
|
21
21
|
|
|
22
|
-
- **Ruby** ≥ 3.2 (the `sasso` engine gem dropped 3.1 in 0.14.0)
|
|
22
|
+
- **Ruby** ≥ 3.2 (the `sasso` engine gem dropped 3.1 in 0.14.0), tested on
|
|
23
|
+
3.2–4.0. Ruby 4.0 needs `sasso` ≥ 0.14.1, the first release with a 4.0
|
|
24
|
+
binary; Bundler resolves one unless your app pins 0.14.0.
|
|
23
25
|
- **Rails** ≥ 7.0 (`railties >= 7.0`), on **either** asset pipeline. Verified
|
|
24
26
|
end-to-end (`generate sasso:install` → `sasso:build` → production
|
|
25
27
|
`assets:precompile` → served CSS) on:
|
|
@@ -162,6 +164,13 @@ compiler. See the [gemspec](sasso-rails.gemspec) for the current range and the
|
|
|
162
164
|
reports the compiler your app actually has installed. An app may pin a specific
|
|
163
165
|
compiler version in its own `Gemfile`.
|
|
164
166
|
|
|
167
|
+
A compiler upgrade within the range is not always a drop-in. **`sasso` 0.21.0
|
|
168
|
+
rejects some stylesheets that 0.14.x compiled** (stricter built-in argument
|
|
169
|
+
checking and selector grammar) and changes some output, so run
|
|
170
|
+
`bin/rails sasso:build` after `bundle update sasso`, and read the engine gem's
|
|
171
|
+
[CHANGELOG](https://github.com/momiji-rs/sasso-ruby/blob/main/CHANGELOG.md)
|
|
172
|
+
before deploying. `gem "sasso", "~> 0.14.0"` keeps the older compiler.
|
|
173
|
+
|
|
165
174
|
## License
|
|
166
175
|
|
|
167
176
|
MIT, matching the Sass ecosystem. (The core `sasso` compiler crate remains
|
data/lib/sasso/rails/version.rb
CHANGED
metadata
CHANGED
|
@@ -1,14 +1,14 @@
|
|
|
1
1
|
--- !ruby/object:Gem::Specification
|
|
2
2
|
name: sasso-rails
|
|
3
3
|
version: !ruby/object:Gem::Version
|
|
4
|
-
version: 0.1.
|
|
4
|
+
version: 0.1.8
|
|
5
5
|
platform: ruby
|
|
6
6
|
authors:
|
|
7
7
|
- momiji-rs
|
|
8
8
|
autorequire:
|
|
9
9
|
bindir: bin
|
|
10
10
|
cert_chain: []
|
|
11
|
-
date: 2026-
|
|
11
|
+
date: 2026-10-30 00:00:00.000000000 Z
|
|
12
12
|
dependencies:
|
|
13
13
|
- !ruby/object:Gem::Dependency
|
|
14
14
|
name: railties
|