rails 2.3.15 → 2.3.16

Sign up to get free protection for your applications and to get access to all the features.
Files changed (5) hide show
  1. checksums.yaml +7 -0
  2. data/Rakefile +5 -5
  3. data/lib/rails/version.rb +1 -1
  4. data/railties.gemspec +22 -0
  5. metadata +97 -110
@@ -0,0 +1,7 @@
1
+ ---
2
+ SHA1:
3
+ metadata.gz: 760751636cb26c54e6d3f0d502e06a37b72de6d7
4
+ data.tar.gz: 8027f4b23589d1d4a45420034e224b5d00abd5f1
5
+ SHA512:
6
+ metadata.gz: d89dd44a24e67de05a8d32fbef1c4110accb022296746f6b8c4e4fadad669b3fa8086684fa7f33f03036790696a572d5eacf1089066223a21929b0770de6884d
7
+ data.tar.gz: cd10e86a3ab44929071ff5354494d8b6dd74bc882b12c328f2951022a404543eff37bd0dba1ce4d525aa0a65fa17189ff50d0b7c97de4d724ea7622f572b6577
data/Rakefile CHANGED
@@ -313,11 +313,11 @@ spec = Gem::Specification.new do |s|
313
313
  EOF
314
314
 
315
315
  s.add_dependency('rake', '>= 0.8.3')
316
- s.add_dependency('activesupport', '= 2.3.15' + PKG_BUILD)
317
- s.add_dependency('activerecord', '= 2.3.15' + PKG_BUILD)
318
- s.add_dependency('actionpack', '= 2.3.15' + PKG_BUILD)
319
- s.add_dependency('actionmailer', '= 2.3.15' + PKG_BUILD)
320
- s.add_dependency('activeresource', '= 2.3.15' + PKG_BUILD)
316
+ s.add_dependency('activesupport', '= 2.3.16' + PKG_BUILD)
317
+ s.add_dependency('activerecord', '= 2.3.16' + PKG_BUILD)
318
+ s.add_dependency('actionpack', '= 2.3.16' + PKG_BUILD)
319
+ s.add_dependency('actionmailer', '= 2.3.16' + PKG_BUILD)
320
+ s.add_dependency('activeresource', '= 2.3.16' + PKG_BUILD)
321
321
 
322
322
  s.rdoc_options << '--exclude' << '.'
323
323
 
@@ -2,7 +2,7 @@ module Rails
2
2
  module VERSION #:nodoc:
3
3
  MAJOR = 2
4
4
  MINOR = 3
5
- TINY = 15
5
+ TINY = 16
6
6
 
7
7
  STRING = [MAJOR, MINOR, TINY].join('.')
8
8
  end
@@ -0,0 +1,22 @@
1
+ Gem::Specification.new do |s|
2
+ s.name = 'rails'
3
+ s.version = '2.3.15'
4
+ s.summary = 'Web-application framework with template engine, control-flow layer, and ORM.'
5
+ s.description = "Rails is a framework for building web-application using CGI, FCGI, mod_ruby, or WEBrick\non top of either MySQL, PostgreSQL, SQLite, DB2, SQL Server, or Oracle with eRuby- or Builder-based templates."
6
+
7
+ s.author = 'David Heinemeier Hansson'
8
+ s.email = 'david@loudthinking.com'
9
+ s.homepage = 'http://www.rubyonrails.org'
10
+
11
+ s.require_path = 'lib'
12
+ s.files = ['bin/rails']
13
+ s.executables = ['rails']
14
+ s.rdoc_options = ['--exclude', '.']
15
+
16
+ s.add_dependency 'rake', '>= 0.8.3'
17
+ s.add_dependency 'activesupport', '= 2.3.15'
18
+ s.add_dependency 'activerecord', '= 2.3.15'
19
+ s.add_dependency 'actionpack', '= 2.3.15'
20
+ s.add_dependency 'actionmailer', '= 2.3.15'
21
+ s.add_dependency 'activeresource', '= 2.3.15'
22
+ end
metadata CHANGED
@@ -1,120 +1,114 @@
1
- --- !ruby/object:Gem::Specification
1
+ --- !ruby/object:Gem::Specification
2
2
  name: rails
3
- version: !ruby/object:Gem::Version
4
- prerelease: false
5
- segments:
6
- - 2
7
- - 3
8
- - 15
9
- version: 2.3.15
3
+ version: !ruby/object:Gem::Version
4
+ version: 2.3.16
10
5
  platform: ruby
11
- authors:
6
+ authors:
12
7
  - David Heinemeier Hansson
13
8
  autorequire:
14
9
  bindir: bin
15
10
  cert_chain: []
16
-
17
- date: 2013-01-08 00:00:00 -08:00
18
- default_executable:
19
- dependencies:
20
- - !ruby/object:Gem::Dependency
11
+ date: 2013-01-28 00:00:00.000000000 Z
12
+ dependencies:
13
+ - !ruby/object:Gem::Dependency
21
14
  name: rake
22
- prerelease: false
23
- requirement: &id001 !ruby/object:Gem::Requirement
24
- requirements:
15
+ requirement: !ruby/object:Gem::Requirement
16
+ requirements:
25
17
  - - ">="
26
- - !ruby/object:Gem::Version
27
- segments:
28
- - 0
29
- - 8
30
- - 3
18
+ - !ruby/object:Gem::Version
31
19
  version: 0.8.3
32
20
  type: :runtime
33
- version_requirements: *id001
34
- - !ruby/object:Gem::Dependency
35
- name: activesupport
36
21
  prerelease: false
37
- requirement: &id002 !ruby/object:Gem::Requirement
38
- requirements:
39
- - - "="
40
- - !ruby/object:Gem::Version
41
- segments:
42
- - 2
43
- - 3
44
- - 15
45
- version: 2.3.15
22
+ version_requirements: !ruby/object:Gem::Requirement
23
+ requirements:
24
+ - - ">="
25
+ - !ruby/object:Gem::Version
26
+ version: 0.8.3
27
+ - !ruby/object:Gem::Dependency
28
+ name: activesupport
29
+ requirement: !ruby/object:Gem::Requirement
30
+ requirements:
31
+ - - '='
32
+ - !ruby/object:Gem::Version
33
+ version: 2.3.16
46
34
  type: :runtime
47
- version_requirements: *id002
48
- - !ruby/object:Gem::Dependency
49
- name: activerecord
50
35
  prerelease: false
51
- requirement: &id003 !ruby/object:Gem::Requirement
52
- requirements:
53
- - - "="
54
- - !ruby/object:Gem::Version
55
- segments:
56
- - 2
57
- - 3
58
- - 15
59
- version: 2.3.15
36
+ version_requirements: !ruby/object:Gem::Requirement
37
+ requirements:
38
+ - - '='
39
+ - !ruby/object:Gem::Version
40
+ version: 2.3.16
41
+ - !ruby/object:Gem::Dependency
42
+ name: activerecord
43
+ requirement: !ruby/object:Gem::Requirement
44
+ requirements:
45
+ - - '='
46
+ - !ruby/object:Gem::Version
47
+ version: 2.3.16
60
48
  type: :runtime
61
- version_requirements: *id003
62
- - !ruby/object:Gem::Dependency
63
- name: actionpack
64
49
  prerelease: false
65
- requirement: &id004 !ruby/object:Gem::Requirement
66
- requirements:
67
- - - "="
68
- - !ruby/object:Gem::Version
69
- segments:
70
- - 2
71
- - 3
72
- - 15
73
- version: 2.3.15
50
+ version_requirements: !ruby/object:Gem::Requirement
51
+ requirements:
52
+ - - '='
53
+ - !ruby/object:Gem::Version
54
+ version: 2.3.16
55
+ - !ruby/object:Gem::Dependency
56
+ name: actionpack
57
+ requirement: !ruby/object:Gem::Requirement
58
+ requirements:
59
+ - - '='
60
+ - !ruby/object:Gem::Version
61
+ version: 2.3.16
74
62
  type: :runtime
75
- version_requirements: *id004
76
- - !ruby/object:Gem::Dependency
77
- name: actionmailer
78
63
  prerelease: false
79
- requirement: &id005 !ruby/object:Gem::Requirement
80
- requirements:
81
- - - "="
82
- - !ruby/object:Gem::Version
83
- segments:
84
- - 2
85
- - 3
86
- - 15
87
- version: 2.3.15
64
+ version_requirements: !ruby/object:Gem::Requirement
65
+ requirements:
66
+ - - '='
67
+ - !ruby/object:Gem::Version
68
+ version: 2.3.16
69
+ - !ruby/object:Gem::Dependency
70
+ name: actionmailer
71
+ requirement: !ruby/object:Gem::Requirement
72
+ requirements:
73
+ - - '='
74
+ - !ruby/object:Gem::Version
75
+ version: 2.3.16
88
76
  type: :runtime
89
- version_requirements: *id005
90
- - !ruby/object:Gem::Dependency
91
- name: activeresource
92
77
  prerelease: false
93
- requirement: &id006 !ruby/object:Gem::Requirement
94
- requirements:
95
- - - "="
96
- - !ruby/object:Gem::Version
97
- segments:
98
- - 2
99
- - 3
100
- - 15
101
- version: 2.3.15
78
+ version_requirements: !ruby/object:Gem::Requirement
79
+ requirements:
80
+ - - '='
81
+ - !ruby/object:Gem::Version
82
+ version: 2.3.16
83
+ - !ruby/object:Gem::Dependency
84
+ name: activeresource
85
+ requirement: !ruby/object:Gem::Requirement
86
+ requirements:
87
+ - - '='
88
+ - !ruby/object:Gem::Version
89
+ version: 2.3.16
102
90
  type: :runtime
103
- version_requirements: *id006
104
- description: " Rails is a framework for building web-application using CGI, FCGI, mod_ruby, or WEBrick\n on top of either MySQL, PostgreSQL, SQLite, DB2, SQL Server, or Oracle with eRuby- or Builder-based templates.\n"
91
+ prerelease: false
92
+ version_requirements: !ruby/object:Gem::Requirement
93
+ requirements:
94
+ - - '='
95
+ - !ruby/object:Gem::Version
96
+ version: 2.3.16
97
+ description: |2
98
+ Rails is a framework for building web-application using CGI, FCGI, mod_ruby, or WEBrick
99
+ on top of either MySQL, PostgreSQL, SQLite, DB2, SQL Server, or Oracle with eRuby- or Builder-based templates.
105
100
  email: david@loudthinking.com
106
- executables:
101
+ executables:
107
102
  - rails
108
103
  extensions: []
109
-
110
104
  extra_rdoc_files: []
111
-
112
- files:
105
+ files:
113
106
  - CHANGELOG
114
107
  - MIT-LICENSE
115
108
  - README
116
109
  - Rakefile
117
110
  - fresh_rakefile
111
+ - railties.gemspec
118
112
  - bin/about
119
113
  - bin/console
120
114
  - bin/dbconsole
@@ -323,36 +317,29 @@ files:
323
317
  - lib/tasks/tmp.rake
324
318
  - lib/test_help.rb
325
319
  - lib/webrick_server.rb
326
- has_rdoc: true
327
320
  homepage: http://www.rubyonrails.org
328
321
  licenses: []
329
-
322
+ metadata: {}
330
323
  post_install_message:
331
- rdoc_options:
332
- - --exclude
333
- - .
334
- require_paths:
324
+ rdoc_options:
325
+ - "--exclude"
326
+ - "."
327
+ require_paths:
335
328
  - lib
336
- required_ruby_version: !ruby/object:Gem::Requirement
337
- requirements:
329
+ required_ruby_version: !ruby/object:Gem::Requirement
330
+ requirements:
338
331
  - - ">="
339
- - !ruby/object:Gem::Version
340
- segments:
341
- - 0
342
- version: "0"
343
- required_rubygems_version: !ruby/object:Gem::Requirement
344
- requirements:
332
+ - !ruby/object:Gem::Version
333
+ version: '0'
334
+ required_rubygems_version: !ruby/object:Gem::Requirement
335
+ requirements:
345
336
  - - ">="
346
- - !ruby/object:Gem::Version
347
- segments:
348
- - 0
349
- version: "0"
337
+ - !ruby/object:Gem::Version
338
+ version: '0'
350
339
  requirements: []
351
-
352
340
  rubyforge_project: rails
353
- rubygems_version: 1.3.6
341
+ rubygems_version: 2.0.0.preview3.1
354
342
  signing_key:
355
- specification_version: 3
343
+ specification_version: 4
356
344
  summary: Web-application framework with template engine, control-flow layer, and ORM.
357
345
  test_files: []
358
-