rails 2.3.12 → 2.3.14

Sign up to get free protection for your applications and to get access to all the features.
data/Rakefile CHANGED
@@ -313,11 +313,11 @@ spec = Gem::Specification.new do |s|
313
313
  EOF
314
314
 
315
315
  s.add_dependency('rake', '>= 0.8.3')
316
- s.add_dependency('activesupport', '= 2.3.12' + PKG_BUILD)
317
- s.add_dependency('activerecord', '= 2.3.12' + PKG_BUILD)
318
- s.add_dependency('actionpack', '= 2.3.12' + PKG_BUILD)
319
- s.add_dependency('actionmailer', '= 2.3.12' + PKG_BUILD)
320
- s.add_dependency('activeresource', '= 2.3.12' + PKG_BUILD)
316
+ s.add_dependency('activesupport', '= 2.3.14' + PKG_BUILD)
317
+ s.add_dependency('activerecord', '= 2.3.14' + PKG_BUILD)
318
+ s.add_dependency('actionpack', '= 2.3.14' + PKG_BUILD)
319
+ s.add_dependency('actionmailer', '= 2.3.14' + PKG_BUILD)
320
+ s.add_dependency('activeresource', '= 2.3.14' + PKG_BUILD)
321
321
 
322
322
  s.rdoc_options << '--exclude' << '.'
323
323
 
@@ -2,7 +2,7 @@ module Rails
2
2
  module VERSION #:nodoc:
3
3
  MAJOR = 2
4
4
  MINOR = 3
5
- TINY = 12
5
+ TINY = 14
6
6
 
7
7
  STRING = [MAJOR, MINOR, TINY].join('.')
8
8
  end
@@ -1,3 +1,5 @@
1
+ begin
2
+ require 'rdoc/task'
1
3
  namespace :doc do
2
4
  desc "Generate documentation for the application. Set custom template with TEMPLATE=/path/to/rdoc/template.rb or title with TITLE=\"Custom Title\""
3
5
  RDoc::Task.new("app") { |rdoc|
@@ -86,3 +88,6 @@ namespace :doc do
86
88
  end
87
89
  end
88
90
  end
91
+ rescue LoadError
92
+ $stderr.puts 'Please install RDoc 2.4.2+ to generate documentation.'
93
+ end
metadata CHANGED
@@ -1,13 +1,13 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: rails
3
3
  version: !ruby/object:Gem::Version
4
- hash: 27
4
+ hash: 31
5
5
  prerelease:
6
6
  segments:
7
7
  - 2
8
8
  - 3
9
- - 12
10
- version: 2.3.12
9
+ - 14
10
+ version: 2.3.14
11
11
  platform: ruby
12
12
  authors:
13
13
  - David Heinemeier Hansson
@@ -15,7 +15,7 @@ autorequire:
15
15
  bindir: bin
16
16
  cert_chain: []
17
17
 
18
- date: 2011-06-08 00:00:00 Z
18
+ date: 2011-08-16 00:00:00 Z
19
19
  dependencies:
20
20
  - !ruby/object:Gem::Dependency
21
21
  name: rake
@@ -41,12 +41,12 @@ dependencies:
41
41
  requirements:
42
42
  - - "="
43
43
  - !ruby/object:Gem::Version
44
- hash: 27
44
+ hash: 31
45
45
  segments:
46
46
  - 2
47
47
  - 3
48
- - 12
49
- version: 2.3.12
48
+ - 14
49
+ version: 2.3.14
50
50
  type: :runtime
51
51
  version_requirements: *id002
52
52
  - !ruby/object:Gem::Dependency
@@ -57,12 +57,12 @@ dependencies:
57
57
  requirements:
58
58
  - - "="
59
59
  - !ruby/object:Gem::Version
60
- hash: 27
60
+ hash: 31
61
61
  segments:
62
62
  - 2
63
63
  - 3
64
- - 12
65
- version: 2.3.12
64
+ - 14
65
+ version: 2.3.14
66
66
  type: :runtime
67
67
  version_requirements: *id003
68
68
  - !ruby/object:Gem::Dependency
@@ -73,12 +73,12 @@ dependencies:
73
73
  requirements:
74
74
  - - "="
75
75
  - !ruby/object:Gem::Version
76
- hash: 27
76
+ hash: 31
77
77
  segments:
78
78
  - 2
79
79
  - 3
80
- - 12
81
- version: 2.3.12
80
+ - 14
81
+ version: 2.3.14
82
82
  type: :runtime
83
83
  version_requirements: *id004
84
84
  - !ruby/object:Gem::Dependency
@@ -89,12 +89,12 @@ dependencies:
89
89
  requirements:
90
90
  - - "="
91
91
  - !ruby/object:Gem::Version
92
- hash: 27
92
+ hash: 31
93
93
  segments:
94
94
  - 2
95
95
  - 3
96
- - 12
97
- version: 2.3.12
96
+ - 14
97
+ version: 2.3.14
98
98
  type: :runtime
99
99
  version_requirements: *id005
100
100
  - !ruby/object:Gem::Dependency
@@ -105,12 +105,12 @@ dependencies:
105
105
  requirements:
106
106
  - - "="
107
107
  - !ruby/object:Gem::Version
108
- hash: 27
108
+ hash: 31
109
109
  segments:
110
110
  - 2
111
111
  - 3
112
- - 12
113
- version: 2.3.12
112
+ - 14
113
+ version: 2.3.14
114
114
  type: :runtime
115
115
  version_requirements: *id006
116
116
  description: " Rails is a framework for building web-application using CGI, FCGI, mod_ruby, or WEBrick\n on top of either MySQL, PostgreSQL, SQLite, DB2, SQL Server, or Oracle with eRuby- or Builder-based templates.\n"
@@ -366,7 +366,7 @@ required_rubygems_version: !ruby/object:Gem::Requirement
366
366
  requirements: []
367
367
 
368
368
  rubyforge_project: rails
369
- rubygems_version: 1.8.2
369
+ rubygems_version: 1.8.8
370
370
  signing_key:
371
371
  specification_version: 3
372
372
  summary: Web-application framework with template engine, control-flow layer, and ORM.