puppet-module-posix-dev-r2.4 0.4.1 → 0.5.1

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
Files changed (2) hide show
  1. checksums.yaml +5 -5
  2. metadata +103 -36
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
- SHA1:
3
- metadata.gz: 8937cdd55673ff30fd85486a6ef56bb18620a9bb
4
- data.tar.gz: 2c44606a5655ef95def5078662844da48cdf6300
2
+ SHA256:
3
+ metadata.gz: 0e489ca49fa38f711e4e9dd946ba0936828d05776c536d98195b320971b707cc
4
+ data.tar.gz: 449313b0dbdeb486c19c4ece4630dd21d245950d57faf23970d60dbad032410e
5
5
  SHA512:
6
- metadata.gz: 8685b253b8ea5019419ce04397c75cedd0a989947d54a7ff16d7fe9d4be14d5233cbb1bd234a6fc8147e085c2edc9dcba6565cc72c091a155b33392b0be57b0e
7
- data.tar.gz: 2d51e3285e401f07fae35b174aa9d71ec2df83ec0efe4cf272b251b2cb43709d5506148abf61eb11ef5b6ee7f8f7886566e588f98dd4df3d26c1faf6a0d82328
6
+ metadata.gz: 1b72e6a532ee3fde438ef849495930a1f022dbf394d5934a3dbff01bedf41724d5eb658d22fe23f3b0178067ca128be86d40f30006debdeb99e51715a4a9d761
7
+ data.tar.gz: 3d80eac8002020aeae2ed846c7247eeb0de4f6c5189f668d1fe9fa12322b67c5be3eb31f8c2379816a6f0e79407f001b9d3e9dbc84543c1a7ed747bdf46b4f1d
metadata CHANGED
@@ -1,63 +1,125 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: puppet-module-posix-dev-r2.4
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.4.1
4
+ version: 0.5.1
5
5
  platform: ruby
6
6
  authors:
7
7
  - Puppet, Inc.
8
- autorequire:
8
+ autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2019-07-30 00:00:00.000000000 Z
11
+ date: 2020-08-19 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
- name: simplecov
14
+ name: puppet-blacksmith
15
+ requirement: !ruby/object:Gem::Requirement
16
+ requirements:
17
+ - - "~>"
18
+ - !ruby/object:Gem::Version
19
+ version: '6.0'
20
+ type: :runtime
21
+ prerelease: false
22
+ version_requirements: !ruby/object:Gem::Requirement
23
+ requirements:
24
+ - - "~>"
25
+ - !ruby/object:Gem::Version
26
+ version: '6.0'
27
+ - !ruby/object:Gem::Dependency
28
+ name: activesupport
15
29
  requirement: !ruby/object:Gem::Requirement
16
30
  requirements:
17
31
  - - ">="
18
32
  - !ruby/object:Gem::Version
19
- version: 0.14.1
33
+ version: 5.0.0
20
34
  - - "<"
21
35
  - !ruby/object:Gem::Version
22
- version: 1.0.0
36
+ version: 6.0.0
23
37
  type: :runtime
24
38
  prerelease: false
25
39
  version_requirements: !ruby/object:Gem::Requirement
26
40
  requirements:
27
41
  - - ">="
28
42
  - !ruby/object:Gem::Version
29
- version: 0.14.1
43
+ version: 5.0.0
30
44
  - - "<"
31
45
  - !ruby/object:Gem::Version
32
- version: 1.0.0
46
+ version: 6.0.0
33
47
  - !ruby/object:Gem::Dependency
34
- name: puppet-blacksmith
48
+ name: simplecov
35
49
  requirement: !ruby/object:Gem::Requirement
36
50
  requirements:
37
- - - ">="
51
+ - - "<"
38
52
  - !ruby/object:Gem::Version
39
- version: 3.4.0
53
+ version: 0.19.0
40
54
  type: :runtime
41
55
  prerelease: false
42
56
  version_requirements: !ruby/object:Gem::Requirement
43
57
  requirements:
44
- - - ">="
58
+ - - "<"
45
59
  - !ruby/object:Gem::Version
46
- version: 3.4.0
60
+ version: 0.19.0
47
61
  - !ruby/object:Gem::Dependency
48
- name: codecov
62
+ name: ed25519
49
63
  requirement: !ruby/object:Gem::Requirement
50
64
  requirements:
51
65
  - - "~>"
52
66
  - !ruby/object:Gem::Version
53
- version: 0.1.10
67
+ version: '1.2'
54
68
  type: :runtime
55
69
  prerelease: false
56
70
  version_requirements: !ruby/object:Gem::Requirement
57
71
  requirements:
58
72
  - - "~>"
59
73
  - !ruby/object:Gem::Version
60
- version: 0.1.10
74
+ version: '1.2'
75
+ - !ruby/object:Gem::Dependency
76
+ name: bcrypt_pbkdf
77
+ requirement: !ruby/object:Gem::Requirement
78
+ requirements:
79
+ - - "~>"
80
+ - !ruby/object:Gem::Version
81
+ version: '1.0'
82
+ type: :runtime
83
+ prerelease: false
84
+ version_requirements: !ruby/object:Gem::Requirement
85
+ requirements:
86
+ - - "~>"
87
+ - !ruby/object:Gem::Version
88
+ version: '1.0'
89
+ - !ruby/object:Gem::Dependency
90
+ name: codecov
91
+ requirement: !ruby/object:Gem::Requirement
92
+ requirements:
93
+ - - ">="
94
+ - !ruby/object:Gem::Version
95
+ version: '0.2'
96
+ - - "<"
97
+ - !ruby/object:Gem::Version
98
+ version: 0.2.6
99
+ type: :runtime
100
+ prerelease: false
101
+ version_requirements: !ruby/object:Gem::Requirement
102
+ requirements:
103
+ - - ">="
104
+ - !ruby/object:Gem::Version
105
+ version: '0.2'
106
+ - - "<"
107
+ - !ruby/object:Gem::Version
108
+ version: 0.2.6
109
+ - !ruby/object:Gem::Dependency
110
+ name: concurrent-ruby
111
+ requirement: !ruby/object:Gem::Requirement
112
+ requirements:
113
+ - - "!="
114
+ - !ruby/object:Gem::Version
115
+ version: 1.1.6
116
+ type: :runtime
117
+ prerelease: false
118
+ version_requirements: !ruby/object:Gem::Requirement
119
+ requirements:
120
+ - - "!="
121
+ - !ruby/object:Gem::Version
122
+ version: 1.1.6
61
123
  - !ruby/object:Gem::Dependency
62
124
  name: dependency_checker
63
125
  requirement: !ruby/object:Gem::Requirement
@@ -76,16 +138,22 @@ dependencies:
76
138
  name: facterdb
77
139
  requirement: !ruby/object:Gem::Requirement
78
140
  requirements:
79
- - - "~>"
141
+ - - ">="
80
142
  - !ruby/object:Gem::Version
81
143
  version: 0.8.1
144
+ - - "<"
145
+ - !ruby/object:Gem::Version
146
+ version: 2.0.0
82
147
  type: :runtime
83
148
  prerelease: false
84
149
  version_requirements: !ruby/object:Gem::Requirement
85
150
  requirements:
86
- - - "~>"
151
+ - - ">="
87
152
  - !ruby/object:Gem::Version
88
153
  version: 0.8.1
154
+ - - "<"
155
+ - !ruby/object:Gem::Version
156
+ version: 2.0.0
89
157
  - !ruby/object:Gem::Dependency
90
158
  name: gettext-setup
91
159
  requirement: !ruby/object:Gem::Requirement
@@ -161,33 +229,33 @@ dependencies:
161
229
  - !ruby/object:Gem::Version
162
230
  version: 2.14.3
163
231
  - !ruby/object:Gem::Dependency
164
- name: parser
232
+ name: pry
165
233
  requirement: !ruby/object:Gem::Requirement
166
234
  requirements:
167
235
  - - "~>"
168
236
  - !ruby/object:Gem::Version
169
- version: 2.5.1.2
237
+ version: 0.10.4
170
238
  type: :runtime
171
239
  prerelease: false
172
240
  version_requirements: !ruby/object:Gem::Requirement
173
241
  requirements:
174
242
  - - "~>"
175
243
  - !ruby/object:Gem::Version
176
- version: 2.5.1.2
244
+ version: 0.10.4
177
245
  - !ruby/object:Gem::Dependency
178
- name: pry
246
+ name: puppet-debugger
179
247
  requirement: !ruby/object:Gem::Requirement
180
248
  requirements:
181
249
  - - "~>"
182
250
  - !ruby/object:Gem::Version
183
- version: 0.10.4
251
+ version: '0.18'
184
252
  type: :runtime
185
253
  prerelease: false
186
254
  version_requirements: !ruby/object:Gem::Requirement
187
255
  requirements:
188
256
  - - "~>"
189
257
  - !ruby/object:Gem::Version
190
- version: 0.10.4
258
+ version: '0.18'
191
259
  - !ruby/object:Gem::Dependency
192
260
  name: puppet-lint
193
261
  requirement: !ruby/object:Gem::Requirement
@@ -242,14 +310,14 @@ dependencies:
242
310
  requirements:
243
311
  - - "~>"
244
312
  - !ruby/object:Gem::Version
245
- version: '1.6'
313
+ version: '1.8'
246
314
  type: :runtime
247
315
  prerelease: false
248
316
  version_requirements: !ruby/object:Gem::Requirement
249
317
  requirements:
250
318
  - - "~>"
251
319
  - !ruby/object:Gem::Version
252
- version: '1.6'
320
+ version: '1.8'
253
321
  - !ruby/object:Gem::Dependency
254
322
  name: puppet-syntax
255
323
  requirement: !ruby/object:Gem::Requirement
@@ -330,14 +398,14 @@ dependencies:
330
398
  requirements:
331
399
  - - "~>"
332
400
  - !ruby/object:Gem::Version
333
- version: 1.9.5
401
+ version: 1.10.0
334
402
  type: :runtime
335
403
  prerelease: false
336
404
  version_requirements: !ruby/object:Gem::Requirement
337
405
  requirements:
338
406
  - - "~>"
339
407
  - !ruby/object:Gem::Version
340
- version: 1.9.5
408
+ version: 1.10.0
341
409
  - !ruby/object:Gem::Dependency
342
410
  name: rubocop
343
411
  requirement: !ruby/object:Gem::Requirement
@@ -428,15 +496,15 @@ dependencies:
428
496
  requirements:
429
497
  - - '='
430
498
  - !ruby/object:Gem::Version
431
- version: 2.77.1
499
+ version: 2.82.2
432
500
  type: :runtime
433
501
  prerelease: false
434
502
  version_requirements: !ruby/object:Gem::Requirement
435
503
  requirements:
436
504
  - - '='
437
505
  - !ruby/object:Gem::Version
438
- version: 2.77.1
439
- description:
506
+ version: 2.82.2
507
+ description:
440
508
  email: puppet-module-gems-maintainers@puppet.com
441
509
  executables: []
442
510
  extensions: []
@@ -446,7 +514,7 @@ homepage: https://github.com/puppetlabs/puppet-module-gems
446
514
  licenses:
447
515
  - Apache-2.0
448
516
  metadata: {}
449
- post_install_message:
517
+ post_install_message:
450
518
  rdoc_options: []
451
519
  require_paths:
452
520
  - lib
@@ -461,9 +529,8 @@ required_rubygems_version: !ruby/object:Gem::Requirement
461
529
  - !ruby/object:Gem::Version
462
530
  version: '0'
463
531
  requirements: []
464
- rubyforge_project:
465
- rubygems_version: 2.6.14
466
- signing_key:
532
+ rubygems_version: 3.0.8
533
+ signing_key:
467
534
  specification_version: 4
468
- summary: A gem used to manage Puppet module dependencies.
535
+ summary: A set of gems declaring Puppet module dependencies.
469
536
  test_files: []