puppet-module-posix-dev-r2.4 0.4.0 → 0.5.0

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
Files changed (2) hide show
  1. checksums.yaml +4 -4
  2. metadata +88 -47
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: b6f62b15c42ac4d81f20505d04180a800731896d0b56166c7dfa8703bf3e65f5
4
- data.tar.gz: ef8d8d3356f9c4cf5a4639eb742a4b8bb16e3680bc2c948ec102672dc33131ab
3
+ metadata.gz: 33cdab43ddf64a53eeacdc8d04236e3ad37babe1d197e0fde21a9af97653b973
4
+ data.tar.gz: c913b1941f4baa58b846af90280742580c568a4551a66a0af547f45a02bfc8f6
5
5
  SHA512:
6
- metadata.gz: 960521be2ed2871a4f8067f1118d990e8beb5df78f508d9c2d9d6d69a5752f8473a50302c481010d99cfa0b0f6743e98fa899a54295aa65f8f62e6d0efd41c74
7
- data.tar.gz: 071a057a922181fd17724307e940bcae735038ed0477166864b2b49575de157d02a88d5c4378614ca89a9d4fc7c9d2603c589bedf7ad58d1896be238c8584502
6
+ metadata.gz: 63a70799ae5564a5fb78fa403c9b5642635f4ed1eca9b327335d34626dbf455d8a47fc4206931f641b8aad23415136f0b26b1078c946550d4ee7933455cbe283
7
+ data.tar.gz: 024e68f1482cb8020481f377b9f47264b172a5d63b72405b7b0573b654270894abc67d3299bab95b8b85e4a259a0f867ef74b81880c4cabc705a4d78fb140f84
metadata CHANGED
@@ -1,49 +1,77 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: puppet-module-posix-dev-r2.4
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.4.0
4
+ version: 0.5.0
5
5
  platform: ruby
6
6
  authors:
7
7
  - Puppet, Inc.
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2019-06-24 00:00:00.000000000 Z
11
+ date: 2020-06-22 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
- name: simplecov
14
+ name: puppet-blacksmith
15
+ requirement: !ruby/object:Gem::Requirement
16
+ requirements:
17
+ - - "~>"
18
+ - !ruby/object:Gem::Version
19
+ version: '6.0'
20
+ type: :runtime
21
+ prerelease: false
22
+ version_requirements: !ruby/object:Gem::Requirement
23
+ requirements:
24
+ - - "~>"
25
+ - !ruby/object:Gem::Version
26
+ version: '6.0'
27
+ - !ruby/object:Gem::Dependency
28
+ name: activesupport
15
29
  requirement: !ruby/object:Gem::Requirement
16
30
  requirements:
17
31
  - - ">="
18
32
  - !ruby/object:Gem::Version
19
- version: 0.14.1
33
+ version: 5.0.0
20
34
  - - "<"
21
35
  - !ruby/object:Gem::Version
22
- version: 1.0.0
36
+ version: 6.0.0
23
37
  type: :runtime
24
38
  prerelease: false
25
39
  version_requirements: !ruby/object:Gem::Requirement
26
40
  requirements:
27
41
  - - ">="
28
42
  - !ruby/object:Gem::Version
29
- version: 0.14.1
43
+ version: 5.0.0
30
44
  - - "<"
31
45
  - !ruby/object:Gem::Version
32
- version: 1.0.0
46
+ version: 6.0.0
33
47
  - !ruby/object:Gem::Dependency
34
- name: puppet-blacksmith
48
+ name: ed25519
35
49
  requirement: !ruby/object:Gem::Requirement
36
50
  requirements:
37
- - - ">="
51
+ - - "~>"
38
52
  - !ruby/object:Gem::Version
39
- version: 3.4.0
53
+ version: '1.2'
40
54
  type: :runtime
41
55
  prerelease: false
42
56
  version_requirements: !ruby/object:Gem::Requirement
43
57
  requirements:
44
- - - ">="
58
+ - - "~>"
59
+ - !ruby/object:Gem::Version
60
+ version: '1.2'
61
+ - !ruby/object:Gem::Dependency
62
+ name: bcrypt_pbkdf
63
+ requirement: !ruby/object:Gem::Requirement
64
+ requirements:
65
+ - - "~>"
45
66
  - !ruby/object:Gem::Version
46
- version: 3.4.0
67
+ version: '1.0'
68
+ type: :runtime
69
+ prerelease: false
70
+ version_requirements: !ruby/object:Gem::Requirement
71
+ requirements:
72
+ - - "~>"
73
+ - !ruby/object:Gem::Version
74
+ version: '1.0'
47
75
  - !ruby/object:Gem::Dependency
48
76
  name: codecov
49
77
  requirement: !ruby/object:Gem::Requirement
@@ -58,6 +86,20 @@ dependencies:
58
86
  - - "~>"
59
87
  - !ruby/object:Gem::Version
60
88
  version: 0.1.10
89
+ - !ruby/object:Gem::Dependency
90
+ name: concurrent-ruby
91
+ requirement: !ruby/object:Gem::Requirement
92
+ requirements:
93
+ - - "!="
94
+ - !ruby/object:Gem::Version
95
+ version: 1.1.6
96
+ type: :runtime
97
+ prerelease: false
98
+ version_requirements: !ruby/object:Gem::Requirement
99
+ requirements:
100
+ - - "!="
101
+ - !ruby/object:Gem::Version
102
+ version: 1.1.6
61
103
  - !ruby/object:Gem::Dependency
62
104
  name: dependency_checker
63
105
  requirement: !ruby/object:Gem::Requirement
@@ -72,6 +114,26 @@ dependencies:
72
114
  - - "~>"
73
115
  - !ruby/object:Gem::Version
74
116
  version: '0.2'
117
+ - !ruby/object:Gem::Dependency
118
+ name: facterdb
119
+ requirement: !ruby/object:Gem::Requirement
120
+ requirements:
121
+ - - ">="
122
+ - !ruby/object:Gem::Version
123
+ version: 0.8.1
124
+ - - "<"
125
+ - !ruby/object:Gem::Version
126
+ version: 2.0.0
127
+ type: :runtime
128
+ prerelease: false
129
+ version_requirements: !ruby/object:Gem::Requirement
130
+ requirements:
131
+ - - ">="
132
+ - !ruby/object:Gem::Version
133
+ version: 0.8.1
134
+ - - "<"
135
+ - !ruby/object:Gem::Version
136
+ version: 2.0.0
75
137
  - !ruby/object:Gem::Dependency
76
138
  name: gettext-setup
77
139
  requirement: !ruby/object:Gem::Requirement
@@ -147,33 +209,33 @@ dependencies:
147
209
  - !ruby/object:Gem::Version
148
210
  version: 2.14.3
149
211
  - !ruby/object:Gem::Dependency
150
- name: parser
212
+ name: pry
151
213
  requirement: !ruby/object:Gem::Requirement
152
214
  requirements:
153
215
  - - "~>"
154
216
  - !ruby/object:Gem::Version
155
- version: 2.5.1.2
217
+ version: 0.10.4
156
218
  type: :runtime
157
219
  prerelease: false
158
220
  version_requirements: !ruby/object:Gem::Requirement
159
221
  requirements:
160
222
  - - "~>"
161
223
  - !ruby/object:Gem::Version
162
- version: 2.5.1.2
224
+ version: 0.10.4
163
225
  - !ruby/object:Gem::Dependency
164
- name: pry
226
+ name: puppet-debugger
165
227
  requirement: !ruby/object:Gem::Requirement
166
228
  requirements:
167
229
  - - "~>"
168
230
  - !ruby/object:Gem::Version
169
- version: 0.10.4
231
+ version: '0.18'
170
232
  type: :runtime
171
233
  prerelease: false
172
234
  version_requirements: !ruby/object:Gem::Requirement
173
235
  requirements:
174
236
  - - "~>"
175
237
  - !ruby/object:Gem::Version
176
- version: 0.10.4
238
+ version: '0.18'
177
239
  - !ruby/object:Gem::Dependency
178
240
  name: puppet-lint
179
241
  requirement: !ruby/object:Gem::Requirement
@@ -194,26 +256,6 @@ dependencies:
194
256
  - - "<"
195
257
  - !ruby/object:Gem::Version
196
258
  version: 3.0.0
197
- - !ruby/object:Gem::Dependency
198
- name: puppet_litmus
199
- requirement: !ruby/object:Gem::Requirement
200
- requirements:
201
- - - ">="
202
- - !ruby/object:Gem::Version
203
- version: 0.4.0
204
- - - "<"
205
- - !ruby/object:Gem::Version
206
- version: 1.0.0
207
- type: :runtime
208
- prerelease: false
209
- version_requirements: !ruby/object:Gem::Requirement
210
- requirements:
211
- - - ">="
212
- - !ruby/object:Gem::Version
213
- version: 0.4.0
214
- - - "<"
215
- - !ruby/object:Gem::Version
216
- version: 1.0.0
217
259
  - !ruby/object:Gem::Dependency
218
260
  name: puppet_pot_generator
219
261
  requirement: !ruby/object:Gem::Requirement
@@ -248,14 +290,14 @@ dependencies:
248
290
  requirements:
249
291
  - - "~>"
250
292
  - !ruby/object:Gem::Version
251
- version: '1.6'
293
+ version: '1.8'
252
294
  type: :runtime
253
295
  prerelease: false
254
296
  version_requirements: !ruby/object:Gem::Requirement
255
297
  requirements:
256
298
  - - "~>"
257
299
  - !ruby/object:Gem::Version
258
- version: '1.6'
300
+ version: '1.8'
259
301
  - !ruby/object:Gem::Dependency
260
302
  name: puppet-syntax
261
303
  requirement: !ruby/object:Gem::Requirement
@@ -336,14 +378,14 @@ dependencies:
336
378
  requirements:
337
379
  - - "~>"
338
380
  - !ruby/object:Gem::Version
339
- version: '1.8'
381
+ version: 1.10.0
340
382
  type: :runtime
341
383
  prerelease: false
342
384
  version_requirements: !ruby/object:Gem::Requirement
343
385
  requirements:
344
386
  - - "~>"
345
387
  - !ruby/object:Gem::Version
346
- version: '1.8'
388
+ version: 1.10.0
347
389
  - !ruby/object:Gem::Dependency
348
390
  name: rubocop
349
391
  requirement: !ruby/object:Gem::Requirement
@@ -434,14 +476,14 @@ dependencies:
434
476
  requirements:
435
477
  - - '='
436
478
  - !ruby/object:Gem::Version
437
- version: 2.77.1
479
+ version: 2.82.2
438
480
  type: :runtime
439
481
  prerelease: false
440
482
  version_requirements: !ruby/object:Gem::Requirement
441
483
  requirements:
442
484
  - - '='
443
485
  - !ruby/object:Gem::Version
444
- version: 2.77.1
486
+ version: 2.82.2
445
487
  description:
446
488
  email: puppet-module-gems-maintainers@puppet.com
447
489
  executables: []
@@ -467,9 +509,8 @@ required_rubygems_version: !ruby/object:Gem::Requirement
467
509
  - !ruby/object:Gem::Version
468
510
  version: '0'
469
511
  requirements: []
470
- rubyforge_project:
471
- rubygems_version: 2.7.7
512
+ rubygems_version: 3.1.2
472
513
  signing_key:
473
514
  specification_version: 4
474
- summary: A gem used to manage Puppet module dependencies.
515
+ summary: A set of gems declaring Puppet module dependencies.
475
516
  test_files: []