pulpcore_client 3.20.0.dev1651385115 → 3.20.0.dev1651723573

Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: 684042a804e26452d4f997254d3e68864344479d7aa040552dfe385be2aadc6c
4
- data.tar.gz: b444d257d58c3ac84649fd4dce2a64e12b858a3b7347e25f700d37d2c20d8d38
3
+ metadata.gz: 292225c9c72ba9bf72f70ffc3c606454f3f2e03d76823998d587013abc8903ce
4
+ data.tar.gz: 517d637da28e22b25b2a1c3e1b653b22191ce43281e7b7a4cb88b8ceeedc75a1
5
5
  SHA512:
6
- metadata.gz: 4180063a8b91ccc695e4a24b2a7e40858ad3f6ae51d983780ce8e3eb65bfdf5c3a111865eac39902e574713ffe7ee3fcfc94cb37e43fefb95b281956b8d48998
7
- data.tar.gz: 23eafa1fe68c5764a9e5bb9c563569ecfc05f7f3b6900e518de64ab08ab4e654bfe4a9eb0dc4d1c22e37de2caf87712aa9813cc59c6892607e5c5fd57097438d
6
+ metadata.gz: 7e87d9146a4e31fb2f2dc3c22967246c29bdb1e42bdbb38b4df62ac118ef99f2711546399f73a4c32430347be58fda7074cf78f75775231b06f2117d0986c410
7
+ data.tar.gz: 0bc6d5d66368621173a6e1380bda568ed011876e588ad9f242385a1f8a8868009e39e4629fc7308054ed7948e144cf749ac2ecb901600f05125d33abf872654c
data/README.md CHANGED
@@ -7,7 +7,7 @@ Fetch, Upload, Organize, and Distribute Software Packages
7
7
  This SDK is automatically generated by the [OpenAPI Generator](https://openapi-generator.tech) project:
8
8
 
9
9
  - API version: v3
10
- - Package version: 3.20.0.dev1651385115
10
+ - Package version: 3.20.0.dev1651723573
11
11
  - Build package: org.openapitools.codegen.languages.RubyClientCodegen
12
12
  For more information, please visit [https://pulpproject.org](https://pulpproject.org)
13
13
 
@@ -24,16 +24,16 @@ gem build pulpcore_client.gemspec
24
24
  Then either install the gem locally:
25
25
 
26
26
  ```shell
27
- gem install ./pulpcore_client-3.20.0.dev1651385115.gem
27
+ gem install ./pulpcore_client-3.20.0.dev1651723573.gem
28
28
  ```
29
29
 
30
- (for development, run `gem install --dev ./pulpcore_client-3.20.0.dev1651385115.gem` to install the development dependencies)
30
+ (for development, run `gem install --dev ./pulpcore_client-3.20.0.dev1651723573.gem` to install the development dependencies)
31
31
 
32
32
  or publish the gem to a gem hosting service, e.g. [RubyGems](https://rubygems.org/).
33
33
 
34
34
  Finally add this to the Gemfile:
35
35
 
36
- gem 'pulpcore_client', '~> 3.20.0.dev1651385115'
36
+ gem 'pulpcore_client', '~> 3.20.0.dev1651723573'
37
37
 
38
38
  ### Install from Git
39
39
 
@@ -41,6 +41,7 @@ opts = {
41
41
  pulp_created__lt: DateTime.parse('2013-10-20T19:20:30+01:00'), # DateTime | Filter results where pulp_created is less than value
42
42
  pulp_created__lte: DateTime.parse('2013-10-20T19:20:30+01:00'), # DateTime | Filter results where pulp_created is less than or equal to value
43
43
  pulp_created__range: [DateTime.parse('2013-10-20T19:20:30+01:00')], # Array<DateTime> | Filter results where pulp_created is between two comma separated values
44
+ repository: 'repository_example', # String | Repository referenced by HREF
44
45
  repository_version: 'repository_version_example', # String | Repository Version referenced by HREF
45
46
  fields: 'fields_example', # String | A list of fields to include in the response.
46
47
  exclude_fields: 'exclude_fields_example' # String | A list of fields to exclude from the response.
@@ -71,6 +72,7 @@ Name | Type | Description | Notes
71
72
  **pulp_created__lt** | **DateTime**| Filter results where pulp_created is less than value | [optional]
72
73
  **pulp_created__lte** | **DateTime**| Filter results where pulp_created is less than or equal to value | [optional]
73
74
  **pulp_created__range** | [**Array&lt;DateTime&gt;**](DateTime.md)| Filter results where pulp_created is between two comma separated values | [optional]
75
+ **repository** | **String**| Repository referenced by HREF | [optional]
74
76
  **repository_version** | [**String**](.md)| Repository Version referenced by HREF | [optional]
75
77
  **fields** | **String**| A list of fields to include in the response. | [optional]
76
78
  **exclude_fields** | **String**| A list of fields to exclude from the response. | [optional]
@@ -33,6 +33,7 @@ module PulpcoreClient
33
33
  # @option opts [DateTime] :pulp_created__lt Filter results where pulp_created is less than value
34
34
  # @option opts [DateTime] :pulp_created__lte Filter results where pulp_created is less than or equal to value
35
35
  # @option opts [Array<DateTime>] :pulp_created__range Filter results where pulp_created is between two comma separated values
36
+ # @option opts [String] :repository Repository referenced by HREF
36
37
  # @option opts [String] :repository_version Repository Version referenced by HREF
37
38
  # @option opts [String] :fields A list of fields to include in the response.
38
39
  # @option opts [String] :exclude_fields A list of fields to exclude from the response.
@@ -56,6 +57,7 @@ module PulpcoreClient
56
57
  # @option opts [DateTime] :pulp_created__lt Filter results where pulp_created is less than value
57
58
  # @option opts [DateTime] :pulp_created__lte Filter results where pulp_created is less than or equal to value
58
59
  # @option opts [Array<DateTime>] :pulp_created__range Filter results where pulp_created is between two comma separated values
60
+ # @option opts [String] :repository Repository referenced by HREF
59
61
  # @option opts [String] :repository_version Repository Version referenced by HREF
60
62
  # @option opts [String] :fields A list of fields to include in the response.
61
63
  # @option opts [String] :exclude_fields A list of fields to exclude from the response.
@@ -80,6 +82,7 @@ module PulpcoreClient
80
82
  query_params[:'pulp_created__lt'] = opts[:'pulp_created__lt'] if !opts[:'pulp_created__lt'].nil?
81
83
  query_params[:'pulp_created__lte'] = opts[:'pulp_created__lte'] if !opts[:'pulp_created__lte'].nil?
82
84
  query_params[:'pulp_created__range'] = @api_client.build_collection_param(opts[:'pulp_created__range'], :csv) if !opts[:'pulp_created__range'].nil?
85
+ query_params[:'repository'] = opts[:'repository'] if !opts[:'repository'].nil?
83
86
  query_params[:'repository_version'] = opts[:'repository_version'] if !opts[:'repository_version'].nil?
84
87
  query_params[:'fields'] = opts[:'fields'] if !opts[:'fields'].nil?
85
88
  query_params[:'exclude_fields'] = opts[:'exclude_fields'] if !opts[:'exclude_fields'].nil?
@@ -11,5 +11,5 @@ OpenAPI Generator version: 4.3.1
11
11
  =end
12
12
 
13
13
  module PulpcoreClient
14
- VERSION = '3.20.0.dev1651385115'
14
+ VERSION = '3.20.0.dev1651723573'
15
15
  end
@@ -47,6 +47,7 @@ describe 'PublicationsApi' do
47
47
  # @option opts [DateTime] :pulp_created__lt Filter results where pulp_created is less than value
48
48
  # @option opts [DateTime] :pulp_created__lte Filter results where pulp_created is less than or equal to value
49
49
  # @option opts [Array<DateTime>] :pulp_created__range Filter results where pulp_created is between two comma separated values
50
+ # @option opts [String] :repository Repository referenced by HREF
50
51
  # @option opts [String] :repository_version Repository Version referenced by HREF
51
52
  # @option opts [String] :fields A list of fields to include in the response.
52
53
  # @option opts [String] :exclude_fields A list of fields to exclude from the response.
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: pulpcore_client
3
3
  version: !ruby/object:Gem::Version
4
- version: 3.20.0.dev1651385115
4
+ version: 3.20.0.dev1651723573
5
5
  platform: ruby
6
6
  authors:
7
7
  - OpenAPI-Generator
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2022-05-01 00:00:00.000000000 Z
11
+ date: 2022-05-05 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: faraday