pay 3.0.16 → 3.0.17

Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: 59b2532c5c7b00afccc1f337f22f89264a5638ce228011166f776c77487b2195
4
- data.tar.gz: b67a36b2fded1ee0a28f6a32efe24c9f2d6a34611b20f6c1a4776d9424f42cfd
3
+ metadata.gz: 2268e7ac1a9c24a08f77336d8e17b46cc0dcefc17762dfd48ad698b11a3e990c
4
+ data.tar.gz: 8227fdb6f1fb10a657f5a731a200ddeb8e711884dcffafe1ffedaf06a1988c0e
5
5
  SHA512:
6
- metadata.gz: c9594441627345f0da762497bb91c465aa37c3c54979c43b47620c5361830add4bb7cf84db1d9e3fbd0bdd8b73997ec676e6ca044a8763a8b4f33757a679c965
7
- data.tar.gz: e0e9918358210d2a8a7cc49e0172c45b0a48884b9d517a73cd19addb0e4c60d4301bb9e33c1deacb8f68941e5ea81f4541c1cb1474c981e8a250f316b59063c6
6
+ metadata.gz: 7b7131afb212c9ff2e0bc657ad26440b09765f2eaa7d2d50c38f110efed513c42547994b65fea9354e5d8429185ca5c5cb109e8cf5d42b57af2f95d69743cf30
7
+ data.tar.gz: d0a9cabba6b63a6a087687efe94f7c13a3040550e57c150dd171ebb4d2b3df6157cd87592de10d216d7c12a4f8bff5ce6e7cb0fd72411930ba6778c0cf0f7de9
data/README.md CHANGED
@@ -27,7 +27,7 @@ Our supported payment processors are:
27
27
 
28
28
  Want to add a new payment provider? Contributions are welcome.
29
29
 
30
- > We make our best attempt to standardize the different payment providers. They function differently so keep that in mind if you plan on doing more complex payments. It would be best to stick witha single payment provider in that case so you don't run into discrepancies.
30
+ > We make our best attempt to standardize the different payment providers. They function differently so keep that in mind if you plan on doing more complex payments. It would be best to stick with a single payment provider in that case so you don't run into discrepancies.
31
31
 
32
32
  ## 📚 Docs
33
33
 
@@ -128,6 +128,12 @@ module Pay
128
128
  processor_subscription(expand: ["latest_invoice.payment_intent"]).latest_invoice.payment_intent
129
129
  end
130
130
 
131
+ def paddle_paused_from
132
+ if (timestamp = super)
133
+ Time.zone.parse(timestamp)
134
+ end
135
+ end
136
+
131
137
  private
132
138
 
133
139
  def cancel_if_active
data/lib/pay/version.rb CHANGED
@@ -1,3 +1,3 @@
1
1
  module Pay
2
- VERSION = "3.0.16"
2
+ VERSION = "3.0.17"
3
3
  end
metadata CHANGED
@@ -1,7 +1,7 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: pay
3
3
  version: !ruby/object:Gem::Version
4
- version: 3.0.16
4
+ version: 3.0.17
5
5
  platform: ruby
6
6
  authors:
7
7
  - Jason Charnes
@@ -9,7 +9,7 @@ authors:
9
9
  autorequire:
10
10
  bindir: bin
11
11
  cert_chain: []
12
- date: 2021-09-11 00:00:00.000000000 Z
12
+ date: 2021-09-14 00:00:00.000000000 Z
13
13
  dependencies:
14
14
  - !ruby/object:Gem::Dependency
15
15
  name: rails
@@ -224,7 +224,7 @@ required_rubygems_version: !ruby/object:Gem::Requirement
224
224
  - !ruby/object:Gem::Version
225
225
  version: '0'
226
226
  requirements: []
227
- rubygems_version: 3.2.22
227
+ rubygems_version: 3.2.3
228
228
  signing_key:
229
229
  specification_version: 4
230
230
  summary: Payments engine for Ruby on Rails