oxidized 0.31.0 → 0.32.1
Sign up to get free protection for your applications and to get access to all the features.
- checksums.yaml +4 -4
- data/.github/workflows/ruby.yml +2 -9
- data/.rubocop.yml +8 -7
- data/.rubocop_todo.yml +6 -6
- data/CHANGELOG.md +40 -0
- data/Dockerfile +5 -2
- data/Rakefile +28 -0
- data/docs/Configuration.md +14 -2
- data/docs/Creating-Models.md +52 -22
- data/docs/DeviceSimulation.md +184 -0
- data/docs/Hooks.md +5 -5
- data/docs/Issues.md +15 -9
- data/docs/Model-Notes/APC_AOS.md +29 -16
- data/docs/Model-Notes/FSOS.md +1 -0
- data/docs/ModelUnitTests.md +186 -0
- data/docs/Release.md +18 -2
- data/docs/Supported-OS-Types.md +3 -2
- data/examples/podman-compose/Makefile +1 -2
- data/{examples/device-simulation → extra}/device2yaml.rb +32 -12
- data/extra/gitdiff-msteams.sh +32 -5
- data/extra/nagios_check_failing_nodes.rb +1 -1
- data/extra/rest_client.rb +1 -1
- data/lib/oxidized/config.rb +1 -1
- data/lib/oxidized/input/ssh.rb +13 -5
- data/lib/oxidized/model/aos7.rb +2 -0
- data/lib/oxidized/model/aosw.rb +1 -1
- data/lib/oxidized/model/apc_aos.rb +1 -1
- data/lib/oxidized/model/arubainstant.rb +1 -1
- data/lib/oxidized/model/asa.rb +2 -1
- data/lib/oxidized/model/asyncos.rb +1 -1
- data/lib/oxidized/model/cumulus.rb +16 -2
- data/lib/oxidized/model/enterprise_sonic.rb +46 -0
- data/lib/oxidized/model/fsos.rb +5 -1
- data/lib/oxidized/model/garderos.rb +4 -4
- data/lib/oxidized/model/junos.rb +1 -1
- data/lib/oxidized/model/kornfeldos.rb +33 -0
- data/lib/oxidized/model/model.rb +2 -2
- data/lib/oxidized/model/powerconnect.rb +1 -1
- data/lib/oxidized/model/sonicos.rb +8 -2
- data/lib/oxidized/model/tplink.rb +1 -0
- data/lib/oxidized/model/xos.rb +1 -1
- data/lib/oxidized/source/source.rb +32 -2
- data/lib/oxidized/version.rb +2 -2
- data/oxidized.gemspec +21 -11
- metadata +47 -71
- data/examples/device-simulation/README.md +0 -173
- data/examples/device-simulation/cmdsets/aoscx +0 -9
- data/examples/device-simulation/cmdsets/arubainstant +0 -5
- data/examples/device-simulation/cmdsets/asa +0 -7
- data/examples/device-simulation/cmdsets/ios +0 -7
- data/examples/device-simulation/cmdsets/nxos +0 -5
- data/examples/device-simulation/cmdsets/routeros +0 -5
- data/examples/device-simulation/cmdsets/srosmd +0 -11
- data/examples/device-simulation/yaml/aoscx_R0X25A-6410_FL.10.10.1100.yaml +0 -2281
- data/examples/device-simulation/yaml/aoscx_R8N85A-C6000-48G-CL4_PL.10.08.1010.yaml +0 -451
- data/examples/device-simulation/yaml/arubainstant_IAP515_8.10.0.6_VWLC.yaml +0 -213
- data/examples/device-simulation/yaml/asa_5512_9.12-4-67_single-context.yaml +0 -531
- data/examples/device-simulation/yaml/asr920_16.8.1b.yaml +0 -1122
- data/examples/device-simulation/yaml/garderos_R7709_003_006_068.yaml +0 -101
- data/examples/device-simulation/yaml/iosxe_C9200L-24P-4G_17.09.04a.yaml +0 -514
- data/examples/device-simulation/yaml/iosxe_C9800-L-F-K9_17.06.05.yaml +0 -417
- data/examples/device-simulation/yaml/riverbed_915.yaml +0 -123
- data/examples/device-simulation/yaml/routeros_CHR_7.10.1.yaml +0 -145
- data/examples/device-simulation/yaml/routeros_CHR_7.16.yaml +0 -79
- data/examples/device-simulation/yaml/routeros_L009UiGS_7.15.2.yaml +0 -353
@@ -1,417 +0,0 @@
|
|
1
|
-
---
|
2
|
-
init_prompt: |-
|
3
|
-
OXIDIZED-WLC1#
|
4
|
-
commands:
|
5
|
-
terminal length 0: |-
|
6
|
-
terminal length 0
|
7
|
-
OXIDIZED-WLC1#
|
8
|
-
terminal width 0: |-
|
9
|
-
terminal width 0
|
10
|
-
OXIDIZED-WLC1#
|
11
|
-
show version: |-
|
12
|
-
show version
|
13
|
-
Cisco IOS XE Software, Version 17.06.05
|
14
|
-
Cisco IOS Software [Bengaluru], C9800 Software (C9800_IOSXE-K9), Version 17.6.5, RELEASE SOFTWARE (fc2)
|
15
|
-
Technical Support: http://www.cisco.com/techsupport
|
16
|
-
Copyright (c) 1986-2023 by Cisco Systems, Inc.
|
17
|
-
Compiled Wed 25-Jan-23 16:09 by mcpre
|
18
|
-
|
19
|
-
|
20
|
-
Cisco IOS-XE software, Copyright (c) 2005-2023 by cisco Systems, Inc.
|
21
|
-
All rights reserved. Certain components of Cisco IOS-XE software are
|
22
|
-
licensed under the GNU General Public License (\"GPL\") Version 2.0. The
|
23
|
-
software code licensed under GPL Version 2.0 is free software that comes
|
24
|
-
with ABSOLUTELY NO WARRANTY. You can redistribute and/or modify such
|
25
|
-
GPL code under the terms of GPL Version 2.0. For more details, see the
|
26
|
-
documentation or \"License Notice\" file accompanying the IOS-XE software,
|
27
|
-
or the applicable URL provided on the flyer accompanying the IOS-XE
|
28
|
-
software.
|
29
|
-
|
30
|
-
|
31
|
-
ROM: 16.12(3r)
|
32
|
-
|
33
|
-
OXIDIZED-WLC1 uptime is 25 weeks, 5 days, 22 hours, 52 minutes
|
34
|
-
Uptime for this control processor is 25 weeks, 5 days, 22 hours, 53 minutes
|
35
|
-
System returned to ROM by Reload Command at 13:53:05 CET Wed Mar 13 2024
|
36
|
-
System restarted at 13:56:37 CET Wed Mar 13 2024
|
37
|
-
System image file is \"bootflash:C9800-L-universalk9_wlc.17.06.05.SPA.bin\"
|
38
|
-
Last reload reason: Reload Command
|
39
|
-
|
40
|
-
|
41
|
-
|
42
|
-
This product contains cryptographic features and is subject to United
|
43
|
-
States and local country laws governing import, export, transfer and
|
44
|
-
use. Delivery of Cisco cryptographic products does not imply
|
45
|
-
third-party authority to import, export, distribute or use encryption.
|
46
|
-
Importers, exporters, distributors and users are responsible for
|
47
|
-
compliance with U.S. and local country laws. By using this product you
|
48
|
-
agree to comply with applicable laws and regulations. If you are unable
|
49
|
-
to comply with U.S. and local laws, return this product immediately.
|
50
|
-
|
51
|
-
A summary of U.S. laws governing Cisco cryptographic products may be found at:
|
52
|
-
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
|
53
|
-
|
54
|
-
If you require further assistance please contact us by sending email to
|
55
|
-
export@cisco.com.
|
56
|
-
|
57
|
-
License Type: Smart License is permanent
|
58
|
-
License Level: adventerprise
|
59
|
-
Next reload license Level: adventerprise
|
60
|
-
AIR License Level: AIR Network Essentials
|
61
|
-
Next reload AIR license Level: AIR Network Essentials
|
62
|
-
|
63
|
-
The current crypto throughput level is 0 kbps\x20
|
64
|
-
|
65
|
-
|
66
|
-
Smart Licensing Status: Registration Not Applicable/Not Applicable
|
67
|
-
|
68
|
-
cisco C9800-L-F-K9 (KATAR) processor (revision KATAR) with 1688671K/6147K bytes of memory.
|
69
|
-
Processor board ID FCL2XXXXXXX
|
70
|
-
Router operating mode: Autonomous
|
71
|
-
2 Virtual Ethernet interfaces
|
72
|
-
4 2.5 Gigabit Ethernet interfaces
|
73
|
-
2 Ten Gigabit Ethernet interfaces
|
74
|
-
32768K bytes of non-volatile configuration memory.
|
75
|
-
16777216K bytes of physical memory.
|
76
|
-
26251263K bytes of eUSB flash at bootflash:.
|
77
|
-
|
78
|
-
Base Ethernet MAC Address : 08:45:D1:00:00:00
|
79
|
-
|
80
|
-
Installation mode is BUNDLE\x20
|
81
|
-
|
82
|
-
Configuration register is 0x2102
|
83
|
-
|
84
|
-
OXIDIZED-WLC1#
|
85
|
-
show vtp status: |-
|
86
|
-
show vtp status
|
87
|
-
VTP Version capable : 1 to 3
|
88
|
-
VTP version running : 1
|
89
|
-
VTP Domain Name :\x20
|
90
|
-
VTP Pruning Mode : Disabled (Operationally Disabled)
|
91
|
-
VTP Traps Generation : Disabled
|
92
|
-
Device ID : 0845.d100.0000
|
93
|
-
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
|
94
|
-
|
95
|
-
Feature VLAN:
|
96
|
-
--------------
|
97
|
-
VTP Operating Mode : Off
|
98
|
-
Maximum VLANs supported locally : 1005
|
99
|
-
Number of existing VLANs : 8
|
100
|
-
Configuration Revision : 0
|
101
|
-
MD5 digest : 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00\x20
|
102
|
-
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00\x20
|
103
|
-
OXIDIZED-WLC1#
|
104
|
-
show inventory: |-
|
105
|
-
show inventory
|
106
|
-
NAME: \"Chassis 1\", DESCR: \"Cisco C9800-L-F-K9 Chassis\"
|
107
|
-
PID: C9800-L-F-K9 , VID: 01 , SN: FCL2XXXXXXX
|
108
|
-
|
109
|
-
NAME: \"Chassis 1 Power Supply Module 0\", DESCR: \"Cisco Catalyst Wireless Controller 12V DC Generic Power Supply\"
|
110
|
-
PID: PWR-12V , VID: , SN: \x20
|
111
|
-
|
112
|
-
NAME: \"Chassis 1 Fan Tray\", DESCR: \"Cisco C9800-L-F-K9 Fan Tray\"
|
113
|
-
PID: C9800-L-F-K9-FAN , VID: , SN: \x20
|
114
|
-
|
115
|
-
NAME: \"module 0\", DESCR: \"Cisco C9800-L-F-K9 Modular Interface Processor\"
|
116
|
-
PID: C9800-L-F-K9 , VID: , SN: \x20
|
117
|
-
|
118
|
-
NAME: \"SPA subslot 0/0\", DESCR: \"Front Panel bay-0 4 ports 2.5 Gigabitethernet Module\"
|
119
|
-
PID: BUILT-IN-4x2_5GE , VID: V01 , SN: N/A \x20
|
120
|
-
|
121
|
-
NAME: \"SPA subslot 0/1\", DESCR: \"Front Panel bay-1 2 ports Ten/Gigabitethernet Module\"
|
122
|
-
PID: BUILT-IN-2x10GE-F , VID: V01 , SN: N/A \x20
|
123
|
-
|
124
|
-
NAME: \"module R0\", DESCR: \"Cisco C9800-L-F-K9 Route Processor\"
|
125
|
-
PID: C9800-L-F-K9 , VID: 01 , SN: FCL2XXXXXXX
|
126
|
-
|
127
|
-
NAME: \"module F0\", DESCR: \"Cisco C9800-L-F-K9 Embedded Services Processor\"
|
128
|
-
PID: C9800-L-F-K9 , VID: , SN: \x20
|
129
|
-
|
130
|
-
|
131
|
-
OXIDIZED-WLC1#
|
132
|
-
show running-config: |-
|
133
|
-
show running-config
|
134
|
-
Building configuration...
|
135
|
-
|
136
|
-
Current configuration : 19796 bytes
|
137
|
-
!
|
138
|
-
! Last configuration change at 13:57:08 CET Wed Mar 13 2024
|
139
|
-
! NVRAM config last updated at 15:26:39 CET Wed Mar 13 2024 by oxidized
|
140
|
-
!
|
141
|
-
version 17.6
|
142
|
-
service timestamps debug datetime localtime show-timezone year
|
143
|
-
service timestamps log datetime localtime show-timezone year
|
144
|
-
service password-encryption
|
145
|
-
platform qos marker-statistics
|
146
|
-
platform qos match-statistics per-filter
|
147
|
-
!
|
148
|
-
hostname OXIDIZED-WLC1
|
149
|
-
!
|
150
|
-
boot-start-marker
|
151
|
-
boot system flash bootflash:C9800-L-universalk9_wlc.17.06.05.SPA.bin
|
152
|
-
boot-end-marker
|
153
|
-
!
|
154
|
-
!
|
155
|
-
vrf definition Mgmt-intf
|
156
|
-
!
|
157
|
-
address-family ipv4
|
158
|
-
exit-address-family
|
159
|
-
!
|
160
|
-
address-family ipv6
|
161
|
-
exit-address-family
|
162
|
-
!
|
163
|
-
logging monitor informational
|
164
|
-
enable secret 9 $9$SECRET_REMOVED
|
165
|
-
!
|
166
|
-
!
|
167
|
-
aaa server radius dynamic-author
|
168
|
-
client 10.42.0.7 server-key 7 REMOVED_SECRET
|
169
|
-
!
|
170
|
-
aaa session-id common
|
171
|
-
clock timezone CET 1 0
|
172
|
-
clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 2:00
|
173
|
-
vtp mode off
|
174
|
-
!
|
175
|
-
!
|
176
|
-
!
|
177
|
-
!
|
178
|
-
subscriber templating
|
179
|
-
!\x20
|
180
|
-
!\x20
|
181
|
-
!\x20
|
182
|
-
!\x20
|
183
|
-
!
|
184
|
-
!
|
185
|
-
!
|
186
|
-
!
|
187
|
-
!
|
188
|
-
interface TwoGigabitEthernet0/0/0
|
189
|
-
description Uplink
|
190
|
-
switchport trunk allowed vlan 2,3,4
|
191
|
-
switchport mode trunk
|
192
|
-
negotiation auto
|
193
|
-
no snmp trap link-status
|
194
|
-
!
|
195
|
-
interface TwoGigabitEthernet0/0/1
|
196
|
-
negotiation auto
|
197
|
-
no snmp trap link-status
|
198
|
-
!
|
199
|
-
! ...
|
200
|
-
!
|
201
|
-
interface TenGigabitEthernet0/1/0
|
202
|
-
no negotiation auto
|
203
|
-
no snmp trap link-status
|
204
|
-
!
|
205
|
-
interface TenGigabitEthernet0/1/1
|
206
|
-
no negotiation auto
|
207
|
-
no snmp trap link-status
|
208
|
-
!
|
209
|
-
interface GigabitEthernet0
|
210
|
-
description Mgmt
|
211
|
-
vrf forwarding Mgmt-intf
|
212
|
-
ip address 10.41.1.10 255.255.255.0
|
213
|
-
negotiation auto
|
214
|
-
!
|
215
|
-
interface Vlan1
|
216
|
-
no ip address
|
217
|
-
shutdown
|
218
|
-
!
|
219
|
-
ip http server
|
220
|
-
ip http authentication aaa
|
221
|
-
ip http secure-server
|
222
|
-
ip http session-idle-timeout 900\x20
|
223
|
-
ip http client source-interface GigabitEthernet0
|
224
|
-
! ...
|
225
|
-
ip route 0.0.0.0 0.0.0.0 10.41.2.1
|
226
|
-
ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 10.41.1.1 250
|
227
|
-
ip ssh version 2
|
228
|
-
ip scp server enable
|
229
|
-
!
|
230
|
-
!
|
231
|
-
banner login ^CThis is an actively monitored system!
|
232
|
-
Unauthorized access prohibited!
|
233
|
-
^C
|
234
|
-
!
|
235
|
-
! ...
|
236
|
-
wlan test 1 test
|
237
|
-
security wpa psk set-key ascii 0 WLANSECR3T
|
238
|
-
wlan test-spaces 2 test-spaces
|
239
|
-
security wpa psk set-key ascii 0 WLAN SECR3T
|
240
|
-
wlan hex 1000 hex
|
241
|
-
security wpa psk set-key hex 0 7df35f90c92ecff2a803e79577b85e978edc0a76404f6cfb534df8d9f9f67beb
|
242
|
-
ap profile default-ap-profile
|
243
|
-
dot1x username dot1x-username password 0 DOT1XPASSW0RD
|
244
|
-
mgmtuser username apmgmtuser password 0 MGMTPASSW0RD secret 0 MGMTSECR3T
|
245
|
-
ap profile \"spaces profile\"
|
246
|
-
dot1x username dot1x-username password 0 DOT1X PASSW0RD
|
247
|
-
mgmtuser username username password 0 MGMT PASSW0RD secret 0 MGMT SECR3T
|
248
|
-
netconf-yang
|
249
|
-
end
|
250
|
-
|
251
|
-
OXIDIZED-WLC1#
|
252
|
-
exit: |-
|
253
|
-
oxidized_output: |
|
254
|
-
! Cisco IOS XE Software, Version 17.06.05
|
255
|
-
!\x20
|
256
|
-
! Image: Software: C9800_IOSXE-K9, 17.6.5, RELEASE SOFTWARE (fc2)
|
257
|
-
! Image: Compiled: Wed 25-Jan-23 16:09 by mcpre
|
258
|
-
! Image: bootflash:C9800-L-universalk9_wlc.17.06.05.SPA.bin
|
259
|
-
! Chassis type: C9800-L-F-K9
|
260
|
-
! Memory: main 1688671K/6147K
|
261
|
-
! Processor ID: FCL2XXXXXXX
|
262
|
-
! CPU: KATAR
|
263
|
-
! Memory: nvram 32768K
|
264
|
-
!\x20
|
265
|
-
! VTP: VTP Version capable : 1 to 3
|
266
|
-
! VTP: VTP version running : 1
|
267
|
-
! VTP: VTP Domain Name :\x20
|
268
|
-
! VTP: VTP Pruning Mode : Disabled (Operationally Disabled)
|
269
|
-
! VTP: VTP Traps Generation : Disabled
|
270
|
-
! VTP: Device ID : 0845.d100.0000
|
271
|
-
! VTP: Feature VLAN:
|
272
|
-
! VTP: --------------
|
273
|
-
! VTP: VTP Operating Mode : Off
|
274
|
-
! VTP: Maximum VLANs supported locally : 1005
|
275
|
-
! VTP: Number of existing VLANs : 8
|
276
|
-
! VTP: Configuration Revision : 0
|
277
|
-
! VTP: MD5 digest : 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00\x20
|
278
|
-
! VTP: 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00\x20
|
279
|
-
!\x20
|
280
|
-
! NAME: \"Chassis 1\", DESCR: \"Cisco C9800-L-F-K9 Chassis\"
|
281
|
-
! PID: C9800-L-F-K9 , VID: 01 , SN: FCL2XXXXXXX
|
282
|
-
!\x20
|
283
|
-
! NAME: \"Chassis 1 Power Supply Module 0\", DESCR: \"Cisco Catalyst Wireless Controller 12V DC Generic Power Supply\"
|
284
|
-
! PID: PWR-12V , VID: , SN: \x20
|
285
|
-
!\x20
|
286
|
-
! NAME: \"Chassis 1 Fan Tray\", DESCR: \"Cisco C9800-L-F-K9 Fan Tray\"
|
287
|
-
! PID: C9800-L-F-K9-FAN , VID: , SN: \x20
|
288
|
-
!\x20
|
289
|
-
! NAME: \"module 0\", DESCR: \"Cisco C9800-L-F-K9 Modular Interface Processor\"
|
290
|
-
! PID: C9800-L-F-K9 , VID: , SN: \x20
|
291
|
-
!\x20
|
292
|
-
! NAME: \"SPA subslot 0/0\", DESCR: \"Front Panel bay-0 4 ports 2.5 Gigabitethernet Module\"
|
293
|
-
! PID: BUILT-IN-4x2_5GE , VID: V01 , SN: N/A \x20
|
294
|
-
!\x20
|
295
|
-
! NAME: \"SPA subslot 0/1\", DESCR: \"Front Panel bay-1 2 ports Ten/Gigabitethernet Module\"
|
296
|
-
! PID: BUILT-IN-2x10GE-F , VID: V01 , SN: N/A \x20
|
297
|
-
!\x20
|
298
|
-
! NAME: \"module R0\", DESCR: \"Cisco C9800-L-F-K9 Route Processor\"
|
299
|
-
! PID: C9800-L-F-K9 , VID: 01 , SN: FCL2XXXXXXX
|
300
|
-
!\x20
|
301
|
-
! NAME: \"module F0\", DESCR: \"Cisco C9800-L-F-K9 Embedded Services Processor\"
|
302
|
-
! PID: C9800-L-F-K9 , VID: , SN: \x20
|
303
|
-
!\x20
|
304
|
-
!\x20
|
305
|
-
!
|
306
|
-
! NVRAM config last updated at 15:26:39 CET Wed Mar 13 2024 by oxidized
|
307
|
-
!
|
308
|
-
version 17.6
|
309
|
-
service timestamps debug datetime localtime show-timezone year
|
310
|
-
service timestamps log datetime localtime show-timezone year
|
311
|
-
service password-encryption
|
312
|
-
platform qos marker-statistics
|
313
|
-
platform qos match-statistics per-filter
|
314
|
-
!
|
315
|
-
hostname OXIDIZED-WLC1
|
316
|
-
!
|
317
|
-
boot-start-marker
|
318
|
-
boot system flash bootflash:C9800-L-universalk9_wlc.17.06.05.SPA.bin
|
319
|
-
boot-end-marker
|
320
|
-
!
|
321
|
-
!
|
322
|
-
vrf definition Mgmt-intf
|
323
|
-
!
|
324
|
-
address-family ipv4
|
325
|
-
exit-address-family
|
326
|
-
!
|
327
|
-
address-family ipv6
|
328
|
-
exit-address-family
|
329
|
-
!
|
330
|
-
logging monitor informational
|
331
|
-
enable secret 9 $9$SECRET_REMOVED
|
332
|
-
!
|
333
|
-
!
|
334
|
-
aaa server radius dynamic-author
|
335
|
-
client 10.42.0.7 server-key 7 REMOVED_SECRET
|
336
|
-
!
|
337
|
-
aaa session-id common
|
338
|
-
clock timezone CET 1 0
|
339
|
-
clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 2:00
|
340
|
-
vtp mode off
|
341
|
-
!
|
342
|
-
!
|
343
|
-
!
|
344
|
-
!
|
345
|
-
subscriber templating
|
346
|
-
!\x20
|
347
|
-
!\x20
|
348
|
-
!\x20
|
349
|
-
!\x20
|
350
|
-
!
|
351
|
-
!
|
352
|
-
!
|
353
|
-
!
|
354
|
-
!
|
355
|
-
interface TwoGigabitEthernet0/0/0
|
356
|
-
description Uplink
|
357
|
-
switchport trunk allowed vlan 2,3,4
|
358
|
-
switchport mode trunk
|
359
|
-
negotiation auto
|
360
|
-
no snmp trap link-status
|
361
|
-
!
|
362
|
-
interface TwoGigabitEthernet0/0/1
|
363
|
-
negotiation auto
|
364
|
-
no snmp trap link-status
|
365
|
-
!
|
366
|
-
! ...
|
367
|
-
!
|
368
|
-
interface TenGigabitEthernet0/1/0
|
369
|
-
no negotiation auto
|
370
|
-
no snmp trap link-status
|
371
|
-
!
|
372
|
-
interface TenGigabitEthernet0/1/1
|
373
|
-
no negotiation auto
|
374
|
-
no snmp trap link-status
|
375
|
-
!
|
376
|
-
interface GigabitEthernet0
|
377
|
-
description Mgmt
|
378
|
-
vrf forwarding Mgmt-intf
|
379
|
-
ip address 10.41.1.10 255.255.255.0
|
380
|
-
negotiation auto
|
381
|
-
!
|
382
|
-
interface Vlan1
|
383
|
-
no ip address
|
384
|
-
shutdown
|
385
|
-
!
|
386
|
-
ip http server
|
387
|
-
ip http authentication aaa
|
388
|
-
ip http secure-server
|
389
|
-
ip http session-idle-timeout 900\x20
|
390
|
-
ip http client source-interface GigabitEthernet0
|
391
|
-
! ...
|
392
|
-
ip route 0.0.0.0 0.0.0.0 10.41.2.1
|
393
|
-
ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 10.41.1.1 250
|
394
|
-
ip ssh version 2
|
395
|
-
ip scp server enable
|
396
|
-
!
|
397
|
-
!
|
398
|
-
banner login ^CThis is an actively monitored system!
|
399
|
-
Unauthorized access prohibited!
|
400
|
-
^C
|
401
|
-
!
|
402
|
-
! ...
|
403
|
-
wlan test 1 test
|
404
|
-
security wpa psk set-key ascii 0 WLANSECR3T
|
405
|
-
wlan test-spaces 2 test-spaces
|
406
|
-
security wpa psk set-key ascii 0 WLAN SECR3T
|
407
|
-
wlan hex 1000 hex
|
408
|
-
security wpa psk set-key hex 0 7df35f90c92ecff2a803e79577b85e978edc0a76404f6cfb534df8d9f9f67beb
|
409
|
-
ap profile default-ap-profile
|
410
|
-
dot1x username dot1x-username password 0 DOT1XPASSW0RD
|
411
|
-
mgmtuser username apmgmtuser password 0 MGMTPASSW0RD secret 0 MGMTSECR3T
|
412
|
-
ap profile \"spaces profile\"
|
413
|
-
dot1x username dot1x-username password 0 DOT1X PASSW0RD
|
414
|
-
mgmtuser username username password 0 MGMT PASSW0RD secret 0 MGMT SECR3T
|
415
|
-
netconf-yang
|
416
|
-
end\n
|
417
|
-
# End of YAML file
|
@@ -1,123 +0,0 @@
|
|
1
|
-
---
|
2
|
-
init_prompt: |-
|
3
|
-
Riverbed SteelHead
|
4
|
-
Last login: Fri Nov 1 05:55:01 2024 from 192.0.2.1
|
5
|
-
steelhead >
|
6
|
-
commands:
|
7
|
-
enable: |-
|
8
|
-
enable
|
9
|
-
steelhead #
|
10
|
-
terminal length 0: |-
|
11
|
-
terminal length 0
|
12
|
-
steelhead #
|
13
|
-
terminal width 1024: |-
|
14
|
-
terminal width 1024
|
15
|
-
steelhead #
|
16
|
-
show version: |-
|
17
|
-
show version
|
18
|
-
Product name: rbt_sh
|
19
|
-
Product release: X.Y.Z
|
20
|
-
Build ID: #1234
|
21
|
-
Build date: YYYY-MM-DD HH:MM:SS
|
22
|
-
Build arch: x86_64
|
23
|
-
Built by: builduser@buildhost
|
24
|
-
|
25
|
-
Uptime: 100d 10h 10m 10s
|
26
|
-
|
27
|
-
Product model: ModelName (ModelVariant)
|
28
|
-
System memory: XXXX MB used / XXXX MB free / XXXX MB total
|
29
|
-
Number of CPUs: XX
|
30
|
-
CPU load averages: X.XX / X.XX / X.XX
|
31
|
-
steelhead #
|
32
|
-
show hardware all: |-
|
33
|
-
show hardware all
|
34
|
-
Hardware revision: RevX
|
35
|
-
Mainboard: MainboardDescription
|
36
|
-
Slot 0: .......... ModuleDescription0
|
37
|
-
Slot 1: .......... ModuleDescription1
|
38
|
-
Slot 2: .......... ModuleDescription2
|
39
|
-
System led: Color
|
40
|
-
steelhead #
|
41
|
-
show info: |-
|
42
|
-
show info
|
43
|
-
Current User: admin
|
44
|
-
|
45
|
-
Status: Normal
|
46
|
-
Config: config.bak
|
47
|
-
Appliance Up Time: 100d 10h 10m 10s
|
48
|
-
Service Up Time: 90d 20h 20m 20s
|
49
|
-
Managed by CMC: no
|
50
|
-
Temperature (C): XX
|
51
|
-
|
52
|
-
Serial: SERIAL1234567
|
53
|
-
Model: ModelName (ModelVariant)
|
54
|
-
Revision: RevX
|
55
|
-
Version: X.Y.Z
|
56
|
-
steelhead #
|
57
|
-
show running-config: |-
|
58
|
-
show running-config
|
59
|
-
##
|
60
|
-
## Network interface configuration
|
61
|
-
##
|
62
|
-
interface inpath0_0 description "Interface Description"
|
63
|
-
no interface inpath0_0 dhcp
|
64
|
-
no interface inpath0_0 dhcp dynamic-dns
|
65
|
-
no interface inpath0_0 dhcpv6
|
66
|
-
no interface inpath0_0 dhcpv6 dynamic-dns
|
67
|
-
##
|
68
|
-
## Secure device access configuration
|
69
|
-
##
|
70
|
-
access enable
|
71
|
-
##
|
72
|
-
## Port Labels
|
73
|
-
##
|
74
|
-
port-label "Label" port "PortNumbers"
|
75
|
-
tacacs-server host 192.0.2.254 key secretkey
|
76
|
-
username admin password 7 secretpassword
|
77
|
-
snmp-server community public
|
78
|
-
ntp server 192.0.2.100 key 1
|
79
|
-
ip security shared secret mysecret
|
80
|
-
!
|
81
|
-
end
|
82
|
-
steelhead #
|
83
|
-
exit: ""
|
84
|
-
oxidized_output: |
|
85
|
-
! Date of version: YYYY-MM-DD HH:MM:SS UTC
|
86
|
-
! Serial: SERIAL1234567
|
87
|
-
! Product name: rbt_sh
|
88
|
-
! Product release: X.Y.Z
|
89
|
-
! Build ID: #1234
|
90
|
-
! Build date: YYYY-MM-DD HH:MM:SS
|
91
|
-
! Build arch: x86_64
|
92
|
-
! Built by: builduser@buildhost
|
93
|
-
! Product model: ModelName (ModelVariant)
|
94
|
-
! Number of CPUs: XX
|
95
|
-
! Hardware revision: RevX
|
96
|
-
! Mainboard: MainboardDescription
|
97
|
-
! Slot 0: ModuleDescription0
|
98
|
-
! Slot 1: ModuleDescription1
|
99
|
-
! Slot 2: ModuleDescription2
|
100
|
-
! System led: Color
|
101
|
-
##
|
102
|
-
## Network interface configuration
|
103
|
-
##
|
104
|
-
interface inpath0_0 description "Interface Description"
|
105
|
-
no interface inpath0_0 dhcp
|
106
|
-
no interface inpath0_0 dhcp dynamic-dns
|
107
|
-
no interface inpath0_0 dhcpv6
|
108
|
-
no interface inpath0_0 dhcpv6 dynamic-dns
|
109
|
-
##
|
110
|
-
## Secure device access configuration
|
111
|
-
##
|
112
|
-
access enable
|
113
|
-
##
|
114
|
-
## Port Labels
|
115
|
-
##
|
116
|
-
port-label "Label" port "PortNumbers"
|
117
|
-
tacacs-server host 192.0.2.254 key <secret hidden>
|
118
|
-
username admin password <secret hidden>
|
119
|
-
snmp-server community <configuration removed>
|
120
|
-
ntp server 192.0.2.100 key <secret hidden>
|
121
|
-
ip security shared secret <secret hidden>
|
122
|
-
!
|
123
|
-
end
|
@@ -1,145 +0,0 @@
|
|
1
|
-
---
|
2
|
-
init_prompt:
|
3
|
-
commands:
|
4
|
-
/system resource print: |-
|
5
|
-
\x20 uptime: 58m18s
|
6
|
-
\x20 version: 7.10.1 (stable)
|
7
|
-
\x20 build-time: Jun/27/2023 09:03:02
|
8
|
-
\x20 factory-software: 7.1
|
9
|
-
\x20 free-memory: 244.1MiB
|
10
|
-
\x20 total-memory: 320.0MiB
|
11
|
-
\x20 cpu: QEMU
|
12
|
-
\x20 cpu-count: 1
|
13
|
-
\x20 cpu-frequency: 2611MHz
|
14
|
-
\x20 cpu-load: 2%
|
15
|
-
\x20 free-hdd-space: 71.0MiB
|
16
|
-
\x20 total-hdd-space: 89.2MiB
|
17
|
-
\x20 write-sect-since-reboot: 1544
|
18
|
-
\x20 write-sect-total: 1544
|
19
|
-
\x20 architecture-name: x86_64
|
20
|
-
\x20 board-name: CHR
|
21
|
-
\x20 platform: MikroTik
|
22
|
-
|
23
|
-
/system package update print: |-
|
24
|
-
\x20 channel: stable
|
25
|
-
\x20 installed-version: 7.10.1
|
26
|
-
|
27
|
-
/system history print without-paging: |-
|
28
|
-
|
29
|
-
/export show-sensitive: |-
|
30
|
-
# 2024-10-25 06:08:35 by RouterOS 7.10.1
|
31
|
-
# software id =\x20
|
32
|
-
#
|
33
|
-
/interface ethernet
|
34
|
-
set [ find default-name=ether1 ] disable-running-check=no
|
35
|
-
set [ find default-name=ether2 ] disable-running-check=no
|
36
|
-
set [ find default-name=ether3 ] disable-running-check=no
|
37
|
-
set [ find default-name=ether4 ] disable-running-check=no
|
38
|
-
set [ find default-name=ether5 ] disable-running-check=no
|
39
|
-
set [ find default-name=ether6 ] disable-running-check=no
|
40
|
-
set [ find default-name=ether7 ] disable-running-check=no
|
41
|
-
set [ find default-name=ether8 ] disable-running-check=no
|
42
|
-
/disk
|
43
|
-
set slot1 slot=slot1 type=hardware
|
44
|
-
set slot2 slot=slot2 type=hardware
|
45
|
-
set slot3 slot=slot3 type=hardware
|
46
|
-
set slot4 slot=slot4 type=hardware
|
47
|
-
set slot5 slot=slot5 type=hardware
|
48
|
-
set slot6 slot=slot6 type=hardware
|
49
|
-
set slot7 slot=slot7 type=hardware
|
50
|
-
set slot8 slot=slot8 type=hardware
|
51
|
-
set slot9 slot=slot9 type=hardware
|
52
|
-
set slot10 slot=slot10 type=hardware
|
53
|
-
set slot11 slot=slot11 type=hardware
|
54
|
-
set slot12 slot=slot12 type=hardware
|
55
|
-
set slot13 slot=slot13 type=hardware
|
56
|
-
set slot14 slot=slot14 type=hardware
|
57
|
-
set slot15 slot=slot15 type=hardware
|
58
|
-
set slot16 slot=slot16 type=hardware
|
59
|
-
set slot17 slot=slot17 type=hardware
|
60
|
-
set slot18 slot=slot18 type=hardware
|
61
|
-
set slot19 slot=slot19 type=hardware
|
62
|
-
set slot20 slot=slot20 type=hardware
|
63
|
-
set slot21 slot=slot21 type=hardware
|
64
|
-
set slot22 slot=slot22 type=hardware
|
65
|
-
set slot23 slot=slot23 type=hardware
|
66
|
-
set slot24 slot=slot24 type=hardware
|
67
|
-
set slot25 slot=slot25 type=hardware
|
68
|
-
set slot26 slot=slot26 type=hardware
|
69
|
-
set slot27 slot=slot27 type=hardware
|
70
|
-
set slot28 slot=slot28 type=hardware
|
71
|
-
/interface wireless security-profiles
|
72
|
-
set [ find default=yes ] supplicant-identity=MikroTik
|
73
|
-
/port
|
74
|
-
set 0 name=serial0
|
75
|
-
/ip address
|
76
|
-
add address=192.168.129.7/24 interface=ether1 network=192.168.129.0
|
77
|
-
/ip dhcp-client
|
78
|
-
add interface=ether1
|
79
|
-
/ip ssh
|
80
|
-
set always-allow-password-login=yes
|
81
|
-
/system note
|
82
|
-
set show-at-login=no
|
83
|
-
quit: |-
|
84
|
-
interrupted
|
85
|
-
oxidized_output: |
|
86
|
-
# version: 7.10.1 (stable)
|
87
|
-
# factory-software: 7.1
|
88
|
-
# total-memory: 320.0MiB
|
89
|
-
# cpu: QEMU
|
90
|
-
# cpu-count: 1
|
91
|
-
# total-hdd-space: 89.2MiB
|
92
|
-
# architecture-name: x86_64
|
93
|
-
# board-name: CHR
|
94
|
-
# platform: MikroTik# installed-version: 7.10.1# software id =\x20
|
95
|
-
#
|
96
|
-
/interface ethernet
|
97
|
-
set [ find default-name=ether1 ] disable-running-check=no
|
98
|
-
set [ find default-name=ether2 ] disable-running-check=no
|
99
|
-
set [ find default-name=ether3 ] disable-running-check=no
|
100
|
-
set [ find default-name=ether4 ] disable-running-check=no
|
101
|
-
set [ find default-name=ether5 ] disable-running-check=no
|
102
|
-
set [ find default-name=ether6 ] disable-running-check=no
|
103
|
-
set [ find default-name=ether7 ] disable-running-check=no
|
104
|
-
set [ find default-name=ether8 ] disable-running-check=no
|
105
|
-
/disk
|
106
|
-
set slot1 slot=slot1 type=hardware
|
107
|
-
set slot2 slot=slot2 type=hardware
|
108
|
-
set slot3 slot=slot3 type=hardware
|
109
|
-
set slot4 slot=slot4 type=hardware
|
110
|
-
set slot5 slot=slot5 type=hardware
|
111
|
-
set slot6 slot=slot6 type=hardware
|
112
|
-
set slot7 slot=slot7 type=hardware
|
113
|
-
set slot8 slot=slot8 type=hardware
|
114
|
-
set slot9 slot=slot9 type=hardware
|
115
|
-
set slot10 slot=slot10 type=hardware
|
116
|
-
set slot11 slot=slot11 type=hardware
|
117
|
-
set slot12 slot=slot12 type=hardware
|
118
|
-
set slot13 slot=slot13 type=hardware
|
119
|
-
set slot14 slot=slot14 type=hardware
|
120
|
-
set slot15 slot=slot15 type=hardware
|
121
|
-
set slot16 slot=slot16 type=hardware
|
122
|
-
set slot17 slot=slot17 type=hardware
|
123
|
-
set slot18 slot=slot18 type=hardware
|
124
|
-
set slot19 slot=slot19 type=hardware
|
125
|
-
set slot20 slot=slot20 type=hardware
|
126
|
-
set slot21 slot=slot21 type=hardware
|
127
|
-
set slot22 slot=slot22 type=hardware
|
128
|
-
set slot23 slot=slot23 type=hardware
|
129
|
-
set slot24 slot=slot24 type=hardware
|
130
|
-
set slot25 slot=slot25 type=hardware
|
131
|
-
set slot26 slot=slot26 type=hardware
|
132
|
-
set slot27 slot=slot27 type=hardware
|
133
|
-
set slot28 slot=slot28 type=hardware
|
134
|
-
/interface wireless security-profiles
|
135
|
-
set [ find default=yes ] supplicant-identity=MikroTik
|
136
|
-
/port
|
137
|
-
set 0 name=serial0
|
138
|
-
/ip address
|
139
|
-
add address=192.168.129.7/24 interface=ether1 network=192.168.129.0
|
140
|
-
/ip dhcp-client
|
141
|
-
add interface=ether1
|
142
|
-
/ip ssh
|
143
|
-
set always-allow-password-login=yes
|
144
|
-
/system note
|
145
|
-
set show-at-login=no
|