net-hippie 1.0.1 → 1.1.0

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: f1a9f93f24017a895ff282243d18635f7f8cba093d0c8dcf07eefb13bf03cc84
4
- data.tar.gz: 791f658b65c6eadd89ae1186bb741e2a6b221f8f4525ebeace5d0452049b2cba
3
+ metadata.gz: 4d4fa43c3b9fd3549ccfa003cf06c2355c472e4d9e34838a78ca2bca1eff2c26
4
+ data.tar.gz: f1f01ac4e24b1414a5aa4e2f0434d3b12f4df21cd921bee0b6ada5c4c20ef1ae
5
5
  SHA512:
6
- metadata.gz: '07954654db72141c0f24fc56d0bea0afd5d2f8bfe90de8d69487c25b2f46a6491f87be2cfe8cb52e5874558b1beec03632f0c8b50856a8248151ff76044d7bba'
7
- data.tar.gz: 7d42be042781637d66038aac71b4a4fc2bb8db7d5479bedf12edf62dd04c232f598071f38c566318ebcb1779ed9ab8a9aee6de0ee2e27d66e321e377cd6f1db6
6
+ metadata.gz: 4a5d071dd9acb91eec03dfc30ce0f33473752330b1a5ae8f7ea9a4f7ca1733bd3d81d2b8270e2f76f3ed71c7c6e13794346a061093aebbaf733c0b07e01fcdb5
7
+ data.tar.gz: beceb3cf65e42d844b9dbd7976f26bc96e3d72c8759a7b10dd26ce4ce5aadc0a62bc153d58464afd2ffc085a364ba5adddfa5bdc84a61455621d2d602161b7ad
@@ -1,4 +1,4 @@
1
- Version 1.0.1
1
+ Version 1.1.0
2
2
 
3
3
  # Changelog
4
4
  All notable changes to this project will be documented in this file.
@@ -8,6 +8,10 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
8
8
 
9
9
  ## [Unreleased]
10
10
 
11
+ ## [1.1.0] - 2020-12-26
12
+ ### Added
13
+ - Add support for Ruby 3.0
14
+
11
15
  ## [1.0.1] - 2020-07-31
12
16
  ### Fixed
13
17
  - Load version before client
@@ -73,7 +77,8 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
73
77
  - with\_retry.https://www.mokhan.ca/%F0%9F%92%8E/2018/11/10/net-hippie-0-2-0.html
74
78
  - authorization header helpers
75
79
 
76
- [Unreleased]: https://github.com/mokhan/net-hippie/compare/v1.0.1...HEAD
80
+ [Unreleased]: https://github.com/mokhan/net-hippie/compare/v1.1.0...HEAD
81
+ [1.1.0]: https://github.com/mokhan/net-hippie/compare/v1.0.1...v1.1.0
77
82
  [1.0.1]: https://github.com/mokhan/net-hippie/compare/v1.0.0...v1.0.1
78
83
  [1.0.0]: https://github.com/mokhan/net-hippie/compare/v0.3.2...v1.0.0
79
84
  [0.3.2]: https://github.com/mokhan/net-hippie/compare/v0.3.1...v0.3.2
@@ -31,7 +31,7 @@ module Net
31
31
  ].freeze
32
32
 
33
33
  def self.logger
34
- @logger ||= Logger.new(STDERR)
34
+ @logger ||= Logger.new($stderr)
35
35
  end
36
36
 
37
37
  def self.logger=(logger)
@@ -61,7 +61,7 @@ module Net
61
61
  end
62
62
 
63
63
  def self.respond_to_missing?(name, _include_private = false)
64
- Client.public_instance_methods.include?(name.to_sym)
64
+ Client.public_instance_methods.include?(name.to_sym) || super
65
65
  end
66
66
 
67
67
  def self.default_client
@@ -2,6 +2,6 @@
2
2
 
3
3
  module Net
4
4
  module Hippie
5
- VERSION = '1.0.1'
5
+ VERSION = '1.1.0'
6
6
  end
7
7
  end
@@ -21,7 +21,7 @@ Gem::Specification.new do |spec|
21
21
  spec.bindir = 'exe'
22
22
  spec.executables = spec.files.grep(%r{^exe/}) { |f| File.basename(f) }
23
23
  spec.require_paths = ['lib']
24
- spec.required_ruby_version = '~> 2.5'
24
+ spec.required_ruby_version = Gem::Requirement.new('>= 2.5.0')
25
25
 
26
26
  spec.add_development_dependency 'minitest', '~> 5.0'
27
27
  spec.add_development_dependency 'rake', '~> 13.0'
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: net-hippie
3
3
  version: !ruby/object:Gem::Version
4
- version: 1.0.1
4
+ version: 1.1.0
5
5
  platform: ruby
6
6
  authors:
7
7
  - mo
8
8
  autorequire:
9
9
  bindir: exe
10
10
  cert_chain: []
11
- date: 2020-08-01 00:00:00.000000000 Z
11
+ date: 2020-12-26 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: minitest
@@ -120,16 +120,16 @@ require_paths:
120
120
  - lib
121
121
  required_ruby_version: !ruby/object:Gem::Requirement
122
122
  requirements:
123
- - - "~>"
123
+ - - ">="
124
124
  - !ruby/object:Gem::Version
125
- version: '2.5'
125
+ version: 2.5.0
126
126
  required_rubygems_version: !ruby/object:Gem::Requirement
127
127
  requirements:
128
128
  - - ">="
129
129
  - !ruby/object:Gem::Version
130
130
  version: '0'
131
131
  requirements: []
132
- rubygems_version: 3.1.4
132
+ rubygems_version: 3.2.3
133
133
  signing_key:
134
134
  specification_version: 4
135
135
  summary: net/http for hippies. ☮️