lastfm 1.4.0 → 1.5.0

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
@@ -62,6 +62,7 @@ It supports methods which require {authentication}[http://www.last.fm/api/authen
62
62
  * {track.search}[http://www.lastfm.jp/api/show?service=286]
63
63
  * {track.share}[http://www.lastfm.jp/api/show?service=305]
64
64
  * {track.updateNowPlaying}[http://www.lastfm.jp/api/show?service=454]
65
+ * {track.unlove}[http://www.last.fm/api/show/track.unlove]
65
66
 
66
67
  === User
67
68
 
@@ -102,18 +103,7 @@ It supports methods which require {authentication}[http://www.last.fm/api/authen
102
103
 
103
104
  == Comitters
104
105
 
105
- * {Matthew Fawcett}[https://github.com/mattfawcett]
106
- * {Christopher Peplin}[https://github.com/peplin]
107
- * {Olli Helenius}[https://github.com/liff]
108
- * {pipedreambomb}[https://github.com/pipedreambomb]
109
- * {Danny Olson}[https://github.com/dbolson]
110
- * {webs}[https://github.com/webs]
111
- * {Gregory Eremin}[https://github.com/magnolia-fan]
112
- * {Gary Shannon}[https://github.com/garyadamshannon]
113
- * {Kyle Fleming}[https://github.com/Garthex]
114
- * {Lucas}[https://github.com/lfzawacki]
115
- * {Johan Oskarsson}[https://github.com/johanoskarsson]
116
- * {Paul Miller}[https://github.com/paulmillr]
106
+ see https://github.com/youpy/ruby-lastfm/contributors
117
107
 
118
108
  == Note on Patches/Pull Requests
119
109
 
data/VERSION CHANGED
@@ -1 +1 @@
1
- 1.4.0
1
+ 1.5.0
@@ -8,6 +8,7 @@ class Lastfm
8
8
  write_method :share, [:artist, :track, :recipient], [[:message, nil]]
9
9
  write_method :scrobble, [:artist, :track], [[:timestamp, Proc.new { Time.now.utc.to_i }], [:album, nil], [:trackNumber, nil], [:mbid, nil], [:duration, nil], [:albumArtist, nil]]
10
10
  write_method :update_now_playing, [:artist, :track], [[:album, nil], [:trackNumber, nil], [:mbid, nil], [:duration, nil], [:albumArtist, nil]]
11
+ write_method :unlove, [:artist, :track]
11
12
 
12
13
  regular_method :get_info, [:artist, :track], [[:username, nil]] do |response|
13
14
  response.xml['track']
@@ -221,4 +221,15 @@ describe '#track' do
221
221
  @lastfm.track.update_now_playing('foo artist', 'foo track', 'foo album', 1, '0383dadf-2a4e-4d10-a46a-e9e041da8eb3', nil, nil)
222
222
  end
223
223
  end
224
+
225
+ describe '#unlove' do
226
+ it 'should unlove' do
227
+ @lastfm.should_receive(:request).with('track.unlove', {
228
+ :artist => 'foo artist',
229
+ :track => 'foo track',
230
+ }, :post, true, true).and_return(@ok_response)
231
+
232
+ @lastfm.track.unlove('foo artist', 'foo track').should be_true
233
+ end
234
+ end
224
235
  end
metadata CHANGED
@@ -1,7 +1,7 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: lastfm
3
3
  version: !ruby/object:Gem::Version
4
- version: 1.4.0
4
+ version: 1.5.0
5
5
  prerelease:
6
6
  platform: ruby
7
7
  authors:
@@ -9,11 +9,11 @@ authors:
9
9
  autorequire:
10
10
  bindir: bin
11
11
  cert_chain: []
12
- date: 2012-03-10 00:00:00.000000000 Z
12
+ date: 2012-03-17 00:00:00.000000000 Z
13
13
  dependencies:
14
14
  - !ruby/object:Gem::Dependency
15
15
  name: httparty
16
- requirement: &70152548903840 !ruby/object:Gem::Requirement
16
+ requirement: &70297504905400 !ruby/object:Gem::Requirement
17
17
  none: false
18
18
  requirements:
19
19
  - - ! '>='
@@ -21,10 +21,10 @@ dependencies:
21
21
  version: '0'
22
22
  type: :runtime
23
23
  prerelease: false
24
- version_requirements: *70152548903840
24
+ version_requirements: *70297504905400
25
25
  - !ruby/object:Gem::Dependency
26
26
  name: xml-simple
27
- requirement: &70152548903220 !ruby/object:Gem::Requirement
27
+ requirement: &70297504903960 !ruby/object:Gem::Requirement
28
28
  none: false
29
29
  requirements:
30
30
  - - ! '>='
@@ -32,10 +32,10 @@ dependencies:
32
32
  version: '0'
33
33
  type: :runtime
34
34
  prerelease: false
35
- version_requirements: *70152548903220
35
+ version_requirements: *70297504903960
36
36
  - !ruby/object:Gem::Dependency
37
37
  name: activesupport
38
- requirement: &70152549401280 !ruby/object:Gem::Requirement
38
+ requirement: &70297504902620 !ruby/object:Gem::Requirement
39
39
  none: false
40
40
  requirements:
41
41
  - - ! '>='
@@ -43,10 +43,10 @@ dependencies:
43
43
  version: 3.0.3
44
44
  type: :runtime
45
45
  prerelease: false
46
- version_requirements: *70152549401280
46
+ version_requirements: *70297504902620
47
47
  - !ruby/object:Gem::Dependency
48
48
  name: rspec
49
- requirement: &70152549400600 !ruby/object:Gem::Requirement
49
+ requirement: &70297504899440 !ruby/object:Gem::Requirement
50
50
  none: false
51
51
  requirements:
52
52
  - - ~>
@@ -54,10 +54,10 @@ dependencies:
54
54
  version: 2.8.0
55
55
  type: :development
56
56
  prerelease: false
57
- version_requirements: *70152549400600
57
+ version_requirements: *70297504899440
58
58
  - !ruby/object:Gem::Dependency
59
59
  name: jeweler
60
- requirement: &70152549399960 !ruby/object:Gem::Requirement
60
+ requirement: &70297504914860 !ruby/object:Gem::Requirement
61
61
  none: false
62
62
  requirements:
63
63
  - - ~>
@@ -65,10 +65,10 @@ dependencies:
65
65
  version: 1.6.4
66
66
  type: :development
67
67
  prerelease: false
68
- version_requirements: *70152549399960
68
+ version_requirements: *70297504914860
69
69
  - !ruby/object:Gem::Dependency
70
70
  name: rdoc
71
- requirement: &70152549399280 !ruby/object:Gem::Requirement
71
+ requirement: &70297504914260 !ruby/object:Gem::Requirement
72
72
  none: false
73
73
  requirements:
74
74
  - - ! '>='
@@ -76,7 +76,7 @@ dependencies:
76
76
  version: '0'
77
77
  type: :development
78
78
  prerelease: false
79
- version_requirements: *70152549399280
79
+ version_requirements: *70297504914260
80
80
  description: A ruby interface for Last.fm web services version 2.0
81
81
  email: youpy@buycheapviagraonlinenow.com
82
82
  executables: []
@@ -167,7 +167,7 @@ required_ruby_version: !ruby/object:Gem::Requirement
167
167
  version: '0'
168
168
  segments:
169
169
  - 0
170
- hash: 877929140514225915
170
+ hash: -2058458698052307244
171
171
  required_rubygems_version: !ruby/object:Gem::Requirement
172
172
  none: false
173
173
  requirements: