lastfm 1.27.2 → 1.27.3

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA1:
3
- metadata.gz: 18953264038d0331b58860c837eb72858e142ad2
4
- data.tar.gz: 0b5017d3c42d0171c252682da2c167ce738dd5fd
3
+ metadata.gz: 147a742ed4bc98a34afd011ec2a27d9dc927a905
4
+ data.tar.gz: 9453ede5c8f07680fd82b780b95e37e74d596079
5
5
  SHA512:
6
- metadata.gz: 4f637061e5b4313a274f7e92383984138c111f8f3ee4fc68f55c4ec8dfdd9f8e4355b7d230ec727f0af7038525407b0ae6e18c703d2a8d99d32f321597812489
7
- data.tar.gz: 0ebd92e374cd0afb203a687d029cda9e72de9a82619828389ab09e27682d4b7b265e8d0c5bcbe90b8948aaa84214ac1b5a6c980c0c2f8e28bc3da3c726bcc5d5
6
+ metadata.gz: 54946841482df488dd3ebbb639863362aa1c37b9f44e4739322babc2c955ff25b9eb91f1f8b6e2d5c8580c0dbfdc6846491061aa729e67f80099fd3cc1956859
7
+ data.tar.gz: e03e1f766ce0b57cc0ae55af7558d153329c382be08c17074f9ea04d4b13ecd1c44fd60a2bace4fc5f50149c6d615723da4239b348df0b0447f6b59312cade20
data/README.md CHANGED
@@ -44,7 +44,7 @@ It supports methods which require [authentication](http://www.last.fm/api/authen
44
44
 
45
45
  ### Artist
46
46
 
47
- * [artist.getEvents](http://www.last.fm/api/show?service=117)
47
+ * ~~[artist.gets](http://www.last.fm/api/show?service=117)~~ deleted
48
48
  * [artist.getInfo](http://www.last.fm/api/show?service=267)
49
49
  * [artist.getSimilar](http://www.last.fm/api/show?service=267)
50
50
  * [artist.getTags](http://www.last.fm/api/show?service=267)
@@ -62,7 +62,7 @@ It supports methods which require [authentication](http://www.last.fm/api/authen
62
62
 
63
63
  ### Event
64
64
 
65
- * [event.getInfo](http://www.last.fm/api/show/event.getInfo)
65
+ * ~~[event.getInfo](http://www.last.fm/api/show/event.getInfo)~~ deleted
66
66
 
67
67
  ### Radio
68
68
 
@@ -78,7 +78,7 @@ It supports methods which require [authentication](http://www.last.fm/api/authen
78
78
 
79
79
  ### Tasteometer
80
80
 
81
- * [tasteometer.compare](http://www.last.fm/api/show/tasteometer.compare)
81
+ * ~~[tasteometer.compare](http://www.last.fm/api/show/tasteometer.compare)~~ deleted
82
82
 
83
83
  ### Track
84
84
 
@@ -106,7 +106,7 @@ It supports methods which require [authentication](http://www.last.fm/api/authen
106
106
  * [user.getNeighbours](http://www.last.fm/api/show?service=264)
107
107
  * [user.getPersonalTags](http://www.last.fm/api/show/user.getPersonalTags)
108
108
  * [user.getRecentTracks](http://www.last.fm/api/show?service=278)
109
- * [user.getRecommendedEvents](http://www.last.fm/api/show/user.getRecommendedEvents)
109
+ * ~~[user.getRecommendedEvents](http://www.last.fm/api/show/user.getRecommendedEvents)~~ deleted
110
110
  * [user.getRecommendedArtists](http://www.last.fm/api/show/user.getRecommendedArtists)
111
111
  * [user.getTopArtists](http://www.last.fm/api/show/user.getTopArtists)
112
112
  * [user.getTopAlbums](http://www.last.fm/api/show/user.getTopAlbums)
@@ -119,7 +119,7 @@ It supports methods which require [authentication](http://www.last.fm/api/authen
119
119
 
120
120
  ### Geo
121
121
 
122
- * [geo.getEvents](http://www.last.fm/api/show?service#270)
122
+ * ~~[geo.getEvents](http://www.last.fm/api/show?service#270)~~ deleted
123
123
 
124
124
  ### Group
125
125
 
@@ -12,12 +12,11 @@ Gem::Specification.new do |gem|
12
12
  gem.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
13
13
  gem.name = %q{lastfm}
14
14
  gem.require_paths = ["lib"]
15
- gem.version = "1.27.2"
15
+ gem.version = "1.27.3"
16
16
  gem.license = 'MIT'
17
17
 
18
18
  gem.add_dependency "xml-simple"
19
19
  gem.add_dependency "httparty"
20
- gem.add_dependency 'activesupport', '>= 3.2.0'
21
20
 
22
21
  gem.add_development_dependency('rspec', ['~> 2.8.0'])
23
22
  gem.add_development_dependency('rake', '< 11.0')
@@ -1,7 +1,6 @@
1
1
  require 'rubygems'
2
2
  require 'digest/md5'
3
3
  require 'httparty'
4
- require 'active_support/core_ext/string/inflections'
5
4
 
6
5
  require 'lastfm/util'
7
6
  require 'lastfm/response'
@@ -45,7 +45,7 @@ class Lastfm
45
45
  block.call(
46
46
  send(
47
47
  method,
48
- id.to_s.camelize(:lower),
48
+ id.to_s.gsub(/_[a-z]/){ |s| s[1].upcase },
49
49
  Lastfm::Util.build_options(
50
50
  args,
51
51
  params[:required],
@@ -92,7 +92,7 @@ class Lastfm
92
92
  response.xml
93
93
  end
94
94
 
95
- method_with_authentication(
95
+ regular_method(
96
96
  :get_tags,
97
97
  :required => [:artist, :track]
98
98
  ) do |response|
@@ -14,7 +14,7 @@ class Lastfm
14
14
  end
15
15
 
16
16
  def get_info(*args)
17
- method = :get_info.to_s.camelize(:lower)
17
+ method = 'getInfo'
18
18
  response = if args.any?
19
19
  options = Lastfm::Util.build_options(args, [:user], [])
20
20
  request(method, options)
@@ -6,6 +6,7 @@ class Lastfm
6
6
  attr_reader :xml
7
7
 
8
8
  def initialize(body)
9
+ # workaround for https://github.com/youpy/ruby-lastfm/issues/83
9
10
  body = fix_body(body)
10
11
 
11
12
  @xml = XmlSimple.xml_in(body, 'ForceArray' => ['image', 'tag', 'user', 'event', 'correction'])
@@ -133,7 +133,7 @@ describe '#track' do
133
133
  @lastfm.should_receive(:request).with('track.getTags', {
134
134
  :artist => 'foo artist',
135
135
  :track => 'foo track',
136
- }, :get, true, true).and_return(make_response('track_get_tags'))
136
+ }).and_return(make_response('track_get_tags'))
137
137
 
138
138
  tags = @lastfm.track.get_tags(
139
139
  :artist => 'foo artist',
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: lastfm
3
3
  version: !ruby/object:Gem::Version
4
- version: 1.27.2
4
+ version: 1.27.3
5
5
  platform: ruby
6
6
  authors:
7
7
  - youpy
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2017-07-05 00:00:00.000000000 Z
11
+ date: 2019-03-13 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: xml-simple
@@ -38,20 +38,6 @@ dependencies:
38
38
  - - ">="
39
39
  - !ruby/object:Gem::Version
40
40
  version: '0'
41
- - !ruby/object:Gem::Dependency
42
- name: activesupport
43
- requirement: !ruby/object:Gem::Requirement
44
- requirements:
45
- - - ">="
46
- - !ruby/object:Gem::Version
47
- version: 3.2.0
48
- type: :runtime
49
- prerelease: false
50
- version_requirements: !ruby/object:Gem::Requirement
51
- requirements:
52
- - - ">="
53
- - !ruby/object:Gem::Version
54
- version: 3.2.0
55
41
  - !ruby/object:Gem::Dependency
56
42
  name: rspec
57
43
  requirement: !ruby/object:Gem::Requirement