kuber_kit 0.3.10 → 0.3.11

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: ed4a9c2ac89b73ddd0b9d7c0c95845318c46e6389869f4b3a876af67b2d122f6
4
- data.tar.gz: 5fb51bb82cc685ee370e880c255ec87e957f5b75c929baf256188582e63fb13f
3
+ metadata.gz: 4a8482307f03712fa9621bd81744aa15292d0378a24316c907050ddb1c379981
4
+ data.tar.gz: 28c6b0a83c41d0e221a62e0c45d034a6ecd28722ecb3e98a65471bcaf206372e
5
5
  SHA512:
6
- metadata.gz: df0ceafb8c37a8c216f08eb5c8692fcc6eb2f909bbcc929beb9725fdaea0a73976b5a462d5904361e20c01b121dd5efa16185c6e8f388fe01a9ae7b2c55531f8
7
- data.tar.gz: 56a8bdf92b31851078a50c679fc1680adb8f598d3a33ca0010de4789e338a7047a3a34e030cbc186f6b59da7899f64291eec44c34eb18c520e1cc04019414958
6
+ metadata.gz: 9034b084c1eb1db7dd70ad33f067a19e093bdaaf040aa3b65473d5e823570e35480b0915d1b0274a40ffda74c218e7aaa24ee919935bc1424d579e7c7cbf3ec5
7
+ data.tar.gz: 39bab8853fed26799be1b3b7e1f708be89c82e9082e70c05d5746fd99e11ab52f45a822bfcba572317c6a6128e7fbc823a7b9d9313379a93bc288bf9d7c80ba2
@@ -1,7 +1,7 @@
1
1
  PATH
2
2
  remote: .
3
3
  specs:
4
- kuber_kit (0.3.10)
4
+ kuber_kit (0.3.11)
5
5
  cli-ui
6
6
  contracts-lite
7
7
  dry-auto_inject
data/TODO.md CHANGED
@@ -5,4 +5,5 @@
5
5
  - allow deploying only services enabled for specific configuration
6
6
  - find a way to always deploy some service, e.g. for migrations and env_files
7
7
  - template should be able to set default attributes
8
- - template should be able to depend on image?
8
+ - template should be able to depend on image?
9
+ - cleanup image builds older than some date
@@ -39,7 +39,7 @@ class KuberKit::ServiceDeployer::Strategies::Docker < KuberKit::ServiceDeployer:
39
39
 
40
40
  command_args = Array(command_args)
41
41
  if container_name
42
- command_args << "-n #{container_name}"
42
+ command_args << "--name #{container_name}"
43
43
  end
44
44
 
45
45
  docker_commands.run(
@@ -1,3 +1,3 @@
1
1
  module KuberKit
2
- VERSION = "0.3.10"
2
+ VERSION = "0.3.11"
3
3
  end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: kuber_kit
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.3.10
4
+ version: 0.3.11
5
5
  platform: ruby
6
6
  authors:
7
7
  - Iskander Khaziev
8
- autorequire:
8
+ autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2021-01-11 00:00:00.000000000 Z
11
+ date: 2021-01-12 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: contracts-lite
@@ -294,7 +294,7 @@ homepage: https://github.com/ArtStation/kuber_kit
294
294
  licenses:
295
295
  - MIT
296
296
  metadata: {}
297
- post_install_message:
297
+ post_install_message:
298
298
  rdoc_options: []
299
299
  require_paths:
300
300
  - lib
@@ -309,8 +309,8 @@ required_rubygems_version: !ruby/object:Gem::Requirement
309
309
  - !ruby/object:Gem::Version
310
310
  version: '0'
311
311
  requirements: []
312
- rubygems_version: 3.0.9
313
- signing_key:
312
+ rubygems_version: 3.0.8
313
+ signing_key:
314
314
  specification_version: 4
315
315
  summary: Docker Containers Build & Deployment
316
316
  test_files: []