kaminari 1.1.0 → 1.1.1

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.

Potentially problematic release.


This version of kaminari might be problematic. Click here for more details.

checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: e327d193e7503f8605000e9f9b50d8a49ad1b5891db7b63f2a2b52e17570f3f0
4
- data.tar.gz: 83d6e7245420c50fd8678fdefbe4ba923df61d3b85c0b7439e1c55880e09c5bd
3
+ metadata.gz: 79e144bce9eea3099a5710a63f8a359dc57d88d3c48c52be0726d8f7d6b09b6a
4
+ data.tar.gz: 41fe275044253ff7e99d514da2acc1a77ea47492483bc1fcfadd521a3d9618b9
5
5
  SHA512:
6
- metadata.gz: 3192413803fb8dcd518b0412ebd3d0d008692f4ced0576f1c5887ed36d5b45d0c067a029187b0be84fc701fcbf3240a72c90431f8bdf5dc363d85dda5e340980
7
- data.tar.gz: '018fa6b74c07c7e77ef824b53354818305fe096d6aeaaecf0a76d28df3953b9d8b4ad287ecc96142efc33746b1d8beb8ed844722173510671e4c053a99c99c46'
6
+ metadata.gz: e424967795237e20c69fc7cc7115f9956a24d48e79b4593f47aee25c22b31715801a7b59fc8d82859ccaf2655a4e58dea41878811117adba019d3a03a201d9ff
7
+ data.tar.gz: 7e3abbde2657bdbb5898a28513e8e7c6a11ba1ce99792aa1a76a2dab24aff571cca16a1a832690acb389b2898e7dd56da981fe45e40ac63f33d6020c5edc9abe
@@ -1,3 +1,9 @@
1
+ ## 1.1.1
2
+
3
+ ### Bug Fixes:
4
+
5
+ * Fixed a bug where `paginate ..., params: { controller: ..., action: ... }` didn't override the `params[:controller]` and `params[:action]` #919 [@chao-mu]
6
+
1
7
  ## 1.1.0
2
8
 
3
9
  ### Enhancements:
@@ -1,4 +1,4 @@
1
1
  # frozen_string_literal: true
2
2
  module Kaminari
3
- VERSION = '1.1.0'
3
+ VERSION = '1.1.1'
4
4
  end
metadata CHANGED
@@ -1,7 +1,7 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: kaminari
3
3
  version: !ruby/object:Gem::Version
4
- version: 1.1.0
4
+ version: 1.1.1
5
5
  platform: ruby
6
6
  authors:
7
7
  - Akira Matsuda
@@ -11,7 +11,7 @@ authors:
11
11
  autorequire:
12
12
  bindir: bin
13
13
  cert_chain: []
14
- date: 2017-10-13 00:00:00.000000000 Z
14
+ date: 2017-10-21 00:00:00.000000000 Z
15
15
  dependencies:
16
16
  - !ruby/object:Gem::Dependency
17
17
  name: activesupport
@@ -33,42 +33,42 @@ dependencies:
33
33
  requirements:
34
34
  - - '='
35
35
  - !ruby/object:Gem::Version
36
- version: 1.1.0
36
+ version: 1.1.1
37
37
  type: :runtime
38
38
  prerelease: false
39
39
  version_requirements: !ruby/object:Gem::Requirement
40
40
  requirements:
41
41
  - - '='
42
42
  - !ruby/object:Gem::Version
43
- version: 1.1.0
43
+ version: 1.1.1
44
44
  - !ruby/object:Gem::Dependency
45
45
  name: kaminari-actionview
46
46
  requirement: !ruby/object:Gem::Requirement
47
47
  requirements:
48
48
  - - '='
49
49
  - !ruby/object:Gem::Version
50
- version: 1.1.0
50
+ version: 1.1.1
51
51
  type: :runtime
52
52
  prerelease: false
53
53
  version_requirements: !ruby/object:Gem::Requirement
54
54
  requirements:
55
55
  - - '='
56
56
  - !ruby/object:Gem::Version
57
- version: 1.1.0
57
+ version: 1.1.1
58
58
  - !ruby/object:Gem::Dependency
59
59
  name: kaminari-activerecord
60
60
  requirement: !ruby/object:Gem::Requirement
61
61
  requirements:
62
62
  - - '='
63
63
  - !ruby/object:Gem::Version
64
- version: 1.1.0
64
+ version: 1.1.1
65
65
  type: :runtime
66
66
  prerelease: false
67
67
  version_requirements: !ruby/object:Gem::Requirement
68
68
  requirements:
69
69
  - - '='
70
70
  - !ruby/object:Gem::Version
71
- version: 1.1.0
71
+ version: 1.1.1
72
72
  - !ruby/object:Gem::Dependency
73
73
  name: test-unit-rails
74
74
  requirement: !ruby/object:Gem::Requirement