jquery-ui-rails 6.0.0 → 6.0.1

Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA1:
3
- metadata.gz: b4055861e7cb05c4bb0fe4d09d93e3694152835d
4
- data.tar.gz: 2c20d391a42606ed6dd2a27a2357b3642ff3a5bc
3
+ metadata.gz: 28b056e3b2bcba8671a859c6c7b6a639a18bd64c
4
+ data.tar.gz: 18da5becc80020a671eb530168ddf68981457ef1
5
5
  SHA512:
6
- metadata.gz: 12eba8436081fd012812ad99de12c114b72d703b0174887e0ed5cc084741be30e1c00dd3721a734f6cdc0b0c5ecf190a6c708a14e8e15be2893b244a77a59e62
7
- data.tar.gz: 0280dc4caa09b7228b4065fe536ed5d91735e944a0ebe8592e29eb80928158f8ec446f1add51e1c5870b9cb57eb99b61f8dcc00f9309b373052f623fbebb561a
6
+ metadata.gz: e4fe73b998dacc7fd9aed76574f8c96812a97f678ab54acbe06c465394693e96e8110f6121b82495857cfb2e6fbd556f5fb3c12112f32c631e5edbd18c7bf49d
7
+ data.tar.gz: 7d8f08e3e338f74401d1fa935a277eda8524291fd85f074e517f04dfb203b660e2c0da8fccc5488c89823c5d1ba6a7a27bfeb8af2ede23839eb3ceb9577788f3
data/History.md CHANGED
@@ -1,5 +1,9 @@
1
1
  # master
2
2
 
3
+ # 6.0.1
4
+
5
+ * Fix "define is not defined" issue in `core.js`
6
+
3
7
  # 6.0.0
4
8
 
5
9
  * Update to jQuery UI 1.12.1
data/README.md CHANGED
@@ -153,22 +153,22 @@ reasons](https://github.com/joliss/jquery-ui-rails/issues/9#issuecomment-6524987
153
153
  OR
154
154
 
155
155
  ```javascript
156
- //= require jquery-ui/effect
157
- //= require jquery-ui/effect-blind
158
- //= require jquery-ui/effect-bounce
159
- //= require jquery-ui/effect-clip
160
- //= require jquery-ui/effect-drop
161
- //= require jquery-ui/effect-explode
162
- //= require jquery-ui/effect-fade
163
- //= require jquery-ui/effect-fold
164
- //= require jquery-ui/effect-highlight
165
- //= require jquery-ui/effect-puff
166
- //= require jquery-ui/effect-pulsate
167
- //= require jquery-ui/effect-scale
168
- //= require jquery-ui/effect-shake
169
- //= require jquery-ui/effect-size
170
- //= require jquery-ui/effect-slide
171
- //= require jquery-ui/effect-transfer
156
+ //= require jquery-ui/effects/effect
157
+ //= require jquery-ui/effects/effect-blind
158
+ //= require jquery-ui/effects/effect-bounce
159
+ //= require jquery-ui/effects/effect-clip
160
+ //= require jquery-ui/effects/effect-drop
161
+ //= require jquery-ui/effects/effect-explode
162
+ //= require jquery-ui/effects/effect-fade
163
+ //= require jquery-ui/effects/effect-fold
164
+ //= require jquery-ui/effects/effect-highlight
165
+ //= require jquery-ui/effects/effect-puff
166
+ //= require jquery-ui/effects/effect-pulsate
167
+ //= require jquery-ui/effects/effect-scale
168
+ //= require jquery-ui/effects/effect-shake
169
+ //= require jquery-ui/effects/effect-size
170
+ //= require jquery-ui/effects/effect-slide
171
+ //= require jquery-ui/effects/effect-transfer
172
172
  ```
173
173
 
174
174
  ## Stylesheet Assets
@@ -190,10 +190,10 @@ pulled in as dependencies.
190
190
 
191
191
  ```css
192
192
  /*
193
- *= require jquery-ui/draggable
194
- *= require jquery-ui/resizable
195
- *= require jquery-ui/selectable
196
- *= require jquery-ui/sortable
193
+ *= require jquery-ui/widgets/draggable
194
+ *= require jquery-ui/widgets/resizable
195
+ *= require jquery-ui/widgets/selectable
196
+ *= require jquery-ui/widgets/sortable
197
197
  */
198
198
  ```
199
199
 
data/Rakefile CHANGED
@@ -128,6 +128,9 @@ task :javascripts => :submodule do
128
128
  mod.gsub!('/ui', '')
129
129
  out.write("//= require #{mod}\n")
130
130
  end
131
+ # core.js is deprecated and uses define function which is usually unavailable
132
+ # so we need only dependency loading there with no file contents
133
+ next if clean_path == 'jquery-ui/core.js'
131
134
  out.write("\n") unless dep_modules.empty?
132
135
  source_code = File.read(path)
133
136
  source_code.gsub!('@VERSION', version)
@@ -2,6 +2,7 @@
2
2
 
3
3
  | Gem | jQuery UI |
4
4
  |--------|-----------|
5
+ | 6.0.1 | 1.12.1 |
5
6
  | 6.0.0 | 1.12.1 |
6
7
  | 5.0.5 | 1.11.4 |
7
8
  | 5.0.4 | 1.11.3 |
@@ -13,25 +13,3 @@
13
13
  //= require jquery-ui/tabbable
14
14
  //= require jquery-ui/unique-id
15
15
  //= require jquery-ui/version
16
-
17
- // This file is deprecated in 1.12.0 to be removed in 1.13
18
- ( function() {
19
- define( [
20
- "jquery",
21
- "./data",
22
- "./disable-selection",
23
- "./focusable",
24
- "./form",
25
- "./ie",
26
- "./keycode",
27
- "./labels",
28
- "./jquery-1-7",
29
- "./plugin",
30
- "./safe-active-element",
31
- "./safe-blur",
32
- "./scroll-parent",
33
- "./tabbable",
34
- "./unique-id",
35
- "./version"
36
- ] );
37
- } )();
@@ -1,7 +1,7 @@
1
1
  module Jquery
2
2
  module Ui
3
3
  module Rails
4
- VERSION = "6.0.0"
4
+ VERSION = "6.0.1"
5
5
  JQUERY_UI_VERSION = "1.12.1"
6
6
  end
7
7
  end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: jquery-ui-rails
3
3
  version: !ruby/object:Gem::Version
4
- version: 6.0.0
4
+ version: 6.0.1
5
5
  platform: ruby
6
6
  authors:
7
7
  - Jo Liss
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2016-11-29 00:00:00.000000000 Z
11
+ date: 2016-12-01 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: railties