jenkins-rails 0.0.1 → 0.0.2

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
data/README.md CHANGED
@@ -7,12 +7,16 @@
7
7
 
8
8
  Add this line to your application's Gemfile:
9
9
 
10
- gem 'jenkins-rails', :git => 'git://github.com/anhkind/jenkins-rails.git'
10
+ gem 'jenkins-rails'
11
11
 
12
12
  And then execute:
13
13
 
14
14
  $ bundle
15
15
 
16
+ Or install it yourself as:
17
+
18
+ $ gem install jenkins-rails
19
+
16
20
  ## Usage
17
21
 
18
22
  ### Configuration
@@ -22,6 +26,7 @@ Create `jenkins.yml` file (with `erb`) as following structure and put to **Rails
22
26
  username: <%= ENV['JENKINS_USERNAME'] %>
23
27
  password: <%= ENV['JENKINS_PASSWORD'] %>
24
28
  host: <%= ENV['JENKINS_HOST'] %>
29
+ port: 80 #optional, default is 8080
25
30
  jobs
26
31
  -
27
32
  name: 'Job 1' #compulsory
@@ -11,9 +11,10 @@ module Jenkins
11
11
  jobs_params = @configuration.params
12
12
 
13
13
  @client = JenkinsApi::Client.new(
14
- :server_ip => @configuration.host,
15
- :username => options[:username] || @configuration.username,
16
- :password => options[:password] || @configuration.password
14
+ :server_ip => @configuration.host,
15
+ :server_port => @configuration.port,
16
+ :username => options[:username] || @configuration.username,
17
+ :password => options[:password] || @configuration.password
17
18
  )
18
19
 
19
20
  jobs_params.each do |job_params|
@@ -17,6 +17,10 @@ module Jenkins
17
17
  config[:host]
18
18
  end
19
19
 
20
+ def port
21
+ config[:port]
22
+ end
23
+
20
24
  def jobs
21
25
  config[:jobs] ||= []
22
26
  end
@@ -1,3 +1,3 @@
1
1
  module Jenkins
2
- VERSION = "0.0.1"
2
+ VERSION = "0.0.2"
3
3
  end
metadata CHANGED
@@ -1,7 +1,7 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: jenkins-rails
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.0.1
4
+ version: 0.0.2
5
5
  prerelease:
6
6
  platform: ruby
7
7
  authors:
@@ -116,12 +116,18 @@ required_ruby_version: !ruby/object:Gem::Requirement
116
116
  - - ! '>='
117
117
  - !ruby/object:Gem::Version
118
118
  version: '0'
119
+ segments:
120
+ - 0
121
+ hash: 2347354143076806183
119
122
  required_rubygems_version: !ruby/object:Gem::Requirement
120
123
  none: false
121
124
  requirements:
122
125
  - - ! '>='
123
126
  - !ruby/object:Gem::Version
124
127
  version: '0'
128
+ segments:
129
+ - 0
130
+ hash: 2347354143076806183
125
131
  requirements: []
126
132
  rubyforge_project:
127
133
  rubygems_version: 1.8.24