jekyll-sitemap 1.3.0 → 1.3.1

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: 337a5086866fdc4e32826bc5f0fe55479f8a21b35a27e680b53caa5280fb579c
4
- data.tar.gz: 5eb0b8f16a9c5d9e05d8e80886e2ae84f67ede7103ec717457e30904e9f13e5a
3
+ metadata.gz: 8d48df23af4df6ba9fecfb131005e085b655b4482f7325fe69894c323d06fd15
4
+ data.tar.gz: 870ba6091d3a84ae9ef7739e6bf37ba8a5de6b18168bc6f561b238de069b0223
5
5
  SHA512:
6
- metadata.gz: 0f81c53e4acc536e757f308c976bcbfa3e233148b99a1c23d289effb0900269cff8dc8be68435541b0794e0fdd61cb0dd161ce95e6142c1678dc903141fab1c3
7
- data.tar.gz: 7f6e69c5b0a3fedf6105d898e0ccd6a904f3a829a7095e09a46f5aaf50179954ad96139af0194f27b446e67762cfb028275baf768fd4f8525f5cf719cab12850
6
+ metadata.gz: ef3cffc55662703294defc8b91ce0ecd41339c261fa9dcc966a22b7ccb9925f8a378e6aaa0577ad9460f4107537474b9fbf129284858be0063a10bc7f9ed9f92
7
+ data.tar.gz: 552379f5a42c4bb325552133d9cb72954158c798b56f4a3c008eaad4c57d85062f22c0e02a7741da9769e379b48a8727bbac3c61028d1960dacdad8248ddade6
@@ -1,9 +1,5 @@
1
1
  inherit_from: .rubocop_todo.yml
2
2
 
3
3
  require: rubocop-jekyll
4
-
5
4
  inherit_gem:
6
5
  rubocop-jekyll: .rubocop.yml
7
-
8
- AllCops:
9
- TargetRubyVersion: 2.4
@@ -1,18 +1,21 @@
1
1
  language: ruby
2
2
  cache: bundler
3
3
  rvm:
4
+ - &latest_ruby 2.6
4
5
  - 2.4
5
- - 2.6
6
+ - 2.3
6
7
  matrix:
7
8
  include:
8
9
  # GitHub Pages
9
10
  - rvm: 2.5.3
10
11
  env:
11
- - JEKYLL_VERSION=3.7.4
12
+ - JEKYLL_VERSION="~> 3.7.4"
12
13
  - GITHUB_PAGES=1 # Only set on one build in matrix
14
+ - rvm: *latest_ruby
15
+ env: JEKYLL_VERSION=">= 4.0.0.pre.alpha1"
13
16
  env:
14
17
  matrix:
15
- - JEKYLL_VERSION=3.8
18
+ - JEKYLL_VERSION="~> 3.8"
16
19
  branches:
17
20
  only:
18
21
  - master
data/Gemfile CHANGED
@@ -3,4 +3,4 @@
3
3
  source "https://rubygems.org"
4
4
  gemspec
5
5
 
6
- gem "jekyll", "~> #{ENV["JEKYLL_VERSION"]}" if ENV["JEKYLL_VERSION"]
6
+ gem "jekyll", ENV["JEKYLL_VERSION"] if ENV["JEKYLL_VERSION"]
@@ -1,6 +1,12 @@
1
- ## HEAD
1
+ ## 1.3.1 / 2019-03-25
2
2
 
3
- * Release: v1.3.0 (#243)
3
+ ### Bug Fixes
4
+
5
+ * Update plugin metadata and dev environment (#244)
6
+
7
+ ### Development Fixes
8
+
9
+ * Lock requirement for `jekyll-last-modified-at` to `>= 1.0`
4
10
 
5
11
  ## 1.3.0 / 2019-03-21
6
12
 
@@ -18,12 +18,12 @@ Gem::Specification.new do |spec|
18
18
  spec.test_files = spec.files.grep(%r!^(test|spec|features)/!)
19
19
  spec.require_paths = ["lib"]
20
20
 
21
- spec.required_ruby_version = ">= 2.4.0"
21
+ spec.required_ruby_version = ">= 2.3.0"
22
22
 
23
23
  spec.add_dependency "jekyll", ">= 3.7", "< 5.0"
24
24
 
25
25
  spec.add_development_dependency "bundler"
26
- spec.add_development_dependency "jekyll-last-modified-at", "0.3.4"
26
+ spec.add_development_dependency "jekyll-last-modified-at", "~> 1.0"
27
27
  spec.add_development_dependency "rake"
28
28
  spec.add_development_dependency "rspec", "~> 3.0"
29
29
  spec.add_development_dependency "rubocop-jekyll", "~> 0.4"
@@ -2,6 +2,6 @@
2
2
 
3
3
  module Jekyll
4
4
  module Sitemap
5
- VERSION = "1.3.0"
5
+ VERSION = "1.3.1"
6
6
  end
7
7
  end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: jekyll-sitemap
3
3
  version: !ruby/object:Gem::Version
4
- version: 1.3.0
4
+ version: 1.3.1
5
5
  platform: ruby
6
6
  authors:
7
7
  - GitHub, Inc.
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2019-03-21 00:00:00.000000000 Z
11
+ date: 2019-03-25 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: jekyll
@@ -48,16 +48,16 @@ dependencies:
48
48
  name: jekyll-last-modified-at
49
49
  requirement: !ruby/object:Gem::Requirement
50
50
  requirements:
51
- - - '='
51
+ - - "~>"
52
52
  - !ruby/object:Gem::Version
53
- version: 0.3.4
53
+ version: '1.0'
54
54
  type: :development
55
55
  prerelease: false
56
56
  version_requirements: !ruby/object:Gem::Requirement
57
57
  requirements:
58
- - - '='
58
+ - - "~>"
59
59
  - !ruby/object:Gem::Version
60
- version: 0.3.4
60
+ version: '1.0'
61
61
  - !ruby/object:Gem::Dependency
62
62
  name: rake
63
63
  requirement: !ruby/object:Gem::Requirement
@@ -175,7 +175,7 @@ required_ruby_version: !ruby/object:Gem::Requirement
175
175
  requirements:
176
176
  - - ">="
177
177
  - !ruby/object:Gem::Version
178
- version: 2.4.0
178
+ version: 2.3.0
179
179
  required_rubygems_version: !ruby/object:Gem::Requirement
180
180
  requirements:
181
181
  - - ">="