github-pages 203 → 208

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: 1f4fbcaac183c75ea9800ff0a4c337006c411875af00b0cbab725a1172a4d74a
4
- data.tar.gz: 2a1e61b3d434303ad014c0b2300b7a4ff2446780915b772bf1bc0abad75909fe
3
+ metadata.gz: d1cee07f1c4abc71d204b63b058ed1479ba2c577189cd7b9012a26841588de83
4
+ data.tar.gz: 7dec48d346d4a52ab20dcab4816a000c86fafab3846a2e9323d58e0850aa8579
5
5
  SHA512:
6
- metadata.gz: 5cbffc2567bd9cd0acbd6e56a6386a278a7a4e2ab15e3edb740705fccb2f8f50464beefb70fbd911e73f42c9eecec0be4cb3e5001498b05e1cdb6217dc87a902
7
- data.tar.gz: 9ca87415d2fc8904c7039074dcff76424a8846c9e2e86c97a4503bb431719cd96cd5929e14038aef66f6b2613ac89b1036068d71899e5bad01fac9bec314a530
6
+ metadata.gz: b6dbcdb88d650987391dce2a0d1cfbb3467291cc3e2adc158fbcf15367476a4974e3c8ebce413bae41bf183a6e2622762b934c787c864cdcb2895c7e229cc7c6
7
+ data.tar.gz: 4909e8411bf733d46cafda4d6e0cadaed8f38164f6e6d947a286ff2a4e30c45283c2e1caee95666e0b8a96963dc3eae84444fab836609abf9c1bf4ee52b086b2
@@ -15,8 +15,15 @@
15
15
  #
16
16
  # If you disable a check, document why.
17
17
 
18
+ inherit_gem:
19
+ rubocop-github:
20
+ - config/default.yml
21
+
22
+ require:
23
+ - rubocop-performance
24
+
18
25
  AllCops:
19
- TargetRubyVersion: 2.3
26
+ TargetRubyVersion: 2.5
20
27
  Exclude:
21
28
  - 'bin/**/*'
22
29
  - 'script/**/*'
@@ -48,10 +55,10 @@ Style/HashSyntax:
48
55
  EnforcedStyle: hash_rockets
49
56
  Severity: error
50
57
 
51
- Layout/AlignHash:
58
+ Layout/HashAlignment:
52
59
  SupportedLastArgumentHashStyles: always_ignore
53
60
 
54
- Layout/AlignParameters:
61
+ Layout/ParameterAlignment:
55
62
  Enabled: false # This is usually true, but we often want to roll back to
56
63
  # the start of a line.
57
64
 
@@ -78,7 +85,7 @@ Metrics/BlockLength:
78
85
  - github-pages.gemspec
79
86
  - !ruby/regexp /spec\/.*.rb/
80
87
 
81
- Metrics/LineLength:
88
+ Layout/LineLength:
82
89
  Max: 90
83
90
  Severity: warning
84
91
  Exclude:
@@ -122,9 +129,6 @@ Metrics/ParameterLists:
122
129
  Metrics/AbcSize:
123
130
  Max: 20
124
131
 
125
- Layout/IndentFirstHashElement:
126
- EnforcedStyle: consistent
127
-
128
132
  Style/SignalException:
129
133
  EnforcedStyle: only_raise
130
134
 
@@ -134,10 +138,13 @@ Layout/MultilineMethodCallIndentation:
134
138
  Layout/MultilineOperationIndentation:
135
139
  EnforcedStyle: indented
136
140
 
137
- Layout/IndentFirstArgument:
141
+ Layout/FirstArgumentIndentation:
142
+ EnforcedStyle: consistent
143
+
144
+ Layout/FirstHashElementIndentation:
138
145
  EnforcedStyle: consistent
139
146
 
140
- Layout/IndentFirstArrayElement:
147
+ Layout/FirstArrayElementIndentation:
141
148
  EnforcedStyle: consistent
142
149
 
143
150
  Layout/ExtraSpacing:
@@ -7,33 +7,34 @@ module GitHubPages
7
7
  class Dependencies
8
8
  VERSIONS = {
9
9
  # Jekyll
10
- "jekyll" => "3.8.5",
10
+ "jekyll" => "3.9.0",
11
11
  "jekyll-sass-converter" => "1.5.2",
12
12
 
13
13
  # Converters
14
- "kramdown" => "1.17.0",
14
+ "kramdown" => "2.3.0",
15
+ "kramdown-parser-gfm" => "1.1.0",
15
16
  "jekyll-commonmark-ghpages" => "0.1.6",
16
17
 
17
18
  # Misc
18
19
  "liquid" => "4.0.3",
19
- "rouge" => "3.13.0",
20
+ "rouge" => "3.23.0",
20
21
  "github-pages-health-check" => "1.16.1",
21
22
 
22
23
  # Plugins
23
- "jekyll-redirect-from" => "0.15.0",
24
+ "jekyll-redirect-from" => "0.16.0",
24
25
  "jekyll-sitemap" => "1.4.0",
25
- "jekyll-feed" => "0.13.0",
26
+ "jekyll-feed" => "0.15.0",
26
27
  "jekyll-gist" => "1.5.0",
27
28
  "jekyll-paginate" => "1.1.0",
28
29
  "jekyll-coffeescript" => "1.1.1",
29
30
  "jekyll-seo-tag" => "2.6.1",
30
- "jekyll-github-metadata" => "2.12.1",
31
+ "jekyll-github-metadata" => "2.13.0",
31
32
  "jekyll-avatar" => "0.7.0",
32
- "jekyll-remote-theme" => "0.4.1",
33
+ "jekyll-remote-theme" => "0.4.2",
33
34
 
34
35
  # Plugins to match GitHub.com Markdown
35
- "jemoji" => "0.11.1",
36
- "jekyll-mentions" => "1.5.1",
36
+ "jemoji" => "0.12.0",
37
+ "jekyll-mentions" => "1.6.0",
37
38
  "jekyll-relative-links" => "0.6.1",
38
39
  "jekyll-optional-front-matter" => "0.3.2",
39
40
  "jekyll-readme-index" => "0.3.0",
@@ -54,7 +54,7 @@ module GitHubPages
54
54
  "jekyll-theme-architect" => "0.1.1",
55
55
  "jekyll-theme-cayman" => "0.1.1",
56
56
  "jekyll-theme-dinky" => "0.1.1",
57
- "jekyll-theme-hacker" => "0.1.1",
57
+ "jekyll-theme-hacker" => "0.1.2",
58
58
  "jekyll-theme-leap-day" => "0.1.1",
59
59
  "jekyll-theme-merlot" => "0.1.1",
60
60
  "jekyll-theme-midnight" => "0.1.1",
@@ -1,5 +1,5 @@
1
1
  # frozen_string_literal: true
2
2
 
3
3
  module GitHubPages
4
- VERSION = 203
4
+ VERSION = 208
5
5
  end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: github-pages
3
3
  version: !ruby/object:Gem::Version
4
- version: '203'
4
+ version: '208'
5
5
  platform: ruby
6
6
  authors:
7
7
  - GitHub, Inc.
8
- autorequire:
8
+ autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2019-12-04 00:00:00.000000000 Z
11
+ date: 2020-09-28 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: jekyll
@@ -16,14 +16,14 @@ dependencies:
16
16
  requirements:
17
17
  - - '='
18
18
  - !ruby/object:Gem::Version
19
- version: 3.8.5
19
+ version: 3.9.0
20
20
  type: :runtime
21
21
  prerelease: false
22
22
  version_requirements: !ruby/object:Gem::Requirement
23
23
  requirements:
24
24
  - - '='
25
25
  - !ruby/object:Gem::Version
26
- version: 3.8.5
26
+ version: 3.9.0
27
27
  - !ruby/object:Gem::Dependency
28
28
  name: jekyll-sass-converter
29
29
  requirement: !ruby/object:Gem::Requirement
@@ -44,14 +44,28 @@ dependencies:
44
44
  requirements:
45
45
  - - '='
46
46
  - !ruby/object:Gem::Version
47
- version: 1.17.0
47
+ version: 2.3.0
48
48
  type: :runtime
49
49
  prerelease: false
50
50
  version_requirements: !ruby/object:Gem::Requirement
51
51
  requirements:
52
52
  - - '='
53
53
  - !ruby/object:Gem::Version
54
- version: 1.17.0
54
+ version: 2.3.0
55
+ - !ruby/object:Gem::Dependency
56
+ name: kramdown-parser-gfm
57
+ requirement: !ruby/object:Gem::Requirement
58
+ requirements:
59
+ - - '='
60
+ - !ruby/object:Gem::Version
61
+ version: 1.1.0
62
+ type: :runtime
63
+ prerelease: false
64
+ version_requirements: !ruby/object:Gem::Requirement
65
+ requirements:
66
+ - - '='
67
+ - !ruby/object:Gem::Version
68
+ version: 1.1.0
55
69
  - !ruby/object:Gem::Dependency
56
70
  name: jekyll-commonmark-ghpages
57
71
  requirement: !ruby/object:Gem::Requirement
@@ -86,14 +100,14 @@ dependencies:
86
100
  requirements:
87
101
  - - '='
88
102
  - !ruby/object:Gem::Version
89
- version: 3.13.0
103
+ version: 3.23.0
90
104
  type: :runtime
91
105
  prerelease: false
92
106
  version_requirements: !ruby/object:Gem::Requirement
93
107
  requirements:
94
108
  - - '='
95
109
  - !ruby/object:Gem::Version
96
- version: 3.13.0
110
+ version: 3.23.0
97
111
  - !ruby/object:Gem::Dependency
98
112
  name: github-pages-health-check
99
113
  requirement: !ruby/object:Gem::Requirement
@@ -114,14 +128,14 @@ dependencies:
114
128
  requirements:
115
129
  - - '='
116
130
  - !ruby/object:Gem::Version
117
- version: 0.15.0
131
+ version: 0.16.0
118
132
  type: :runtime
119
133
  prerelease: false
120
134
  version_requirements: !ruby/object:Gem::Requirement
121
135
  requirements:
122
136
  - - '='
123
137
  - !ruby/object:Gem::Version
124
- version: 0.15.0
138
+ version: 0.16.0
125
139
  - !ruby/object:Gem::Dependency
126
140
  name: jekyll-sitemap
127
141
  requirement: !ruby/object:Gem::Requirement
@@ -142,14 +156,14 @@ dependencies:
142
156
  requirements:
143
157
  - - '='
144
158
  - !ruby/object:Gem::Version
145
- version: 0.13.0
159
+ version: 0.15.0
146
160
  type: :runtime
147
161
  prerelease: false
148
162
  version_requirements: !ruby/object:Gem::Requirement
149
163
  requirements:
150
164
  - - '='
151
165
  - !ruby/object:Gem::Version
152
- version: 0.13.0
166
+ version: 0.15.0
153
167
  - !ruby/object:Gem::Dependency
154
168
  name: jekyll-gist
155
169
  requirement: !ruby/object:Gem::Requirement
@@ -212,14 +226,14 @@ dependencies:
212
226
  requirements:
213
227
  - - '='
214
228
  - !ruby/object:Gem::Version
215
- version: 2.12.1
229
+ version: 2.13.0
216
230
  type: :runtime
217
231
  prerelease: false
218
232
  version_requirements: !ruby/object:Gem::Requirement
219
233
  requirements:
220
234
  - - '='
221
235
  - !ruby/object:Gem::Version
222
- version: 2.12.1
236
+ version: 2.13.0
223
237
  - !ruby/object:Gem::Dependency
224
238
  name: jekyll-avatar
225
239
  requirement: !ruby/object:Gem::Requirement
@@ -240,42 +254,42 @@ dependencies:
240
254
  requirements:
241
255
  - - '='
242
256
  - !ruby/object:Gem::Version
243
- version: 0.4.1
257
+ version: 0.4.2
244
258
  type: :runtime
245
259
  prerelease: false
246
260
  version_requirements: !ruby/object:Gem::Requirement
247
261
  requirements:
248
262
  - - '='
249
263
  - !ruby/object:Gem::Version
250
- version: 0.4.1
264
+ version: 0.4.2
251
265
  - !ruby/object:Gem::Dependency
252
266
  name: jemoji
253
267
  requirement: !ruby/object:Gem::Requirement
254
268
  requirements:
255
269
  - - '='
256
270
  - !ruby/object:Gem::Version
257
- version: 0.11.1
271
+ version: 0.12.0
258
272
  type: :runtime
259
273
  prerelease: false
260
274
  version_requirements: !ruby/object:Gem::Requirement
261
275
  requirements:
262
276
  - - '='
263
277
  - !ruby/object:Gem::Version
264
- version: 0.11.1
278
+ version: 0.12.0
265
279
  - !ruby/object:Gem::Dependency
266
280
  name: jekyll-mentions
267
281
  requirement: !ruby/object:Gem::Requirement
268
282
  requirements:
269
283
  - - '='
270
284
  - !ruby/object:Gem::Version
271
- version: 1.5.1
285
+ version: 1.6.0
272
286
  type: :runtime
273
287
  prerelease: false
274
288
  version_requirements: !ruby/object:Gem::Requirement
275
289
  requirements:
276
290
  - - '='
277
291
  - !ruby/object:Gem::Version
278
- version: 1.5.1
292
+ version: 1.6.0
279
293
  - !ruby/object:Gem::Dependency
280
294
  name: jekyll-relative-links
281
295
  requirement: !ruby/object:Gem::Requirement
@@ -436,14 +450,14 @@ dependencies:
436
450
  requirements:
437
451
  - - '='
438
452
  - !ruby/object:Gem::Version
439
- version: 0.1.1
453
+ version: 0.1.2
440
454
  type: :runtime
441
455
  prerelease: false
442
456
  version_requirements: !ruby/object:Gem::Requirement
443
457
  requirements:
444
458
  - - '='
445
459
  - !ruby/object:Gem::Version
446
- version: 0.1.1
460
+ version: 0.1.2
447
461
  - !ruby/object:Gem::Dependency
448
462
  name: jekyll-theme-leap-day
449
463
  requirement: !ruby/object:Gem::Requirement
@@ -647,19 +661,19 @@ dependencies:
647
661
  - !ruby/object:Gem::Version
648
662
  version: '3.3'
649
663
  - !ruby/object:Gem::Dependency
650
- name: rubocop
664
+ name: rubocop-github
651
665
  requirement: !ruby/object:Gem::Requirement
652
666
  requirements:
653
- - - "~>"
667
+ - - '='
654
668
  - !ruby/object:Gem::Version
655
- version: '0.76'
669
+ version: 0.16.0
656
670
  type: :development
657
671
  prerelease: false
658
672
  version_requirements: !ruby/object:Gem::Requirement
659
673
  requirements:
660
- - - "~>"
674
+ - - '='
661
675
  - !ruby/object:Gem::Version
662
- version: '0.76'
676
+ version: 0.16.0
663
677
  description: Bootstrap the GitHub Pages Jekyll environment locally.
664
678
  email: support@github.com
665
679
  executables:
@@ -678,7 +692,7 @@ homepage: https://github.com/github/pages-gem
678
692
  licenses:
679
693
  - MIT
680
694
  metadata: {}
681
- post_install_message:
695
+ post_install_message:
682
696
  rdoc_options: []
683
697
  require_paths:
684
698
  - lib
@@ -693,9 +707,8 @@ required_rubygems_version: !ruby/object:Gem::Requirement
693
707
  - !ruby/object:Gem::Version
694
708
  version: '0'
695
709
  requirements: []
696
- rubyforge_project:
697
- rubygems_version: 2.7.6
698
- signing_key:
710
+ rubygems_version: 3.1.2
711
+ signing_key:
699
712
  specification_version: 4
700
713
  summary: Track GitHub Pages dependencies.
701
714
  test_files: []