github-pages 202 → 207

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: cccd4c95e60061b897f65c8430699b35239496d95766c7229ede356d29a96ea5
4
- data.tar.gz: 2140def22edd1ad945084d67e75c24c15ec879cfbb36c2978c5d7d6cce3247ae
3
+ metadata.gz: '0073651459aeb888bc754910dd92a8740cd7234fda4b14dcde339dcfe91c1853'
4
+ data.tar.gz: 954ad76b7a70098cb89b729d3dfbf6d16beeca0ddbf3d156925e10b4159d98da
5
5
  SHA512:
6
- metadata.gz: 9b502a6d5f939420fa16d73acde0b9601bfb832caf0adcb414c5985e4e50f3221a741265e271f53e14f58fa320bc6aba832aa891bdbf08b26bc34435ed45f600
7
- data.tar.gz: 064dc26f80c558c877615b31c5dfc9a09255bac36f13eed5eafe6920c4354d0483a91989701c039155beeb44318380435bdd38da7dd06df8d701e43ba45cc587
6
+ metadata.gz: 3fbdf567d1a32fb637a17afe76e81dc2f362e0bd0374b039a5cab4ef2ed377e5c2a7c8ea4994d7c48c398fc15050abf0dbf68135236f087da5d5980aab87c321
7
+ data.tar.gz: 915cbecb10cf8f37ba54559cf5eefd94a19cc781b24ea8ac512ee85ebfe882ac0bff40c0ce823d552c60a6e83dae8fcdb0569b58b3e49c4674b8d1928569f279
@@ -15,15 +15,22 @@
15
15
  #
16
16
  # If you disable a check, document why.
17
17
 
18
+ inherit_gem:
19
+ rubocop-github:
20
+ - config/default.yml
21
+
22
+ require:
23
+ - rubocop-performance
24
+
18
25
  AllCops:
19
- TargetRubyVersion: 2.3
26
+ TargetRubyVersion: 2.5
20
27
  Exclude:
21
28
  - 'bin/**/*'
22
29
  - 'script/**/*'
23
30
  - 'vendor/**/*'
24
31
  - 'test-site/**/*'
25
32
 
26
- Lint/EndAlignment:
33
+ Layout/EndAlignment:
27
34
  Severity: error
28
35
 
29
36
  Lint/RescueException:
@@ -48,10 +55,10 @@ Style/HashSyntax:
48
55
  EnforcedStyle: hash_rockets
49
56
  Severity: error
50
57
 
51
- Layout/AlignHash:
58
+ Layout/HashAlignment:
52
59
  SupportedLastArgumentHashStyles: always_ignore
53
60
 
54
- Layout/AlignParameters:
61
+ Layout/ParameterAlignment:
55
62
  Enabled: false # This is usually true, but we often want to roll back to
56
63
  # the start of a line.
57
64
 
@@ -73,17 +80,12 @@ Metrics/ClassLength:
73
80
  - !ruby/regexp /features\/.*.rb$/
74
81
  - lib/github-pages/configuration.rb
75
82
 
76
- Style/PercentLiteralDelimiters:
77
- PreferredDelimiters:
78
- '%w': '{}'
79
- '%r': '{}'
80
-
81
83
  Metrics/BlockLength:
82
84
  Exclude:
83
85
  - github-pages.gemspec
84
86
  - !ruby/regexp /spec\/.*.rb/
85
87
 
86
- Metrics/LineLength:
88
+ Layout/LineLength:
87
89
  Max: 90
88
90
  Severity: warning
89
91
  Exclude:
@@ -115,23 +117,44 @@ Style/RedundantSelf:
115
117
  Style/IfUnlessModifier:
116
118
  Enabled: false
117
119
 
118
- Style/FileName: #Rubocop doesn't like the Git*H*ub namespace
120
+ Naming/FileName: #Rubocop doesn't like the Git*H*ub namespace
119
121
  Enabled: false
120
122
 
121
- Metrics/CyclomaticComplexity: { Max: 8 }
122
- Metrics/PerceivedComplexity: { Max: 8 }
123
- Metrics/ParameterLists: { Max: 4 }
124
- Metrics/AbcSize: { Max: 20 }
125
-
126
- Layout/IndentHash: { EnforcedStyle: consistent }
127
- Style/SignalException: { EnforcedStyle: only_raise }
128
- Layout/MultilineMethodCallIndentation: { EnforcedStyle: indented }
129
- Layout/MultilineOperationIndentation: { EnforcedStyle: indented }
130
- Layout/FirstParameterIndentation: { EnforcedStyle: consistent }
131
- Style/StringLiterals: { EnforcedStyle: double_quotes }
132
- Layout/IndentArray: { EnforcedStyle: consistent }
133
- Layout/ExtraSpacing: { AllowForAlignment: true }
134
- Style/TrailingCommaInLiteral: { EnforcedStyleForMultiline: consistent_comma }
123
+ Metrics/CyclomaticComplexity:
124
+ Max: 8
125
+ Metrics/PerceivedComplexity:
126
+ Max: 8
127
+ Metrics/ParameterLists:
128
+ Max: 4
129
+ Metrics/AbcSize:
130
+ Max: 20
131
+
132
+ Style/SignalException:
133
+ EnforcedStyle: only_raise
134
+
135
+ Layout/MultilineMethodCallIndentation:
136
+ EnforcedStyle: indented
137
+
138
+ Layout/MultilineOperationIndentation:
139
+ EnforcedStyle: indented
140
+
141
+ Layout/FirstArgumentIndentation:
142
+ EnforcedStyle: consistent
143
+
144
+ Layout/FirstHashElementIndentation:
145
+ EnforcedStyle: consistent
146
+
147
+ Layout/FirstArrayElementIndentation:
148
+ EnforcedStyle: consistent
149
+
150
+ Layout/ExtraSpacing:
151
+ AllowForAlignment: true
152
+
153
+ Style/TrailingCommaInArrayLiteral:
154
+ EnforcedStyleForMultiline: consistent_comma
155
+
156
+ Style/TrailingCommaInHashLiteral:
157
+ EnforcedStyleForMultiline: consistent_comma
135
158
 
136
159
  Style/PercentLiteralDelimiters:
137
160
  PreferredDelimiters:
@@ -13,13 +13,13 @@ module GitHubPages
13
13
 
14
14
  # Default, user overwritable options
15
15
  DEFAULTS = {
16
- "jailed" => false,
17
- "plugins" => GitHubPages::Plugins::DEFAULT_PLUGINS,
18
- "future" => true,
19
- "theme" => "jekyll-theme-primer",
16
+ "jailed" => false,
17
+ "plugins" => GitHubPages::Plugins::DEFAULT_PLUGINS,
18
+ "future" => true,
19
+ "theme" => "jekyll-theme-primer",
20
20
  "markdown" => "kramdown",
21
21
  "kramdown" => {
22
- "input" => "GFM",
22
+ "input" => "GFM",
23
23
  "hard_wrap" => false,
24
24
  "gfm_quirks" => "paragraph_end",
25
25
  "syntax_highlighter_opts" => {
@@ -47,18 +47,18 @@ module GitHubPages
47
47
  # * incremental
48
48
  # * GH_ENV
49
49
  OVERRIDES = {
50
- "lsi" => false,
51
- "safe" => true,
50
+ "lsi" => false,
51
+ "safe" => true,
52
52
  "plugins_dir" => SecureRandom.hex,
53
- "whitelist" => GitHubPages::Plugins::PLUGIN_WHITELIST,
53
+ "whitelist" => GitHubPages::Plugins::PLUGIN_WHITELIST,
54
54
  "highlighter" => "rouge",
55
- "kramdown" => {
56
- "template" => "",
57
- "math_engine" => "mathjax",
55
+ "kramdown" => {
56
+ "template" => "",
57
+ "math_engine" => "mathjax",
58
58
  "syntax_highlighter" => "rouge",
59
59
  },
60
- "gist" => {
61
- "noscript" => false,
60
+ "gist" => {
61
+ "noscript" => false,
62
62
  },
63
63
  }.freeze
64
64
 
@@ -124,6 +124,7 @@ module GitHubPages
124
124
  # guards against double-processing via the value in #processed.
125
125
  def set(site)
126
126
  return if processed? site
127
+
127
128
  debug_print_versions
128
129
  set!(site)
129
130
  processed(site)
@@ -158,6 +159,7 @@ module GitHubPages
158
159
  # If the user's 'exclude' config is the default, also exclude the CNAME
159
160
  def exclude_cname(config)
160
161
  return unless config["exclude"].eql? Jekyll::Configuration::DEFAULTS["exclude"]
162
+
161
163
  config["exclude"].concat(DEFAULTS["exclude"])
162
164
  end
163
165
 
@@ -7,45 +7,39 @@ module GitHubPages
7
7
  class Dependencies
8
8
  VERSIONS = {
9
9
  # Jekyll
10
- "jekyll" => "3.8.5",
11
- "jekyll-sass-converter" => "1.5.2",
10
+ "jekyll" => "3.9.0",
11
+ "jekyll-sass-converter" => "1.5.2",
12
12
 
13
13
  # Converters
14
- "kramdown" => "1.17.0",
14
+ "kramdown" => "2.3.0",
15
+ "kramdown-parser-gfm" => "1.1.0",
15
16
  "jekyll-commonmark-ghpages" => "0.1.6",
16
17
 
17
18
  # Misc
18
- "liquid" => "4.0.0",
19
- "rouge" => "3.11.0",
19
+ "liquid" => "4.0.3",
20
+ "rouge" => "3.19.0",
20
21
  "github-pages-health-check" => "1.16.1",
21
22
 
22
23
  # Plugins
23
- "jekyll-redirect-from" => "0.14.0",
24
- "jekyll-sitemap" => "1.2.0",
25
- "jekyll-feed" => "0.11.0",
26
- "jekyll-gist" => "1.5.0",
27
- "jekyll-paginate" => "1.1.0",
28
- "jekyll-coffeescript" => "1.1.1",
29
- "jekyll-seo-tag" => "2.5.0",
30
- "jekyll-github-metadata" => "2.12.1",
31
- "jekyll-avatar" => "0.6.0",
32
- "jekyll-remote-theme" => "0.4.0",
24
+ "jekyll-redirect-from" => "0.15.0",
25
+ "jekyll-sitemap" => "1.4.0",
26
+ "jekyll-feed" => "0.13.0",
27
+ "jekyll-gist" => "1.5.0",
28
+ "jekyll-paginate" => "1.1.0",
29
+ "jekyll-coffeescript" => "1.1.1",
30
+ "jekyll-seo-tag" => "2.6.1",
31
+ "jekyll-github-metadata" => "2.13.0",
32
+ "jekyll-avatar" => "0.7.0",
33
+ "jekyll-remote-theme" => "0.4.1",
33
34
 
34
35
  # Plugins to match GitHub.com Markdown
35
- "jemoji" => "0.10.2",
36
- "jekyll-mentions" => "1.4.1",
37
- "jekyll-relative-links" => "0.6.0",
38
- "jekyll-optional-front-matter" => "0.3.0",
39
- "jekyll-readme-index" => "0.2.0",
40
- "jekyll-default-layout" => "0.1.4",
41
- "jekyll-titles-from-headings" => "0.5.1",
42
-
43
- # Pin listen because it's broken on 2.1 & that's what we recommend.
44
- # https://github.com/guard/listen/pull/371
45
- "listen" => "3.1.5",
46
-
47
- # Pin activesupport because 5.0 is broken on 2.1
48
- "activesupport" => "4.2.11.1",
36
+ "jemoji" => "0.11.1",
37
+ "jekyll-mentions" => "1.5.1",
38
+ "jekyll-relative-links" => "0.6.1",
39
+ "jekyll-optional-front-matter" => "0.3.2",
40
+ "jekyll-readme-index" => "0.3.0",
41
+ "jekyll-default-layout" => "0.1.4",
42
+ "jekyll-titles-from-headings" => "0.5.3",
49
43
  }.freeze
50
44
 
51
45
  # Jekyll and related dependency versions as used by GitHub Pages.
@@ -71,11 +65,11 @@ module GitHubPages
71
65
  "ruby" => RUBY_VERSION,
72
66
 
73
67
  # Gem versions we're curious about
74
- "github-pages" => VERSION.to_s,
68
+ "github-pages" => VERSION.to_s,
75
69
  "html-pipeline" => HTML::Pipeline::VERSION,
76
- "sass" => Sass.version[:number],
77
- "safe_yaml" => SafeYAML::VERSION,
78
- "nokogiri" => Nokogiri::VERSION,
70
+ "sass" => Sass.version[:number],
71
+ "safe_yaml" => SafeYAML::VERSION,
72
+ "nokogiri" => Nokogiri::VERSION,
79
73
  }
80
74
  end
81
75
  end
@@ -48,21 +48,21 @@ module GitHubPages
48
48
 
49
49
  # Themes
50
50
  THEMES = {
51
- "jekyll-swiss" => "0.4.0",
52
- "minima" => "2.5.0",
53
- "jekyll-theme-primer" => "0.5.3",
54
- "jekyll-theme-architect" => "0.1.1",
55
- "jekyll-theme-cayman" => "0.1.1",
56
- "jekyll-theme-dinky" => "0.1.1",
57
- "jekyll-theme-hacker" => "0.1.1",
58
- "jekyll-theme-leap-day" => "0.1.1",
59
- "jekyll-theme-merlot" => "0.1.1",
60
- "jekyll-theme-midnight" => "0.1.1",
61
- "jekyll-theme-minimal" => "0.1.1",
62
- "jekyll-theme-modernist" => "0.1.1",
63
- "jekyll-theme-slate" => "0.1.1",
64
- "jekyll-theme-tactile" => "0.1.1",
65
- "jekyll-theme-time-machine" => "0.1.1",
51
+ "jekyll-swiss" => "1.0.0",
52
+ "minima" => "2.5.1",
53
+ "jekyll-theme-primer" => "0.5.4",
54
+ "jekyll-theme-architect" => "0.1.1",
55
+ "jekyll-theme-cayman" => "0.1.1",
56
+ "jekyll-theme-dinky" => "0.1.1",
57
+ "jekyll-theme-hacker" => "0.1.1",
58
+ "jekyll-theme-leap-day" => "0.1.1",
59
+ "jekyll-theme-merlot" => "0.1.1",
60
+ "jekyll-theme-midnight" => "0.1.1",
61
+ "jekyll-theme-minimal" => "0.1.1",
62
+ "jekyll-theme-modernist" => "0.1.1",
63
+ "jekyll-theme-slate" => "0.1.1",
64
+ "jekyll-theme-tactile" => "0.1.1",
65
+ "jekyll-theme-time-machine" => "0.1.1",
66
66
  }.freeze
67
67
  end
68
68
  end
@@ -1,5 +1,5 @@
1
1
  # frozen_string_literal: true
2
2
 
3
3
  module GitHubPages
4
- VERSION = 202
4
+ VERSION = 207
5
5
  end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: github-pages
3
3
  version: !ruby/object:Gem::Version
4
- version: '202'
4
+ version: '207'
5
5
  platform: ruby
6
6
  authors:
7
7
  - GitHub, Inc.
8
- autorequire:
8
+ autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2019-10-23 00:00:00.000000000 Z
11
+ date: 2020-08-07 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: jekyll
@@ -16,14 +16,14 @@ dependencies:
16
16
  requirements:
17
17
  - - '='
18
18
  - !ruby/object:Gem::Version
19
- version: 3.8.5
19
+ version: 3.9.0
20
20
  type: :runtime
21
21
  prerelease: false
22
22
  version_requirements: !ruby/object:Gem::Requirement
23
23
  requirements:
24
24
  - - '='
25
25
  - !ruby/object:Gem::Version
26
- version: 3.8.5
26
+ version: 3.9.0
27
27
  - !ruby/object:Gem::Dependency
28
28
  name: jekyll-sass-converter
29
29
  requirement: !ruby/object:Gem::Requirement
@@ -44,14 +44,28 @@ dependencies:
44
44
  requirements:
45
45
  - - '='
46
46
  - !ruby/object:Gem::Version
47
- version: 1.17.0
47
+ version: 2.3.0
48
48
  type: :runtime
49
49
  prerelease: false
50
50
  version_requirements: !ruby/object:Gem::Requirement
51
51
  requirements:
52
52
  - - '='
53
53
  - !ruby/object:Gem::Version
54
- version: 1.17.0
54
+ version: 2.3.0
55
+ - !ruby/object:Gem::Dependency
56
+ name: kramdown-parser-gfm
57
+ requirement: !ruby/object:Gem::Requirement
58
+ requirements:
59
+ - - '='
60
+ - !ruby/object:Gem::Version
61
+ version: 1.1.0
62
+ type: :runtime
63
+ prerelease: false
64
+ version_requirements: !ruby/object:Gem::Requirement
65
+ requirements:
66
+ - - '='
67
+ - !ruby/object:Gem::Version
68
+ version: 1.1.0
55
69
  - !ruby/object:Gem::Dependency
56
70
  name: jekyll-commonmark-ghpages
57
71
  requirement: !ruby/object:Gem::Requirement
@@ -72,28 +86,28 @@ dependencies:
72
86
  requirements:
73
87
  - - '='
74
88
  - !ruby/object:Gem::Version
75
- version: 4.0.0
89
+ version: 4.0.3
76
90
  type: :runtime
77
91
  prerelease: false
78
92
  version_requirements: !ruby/object:Gem::Requirement
79
93
  requirements:
80
94
  - - '='
81
95
  - !ruby/object:Gem::Version
82
- version: 4.0.0
96
+ version: 4.0.3
83
97
  - !ruby/object:Gem::Dependency
84
98
  name: rouge
85
99
  requirement: !ruby/object:Gem::Requirement
86
100
  requirements:
87
101
  - - '='
88
102
  - !ruby/object:Gem::Version
89
- version: 3.11.0
103
+ version: 3.19.0
90
104
  type: :runtime
91
105
  prerelease: false
92
106
  version_requirements: !ruby/object:Gem::Requirement
93
107
  requirements:
94
108
  - - '='
95
109
  - !ruby/object:Gem::Version
96
- version: 3.11.0
110
+ version: 3.19.0
97
111
  - !ruby/object:Gem::Dependency
98
112
  name: github-pages-health-check
99
113
  requirement: !ruby/object:Gem::Requirement
@@ -114,42 +128,42 @@ dependencies:
114
128
  requirements:
115
129
  - - '='
116
130
  - !ruby/object:Gem::Version
117
- version: 0.14.0
131
+ version: 0.15.0
118
132
  type: :runtime
119
133
  prerelease: false
120
134
  version_requirements: !ruby/object:Gem::Requirement
121
135
  requirements:
122
136
  - - '='
123
137
  - !ruby/object:Gem::Version
124
- version: 0.14.0
138
+ version: 0.15.0
125
139
  - !ruby/object:Gem::Dependency
126
140
  name: jekyll-sitemap
127
141
  requirement: !ruby/object:Gem::Requirement
128
142
  requirements:
129
143
  - - '='
130
144
  - !ruby/object:Gem::Version
131
- version: 1.2.0
145
+ version: 1.4.0
132
146
  type: :runtime
133
147
  prerelease: false
134
148
  version_requirements: !ruby/object:Gem::Requirement
135
149
  requirements:
136
150
  - - '='
137
151
  - !ruby/object:Gem::Version
138
- version: 1.2.0
152
+ version: 1.4.0
139
153
  - !ruby/object:Gem::Dependency
140
154
  name: jekyll-feed
141
155
  requirement: !ruby/object:Gem::Requirement
142
156
  requirements:
143
157
  - - '='
144
158
  - !ruby/object:Gem::Version
145
- version: 0.11.0
159
+ version: 0.13.0
146
160
  type: :runtime
147
161
  prerelease: false
148
162
  version_requirements: !ruby/object:Gem::Requirement
149
163
  requirements:
150
164
  - - '='
151
165
  - !ruby/object:Gem::Version
152
- version: 0.11.0
166
+ version: 0.13.0
153
167
  - !ruby/object:Gem::Dependency
154
168
  name: jekyll-gist
155
169
  requirement: !ruby/object:Gem::Requirement
@@ -198,126 +212,126 @@ dependencies:
198
212
  requirements:
199
213
  - - '='
200
214
  - !ruby/object:Gem::Version
201
- version: 2.5.0
215
+ version: 2.6.1
202
216
  type: :runtime
203
217
  prerelease: false
204
218
  version_requirements: !ruby/object:Gem::Requirement
205
219
  requirements:
206
220
  - - '='
207
221
  - !ruby/object:Gem::Version
208
- version: 2.5.0
222
+ version: 2.6.1
209
223
  - !ruby/object:Gem::Dependency
210
224
  name: jekyll-github-metadata
211
225
  requirement: !ruby/object:Gem::Requirement
212
226
  requirements:
213
227
  - - '='
214
228
  - !ruby/object:Gem::Version
215
- version: 2.12.1
229
+ version: 2.13.0
216
230
  type: :runtime
217
231
  prerelease: false
218
232
  version_requirements: !ruby/object:Gem::Requirement
219
233
  requirements:
220
234
  - - '='
221
235
  - !ruby/object:Gem::Version
222
- version: 2.12.1
236
+ version: 2.13.0
223
237
  - !ruby/object:Gem::Dependency
224
238
  name: jekyll-avatar
225
239
  requirement: !ruby/object:Gem::Requirement
226
240
  requirements:
227
241
  - - '='
228
242
  - !ruby/object:Gem::Version
229
- version: 0.6.0
243
+ version: 0.7.0
230
244
  type: :runtime
231
245
  prerelease: false
232
246
  version_requirements: !ruby/object:Gem::Requirement
233
247
  requirements:
234
248
  - - '='
235
249
  - !ruby/object:Gem::Version
236
- version: 0.6.0
250
+ version: 0.7.0
237
251
  - !ruby/object:Gem::Dependency
238
252
  name: jekyll-remote-theme
239
253
  requirement: !ruby/object:Gem::Requirement
240
254
  requirements:
241
255
  - - '='
242
256
  - !ruby/object:Gem::Version
243
- version: 0.4.0
257
+ version: 0.4.1
244
258
  type: :runtime
245
259
  prerelease: false
246
260
  version_requirements: !ruby/object:Gem::Requirement
247
261
  requirements:
248
262
  - - '='
249
263
  - !ruby/object:Gem::Version
250
- version: 0.4.0
264
+ version: 0.4.1
251
265
  - !ruby/object:Gem::Dependency
252
266
  name: jemoji
253
267
  requirement: !ruby/object:Gem::Requirement
254
268
  requirements:
255
269
  - - '='
256
270
  - !ruby/object:Gem::Version
257
- version: 0.10.2
271
+ version: 0.11.1
258
272
  type: :runtime
259
273
  prerelease: false
260
274
  version_requirements: !ruby/object:Gem::Requirement
261
275
  requirements:
262
276
  - - '='
263
277
  - !ruby/object:Gem::Version
264
- version: 0.10.2
278
+ version: 0.11.1
265
279
  - !ruby/object:Gem::Dependency
266
280
  name: jekyll-mentions
267
281
  requirement: !ruby/object:Gem::Requirement
268
282
  requirements:
269
283
  - - '='
270
284
  - !ruby/object:Gem::Version
271
- version: 1.4.1
285
+ version: 1.5.1
272
286
  type: :runtime
273
287
  prerelease: false
274
288
  version_requirements: !ruby/object:Gem::Requirement
275
289
  requirements:
276
290
  - - '='
277
291
  - !ruby/object:Gem::Version
278
- version: 1.4.1
292
+ version: 1.5.1
279
293
  - !ruby/object:Gem::Dependency
280
294
  name: jekyll-relative-links
281
295
  requirement: !ruby/object:Gem::Requirement
282
296
  requirements:
283
297
  - - '='
284
298
  - !ruby/object:Gem::Version
285
- version: 0.6.0
299
+ version: 0.6.1
286
300
  type: :runtime
287
301
  prerelease: false
288
302
  version_requirements: !ruby/object:Gem::Requirement
289
303
  requirements:
290
304
  - - '='
291
305
  - !ruby/object:Gem::Version
292
- version: 0.6.0
306
+ version: 0.6.1
293
307
  - !ruby/object:Gem::Dependency
294
308
  name: jekyll-optional-front-matter
295
309
  requirement: !ruby/object:Gem::Requirement
296
310
  requirements:
297
311
  - - '='
298
312
  - !ruby/object:Gem::Version
299
- version: 0.3.0
313
+ version: 0.3.2
300
314
  type: :runtime
301
315
  prerelease: false
302
316
  version_requirements: !ruby/object:Gem::Requirement
303
317
  requirements:
304
318
  - - '='
305
319
  - !ruby/object:Gem::Version
306
- version: 0.3.0
320
+ version: 0.3.2
307
321
  - !ruby/object:Gem::Dependency
308
322
  name: jekyll-readme-index
309
323
  requirement: !ruby/object:Gem::Requirement
310
324
  requirements:
311
325
  - - '='
312
326
  - !ruby/object:Gem::Version
313
- version: 0.2.0
327
+ version: 0.3.0
314
328
  type: :runtime
315
329
  prerelease: false
316
330
  version_requirements: !ruby/object:Gem::Requirement
317
331
  requirements:
318
332
  - - '='
319
333
  - !ruby/object:Gem::Version
320
- version: 0.2.0
334
+ version: 0.3.0
321
335
  - !ruby/object:Gem::Dependency
322
336
  name: jekyll-default-layout
323
337
  requirement: !ruby/object:Gem::Requirement
@@ -338,84 +352,56 @@ dependencies:
338
352
  requirements:
339
353
  - - '='
340
354
  - !ruby/object:Gem::Version
341
- version: 0.5.1
342
- type: :runtime
343
- prerelease: false
344
- version_requirements: !ruby/object:Gem::Requirement
345
- requirements:
346
- - - '='
347
- - !ruby/object:Gem::Version
348
- version: 0.5.1
349
- - !ruby/object:Gem::Dependency
350
- name: listen
351
- requirement: !ruby/object:Gem::Requirement
352
- requirements:
353
- - - '='
354
- - !ruby/object:Gem::Version
355
- version: 3.1.5
356
- type: :runtime
357
- prerelease: false
358
- version_requirements: !ruby/object:Gem::Requirement
359
- requirements:
360
- - - '='
361
- - !ruby/object:Gem::Version
362
- version: 3.1.5
363
- - !ruby/object:Gem::Dependency
364
- name: activesupport
365
- requirement: !ruby/object:Gem::Requirement
366
- requirements:
367
- - - '='
368
- - !ruby/object:Gem::Version
369
- version: 4.2.11.1
355
+ version: 0.5.3
370
356
  type: :runtime
371
357
  prerelease: false
372
358
  version_requirements: !ruby/object:Gem::Requirement
373
359
  requirements:
374
360
  - - '='
375
361
  - !ruby/object:Gem::Version
376
- version: 4.2.11.1
362
+ version: 0.5.3
377
363
  - !ruby/object:Gem::Dependency
378
364
  name: jekyll-swiss
379
365
  requirement: !ruby/object:Gem::Requirement
380
366
  requirements:
381
367
  - - '='
382
368
  - !ruby/object:Gem::Version
383
- version: 0.4.0
369
+ version: 1.0.0
384
370
  type: :runtime
385
371
  prerelease: false
386
372
  version_requirements: !ruby/object:Gem::Requirement
387
373
  requirements:
388
374
  - - '='
389
375
  - !ruby/object:Gem::Version
390
- version: 0.4.0
376
+ version: 1.0.0
391
377
  - !ruby/object:Gem::Dependency
392
378
  name: minima
393
379
  requirement: !ruby/object:Gem::Requirement
394
380
  requirements:
395
381
  - - '='
396
382
  - !ruby/object:Gem::Version
397
- version: 2.5.0
383
+ version: 2.5.1
398
384
  type: :runtime
399
385
  prerelease: false
400
386
  version_requirements: !ruby/object:Gem::Requirement
401
387
  requirements:
402
388
  - - '='
403
389
  - !ruby/object:Gem::Version
404
- version: 2.5.0
390
+ version: 2.5.1
405
391
  - !ruby/object:Gem::Dependency
406
392
  name: jekyll-theme-primer
407
393
  requirement: !ruby/object:Gem::Requirement
408
394
  requirements:
409
395
  - - '='
410
396
  - !ruby/object:Gem::Version
411
- version: 0.5.3
397
+ version: 0.5.4
412
398
  type: :runtime
413
399
  prerelease: false
414
400
  version_requirements: !ruby/object:Gem::Requirement
415
401
  requirements:
416
402
  - - '='
417
403
  - !ruby/object:Gem::Version
418
- version: 0.5.3
404
+ version: 0.5.4
419
405
  - !ruby/object:Gem::Dependency
420
406
  name: jekyll-theme-architect
421
407
  requirement: !ruby/object:Gem::Requirement
@@ -598,20 +584,6 @@ dependencies:
598
584
  - - "~>"
599
585
  - !ruby/object:Gem::Version
600
586
  version: '0.3'
601
- - !ruby/object:Gem::Dependency
602
- name: terminal-table
603
- requirement: !ruby/object:Gem::Requirement
604
- requirements:
605
- - - "~>"
606
- - !ruby/object:Gem::Version
607
- version: '1.4'
608
- type: :runtime
609
- prerelease: false
610
- version_requirements: !ruby/object:Gem::Requirement
611
- requirements:
612
- - - "~>"
613
- - !ruby/object:Gem::Version
614
- version: '1.4'
615
587
  - !ruby/object:Gem::Dependency
616
588
  name: nokogiri
617
589
  requirement: !ruby/object:Gem::Requirement
@@ -633,33 +605,33 @@ dependencies:
633
605
  - !ruby/object:Gem::Version
634
606
  version: '2.0'
635
607
  - !ruby/object:Gem::Dependency
636
- name: rspec
608
+ name: terminal-table
637
609
  requirement: !ruby/object:Gem::Requirement
638
610
  requirements:
639
611
  - - "~>"
640
612
  - !ruby/object:Gem::Version
641
- version: '3.3'
642
- type: :development
613
+ version: '1.4'
614
+ type: :runtime
643
615
  prerelease: false
644
616
  version_requirements: !ruby/object:Gem::Requirement
645
617
  requirements:
646
618
  - - "~>"
647
619
  - !ruby/object:Gem::Version
648
- version: '3.3'
620
+ version: '1.4'
649
621
  - !ruby/object:Gem::Dependency
650
- name: rainbow
622
+ name: jekyll_test_plugin_malicious
651
623
  requirement: !ruby/object:Gem::Requirement
652
624
  requirements:
653
625
  - - "~>"
654
626
  - !ruby/object:Gem::Version
655
- version: 2.1.0
627
+ version: '0.2'
656
628
  type: :development
657
629
  prerelease: false
658
630
  version_requirements: !ruby/object:Gem::Requirement
659
631
  requirements:
660
632
  - - "~>"
661
633
  - !ruby/object:Gem::Version
662
- version: 2.1.0
634
+ version: '0.2'
663
635
  - !ruby/object:Gem::Dependency
664
636
  name: pry
665
637
  requirement: !ruby/object:Gem::Requirement
@@ -675,39 +647,33 @@ dependencies:
675
647
  - !ruby/object:Gem::Version
676
648
  version: '0.10'
677
649
  - !ruby/object:Gem::Dependency
678
- name: jekyll_test_plugin_malicious
650
+ name: rspec
679
651
  requirement: !ruby/object:Gem::Requirement
680
652
  requirements:
681
653
  - - "~>"
682
654
  - !ruby/object:Gem::Version
683
- version: '0.2'
655
+ version: '3.3'
684
656
  type: :development
685
657
  prerelease: false
686
658
  version_requirements: !ruby/object:Gem::Requirement
687
659
  requirements:
688
660
  - - "~>"
689
661
  - !ruby/object:Gem::Version
690
- version: '0.2'
662
+ version: '3.3'
691
663
  - !ruby/object:Gem::Dependency
692
- name: rubocop
664
+ name: rubocop-github
693
665
  requirement: !ruby/object:Gem::Requirement
694
666
  requirements:
695
- - - ">="
696
- - !ruby/object:Gem::Version
697
- version: 0.48.1
698
- - - "<"
667
+ - - '='
699
668
  - !ruby/object:Gem::Version
700
- version: '5.0'
669
+ version: 0.16.0
701
670
  type: :development
702
671
  prerelease: false
703
672
  version_requirements: !ruby/object:Gem::Requirement
704
673
  requirements:
705
- - - ">="
706
- - !ruby/object:Gem::Version
707
- version: 0.48.1
708
- - - "<"
674
+ - - '='
709
675
  - !ruby/object:Gem::Version
710
- version: '5.0'
676
+ version: 0.16.0
711
677
  description: Bootstrap the GitHub Pages Jekyll environment locally.
712
678
  email: support@github.com
713
679
  executables:
@@ -726,7 +692,7 @@ homepage: https://github.com/github/pages-gem
726
692
  licenses:
727
693
  - MIT
728
694
  metadata: {}
729
- post_install_message:
695
+ post_install_message:
730
696
  rdoc_options: []
731
697
  require_paths:
732
698
  - lib
@@ -741,9 +707,8 @@ required_rubygems_version: !ruby/object:Gem::Requirement
741
707
  - !ruby/object:Gem::Version
742
708
  version: '0'
743
709
  requirements: []
744
- rubyforge_project:
745
- rubygems_version: 2.7.6
746
- signing_key:
710
+ rubygems_version: 3.1.2
711
+ signing_key:
747
712
  specification_version: 4
748
713
  summary: Track GitHub Pages dependencies.
749
714
  test_files: []