github-pages 174 → 175

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA1:
3
- metadata.gz: 6ca8ac599f93e9a5afaf1df85068cdcc589d2e39
4
- data.tar.gz: 60026422083678039afe0771b2db28ad357f9c25
3
+ metadata.gz: 3377072962dcd496e49add64c20a88b811adba00
4
+ data.tar.gz: 16336d9c052b95ed2bdd9fae379c03f1d3cb27b5
5
5
  SHA512:
6
- metadata.gz: 6746385d4eda8696cde9bad19ea465eec37fb23e500e64a3a8a0c974773afe79321c4512f56fd804e26db47515064902d675f9bc0236f5855f755c22a614cb86
7
- data.tar.gz: c4599a2189d65e85dc8031c821d60c7c7d48aa7119610fa7d0c07eb73fec4a5eb69e153cebb49f187e443f08b2f197696af0cd43f62f1c5e71810f215f9b3fc5
6
+ metadata.gz: 15d0d5c1e1015841e32e6e06fa6f805c764eec49084387d26405cbb90dc330397d81563c9393f23d26b40425f1a515a72aa2066c684fda6f454790dd307882af
7
+ data.tar.gz: cc1bdd84352bc7cdf74894c5bf7623e67aa9c528e36fd6440f6babc1f3ab1695676299533e0bfcdc580a52e0514a4840bee95043d71197853f313fbf0611346c
@@ -108,6 +108,9 @@ module GitHubPages
108
108
  # Ensure we have those gems we want.
109
109
  config["plugins"] = Array(config["plugins"]) | DEFAULT_PLUGINS
110
110
 
111
+ # To minimize erorrs, lazy-require jekyll-remote-theme if requested by the user
112
+ config["plugins"].push("jekyll-remote-theme") if config.key? "remote_theme"
113
+
111
114
  if disable_whitelist?
112
115
  config["whitelist"] = config["whitelist"] | config["plugins"]
113
116
  end
@@ -127,7 +130,6 @@ module GitHubPages
127
130
  debug_print_versions
128
131
  set!(site)
129
132
  processed(site)
130
- conditionally_require_plugins(site)
131
133
  end
132
134
 
133
135
  # Set the site's configuration with all the proper defaults and overrides.
@@ -162,15 +164,6 @@ module GitHubPages
162
164
  Jekyll.logger.debug "GitHub Pages:", "github-pages v#{GitHubPages::VERSION}"
163
165
  Jekyll.logger.debug "GitHub Pages:", "jekyll v#{Jekyll::VERSION}"
164
166
  end
165
-
166
- # To minimize erorrs, lazy-load plugins if they're requested by the user
167
- def conditionally_require_plugins(site)
168
- plugins = []
169
- plugins.push "jekyll-remote-theme" if site.config.key? "remote_theme"
170
- Jekyll::External.require_with_graceful_fail(
171
- plugins.select { |plugin| site.plugin_manager.plugin_allowed?(plugin) }
172
- )
173
- end
174
167
  end
175
168
  end
176
169
  end
@@ -1,5 +1,5 @@
1
1
  # frozen_string_literal: true
2
2
 
3
3
  module GitHubPages
4
- VERSION = 174
4
+ VERSION = 175
5
5
  end
metadata CHANGED
@@ -1,7 +1,7 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: github-pages
3
3
  version: !ruby/object:Gem::Version
4
- version: '174'
4
+ version: '175'
5
5
  platform: ruby
6
6
  authors:
7
7
  - GitHub, Inc.