geminstaller 0.5.5 → 0.5.6

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
@@ -1,3 +1,6 @@
1
+ == 0.5.6 / 2010-05-10
2
+ * Handle platforms in gem list version output for Rubygems 1.3.7.
3
+
1
4
  == 0.5.5 / 2010-03-25
2
5
  * Add source to --bundler-export option. Handle Rubygems errors when parsing gem prerelease versions in older Rubygems versions.
3
6
 
@@ -24,7 +24,8 @@ gems:
24
24
  version: '>= 1.2.8'
25
25
  # install dev dependencies for rspec, or else regression tests on older versions of rubygems with the dev dependencies
26
26
  # bug (1.0, 1.1) fail - and currently Hoe swallows Rspec load error silently
27
- install_options: --no-ri --no-rdoc --development
27
+ # install_options: --no-ri --no-rdoc --development # but since 2010-05-10 rspec fails with dev dependencies
28
+ install_options: --no-ri --no-rdoc
28
29
  - name: cmdparse
29
30
  version: '>= 2.0.2'
30
31
  - name: ruby-debug
@@ -34,7 +34,7 @@ module GemInstaller
34
34
  end
35
35
 
36
36
  def self.version
37
- "0.5.5"
37
+ "0.5.6"
38
38
  end
39
39
 
40
40
  def self.create_application(args = [], registry = nil)
@@ -8,7 +8,8 @@ module GemInstaller
8
8
  available_versions = available_versions.split(', ')
9
9
  end
10
10
  available_versions.each do |available_version_string|
11
- available_version = Gem::Version.new(available_version_string)
11
+ available_version_string_without_platforms = available_version_string.split(' ').first
12
+ available_version = Gem::Version.new(available_version_string_without_platforms)
12
13
  if rubygems_version_requirement.satisfied_by?(available_version)
13
14
  return available_version.to_s
14
15
  end
@@ -49,6 +49,8 @@ Please "report any others that you find":http://thewoolleyweb.lighthouseapp.com/
49
49
 
50
50
  h2(#history). History
51
51
 
52
+ * 0.5.6
53
+ ** Handle platforms in gem list version output for Rubygems 1.3.7.
52
54
  * 0.5.5
53
55
  ** Add source to --bundler-export option. Handle Rubygems errors when parsing gem prerelease versions in older Rubygems versions.
54
56
  * 0.5.4
metadata CHANGED
@@ -1,12 +1,13 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: geminstaller
3
3
  version: !ruby/object:Gem::Version
4
+ hash: 7
4
5
  prerelease: false
5
6
  segments:
6
7
  - 0
7
8
  - 5
8
- - 5
9
- version: 0.5.5
9
+ - 6
10
+ version: 0.5.6
10
11
  platform: ruby
11
12
  authors:
12
13
  - Chad Woolley
@@ -14,7 +15,7 @@ autorequire:
14
15
  bindir: bin
15
16
  cert_chain: []
16
17
 
17
- date: 2010-03-25 00:00:00 -07:00
18
+ date: 2010-05-10 00:00:00 -07:00
18
19
  default_executable:
19
20
  dependencies: []
20
21
 
@@ -119,23 +120,27 @@ rdoc_options:
119
120
  require_paths:
120
121
  - lib
121
122
  required_ruby_version: !ruby/object:Gem::Requirement
123
+ none: false
122
124
  requirements:
123
125
  - - ">="
124
126
  - !ruby/object:Gem::Version
127
+ hash: 3
125
128
  segments:
126
129
  - 0
127
130
  version: "0"
128
131
  required_rubygems_version: !ruby/object:Gem::Requirement
132
+ none: false
129
133
  requirements:
130
134
  - - ">="
131
135
  - !ruby/object:Gem::Version
136
+ hash: 3
132
137
  segments:
133
138
  - 0
134
139
  version: "0"
135
140
  requirements: []
136
141
 
137
142
  rubyforge_project: geminstaller
138
- rubygems_version: 1.3.6.1
143
+ rubygems_version: 1.3.7.pre.1.1
139
144
  signing_key:
140
145
  specification_version: 3
141
146
  summary: See http://geminstaller.rubyforge.org