fie 0.3.5 → 0.3.6

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: dc802790a954dae1b97d1ab80ca3b66b34db0e086e588e6321b9ea4d8b37c0e9
4
- data.tar.gz: 6b3ff748b2fa4bcc4a7f870967554af773923813565a9dbb7018a16a14d4abf8
3
+ metadata.gz: 24e5b12cad75d4205b4747a5f9ba5d86e5c76611f31d17471838e78171d16d6f
4
+ data.tar.gz: 73624dafafa69ee09a0194b7b79c13c963b11e0da3049f149615303b27e485f1
5
5
  SHA512:
6
- metadata.gz: e4e56d5684bafc8cfb1847923e1d9ea52785d598e7cac131746437d8dbb32fcab81f8ce9dd578bbd1b6bd5ef19095983e3d63eb27219f01915e77439cd7bfeeb
7
- data.tar.gz: a964c13fbec65884d8b78dbde9f55b82f7149b228d1537b0195f9ece1050efaceab5ccaf53fc0753a49a26d1e38cd2b58acd1a58c76d82379730e46822b8cb38
6
+ metadata.gz: 92b62507faf5bc11e818ce351f5fff637b4d77bf01b7d9bfd929c12d4b3b4afccdd939f2360f4c57f70b7d5ffae0f9cc52834ffaa392abadcd8e496d8dcb960e
7
+ data.tar.gz: 7967a6b8cdd9ebec6d334f5ff60e04d8fbd1ac2bab8829a38559c0bce9319401d4d754ba743408dceaa7f416d9cceee0f6a228fd2945da78b5d862a958beaf9f
data/README.md CHANGED
@@ -22,7 +22,7 @@ fie therefore replaces traditional Javascript frontend frameworks while requirin
22
22
  1. Add the gem to your gemfile like so:
23
23
 
24
24
  ```ruby
25
- gem 'fie', '~> 0.3.5'
25
+ gem 'fie', '~> 0.3.6'
26
26
  ```
27
27
 
28
28
  2. Run the bundler
@@ -15,7 +15,7 @@ module Fie
15
15
  command: 'publish_to_pool_lazy',
16
16
  parameters: {
17
17
  subject: subject,
18
- object: Marshal.dump(object)
18
+ object: Marshal.dump(object).force_encoding(Encoding::UTF_8)
19
19
  }
20
20
  end
21
21
 
@@ -25,7 +25,7 @@ module Fie
25
25
  command: 'publish_to_pool',
26
26
  parameters: {
27
27
  subject: subject,
28
- object: Marshal.dump(object),
28
+ object: Marshal.dump(object).force_encoding(Encoding::UTF_8),
29
29
  sender_uuid: sender_uuid
30
30
  }
31
31
  end
@@ -1,3 +1,3 @@
1
1
  module Fie
2
- VERSION = '0.3.5'
2
+ VERSION = '0.3.6'
3
3
  end
metadata CHANGED
@@ -1,153 +1,153 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: fie
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.3.5
4
+ version: 0.3.6
5
5
  platform: ruby
6
6
  authors:
7
7
  - Eran Peer
8
8
  autorequire:
9
9
  bindir: exe
10
10
  cert_chain: []
11
- date: 2018-11-26 00:00:00.000000000 Z
11
+ date: 2019-04-09 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: bundler
15
15
  requirement: !ruby/object:Gem::Requirement
16
16
  requirements:
17
- - - "~>"
17
+ - - ">="
18
18
  - !ruby/object:Gem::Version
19
19
  version: '1.16'
20
- - - ">="
20
+ - - "~>"
21
21
  - !ruby/object:Gem::Version
22
22
  version: '1.16'
23
23
  type: :development
24
24
  prerelease: false
25
25
  version_requirements: !ruby/object:Gem::Requirement
26
26
  requirements:
27
- - - "~>"
27
+ - - ">="
28
28
  - !ruby/object:Gem::Version
29
29
  version: '1.16'
30
- - - ">="
30
+ - - "~>"
31
31
  - !ruby/object:Gem::Version
32
32
  version: '1.16'
33
33
  - !ruby/object:Gem::Dependency
34
34
  name: rake
35
35
  requirement: !ruby/object:Gem::Requirement
36
36
  requirements:
37
- - - "~>"
37
+ - - ">="
38
38
  - !ruby/object:Gem::Version
39
39
  version: '10.0'
40
- - - ">="
40
+ - - "~>"
41
41
  - !ruby/object:Gem::Version
42
42
  version: '10.0'
43
43
  type: :development
44
44
  prerelease: false
45
45
  version_requirements: !ruby/object:Gem::Requirement
46
46
  requirements:
47
- - - "~>"
47
+ - - ">="
48
48
  - !ruby/object:Gem::Version
49
49
  version: '10.0'
50
- - - ">="
50
+ - - "~>"
51
51
  - !ruby/object:Gem::Version
52
52
  version: '10.0'
53
53
  - !ruby/object:Gem::Dependency
54
54
  name: rspec-rails
55
55
  requirement: !ruby/object:Gem::Requirement
56
56
  requirements:
57
- - - "~>"
57
+ - - ">="
58
58
  - !ruby/object:Gem::Version
59
59
  version: '3.7'
60
- - - ">="
60
+ - - "~>"
61
61
  - !ruby/object:Gem::Version
62
62
  version: '3.7'
63
63
  type: :development
64
64
  prerelease: false
65
65
  version_requirements: !ruby/object:Gem::Requirement
66
66
  requirements:
67
- - - "~>"
67
+ - - ">="
68
68
  - !ruby/object:Gem::Version
69
69
  version: '3.7'
70
- - - ">="
70
+ - - "~>"
71
71
  - !ruby/object:Gem::Version
72
72
  version: '3.7'
73
73
  - !ruby/object:Gem::Dependency
74
74
  name: factory_bot_rails
75
75
  requirement: !ruby/object:Gem::Requirement
76
76
  requirements:
77
- - - "~>"
77
+ - - ">="
78
78
  - !ruby/object:Gem::Version
79
79
  version: 4.10.0
80
- - - ">="
80
+ - - "~>"
81
81
  - !ruby/object:Gem::Version
82
82
  version: 4.10.0
83
83
  type: :development
84
84
  prerelease: false
85
85
  version_requirements: !ruby/object:Gem::Requirement
86
86
  requirements:
87
- - - "~>"
87
+ - - ">="
88
88
  - !ruby/object:Gem::Version
89
89
  version: 4.10.0
90
- - - ">="
90
+ - - "~>"
91
91
  - !ruby/object:Gem::Version
92
92
  version: 4.10.0
93
93
  - !ruby/object:Gem::Dependency
94
94
  name: action-cable-testing
95
95
  requirement: !ruby/object:Gem::Requirement
96
96
  requirements:
97
- - - "~>"
97
+ - - ">="
98
98
  - !ruby/object:Gem::Version
99
99
  version: 0.3.1
100
- - - ">="
100
+ - - "~>"
101
101
  - !ruby/object:Gem::Version
102
102
  version: 0.3.1
103
103
  type: :development
104
104
  prerelease: false
105
105
  version_requirements: !ruby/object:Gem::Requirement
106
106
  requirements:
107
- - - "~>"
107
+ - - ">="
108
108
  - !ruby/object:Gem::Version
109
109
  version: 0.3.1
110
- - - ">="
110
+ - - "~>"
111
111
  - !ruby/object:Gem::Version
112
112
  version: 0.3.1
113
113
  - !ruby/object:Gem::Dependency
114
114
  name: coveralls
115
115
  requirement: !ruby/object:Gem::Requirement
116
116
  requirements:
117
- - - "~>"
117
+ - - ">="
118
118
  - !ruby/object:Gem::Version
119
119
  version: 0.8.21
120
- - - ">="
120
+ - - "~>"
121
121
  - !ruby/object:Gem::Version
122
122
  version: 0.8.21
123
123
  type: :development
124
124
  prerelease: false
125
125
  version_requirements: !ruby/object:Gem::Requirement
126
126
  requirements:
127
- - - "~>"
127
+ - - ">="
128
128
  - !ruby/object:Gem::Version
129
129
  version: 0.8.21
130
- - - ">="
130
+ - - "~>"
131
131
  - !ruby/object:Gem::Version
132
132
  version: 0.8.21
133
133
  - !ruby/object:Gem::Dependency
134
134
  name: pry-rails
135
135
  requirement: !ruby/object:Gem::Requirement
136
136
  requirements:
137
- - - "~>"
137
+ - - ">="
138
138
  - !ruby/object:Gem::Version
139
139
  version: 0.3.6
140
- - - ">="
140
+ - - "~>"
141
141
  - !ruby/object:Gem::Version
142
142
  version: 0.3.6
143
143
  type: :development
144
144
  prerelease: false
145
145
  version_requirements: !ruby/object:Gem::Requirement
146
146
  requirements:
147
- - - "~>"
147
+ - - ">="
148
148
  - !ruby/object:Gem::Version
149
149
  version: 0.3.6
150
- - - ">="
150
+ - - "~>"
151
151
  - !ruby/object:Gem::Version
152
152
  version: 0.3.6
153
153
  - !ruby/object:Gem::Dependency
@@ -160,7 +160,7 @@ dependencies:
160
160
  - - ">="
161
161
  - !ruby/object:Gem::Version
162
162
  version: 4.0.1
163
- type: :runtime
163
+ type: :development
164
164
  prerelease: false
165
165
  version_requirements: !ruby/object:Gem::Requirement
166
166
  requirements:
@@ -174,42 +174,42 @@ dependencies:
174
174
  name: rails
175
175
  requirement: !ruby/object:Gem::Requirement
176
176
  requirements:
177
- - - "~>"
178
- - !ruby/object:Gem::Version
179
- version: '5.2'
180
177
  - - ">="
181
178
  - !ruby/object:Gem::Version
182
179
  version: 5.2.0
183
- type: :runtime
184
- prerelease: false
185
- version_requirements: !ruby/object:Gem::Requirement
186
- requirements:
187
180
  - - "~>"
188
181
  - !ruby/object:Gem::Version
189
182
  version: '5.2'
183
+ type: :development
184
+ prerelease: false
185
+ version_requirements: !ruby/object:Gem::Requirement
186
+ requirements:
190
187
  - - ">="
191
188
  - !ruby/object:Gem::Version
192
189
  version: 5.2.0
190
+ - - "~>"
191
+ - !ruby/object:Gem::Version
192
+ version: '5.2'
193
193
  - !ruby/object:Gem::Dependency
194
194
  name: railties
195
195
  requirement: !ruby/object:Gem::Requirement
196
196
  requirements:
197
- - - "~>"
198
- - !ruby/object:Gem::Version
199
- version: '5.2'
200
197
  - - ">="
201
198
  - !ruby/object:Gem::Version
202
199
  version: 5.2.0
203
- type: :runtime
204
- prerelease: false
205
- version_requirements: !ruby/object:Gem::Requirement
206
- requirements:
207
200
  - - "~>"
208
201
  - !ruby/object:Gem::Version
209
202
  version: '5.2'
203
+ type: :development
204
+ prerelease: false
205
+ version_requirements: !ruby/object:Gem::Requirement
206
+ requirements:
210
207
  - - ">="
211
208
  - !ruby/object:Gem::Version
212
209
  version: 5.2.0
210
+ - - "~>"
211
+ - !ruby/object:Gem::Version
212
+ version: '5.2'
213
213
  description:
214
214
  email:
215
215
  - eran.peer79@gmail.com
@@ -272,8 +272,7 @@ required_rubygems_version: !ruby/object:Gem::Requirement
272
272
  - !ruby/object:Gem::Version
273
273
  version: '0'
274
274
  requirements: []
275
- rubyforge_project:
276
- rubygems_version: 2.7.6
275
+ rubygems_version: 3.0.3
277
276
  signing_key:
278
277
  specification_version: 4
279
278
  summary: Fie is a Rails-centric frontend framework running over a permanent WebSocket