ffi-gphoto2 0.7.1 → 0.8.0

This diff has not been reviewed by any users.
Log in in order to be able to vote.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
- SHA1:
3
- metadata.gz: e50a9e04b06cdc18cead6f92baf437f56e628a94
4
- data.tar.gz: bc8c67ce83a6267570067d89b538fc9df71c0199
2
+ SHA256:
3
+ metadata.gz: 705f84af5e6252107a78d9f76cefe51f3d1f9933c6e48b07ce21b7d507db2841
4
+ data.tar.gz: 3691c97cfc7551b30d3d4aff35cb7c33b5c09d28d81bb073a86210923814fa32
5
5
  SHA512:
6
- metadata.gz: 4e0f1540910f52a7a5dc6c46ee6c405d234214d35ecfa222803a2afaef3ca4496df10fa4aa11337763073f8bc9406ae0e95d02869fff04158f85b43e86ddb6f3
7
- data.tar.gz: ade4bf305c186c0e515b573b3ccd1ff87d5c9bab769fa7a8e5ea03394ec5cf600430e322c81e970792702bc4924d8179b7b3f88ea9dd1fb5d31cb2523c4b7688
6
+ metadata.gz: 792e487489753ac550cdbe27330c67aa2b522263ed8632a18fbfa44076e0dddadc44c201ef8c9cfdd1524c2338705760b11d576856d2fd4d266f9f02606a2f32
7
+ data.tar.gz: 276768da7221b07894b389081af32849cb36b926df2e2961a41381391a6fc4311df4d0842b0a4045e56ad7defff4c8366a551e7b65d95d3f9b1567e62780994a
@@ -2,6 +2,13 @@
2
2
 
3
3
  ## HEAD
4
4
 
5
+ ## 0.8.0 (2020-06-29)
6
+
7
+ * [FIX] Fix deprecation warning (`warning: rb_safe_level will be removed in
8
+ Ruby 3.0`) by updating to ffi 1.12.0.
9
+ * [CHANGE] Raise minimum Ruby version to 2.0.0, which comes from the dependency
10
+ on ffi 1.12.0 (specifically 1.11.1).
11
+
5
12
  ## 0.7.1 (2017-01-02)
6
13
 
7
14
  * [FIX] Load `ffi` before any usage of the bindings.
data/README.md CHANGED
@@ -12,7 +12,7 @@ idiomatic Ruby way.
12
12
 
13
13
  ### Prerequisites
14
14
 
15
- * Ruby >= 1.9
15
+ * Ruby >= 2.0
16
16
  * libgphoto2 >= 2.5.2
17
17
  * libgphoto2_port >= 0.10.1
18
18
 
@@ -21,12 +21,12 @@ Gem::Specification.new do |spec|
21
21
 
22
22
  spec.requirements << 'libgphoto2 >= 2.5.2'
23
23
  spec.requirements << 'libgphoto2_port >= 0.10.1'
24
- spec.required_ruby_version = '>= 1.9'
24
+ spec.required_ruby_version = '>= 2.0'
25
25
 
26
- spec.add_development_dependency 'bundler', '~> 1.3'
27
- spec.add_development_dependency 'rake', '~> 12.0'
28
- spec.add_development_dependency 'rspec', '~> 3.5.0'
26
+ spec.add_development_dependency 'bundler', '~> 2.0'
27
+ spec.add_development_dependency 'rake', '~> 13.0'
28
+ spec.add_development_dependency 'rspec', '~> 3.9.0'
29
29
  spec.add_development_dependency 'yard', '~> 0.9.0'
30
30
 
31
- spec.add_dependency 'ffi', '~> 1.9.0'
31
+ spec.add_dependency 'ffi', '~> 1.12.0'
32
32
  end
@@ -1,3 +1,3 @@
1
1
  module GPhoto2
2
- VERSION = '0.7.1'
2
+ VERSION = '0.8.0'
3
3
  end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: ffi-gphoto2
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.7.1
4
+ version: 0.8.0
5
5
  platform: ruby
6
6
  authors:
7
7
  - Michael Macias
8
- autorequire:
8
+ autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2017-01-02 00:00:00.000000000 Z
11
+ date: 2020-06-30 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: bundler
@@ -16,42 +16,42 @@ dependencies:
16
16
  requirements:
17
17
  - - "~>"
18
18
  - !ruby/object:Gem::Version
19
- version: '1.3'
19
+ version: '2.0'
20
20
  type: :development
21
21
  prerelease: false
22
22
  version_requirements: !ruby/object:Gem::Requirement
23
23
  requirements:
24
24
  - - "~>"
25
25
  - !ruby/object:Gem::Version
26
- version: '1.3'
26
+ version: '2.0'
27
27
  - !ruby/object:Gem::Dependency
28
28
  name: rake
29
29
  requirement: !ruby/object:Gem::Requirement
30
30
  requirements:
31
31
  - - "~>"
32
32
  - !ruby/object:Gem::Version
33
- version: '12.0'
33
+ version: '13.0'
34
34
  type: :development
35
35
  prerelease: false
36
36
  version_requirements: !ruby/object:Gem::Requirement
37
37
  requirements:
38
38
  - - "~>"
39
39
  - !ruby/object:Gem::Version
40
- version: '12.0'
40
+ version: '13.0'
41
41
  - !ruby/object:Gem::Dependency
42
42
  name: rspec
43
43
  requirement: !ruby/object:Gem::Requirement
44
44
  requirements:
45
45
  - - "~>"
46
46
  - !ruby/object:Gem::Version
47
- version: 3.5.0
47
+ version: 3.9.0
48
48
  type: :development
49
49
  prerelease: false
50
50
  version_requirements: !ruby/object:Gem::Requirement
51
51
  requirements:
52
52
  - - "~>"
53
53
  - !ruby/object:Gem::Version
54
- version: 3.5.0
54
+ version: 3.9.0
55
55
  - !ruby/object:Gem::Dependency
56
56
  name: yard
57
57
  requirement: !ruby/object:Gem::Requirement
@@ -72,15 +72,15 @@ dependencies:
72
72
  requirements:
73
73
  - - "~>"
74
74
  - !ruby/object:Gem::Version
75
- version: 1.9.0
75
+ version: 1.12.0
76
76
  type: :runtime
77
77
  prerelease: false
78
78
  version_requirements: !ruby/object:Gem::Requirement
79
79
  requirements:
80
80
  - - "~>"
81
81
  - !ruby/object:Gem::Version
82
- version: 1.9.0
83
- description:
82
+ version: 1.12.0
83
+ description:
84
84
  email:
85
85
  - zaeleus@gmail.com
86
86
  executables: []
@@ -205,7 +205,7 @@ homepage: https://github.com/zaeleus/ffi-gphoto2
205
205
  licenses:
206
206
  - MIT
207
207
  metadata: {}
208
- post_install_message:
208
+ post_install_message:
209
209
  rdoc_options: []
210
210
  require_paths:
211
211
  - lib
@@ -213,7 +213,7 @@ required_ruby_version: !ruby/object:Gem::Requirement
213
213
  requirements:
214
214
  - - ">="
215
215
  - !ruby/object:Gem::Version
216
- version: '1.9'
216
+ version: '2.0'
217
217
  required_rubygems_version: !ruby/object:Gem::Requirement
218
218
  requirements:
219
219
  - - ">="
@@ -222,9 +222,8 @@ required_rubygems_version: !ruby/object:Gem::Requirement
222
222
  requirements:
223
223
  - libgphoto2 >= 2.5.2
224
224
  - libgphoto2_port >= 0.10.1
225
- rubyforge_project:
226
- rubygems_version: 2.6.8
227
- signing_key:
225
+ rubygems_version: 3.1.2
226
+ signing_key:
228
227
  specification_version: 4
229
228
  summary: A Ruby FFI for common functions in libgphoto2
230
229
  test_files: