dependency_spy 0.3.0 → 0.4.0

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA1:
3
- metadata.gz: 0bd2e870a6e0baec4974d3d1eb6603c73b2d40cd
4
- data.tar.gz: c07f0e46d2954d97a1787cc06355a97a465a2c64
3
+ metadata.gz: 16078b623716d608f5f7fb741a51a562d82040ad
4
+ data.tar.gz: 4755ef13efb4b61b8c41fa922c0f2f54bc49996a
5
5
  SHA512:
6
- metadata.gz: b8b3607be32c792bc9457a5c67fb539cbbacdfbffd09283c0aacff793c484be82f546ab88d5c6ef4bf23989b2eb47a86e85829e21abf169b6d70ffeedfececda
7
- data.tar.gz: f9fe9f2185c0dc51514632c4a6b9cd1c2449dd517f369cfc77d5541e00bb2b4fa67f7e464f8db852ed0c984eea49a5283072fdd2ea33e193ba5cbc185854ae42
6
+ metadata.gz: 4c4925e93f08abb65e60cdaabb8de172392db41ae873086379855e9fccde899387795f4fcc11c30e6dbc2a8b9cf289c9ba1c550b5cbc32194b096efa6daa83a4
7
+ data.tar.gz: bc7aa3c3ae1f8a08b77fcd51927a7160de671b9e64484f27fe4b24dc3c82f7d4e8d054e317b92cc81a3e890e2eb9e773eeab6f430011fd5e1f11dc7d0363394a
@@ -8,17 +8,15 @@ jobs:
8
8
  steps:
9
9
  - checkout
10
10
 
11
- - name: Install Bundler Version
12
- type: shell
13
- command: gem install bundler -v 1.16
14
-
15
11
  - name: Restore cache
16
12
  type: cache-restore
17
13
  key: yavdb-{{ checksum "Gemfile.lock" }}
18
14
 
19
15
  - name: Bundle Install
20
16
  type: shell
21
- command: bundle install --path /tmp/vendor/bundle
17
+ command: |
18
+ sudo gem update --system
19
+ bundle install --path /tmp/vendor/bundle
22
20
 
23
21
  - name: Save cache
24
22
  type: cache-save
@@ -1,12 +1,12 @@
1
1
  PATH
2
2
  remote: .
3
3
  specs:
4
- dependency_spy (0.3.0)
4
+ dependency_spy (0.4.0)
5
5
  bibliothecary (~> 6.3)
6
6
  colorize (~> 0.8.1)
7
7
  semantic_range (~> 2.1)
8
8
  thor (~> 0.20)
9
- yavdb (~> 0.4)
9
+ yavdb (~> 0.5)
10
10
 
11
11
  GEM
12
12
  remote: https://rubygems.org/
@@ -30,24 +30,27 @@ GEM
30
30
  deb_control (0.0.1)
31
31
  diff-lcs (1.3)
32
32
  docile (1.3.1)
33
- ethon (0.11.0)
33
+ ethon (0.12.0)
34
34
  ffi (>= 1.3.0)
35
- ffi (1.9.25)
36
- highline (2.0.0)
37
- jaro_winkler (1.5.1)
35
+ execjs (2.7.0)
36
+ ffi (1.10.0)
37
+ highline (2.0.1)
38
+ jaro_winkler (1.5.2)
38
39
  json (2.1.0)
39
40
  kramdown (1.17.0)
40
41
  librariesio-gem-parser (1.0.0)
42
+ libv8 (3.16.14.19)
41
43
  oga (2.15)
42
44
  ast
43
45
  ruby-ll (~> 2.1)
44
46
  ox (2.10.0)
45
- parallel (1.12.1)
46
- parser (2.5.1.2)
47
+ parallel (1.13.0)
48
+ parser (2.6.0.0)
47
49
  ast (~> 2.4.0)
48
50
  powerpack (0.1.2)
49
51
  rainbow (3.0.0)
50
- rake (12.3.1)
52
+ rake (12.3.2)
53
+ ref (2.0.0)
51
54
  rspec (3.8.0)
52
55
  rspec-core (~> 3.8.0)
53
56
  rspec-expectations (~> 3.8.0)
@@ -63,7 +66,7 @@ GEM
63
66
  diff-lcs (>= 1.2.0, < 2.0)
64
67
  rspec-support (~> 3.8.0)
65
68
  rspec-support (3.8.0)
66
- rubocop (0.60.0)
69
+ rubocop (0.64.0)
67
70
  jaro_winkler (~> 1.5.1)
68
71
  parallel (~> 1.10)
69
72
  parser (>= 2.5, != 2.5.1.1)
@@ -71,8 +74,8 @@ GEM
71
74
  rainbow (>= 2.2.2, < 4.0)
72
75
  ruby-progressbar (~> 1.7)
73
76
  unicode-display_width (~> 1.4.0)
74
- rubocop-rspec (1.30.0)
75
- rubocop (>= 0.58.0)
77
+ rubocop-rspec (1.32.0)
78
+ rubocop (>= 0.60.0)
76
79
  ruby-ll (2.1.2)
77
80
  ansi
78
81
  ast
@@ -85,24 +88,29 @@ GEM
85
88
  json (>= 1.8, < 3)
86
89
  simplecov-html (~> 0.10.0)
87
90
  simplecov-html (0.10.2)
88
- thor (0.20.0)
91
+ therubyracer (0.12.3)
92
+ libv8 (~> 3.16.14.15)
93
+ ref
94
+ thor (0.20.3)
89
95
  toml-rb (1.1.2)
90
96
  citrus (~> 3.0, > 3.0)
91
- typhoeus (1.3.0)
97
+ typhoeus (1.3.1)
92
98
  ethon (>= 0.9.0)
93
- unicode-display_width (1.4.0)
94
- yavdb (0.4.1)
99
+ unicode-display_width (1.4.1)
100
+ yavdb (0.5.0)
101
+ execjs (~> 2.7.0)
95
102
  json (~> 2.1)
96
103
  kramdown (~> 1.17)
97
104
  oga (~> 2.15)
98
105
  semantic_interval (~> 0.1)
106
+ therubyracer (~> 0.12)
99
107
  thor (~> 0.20)
108
+ toml-rb (~> 1.1)
100
109
 
101
110
  PLATFORMS
102
111
  ruby
103
112
 
104
113
  DEPENDENCIES
105
- bundler (~> 1.16)
106
114
  codacy-coverage
107
115
  dependency_spy!
108
116
  rake (~> 12.3)
@@ -113,4 +121,4 @@ DEPENDENCIES
113
121
  simplecov
114
122
 
115
123
  BUNDLED WITH
116
- 1.16.6
124
+ 1.17.3
data/README.md CHANGED
@@ -26,11 +26,11 @@ Use as a complement to other tools at your own risk.
26
26
  * Packagist
27
27
  * Pypi
28
28
  * Go
29
+ * Cargo
29
30
 
30
31
  ## Prerequisites
31
32
 
32
33
  * Ruby 2.3 or newer
33
- * Bundler `gem install bundler`
34
34
 
35
35
  ## Installation
36
36
 
@@ -23,7 +23,6 @@ Gem::Specification.new do |spec|
23
23
  spec.required_ruby_version = '>= 2.3.7'
24
24
 
25
25
  # Development
26
- spec.add_development_dependency 'bundler', ['~> 1.16']
27
26
  spec.add_development_dependency 'codacy-coverage'
28
27
  spec.add_development_dependency 'rake', ['~> 12.3']
29
28
  spec.add_development_dependency 'rspec', ['~> 3.8']
@@ -39,5 +38,5 @@ Gem::Specification.new do |spec|
39
38
  spec.add_runtime_dependency 'colorize', ['~> 0.8.1']
40
39
  spec.add_runtime_dependency 'semantic_range', ['~> 2.1']
41
40
  spec.add_runtime_dependency 'thor', ['~> 0.20']
42
- spec.add_runtime_dependency 'yavdb', ['~> 0.4']
41
+ spec.add_runtime_dependency 'yavdb', ['~> 0.5']
43
42
  end
@@ -16,6 +16,6 @@
16
16
 
17
17
  module DependencySpy
18
18
 
19
- VERSION = '0.3.0'
19
+ VERSION = '0.4.0'
20
20
 
21
21
  end
metadata CHANGED
@@ -1,29 +1,15 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: dependency_spy
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.3.0
4
+ version: 0.4.0
5
5
  platform: ruby
6
6
  authors:
7
7
  - Rodrigo Fernandes
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2018-10-28 00:00:00.000000000 Z
11
+ date: 2019-02-17 00:00:00.000000000 Z
12
12
  dependencies:
13
- - !ruby/object:Gem::Dependency
14
- name: bundler
15
- requirement: !ruby/object:Gem::Requirement
16
- requirements:
17
- - - "~>"
18
- - !ruby/object:Gem::Version
19
- version: '1.16'
20
- type: :development
21
- prerelease: false
22
- version_requirements: !ruby/object:Gem::Requirement
23
- requirements:
24
- - - "~>"
25
- - !ruby/object:Gem::Version
26
- version: '1.16'
27
13
  - !ruby/object:Gem::Dependency
28
14
  name: codacy-coverage
29
15
  requirement: !ruby/object:Gem::Requirement
@@ -184,14 +170,14 @@ dependencies:
184
170
  requirements:
185
171
  - - "~>"
186
172
  - !ruby/object:Gem::Version
187
- version: '0.4'
173
+ version: '0.5'
188
174
  type: :runtime
189
175
  prerelease: false
190
176
  version_requirements: !ruby/object:Gem::Requirement
191
177
  requirements:
192
178
  - - "~>"
193
179
  - !ruby/object:Gem::Version
194
- version: '0.4'
180
+ version: '0.5'
195
181
  description: "\n Finds known vulnerabilities in your dependencies\n Using rubysec/ruby-advisory-db,
196
182
  snyk.io, ossindex.net, nodesecurity.io\n "
197
183
  email: