chrono_logger 1.1.0 → 1.1.1

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA1:
3
- metadata.gz: 319032cdafb0eafdaf8988a638704e5b9a34dfeb
4
- data.tar.gz: d5583282916fa7104affcea80620c993f5ba0deb
3
+ metadata.gz: 97bed9c7ad6f06d08927b617a1d7b75f2e95aa55
4
+ data.tar.gz: 8276b26110368c35b54b2ea1eaf12bdd073034a8
5
5
  SHA512:
6
- metadata.gz: 807e591c9ea27e1c046e761ab61214112246a99a98e9bf9ad9567d917fadc244c89cda1acd6c40506d1a3d224368fe3dbe9886b26fba0566e2e4422de509cce1
7
- data.tar.gz: c2f93bd2d7946e787c0f3a815b67151c7473ba20f16704b0b0869d023cb5e0ddd5591eab7d5040ec87676adda1b3dfdda443e8d12fbc78261dc70031af6310f1
6
+ metadata.gz: c2c29589a695f8bb9657803e44d307939c7affe75a2f2d153a1903eef0ef41705f014a4ddb319d117484017bd50b28cfabfe2d5da4f190bfa1a030a32d499535
7
+ data.tar.gz: 8d0524b4bfb8a4b6228cf9ce1b93e9755e33911692e9de42759baa2908a7a5ff4561a97e1e6cca9090c749672e4e868c00dfcff771c201c63541629b8122d00d
@@ -3,5 +3,6 @@ rvm:
3
3
  - 2.0.0-p598
4
4
  - 2.1.5
5
5
  - 2.2.0
6
+ - 2.3.0
6
7
  sudo: false
7
8
  cache: bundler
@@ -55,7 +55,12 @@ class ChronoLogger < Logger
55
55
 
56
56
  def initialize(log = nil, opt = {})
57
57
  @dev = @filename = nil
58
- @mutex = LogDeviceMutex.new
58
+ if defined?(LogDeviceMutex) # Ruby < 2.3
59
+ @mutex = LogDeviceMutex.new
60
+ else
61
+ mon_initialize
62
+ @mutex = self
63
+ end
59
64
  if log.respond_to?(:write) and log.respond_to?(:close)
60
65
  @dev = log
61
66
  else
@@ -1,5 +1,5 @@
1
1
  require 'logger'
2
2
 
3
3
  class ChronoLogger < Logger
4
- VERSION = "1.1.0"
4
+ VERSION = "1.1.1"
5
5
  end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: chrono_logger
3
3
  version: !ruby/object:Gem::Version
4
- version: 1.1.0
4
+ version: 1.1.1
5
5
  platform: ruby
6
6
  authors:
7
7
  - Takayuki Matsubara
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2015-08-17 00:00:00.000000000 Z
11
+ date: 2016-04-21 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: bundler