active_record_tweaks 0.2.2 → 0.2.3

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA1:
3
- metadata.gz: 907dc18ab4a4346c68db08ad648bfdd095ca199d
4
- data.tar.gz: 6c3f9dc0d9db503dd1d3c717c9dbe5e9579f0e99
3
+ metadata.gz: 4181ff6d4814848df11ead048c223a27a82bb6a4
4
+ data.tar.gz: a99fc30f8a1e229dfd492de2fb4e4e16b8e4c804
5
5
  SHA512:
6
- metadata.gz: d5d69618eb731fa67eccce64b0c04e4bc84d4a349ae316064a7812a4959f66c3081468444c60452aa4b1562933bca0e5ffb36785c87bab227bc84da4bc91d54c
7
- data.tar.gz: 9a0aa4c7a1bce4c486cc5b778e55cf5220c62a6d00e92ee9a51e86c5332f83b1f929d84b22bdd0ff49ea8a7a8f339ae35d73e9d3ffacdbfafc26c0eeb9c052f5
6
+ metadata.gz: 5148b9e28d8cdefaf8c83f4274dae441080c37146a0c8cb01c92d1b8a3e4fe7f076a1f25885c9584d2aa64d45b129b7e696634266c6614d49a15e7d40da5dcb6
7
+ data.tar.gz: c20d4889caf5ce0d95e3d6d989b46724549e4b03366545d251c5f3cf525fa1e357745fbd182bbd8240865b8706d7212b29ff69a3d331ed626937b8bac57859de
@@ -5,21 +5,21 @@ language: ruby
5
5
  cache:
6
6
  - bundler
7
7
  rvm:
8
- - 2.1.10
9
8
  - 2.2.6
10
9
  - 2.3.3
10
+ - 2.4.1
11
11
  - ruby-head
12
12
  gemfile:
13
- - gemfiles/rails_4_0.gemfile
14
- - gemfiles/rails_4_1.gemfile
15
13
  - gemfiles/rails_4_2.gemfile
14
+ - gemfiles/rails_5_0.gemfile
15
+ - gemfiles/rails_5_1.gemfile
16
16
  matrix:
17
17
  fast_finish: true
18
18
  allow_failures:
19
19
  - rvm: ruby-head
20
20
  include:
21
+ - rvm: 2.2.6
22
+ gemfile: gemfiles/rails_4_1.gemfile
21
23
  - rvm: 2.3.3
22
- gemfile: gemfiles/rails_5_0.gemfile
23
- - rvm: ruby-head
24
- gemfile: gemfiles/rails_5_0.gemfile
24
+ gemfile: gemfiles/rails_4_1.gemfile
25
25
 
data/Appraisals CHANGED
@@ -1,12 +1,4 @@
1
1
 
2
- appraise "rails_4_0" do
3
- version = "~> 4.0.12"
4
- gem "activesupport", version
5
- gem "actionpack", version
6
- gem "activerecord", version
7
- gem "railties", version
8
- end
9
-
10
2
  appraise "rails_4_1" do
11
3
  version = "~> 4.1.8"
12
4
  gem "activesupport", version
@@ -30,3 +22,11 @@ appraise "rails_5_0" do
30
22
  gem "activerecord", version
31
23
  gem "railties", version
32
24
  end
25
+
26
+ appraise "rails_5_1" do
27
+ version = "~> 5.1.0"
28
+ gem "activesupport", version
29
+ gem "actionpack", version
30
+ gem "activerecord", version
31
+ gem "railties", version
32
+ end
@@ -18,6 +18,15 @@ This project adheres to [Semantic Versioning](http://semver.org/).
18
18
  - Nothing
19
19
 
20
20
 
21
+ ## [0.2.3] - 2017-05-11
22
+
23
+ ### Changed
24
+
25
+ - Add support for AR 5.1.x
26
+ - Drop support for AR 4.0.x
27
+ - Drop support for Ruby < 2.2
28
+
29
+
21
30
  ## [0.2.2] - 2016-12-23
22
31
 
23
32
  ### Changed
@@ -51,7 +60,8 @@ This project adheres to [Semantic Versioning](http://semver.org/).
51
60
  - Initial Release
52
61
 
53
62
 
54
- [Unreleased]: https://github.com/AssetSync/asset_sync/compare/v0.2.2...HEAD
63
+ [Unreleased]: https://github.com/AssetSync/asset_sync/compare/v0.2.3...HEAD
64
+ [0.2.3]: https://github.com/AssetSync/asset_sync/compare/v0.2.2...v0.2.3
55
65
  [0.2.2]: https://github.com/AssetSync/asset_sync/compare/v0.2.1...v0.2.2
56
66
  [0.2.1]: https://github.com/AssetSync/asset_sync/compare/v0.2.0...v0.2.1
57
67
  [0.2.0]: https://github.com/AssetSync/asset_sync/compare/v0.1...v0.2.0
@@ -27,10 +27,10 @@ Gem::Specification.new do |s|
27
27
  s.executables = `git ls-files -- bin/*`.split("\n").map { |f| File.basename(f) }
28
28
  s.require_paths = ["lib"]
29
29
 
30
- s.add_dependency "activerecord", ">= 4.0.0", "< 5.1.0"
30
+ s.add_dependency "activerecord", ">= 4.1.0", "< 6.0.0"
31
31
 
32
32
  s.add_development_dependency "bundler", ">= 1.0.0"
33
- s.add_development_dependency "rake", "~> 10.0"
33
+ s.add_development_dependency "rake", ">= 10.0", "<= 13.0"
34
34
  s.add_development_dependency "appraisal", "~> 2.0"
35
35
  s.add_development_dependency "rspec", "~> 3.0"
36
36
  s.add_development_dependency "rspec-its", "~> 1.0"
@@ -41,7 +41,7 @@ Gem::Specification.new do |s|
41
41
  s.add_development_dependency "timecop", ">= 0.7.1"
42
42
  s.add_development_dependency "rubocop", "~> 0.30"
43
43
 
44
- s.required_ruby_version = ">= 2.1.0"
44
+ s.required_ruby_version = ">= 2.2.0"
45
45
 
46
46
  s.required_rubygems_version = ">= 1.4.0"
47
47
  end
@@ -0,0 +1,2 @@
1
+ ---
2
+ BUNDLE_RETRY: "1"
@@ -7,4 +7,4 @@ gem "actionpack", "~> 4.1.8"
7
7
  gem "activerecord", "~> 4.1.8"
8
8
  gem "railties", "~> 4.1.8"
9
9
 
10
- gemspec :path => "../"
10
+ gemspec path: "../"
@@ -7,4 +7,4 @@ gem "actionpack", "~> 4.2.0"
7
7
  gem "activerecord", "~> 4.2.0"
8
8
  gem "railties", "~> 4.2.0"
9
9
 
10
- gemspec :path => "../"
10
+ gemspec path: "../"
@@ -7,4 +7,4 @@ gem "actionpack", "~> 5.0.0"
7
7
  gem "activerecord", "~> 5.0.0"
8
8
  gem "railties", "~> 5.0.0"
9
9
 
10
- gemspec :path => "../"
10
+ gemspec path: "../"
@@ -0,0 +1,10 @@
1
+ # This file was generated by Appraisal
2
+
3
+ source "https://rubygems.org"
4
+
5
+ gem "activesupport", "~> 5.1.0"
6
+ gem "actionpack", "~> 5.1.0"
7
+ gem "activerecord", "~> 5.1.0"
8
+ gem "railties", "~> 5.1.0"
9
+
10
+ gemspec path: "../"
@@ -61,9 +61,15 @@ module ActiveRecordTweaks
61
61
  end
62
62
 
63
63
  module ClassMethods
64
- # rubocop:disable all
65
- warn "[DEPRECATION] `ActiveRecordTweaks::Integration::ClassMethods` is deprecated without replacement. Please read README in project for details."
66
- # rubocop:enable all
64
+ def self.extended(_base)
65
+ # rubocop:disable all
66
+ warn ([
67
+ "[DEPRECATION]",
68
+ "`ActiveRecordTweaks::Integration::ClassMethods` is deprecated without replacement.",
69
+ "Please read README in project for details."
70
+ ].join(" "))
71
+ # rubocop:enable all
72
+ end
67
73
 
68
74
  # Returns a cache key for the ActiveRecord class based
69
75
  # based on count and maximum value of update timestamp columns
@@ -1,5 +1,5 @@
1
1
  module ActiveRecordTweaks
2
- VERSION = "0.2.2".freeze
2
+ VERSION = "0.2.3".freeze
3
3
 
4
4
  def self.version
5
5
  Gem::Version.new(VERSION)
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: active_record_tweaks
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.2.2
4
+ version: 0.2.3
5
5
  platform: ruby
6
6
  authors:
7
7
  - PikachuEXE
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2016-12-23 00:00:00.000000000 Z
11
+ date: 2017-05-11 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: activerecord
@@ -16,20 +16,20 @@ dependencies:
16
16
  requirements:
17
17
  - - ">="
18
18
  - !ruby/object:Gem::Version
19
- version: 4.0.0
19
+ version: 4.1.0
20
20
  - - "<"
21
21
  - !ruby/object:Gem::Version
22
- version: 5.1.0
22
+ version: 6.0.0
23
23
  type: :runtime
24
24
  prerelease: false
25
25
  version_requirements: !ruby/object:Gem::Requirement
26
26
  requirements:
27
27
  - - ">="
28
28
  - !ruby/object:Gem::Version
29
- version: 4.0.0
29
+ version: 4.1.0
30
30
  - - "<"
31
31
  - !ruby/object:Gem::Version
32
- version: 5.1.0
32
+ version: 6.0.0
33
33
  - !ruby/object:Gem::Dependency
34
34
  name: bundler
35
35
  requirement: !ruby/object:Gem::Requirement
@@ -48,16 +48,22 @@ dependencies:
48
48
  name: rake
49
49
  requirement: !ruby/object:Gem::Requirement
50
50
  requirements:
51
- - - "~>"
51
+ - - ">="
52
52
  - !ruby/object:Gem::Version
53
53
  version: '10.0'
54
+ - - "<="
55
+ - !ruby/object:Gem::Version
56
+ version: '13.0'
54
57
  type: :development
55
58
  prerelease: false
56
59
  version_requirements: !ruby/object:Gem::Requirement
57
60
  requirements:
58
- - - "~>"
61
+ - - ">="
59
62
  - !ruby/object:Gem::Version
60
63
  version: '10.0'
64
+ - - "<="
65
+ - !ruby/object:Gem::Version
66
+ version: '13.0'
61
67
  - !ruby/object:Gem::Dependency
62
68
  name: appraisal
63
69
  requirement: !ruby/object:Gem::Requirement
@@ -203,10 +209,11 @@ files:
203
209
  - README.md
204
210
  - Rakefile
205
211
  - active_record_tweaks.gemspec
206
- - gemfiles/rails_4_0.gemfile
212
+ - gemfiles/.bundle/config
207
213
  - gemfiles/rails_4_1.gemfile
208
214
  - gemfiles/rails_4_2.gemfile
209
215
  - gemfiles/rails_5_0.gemfile
216
+ - gemfiles/rails_5_1.gemfile
210
217
  - lib/active_record_tweaks.rb
211
218
  - lib/active_record_tweaks/integration.rb
212
219
  - lib/active_record_tweaks/version.rb
@@ -224,7 +231,7 @@ required_ruby_version: !ruby/object:Gem::Requirement
224
231
  requirements:
225
232
  - - ">="
226
233
  - !ruby/object:Gem::Version
227
- version: 2.1.0
234
+ version: 2.2.0
228
235
  required_rubygems_version: !ruby/object:Gem::Requirement
229
236
  requirements:
230
237
  - - ">="
@@ -232,11 +239,10 @@ required_rubygems_version: !ruby/object:Gem::Requirement
232
239
  version: 1.4.0
233
240
  requirements: []
234
241
  rubyforge_project:
235
- rubygems_version: 2.5.2
242
+ rubygems_version: 2.6.12
236
243
  signing_key:
237
244
  specification_version: 4
238
245
  summary: Some Tweaks for ActiveRecord
239
246
  test_files:
240
247
  - spec/active_record_tweaks_spec.rb
241
248
  - spec/spec_helper.rb
242
- has_rdoc:
@@ -1,10 +0,0 @@
1
- # This file was generated by Appraisal
2
-
3
- source "https://rubygems.org"
4
-
5
- gem "activesupport", "~> 4.0.12"
6
- gem "actionpack", "~> 4.0.12"
7
- gem "activerecord", "~> 4.0.12"
8
- gem "railties", "~> 4.0.12"
9
-
10
- gemspec :path => "../"