unicode-age 2.0.1 → 2.1.0

This diff has not been reviewed by any users.
Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: 504a0269e6357104b6ac5ec61ec78cb647b87a0549e3b02cddc31f171a5357d9
4
- data.tar.gz: 68c0f40814a0de9401942cf17d4bc31d880f2e7c993a5ceced24a5f368441a8f
3
+ metadata.gz: 93a659e9c501a1314adde22291a9591574b61ca2e00c198eed3c7be4651b052d
4
+ data.tar.gz: 6cd016b31f50f1e06fa2303d991f51c076d47e71127ac29cb6a637aa89e6c799
5
5
  SHA512:
6
- metadata.gz: 8b153714b4eb5af0aa8f88ee1fbd46f6b732c1feedba06def94edf05f9541c93fa59a165a0f8ebb0e18237e97418310cccd71efb731516fa2aec917d16dfd5d1
7
- data.tar.gz: 91f14e6910f70101bf6b152c54ecbe7846981aeda91ef4d01b21c2812038052143b31df1342486f537b319d6872268876461ce54b566eca22ddc816ecffea286
6
+ metadata.gz: 790e876f048df53e8bce02768de8d3f2b10d18c5022f0c2cd9e9fff55718538e600d769229e658e33da79e3edf1ced274c313a1f952b5947db5cd1ecbfc48e71
7
+ data.tar.gz: eba1a3620908a94f91053c40e9cfc994412c5db5cc35513f4e771f33cde541abb24f3d8cd43e3210e4a51621dd16eabb57739b7aa971a4fe031f0adfd8fa10c0
@@ -4,19 +4,21 @@ language: ruby
4
4
  script: bundle exec ruby spec/unicode_age_spec.rb
5
5
 
6
6
  rvm:
7
- - 2.6.0
8
- - 2.5.3
9
- - 2.4.5
7
+ - 2.6.3
8
+ - 2.6.2
9
+ - 2.6.1
10
+ - 2.5.4
11
+ - 2.4.6
10
12
  - 2.3.8
11
13
  - 2.2
12
14
  - 2.1
13
15
  - ruby-head
14
16
  - jruby-head
15
- - jruby-9.2.5.0
17
+ - jruby-9.2.6.0
16
18
 
17
19
  matrix:
18
20
  allow_failures:
19
21
  - rvm: 2.2
20
22
  - rvm: 2.1
21
23
  - rvm: jruby-head
22
- - rvm: jruby-9.2.5.0
24
+ - rvm: jruby-9.2.6.0
@@ -1,8 +1,12 @@
1
1
  ## CHANGELOG
2
2
 
3
+ ### 2.1.0
4
+
5
+ * Support Unicode 12.0 (Ruby 2.6.2), Unicode 12.1 (Ruby 2.6.3)
6
+
3
7
  ### 2.0.1
4
8
 
5
- * Support Unicode 11 (Ruby 2.6)
9
+ * Support Unicode 11 (Ruby 2.6.1, 2.6.0)
6
10
 
7
11
  ### 2.0.0
8
12
 
data/README.md CHANGED
@@ -23,7 +23,9 @@ Characters of status "Unassigned" (Unicode General Category of **Cn**) will rais
23
23
 
24
24
  Ruby version | Unicode version
25
25
  -------------|----------------
26
- **2.6** | **11.0.0**
26
+ **2.6.3+** | **12.1.0**
27
+ **2.6.2** | **12.0.0**
28
+ **2.6.1-** | **11.0.0**
27
29
  **2.5** | **10.0.0**
28
30
  **2.4** | **9.0.0**
29
31
  **2.3** | **8.0.0**
@@ -25,6 +25,8 @@ module Unicode
25
25
  9.0,
26
26
  10.0,
27
27
  11.0,
28
+ 12.0,
29
+ 12.1,
28
30
  ].freeze
29
31
 
30
32
  KNOWN_UNICODE_REGEXES = KNOWN_UNICODE_VERSIONS.map{ |uv|
@@ -35,7 +37,7 @@ module Unicode
35
37
  }.compact.freeze
36
38
 
37
39
  def self.of(string)
38
- raise(UnknownAge, "The string contains unassigned codepoints, so the Unicode version required cannot be determined. Your Ruby version supports Unicode #{UNICODE_VERSION}.") if string =~ /\A\p{Unassigned}*\z/
40
+ raise(UnknownAge, "The string contains unassigned codepoints, so the Unicode version required cannot be determined. This gem version supports Unicode upto version #{UNICODE_VERSION}.") if string =~ /\A\p{Unassigned}*\z/
39
41
  KNOWN_UNICODE_VERSIONS.find.with_index{ |uv, index|
40
42
  string =~ KNOWN_UNICODE_REGEXES[index]
41
43
  }
@@ -2,8 +2,8 @@
2
2
 
3
3
  module Unicode
4
4
  module Age
5
- VERSION = "2.0.1"
6
- UNICODE_VERSION = "11.0.0"
5
+ VERSION = "2.1.0"
6
+ UNICODE_VERSION = "12.1.0"
7
7
  end
8
8
  end
9
9
 
metadata CHANGED
@@ -1,16 +1,16 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: unicode-age
3
3
  version: !ruby/object:Gem::Version
4
- version: 2.0.1
4
+ version: 2.1.0
5
5
  platform: ruby
6
6
  authors:
7
7
  - Jan Lelis
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2018-12-30 00:00:00.000000000 Z
11
+ date: 2019-04-17 00:00:00.000000000 Z
12
12
  dependencies: []
13
- description: "[Unicode 11.0.0] A micromodule to detect which Unicode version is required
13
+ description: "[Unicode 12.1.0] A micromodule to detect which Unicode version is required
14
14
  to display a string."
15
15
  email:
16
16
  - mail@janlelis.de
@@ -51,7 +51,7 @@ required_rubygems_version: !ruby/object:Gem::Requirement
51
51
  - !ruby/object:Gem::Version
52
52
  version: '0'
53
53
  requirements: []
54
- rubygems_version: 3.0.1
54
+ rubygems_version: 3.0.3
55
55
  signing_key:
56
56
  specification_version: 4
57
57
  summary: Determine required Unicode version of a string.