phcnotifi 13.0.0 → 14.0.0

Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA1:
3
- metadata.gz: 4e90f58ced30d202c886b5fe99b08f3ca8fb5d44
4
- data.tar.gz: 678e6cd5d81cba5187b87d976dbb6527c344d23b
3
+ metadata.gz: a8419976f1f6a26f5528a724ebbfaceabff32fe2
4
+ data.tar.gz: 5214d64bbc85909d0354e18f69332d62b218a786
5
5
  SHA512:
6
- metadata.gz: 046d2f41b8ca270ac1e1ea1267b15571b57de3ec7666e5119b1311daaf553ce8b98729280120da31705e1d95d7dd4dee50eb940caee419cd8e46f31ea06448ab
7
- data.tar.gz: 159e0ab92019d37d0f4d28c4696766165ce9ca70cd249ba934b585bcb8fdff641ccfb0d82a69f3006ff0dad345221649978cf78a4232577bb046f33bca5c688e
6
+ metadata.gz: bfcb371ca749f025bc9ca448cd48ded07e4ac4adc08eb551a79bfefcbffda22bda11852f6e827d73af7f638f67dead4a87511affd08aa687f6ebaeae0e3d3cf0
7
+ data.tar.gz: 900144d2d56f93633ec91ca217859e551a89d850e890d355ae9559c08283ed878fbc6e0989a1b7f7f60c700ac48c9132fc00c772983273dc5a24276a5abfe383
data/README.md CHANGED
@@ -1,18 +1,13 @@
1
- [![security](https://hakiri.io/github/PHCNetworks/phc-notifi/master.svg)](https://hakiri.io/github/PHCNetworks/phc-notifi/master)
2
- [![Code Climate](https://codeclimate.com/github/PHCNetworks/phc-notifi/badges/gpa.svg)](https://codeclimate.com/github/PHCNetworks/phc-notifi)
3
- [![Gem Version](https://badge.fury.io/rb/phcnotifi.svg)](https://badge.fury.io/rb/phcnotifi)
4
- [![License: MIT](https://img.shields.io/badge/License-MIT-blue.svg)](https://github.com/PHCNetworks/phc-notifi/blob/master/MIT-LICENSE)
5
-
6
1
  ### PHC-Notifi for Rails 5.1 (Form Validation & Notification Engine) Documentation
7
2
  PHCNotifi Rails 5.1 engine with helpers for alerts and form validation notifications.
8
3
 
9
- * Add alert and form validation helpers to any project.
4
+ * Add alert and form validation helpers ruby on rails.
10
5
  * Setup in seconds with only one line of code in the application_helper file.
11
6
  * Save time and keep your rails projects manageable, tidy and secure.
12
7
 
13
8
  #### Step 1 - Add PHCNotifi to your gemfile
14
9
 
15
- gem 'phcnotifi', '~> 13.0'
10
+ gem 'phcnotifi', '~> 14.0'
16
11
  bundle install
17
12
 
18
13
  #### Step 2 - Load Helpers in the Application's Controller
@@ -30,6 +25,5 @@ Add the line of code below to your _form.rb file. Change @example_object to the
30
25
 
31
26
  <%= render 'phcnotifi/validations', :object => @example_object %>
32
27
 
33
- #### Additional Information
34
-
35
- - [Critical Security Updates](https://github.com/PHCNetworks/phc-notifi/wiki/Critical-Security-Updates)
28
+ [![Gem Version](https://badge.fury.io/rb/phcnotifi.svg)](https://badge.fury.io/rb/phcnotifi)
29
+ [![License: MIT](https://img.shields.io/badge/License-MIT-blue.svg)](https://github.com/PHCNetworks/phc-notifi/blob/master/MIT-LICENSE)
@@ -21,7 +21,7 @@ module Phcnotifi
21
21
  routing_specs: false,
22
22
  controller_specs: true,
23
23
  request_specs: false
24
- g.fixture_replacement :factory_girl, dir: "spec/factories"
24
+ g.fixture_replacement :factory_bot_rails, dir: "spec/factories"
25
25
  end
26
26
 
27
27
  # Load Requried Helper Files
@@ -1,3 +1,3 @@
1
1
  module Phcnotifi
2
- VERSION = "13.0.0"
2
+ VERSION = "14.0.0"
3
3
  end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: phcnotifi
3
3
  version: !ruby/object:Gem::Version
4
- version: 13.0.0
4
+ version: 14.0.0
5
5
  platform: ruby
6
6
  authors:
7
7
  - BradPotts
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2017-12-02 00:00:00.000000000 Z
11
+ date: 2017-12-17 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: paper_trail
@@ -17,6 +17,9 @@ dependencies:
17
17
  - - "~>"
18
18
  - !ruby/object:Gem::Version
19
19
  version: '8.1'
20
+ - - ">="
21
+ - !ruby/object:Gem::Version
22
+ version: 8.1.1
20
23
  type: :runtime
21
24
  prerelease: false
22
25
  version_requirements: !ruby/object:Gem::Requirement
@@ -24,6 +27,9 @@ dependencies:
24
27
  - - "~>"
25
28
  - !ruby/object:Gem::Version
26
29
  version: '8.1'
30
+ - - ">="
31
+ - !ruby/object:Gem::Version
32
+ version: 8.1.1
27
33
  - !ruby/object:Gem::Dependency
28
34
  name: pg
29
35
  requirement: !ruby/object:Gem::Requirement
@@ -164,20 +170,14 @@ dependencies:
164
170
  requirements:
165
171
  - - "~>"
166
172
  - !ruby/object:Gem::Version
167
- version: '3.0'
168
- - - ">="
169
- - !ruby/object:Gem::Version
170
- version: 3.0.2
173
+ version: '3.2'
171
174
  type: :runtime
172
175
  prerelease: false
173
176
  version_requirements: !ruby/object:Gem::Requirement
174
177
  requirements:
175
178
  - - "~>"
176
179
  - !ruby/object:Gem::Version
177
- version: '3.0'
178
- - - ">="
179
- - !ruby/object:Gem::Version
180
- version: 3.0.2
180
+ version: '3.2'
181
181
  - !ruby/object:Gem::Dependency
182
182
  name: byebug
183
183
  requirement: !ruby/object:Gem::Requirement
@@ -261,7 +261,7 @@ dependencies:
261
261
  version: '1.8'
262
262
  - - ">="
263
263
  - !ruby/object:Gem::Version
264
- version: 1.8.4
264
+ version: 1.8.5
265
265
  type: :development
266
266
  prerelease: false
267
267
  version_requirements: !ruby/object:Gem::Requirement
@@ -271,7 +271,7 @@ dependencies:
271
271
  version: '1.8'
272
272
  - - ">="
273
273
  - !ruby/object:Gem::Version
274
- version: 1.8.4
274
+ version: 1.8.5
275
275
  - !ruby/object:Gem::Dependency
276
276
  name: launchy
277
277
  requirement: !ruby/object:Gem::Requirement