optionalargument 0.2.1 → 0.3

Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
- SHA1:
3
- metadata.gz: 08a8352bcc8449ab8122db99ccabe7f56ddd09eb
4
- data.tar.gz: 1115bcf75a331a3e1aad32b59456671a7528890b
2
+ SHA256:
3
+ metadata.gz: c81bbece17d9283e74017a1de8c36a21014bb3b92c7a3c507c39c67b7323a0dd
4
+ data.tar.gz: 70e6ad4b0100e9b562fd661a23a90c7068168c8c75e67e9df6766c4afbbe3a10
5
5
  SHA512:
6
- metadata.gz: 436ef9bf5917f45cee15a4559dac0d0e11d6f5e72a1d2cdf7f1ceb456a2c6d8275da0a8a0b86a5646ba572d68131f2ddd82fec6f346e1d0d6e2d74788a6fe88c
7
- data.tar.gz: 9d4d7545374194e3279dc991b9b6be080188aa241dbe4cc6e42b44c823cacf5a55bae203673c705f4f1f2bd069a1639b63cd9939763a3ae1eb9cd741115bf31e
6
+ metadata.gz: 5112ba43adb1f9357b27d374f95b47b89c1388fdd34fd7fd453e7f86a78c91dde27ef8528170bdd0b4e938dc2417e94e09fc76177ca3591b6f24e33ab70464df
7
+ data.tar.gz: '018943e8d8e79eaedb261df2573af36e96be2f9bf741673cffd08f521f3ea6d025201c5975667dfa5961a43b706a877e089887399150b7d95144b3b5f05dbbc5'
@@ -5,16 +5,16 @@ branches:
5
5
  - master
6
6
 
7
7
  rvm:
8
- - 2.2
9
- - 2.1
8
+ - 2.5
9
+ - 2.4
10
10
  - ruby-head
11
- - rbx-2.5.8
11
+ - rbx-3
12
12
  - jruby-head
13
13
 
14
14
  matrix:
15
15
  allow_failures:
16
16
  - rvm: ruby-head
17
- - rvm: rbx-2.5.8
17
+ - rvm: rbx-3
18
18
  - rvm: jruby-head
19
19
 
20
20
  before_install:
data/README.md CHANGED
@@ -133,12 +133,9 @@ gem install optionalargument
133
133
  Link
134
134
  ----
135
135
 
136
- * [Home](http://kachick.github.com/optionalargument/)
137
136
  * [code](https://github.com/kachick/optionalargument)
138
- * [API](http://kachick.github.com/optionalargument/yard/frames.html)
137
+ * [API](http://www.rubydoc.info/github/kachick/optionalargument)
139
138
  * [issues](https://github.com/kachick/optionalargument/issues)
140
- * [CI](http://travis-ci.org/#!/kachick/optionalargument)
141
- * [gem](https://rubygems.org/gems/optionalargument)
142
139
 
143
140
  License
144
141
  --------
@@ -2,6 +2,6 @@
2
2
 
3
3
  module OptionalArgument
4
4
 
5
- VERSION = '0.2.1'.freeze
5
+ VERSION = '0.3'.freeze
6
6
 
7
7
  end
@@ -16,8 +16,8 @@ Gem::Specification.new do |gem|
16
16
 
17
17
  gem.required_ruby_version = '>= 2.1'
18
18
 
19
- gem.add_runtime_dependency 'keyvalidatable', '~> 0.0.5'
20
- gem.add_runtime_dependency 'validation', '~> 0.0.7'
19
+ gem.add_runtime_dependency 'keyvalidatable'
20
+ gem.add_runtime_dependency 'validation', '~> 0.1'
21
21
 
22
22
  gem.add_development_dependency 'yard', '>= 0.8.7.6', '< 0.9'
23
23
  gem.add_development_dependency 'rake', '>= 10', '< 20'
@@ -11,7 +11,7 @@ class Test_OptionalArgument_BasicAPI < Test::Unit::TestCase
11
11
  }
12
12
 
13
13
  def test_version
14
- assert_match(/\A\d+\.\d+\.\d+(\.\d)?(\.[a-z])?\z/, OptionalArgument::VERSION)
14
+ assert_match(/\A\d+\.\d+/, OptionalArgument::VERSION)
15
15
  assert_equal true, OptionalArgument::VERSION.frozen?
16
16
  end
17
17
 
@@ -41,7 +41,7 @@ class Test_OptionalArgument_BasicAPI < Test::Unit::TestCase
41
41
  store = OptionalArgument.define {
42
42
  opt :foo
43
43
  }
44
- assert_raises RuntimeError do
44
+ assert_raises do
45
45
  store.__send__ :opt, :bar
46
46
  end
47
47
  end
metadata CHANGED
@@ -1,43 +1,43 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: optionalargument
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.2.1
4
+ version: '0.3'
5
5
  platform: ruby
6
6
  authors:
7
7
  - Kenichi Kamiya
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2015-10-20 00:00:00.000000000 Z
11
+ date: 2018-03-08 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: keyvalidatable
15
15
  requirement: !ruby/object:Gem::Requirement
16
16
  requirements:
17
- - - "~>"
17
+ - - ">="
18
18
  - !ruby/object:Gem::Version
19
- version: 0.0.5
19
+ version: '0'
20
20
  type: :runtime
21
21
  prerelease: false
22
22
  version_requirements: !ruby/object:Gem::Requirement
23
23
  requirements:
24
- - - "~>"
24
+ - - ">="
25
25
  - !ruby/object:Gem::Version
26
- version: 0.0.5
26
+ version: '0'
27
27
  - !ruby/object:Gem::Dependency
28
28
  name: validation
29
29
  requirement: !ruby/object:Gem::Requirement
30
30
  requirements:
31
31
  - - "~>"
32
32
  - !ruby/object:Gem::Version
33
- version: 0.0.7
33
+ version: '0.1'
34
34
  type: :runtime
35
35
  prerelease: false
36
36
  version_requirements: !ruby/object:Gem::Requirement
37
37
  requirements:
38
38
  - - "~>"
39
39
  - !ruby/object:Gem::Version
40
- version: 0.0.7
40
+ version: '0.1'
41
41
  - !ruby/object:Gem::Dependency
42
42
  name: yard
43
43
  requirement: !ruby/object:Gem::Requirement
@@ -170,7 +170,7 @@ required_rubygems_version: !ruby/object:Gem::Requirement
170
170
  version: '0'
171
171
  requirements: []
172
172
  rubyforge_project:
173
- rubygems_version: 2.4.5.1
173
+ rubygems_version: 2.7.3
174
174
  signing_key:
175
175
  specification_version: 4
176
176
  summary: Revenge of the Hash options
@@ -180,4 +180,3 @@ test_files:
180
180
  - test/test_oarg_readme.rb
181
181
  - test/test_oarg_reflection.rb
182
182
  - test/test_oarg_validate_value.rb
183
- has_rdoc: