keyvalidatable 0.2.0 → 0.2.1

Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: a819ae40e868ea5e3bbfe95d67a32bc1fb1c5c774c48bff656c641910fd40260
4
- data.tar.gz: 3ad5d3839812989e34ebf8065f46bbcbae2cf41271fadfea4187d9aa5d8f18e7
3
+ metadata.gz: c90a6caf9323b781de9332b14213b865eaad8708f3aeacd0d3253e09da7911c2
4
+ data.tar.gz: 87e651e62dcd85bd6fd480785116c13a1d0c90d3670322aed768f833da0cfe5d
5
5
  SHA512:
6
- metadata.gz: acf72f303667cb531bb26505e8199df01b870d5df26dfddbc2189821df30804c5e12b0a2263946d2b77651aacfa19bb6a54a582c2259cb158f29045b28e0188d
7
- data.tar.gz: 3158de1da752e047354e2942a1c9bcfb8c2f59f6ee44ebf7531ee50e6ec3c167d3f294dbd93f88ddfd10e87c089af114431f0ab3db54916f757c9b3468a2ff51
6
+ metadata.gz: e1fd8838ef04c25721d98f994d79ab89896fe6b6cdd7feea4ea861ce9786b86d34acc530fcabdb6664d4823f85cc7d64e1c3d482cfb9dffea953f156d82a2312
7
+ data.tar.gz: 483e73238ed36bb2f68b1c7395aa24faa2c1bcce8e5ae7db11659c27faef660a2b282afd905bdfe83d3d13b632bc6e7a6f12c964b2ac44fb6f00a83449936e59
data/README.md CHANGED
@@ -1,5 +1,9 @@
1
1
  # keyvalidatable
2
2
 
3
+ * ***This repository is archived***
4
+ * ***No longer maintained***
5
+ * ***If someone want to use this namespace to publish new awesome gem, please [contact me](https://github.com/kachick/times_kachick/discussions/new)!***
6
+
3
7
  ![Build Status](https://github.com/kachick/keyvalidatable/actions/workflows/test_behaviors.yml/badge.svg?branch=main)
4
8
  [![Gem Version](https://badge.fury.io/rb/keyvalidatable.png)](http://badge.fury.io/rb/keyvalidatable)
5
9
 
@@ -10,11 +14,12 @@ Validate shortage/excess keys in pairs.
10
14
  ### Install
11
15
 
12
16
  Require Ruby 2.5 or later
17
+ (Last tested rubies are 3.0.1 and 3.1.0dev)
13
18
 
14
- Add this line to your application/library's `Gemfile` is needed in basic use-case
19
+ Add this line to your`Gemfile`
15
20
 
16
21
  ```ruby
17
- gem 'keyvalidatable', '>= 0.2.0', '< 0.3.0'
22
+ gem 'keyvalidatable', '>= 0.2.1', '< 0.3.0'
18
23
  ```
19
24
 
20
25
  ### Overview
@@ -41,5 +46,5 @@ foo.func(a: 1, b: 2, c: 3, d: 4) #=> InvalidKeysError: Shortage: [] / Excess: [:
41
46
 
42
47
  ## Links
43
48
 
44
- - [Repository](https://github.com/kachick/keyvalidatable)
45
- - [API documents](https://kachick.github.io/keyvalidatable)
49
+ * [Repository](https://github.com/kachick/keyvalidatable)
50
+ * [API documents](https://kachick.github.io/keyvalidatable)
@@ -2,5 +2,5 @@
2
2
  # frozen_string_literal: true
3
3
 
4
4
  module KeyValidatable
5
- VERSION = '0.2.0'
5
+ VERSION = '0.2.1'
6
6
  end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: keyvalidatable
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.2.0
4
+ version: 0.2.1
5
5
  platform: ruby
6
6
  authors:
7
7
  - Kenichi Kamiya
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2021-05-30 00:00:00.000000000 Z
11
+ date: 2021-06-04 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: declare
@@ -133,7 +133,7 @@ dependencies:
133
133
  version: 1.15.0
134
134
  - - "<"
135
135
  - !ruby/object:Gem::Version
136
- version: 1.16.0
136
+ version: 1.17.0
137
137
  type: :development
138
138
  prerelease: false
139
139
  version_requirements: !ruby/object:Gem::Requirement
@@ -143,7 +143,7 @@ dependencies:
143
143
  version: 1.15.0
144
144
  - - "<"
145
145
  - !ruby/object:Gem::Version
146
- version: 1.16.0
146
+ version: 1.17.0
147
147
  - !ruby/object:Gem::Dependency
148
148
  name: rubocop-rake
149
149
  requirement: !ruby/object:Gem::Requirement
@@ -255,6 +255,9 @@ required_ruby_version: !ruby/object:Gem::Requirement
255
255
  - - ">="
256
256
  - !ruby/object:Gem::Version
257
257
  version: 2.5.0
258
+ - - "<"
259
+ - !ruby/object:Gem::Version
260
+ version: 3.1.0
258
261
  required_rubygems_version: !ruby/object:Gem::Requirement
259
262
  requirements:
260
263
  - - ">="