keyvalidatable 0.0.5.1 → 0.1.0

Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
- SHA1:
3
- metadata.gz: 3131af15f2918f7bae4e6c3bdeead792d54d8719
4
- data.tar.gz: 44f5abf0706495ed166696e71ef4117fbcf0fa1e
2
+ SHA256:
3
+ metadata.gz: c1533215222b427b2bd59e107dc6ae0db9f92cc384641663f3290ec91e381dbb
4
+ data.tar.gz: 181510cf3792e1b489a8197f552791691453f87f7285d0130a599a70d520841a
5
5
  SHA512:
6
- metadata.gz: 7b886c42f193fdd57b23c8a79226db993c868fa5914cb8b70c637649e6e5a87dd2778d45b76a92afa66d5804c1b8a35fdd23775047c4a160c6b0d60f7732e828
7
- data.tar.gz: 157d703ed3da1e9824133a46d2d65f3c71e14d994278c4042447214e94fd200a700265968c9c12263d59a8ea0e5d1786b859b1cde75311266531fcec3b7ccc60
6
+ metadata.gz: b5b552d7036a870c696c6d7dc756e3aab2b0509aac9b19552f4380a36291d002e8cf0460995681a59670591263c792c108f29cc8d1e015316a45d0c1d05d13e0
7
+ data.tar.gz: 901001a2d0d2b6248f2612098c3518fe3cada0a83de418a33e5677d30b22dd239fc23c22864d1ceb35d516e68bd05385fd7c9001dd255db6470902b86201d051
@@ -5,18 +5,16 @@ branches:
5
5
  - master
6
6
 
7
7
  rvm:
8
- - 2.2
9
- - 2.1
10
- - 2.0
11
- - 1.9.3
8
+ - 2.5
9
+ - 2.4
12
10
  - ruby-head
13
- - rbx-2
11
+ - rbx-3
14
12
  - jruby-head
15
13
 
16
14
  matrix:
17
15
  allow_failures:
18
16
  - rvm: ruby-head
19
- - rvm: rbx-2
17
+ - rvm: rbx-3
20
18
  - rvm: jruby-head
21
19
 
22
20
  before_install:
data/README.md CHANGED
@@ -40,7 +40,7 @@ foo.func(a: 1, b: 2, c: 3, d: 4) #=> InvalidKeysError: Shortage: [] / Excess: [:
40
40
  Requirements
41
41
  ------------
42
42
 
43
- * Ruby - [1.9.3 or later](http://travis-ci.org/#!/kachick/keyvalidatable)
43
+ * Ruby - [2.2 or later](http://travis-ci.org/#!/kachick/keyvalidatable)
44
44
 
45
45
  Install
46
46
  -------
data/Rakefile CHANGED
@@ -7,4 +7,5 @@ task default: [:test]
7
7
 
8
8
  Rake::TestTask.new do |tt|
9
9
  tt.verbose = true
10
+ tt.warning = true
10
11
  end
@@ -10,12 +10,12 @@ Gem::Specification.new do |gem|
10
10
  gem.homepage = "https://github.com/kachick/#{lib_name}"
11
11
  gem.license = 'MIT'
12
12
  gem.name = lib_name.dup
13
- gem.version = '0.0.5.1'
13
+ gem.version = '0.1.0'
14
14
 
15
- gem.required_ruby_version = '>= 1.9.3'
15
+ gem.required_ruby_version = '>= 2.2'
16
16
 
17
- gem.add_development_dependency 'yard', '>= 0.8.7.6', '< 0.9'
18
- gem.add_development_dependency 'rake', '~> 10'
17
+ gem.add_development_dependency 'yard', '>= 0.9.11', '< 2.0'
18
+ gem.add_development_dependency 'rake', '>= 10', '< 20'
19
19
  gem.add_development_dependency 'bundler', '>= 1.10', '< 2'
20
20
  gem.add_development_dependency 'declare', '~> 0.0.6'
21
21
 
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: keyvalidatable
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.0.5.1
4
+ version: 0.1.0
5
5
  platform: ruby
6
6
  authors:
7
7
  - Kenichi Kamiya
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2015-06-17 00:00:00.000000000 Z
11
+ date: 2018-03-08 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: yard
@@ -16,34 +16,40 @@ dependencies:
16
16
  requirements:
17
17
  - - ">="
18
18
  - !ruby/object:Gem::Version
19
- version: 0.8.7.6
19
+ version: 0.9.11
20
20
  - - "<"
21
21
  - !ruby/object:Gem::Version
22
- version: '0.9'
22
+ version: '2.0'
23
23
  type: :development
24
24
  prerelease: false
25
25
  version_requirements: !ruby/object:Gem::Requirement
26
26
  requirements:
27
27
  - - ">="
28
28
  - !ruby/object:Gem::Version
29
- version: 0.8.7.6
29
+ version: 0.9.11
30
30
  - - "<"
31
31
  - !ruby/object:Gem::Version
32
- version: '0.9'
32
+ version: '2.0'
33
33
  - !ruby/object:Gem::Dependency
34
34
  name: rake
35
35
  requirement: !ruby/object:Gem::Requirement
36
36
  requirements:
37
- - - "~>"
37
+ - - ">="
38
38
  - !ruby/object:Gem::Version
39
39
  version: '10'
40
+ - - "<"
41
+ - !ruby/object:Gem::Version
42
+ version: '20'
40
43
  type: :development
41
44
  prerelease: false
42
45
  version_requirements: !ruby/object:Gem::Requirement
43
46
  requirements:
44
- - - "~>"
47
+ - - ">="
45
48
  - !ruby/object:Gem::Version
46
49
  version: '10'
50
+ - - "<"
51
+ - !ruby/object:Gem::Version
52
+ version: '20'
47
53
  - !ruby/object:Gem::Dependency
48
54
  name: bundler
49
55
  requirement: !ruby/object:Gem::Requirement
@@ -116,7 +122,7 @@ required_ruby_version: !ruby/object:Gem::Requirement
116
122
  requirements:
117
123
  - - ">="
118
124
  - !ruby/object:Gem::Version
119
- version: 1.9.3
125
+ version: '2.2'
120
126
  required_rubygems_version: !ruby/object:Gem::Requirement
121
127
  requirements:
122
128
  - - ">="
@@ -124,7 +130,7 @@ required_rubygems_version: !ruby/object:Gem::Requirement
124
130
  version: '0'
125
131
  requirements: []
126
132
  rubyforge_project:
127
- rubygems_version: 2.4.5
133
+ rubygems_version: 2.7.3
128
134
  signing_key:
129
135
  specification_version: 4
130
136
  summary: Validate shortage/excess keys in pairs.
@@ -135,4 +141,3 @@ test_files:
135
141
  - test/test_basic_from_struct.rb
136
142
  - test/test_let_from_hash.rb
137
143
  - test/test_let_from_struct.rb
138
- has_rdoc: