io-nosey 0.1.2.2 → 0.1.3

Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
- SHA1:
3
- metadata.gz: ada2d8d3f5601c416ee45cfd991c1cb1fc8815d8
4
- data.tar.gz: c47c2a1d7ccee8e6ce73ddb8e2396937b3cb55be
2
+ SHA256:
3
+ metadata.gz: 45260ef527d3dfe8cbd40692e1029bc5e85bac448f3423ebb1831cbbb1815e86
4
+ data.tar.gz: 8e065bd7c191e2cc02c22c408d229f0a41d30d439c24fd75902f367d9ca9b27c
5
5
  SHA512:
6
- metadata.gz: f1859928b283c0ec4fcd14b9af911c282f790703eca60295bcfdf175696624339c0431b727a1013f43c9bd5d37e86fd513cfc19470c8c68adad91c37e5452e69
7
- data.tar.gz: 6acb170cb6a05b6fdcbe5705d40948b752340bd4e34f33918c4238a3acd956d705d874cd590addd66ca6df42bc3c4d123a6e6625a1888b52e1821a0ea54b11e8
6
+ metadata.gz: 227907484423350cfc724ba90505835bc7de7cffb79eeb3ba36d8a75cfd4eb4407839a8658f8c70a1e8a79b7d86fac264b9926c1d199b544d6de40afe0029285
7
+ data.tar.gz: 7432b23d6854cd6c831cbf0584e62f2d11bf8b1054d3a868388bdb9528ece324b8ef43801128a158dd90a9a28cca9d1414d8d0bc30690e0955d95e4d61f3be66
@@ -1,23 +1,17 @@
1
1
  language: ruby
2
2
 
3
- branches:
4
- only:
5
- - master
6
-
7
3
  rvm:
8
- - 2.2
9
- - 2.1
10
- - 2.0
11
- - 1.9.3
12
4
  - ruby-head
13
- - rbx-2
5
+ - 2.6
6
+ - 2.5
7
+ - rbx-3
14
8
  - jruby-head
15
9
 
16
10
  matrix:
17
11
  allow_failures:
18
12
  - rvm: ruby-head
19
- - rvm: rbx-2
13
+ - rvm: rbx-3
20
14
  - rvm: jruby-head
21
15
 
22
16
  before_install:
23
- - gem install bundler
17
+ - gem install bundler
data/README.md CHANGED
@@ -73,7 +73,7 @@ ask 'Write your poem and exit ctrl+d :) ', multi_line: true
73
73
  Requirements
74
74
  -------------
75
75
 
76
- * [Ruby 1.9.3 or later](http://travis-ci.org/#!/kachick/io-nosey)
76
+ * [Ruby 2.5 or later](http://travis-ci.org/#!/kachick/io-nosey)
77
77
 
78
78
  Install
79
79
  -------
@@ -13,13 +13,12 @@ Gem::Specification.new do |gem|
13
13
  gem.name = lib_name.dup
14
14
  gem.version = IO::Nosey::VERSION.dup
15
15
 
16
- gem.required_ruby_version = '>= 1.9.3'
17
16
  gem.add_dependency 'validation', '~> 0.0.7'
18
17
  gem.add_dependency 'optionalargument', '~> 0.1.0'
19
- gem.add_development_dependency 'rspec', '>= 3.3', '< 4'
20
- gem.add_development_dependency 'yard', '>= 0.8.7.6', '< 0.9'
18
+ gem.add_development_dependency 'rspec', '>= 3.8', '< 4'
19
+ gem.add_development_dependency 'yard', '>= 0.9.20', '< 2'
21
20
  gem.add_development_dependency 'rake', '>= 10', '< 20'
22
- gem.add_development_dependency 'bundler', '>= 1.10', '< 2'
21
+ gem.add_development_dependency 'bundler', '>= 2', '< 3'
23
22
 
24
23
  if RUBY_ENGINE == 'rbx'
25
24
  gem.add_dependency 'rubysl', '~> 2.1'
@@ -2,6 +2,6 @@
2
2
 
3
3
  class IO; module Nosey
4
4
 
5
- VERSION = '0.1.2.2'.freeze
5
+ VERSION = '0.1.3'.freeze
6
6
 
7
7
  end; end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: io-nosey
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.1.2.2
4
+ version: 0.1.3
5
5
  platform: ruby
6
6
  authors:
7
7
  - Kenichi Kamiya
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2015-06-17 00:00:00.000000000 Z
11
+ date: 2019-07-04 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: validation
@@ -44,7 +44,7 @@ dependencies:
44
44
  requirements:
45
45
  - - ">="
46
46
  - !ruby/object:Gem::Version
47
- version: '3.3'
47
+ version: '3.8'
48
48
  - - "<"
49
49
  - !ruby/object:Gem::Version
50
50
  version: '4'
@@ -54,7 +54,7 @@ dependencies:
54
54
  requirements:
55
55
  - - ">="
56
56
  - !ruby/object:Gem::Version
57
- version: '3.3'
57
+ version: '3.8'
58
58
  - - "<"
59
59
  - !ruby/object:Gem::Version
60
60
  version: '4'
@@ -64,20 +64,20 @@ dependencies:
64
64
  requirements:
65
65
  - - ">="
66
66
  - !ruby/object:Gem::Version
67
- version: 0.8.7.6
67
+ version: 0.9.20
68
68
  - - "<"
69
69
  - !ruby/object:Gem::Version
70
- version: '0.9'
70
+ version: '2'
71
71
  type: :development
72
72
  prerelease: false
73
73
  version_requirements: !ruby/object:Gem::Requirement
74
74
  requirements:
75
75
  - - ">="
76
76
  - !ruby/object:Gem::Version
77
- version: 0.8.7.6
77
+ version: 0.9.20
78
78
  - - "<"
79
79
  - !ruby/object:Gem::Version
80
- version: '0.9'
80
+ version: '2'
81
81
  - !ruby/object:Gem::Dependency
82
82
  name: rake
83
83
  requirement: !ruby/object:Gem::Requirement
@@ -104,20 +104,20 @@ dependencies:
104
104
  requirements:
105
105
  - - ">="
106
106
  - !ruby/object:Gem::Version
107
- version: '1.10'
107
+ version: '2'
108
108
  - - "<"
109
109
  - !ruby/object:Gem::Version
110
- version: '2'
110
+ version: '3'
111
111
  type: :development
112
112
  prerelease: false
113
113
  version_requirements: !ruby/object:Gem::Requirement
114
114
  requirements:
115
115
  - - ">="
116
116
  - !ruby/object:Gem::Version
117
- version: '1.10'
117
+ version: '2'
118
118
  - - "<"
119
119
  - !ruby/object:Gem::Version
120
- version: '2'
120
+ version: '3'
121
121
  description: A tiny assistant for CUI operations.
122
122
  email:
123
123
  - kachick1+ruby@gmail.com
@@ -160,7 +160,7 @@ required_ruby_version: !ruby/object:Gem::Requirement
160
160
  requirements:
161
161
  - - ">="
162
162
  - !ruby/object:Gem::Version
163
- version: 1.9.3
163
+ version: '0'
164
164
  required_rubygems_version: !ruby/object:Gem::Requirement
165
165
  requirements:
166
166
  - - ">="
@@ -168,7 +168,7 @@ required_rubygems_version: !ruby/object:Gem::Requirement
168
168
  version: '0'
169
169
  requirements: []
170
170
  rubyforge_project:
171
- rubygems_version: 2.4.8
171
+ rubygems_version: 2.7.6
172
172
  signing_key:
173
173
  specification_version: 4
174
174
  summary: A tiny assistant for CUI operations.
@@ -177,4 +177,3 @@ test_files:
177
177
  - spec/ask_spec.rb
178
178
  - spec/choose_spec.rb
179
179
  - spec/helper.rb
180
- has_rdoc: