declare 0.3.0 → 0.3.1

Sign up to get free protection for your applications and to get access to all the features.
Files changed (4) hide show
  1. checksums.yaml +4 -4
  2. data/README.md +2 -2
  3. data/lib/declare/version.rb +1 -1
  4. metadata +4 -218
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
2
  SHA256:
3
- metadata.gz: 9fc4f59e5807508444f5cc87c6d6e1bc711bbf1143367681b3445ab0849aa0b8
4
- data.tar.gz: d0db3947cce92b8c36149e7592a77b58d7c4f92f64fd5ee3c4962b323b47af85
3
+ metadata.gz: a0c42db547952e2ade03e37f69970296a7de5417d2c4b7bc647c1b8f700b55d7
4
+ data.tar.gz: f8e235aa5e626d306b4af901982e86fb76ddf7372b69ad002857dbe83d11729b
5
5
  SHA512:
6
- metadata.gz: e8cb85570fecabc508bc288cc50addc44323e037b14345ae7958ed655ca0581490f91d734477c8a4e2d11e0b68a6e1e95a407dd61a27bce23bd24a72fc12afe1
7
- data.tar.gz: 39748dd341c960b2a06eb6559fb024e0086d3d23048c48d2efbc5a95d6c13850b888af2447244dcd2278807f4f2216050c96b420b33ec401277af6cf99893c74
6
+ metadata.gz: 57c4fa65e058df1d96873d7cbec45073f692bd40090ed1638e07f5a8b144f93c386a08dd7d55e383c11d3bcf48d7e72045e85e5aac754f56e04d10898ebb8ec9
7
+ data.tar.gz: 703c62711ac434967257986c1ca1af407fc0eb961a576eff84a874c8d09e0697f918baf48a745d50356431f95af0b00a5d2453bf39682448a0189ca36f33bf0f
data/README.md CHANGED
@@ -7,13 +7,13 @@ A unit testing framework
7
7
 
8
8
  ## Usage
9
9
 
10
- Require Ruby 2.5 or later
10
+ Require Ruby 2.6 or later
11
11
 
12
12
  Add below code into your Gemfile`
13
13
 
14
14
  ```ruby
15
15
  group :test do
16
- gem 'declare', '>= 0.3.0', '< 0.4.0'
16
+ gem 'declare', '>= 0.3.1', '< 0.4.0'
17
17
  end
18
18
  ```
19
19
 
@@ -2,5 +2,5 @@
2
2
  # frozen_string_literal: true
3
3
 
4
4
  module Declare
5
- VERSION = '0.3.0'
5
+ VERSION = '0.3.1'
6
6
  end
metadata CHANGED
@@ -1,229 +1,15 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: declare
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.3.0
4
+ version: 0.3.1
5
5
  platform: ruby
6
6
  authors:
7
7
  - Kenichi Kamiya
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2021-05-30 00:00:00.000000000 Z
12
- dependencies:
13
- - !ruby/object:Gem::Dependency
14
- name: test-unit
15
- requirement: !ruby/object:Gem::Requirement
16
- requirements:
17
- - - ">="
18
- - !ruby/object:Gem::Version
19
- version: 3.4.1
20
- - - "<"
21
- - !ruby/object:Gem::Version
22
- version: '4.0'
23
- type: :development
24
- prerelease: false
25
- version_requirements: !ruby/object:Gem::Requirement
26
- requirements:
27
- - - ">="
28
- - !ruby/object:Gem::Version
29
- version: 3.4.1
30
- - - "<"
31
- - !ruby/object:Gem::Version
32
- version: '4.0'
33
- - !ruby/object:Gem::Dependency
34
- name: irb
35
- requirement: !ruby/object:Gem::Requirement
36
- requirements:
37
- - - ">="
38
- - !ruby/object:Gem::Version
39
- version: 1.3.5
40
- - - "<"
41
- - !ruby/object:Gem::Version
42
- version: '2.0'
43
- type: :development
44
- prerelease: false
45
- version_requirements: !ruby/object:Gem::Requirement
46
- requirements:
47
- - - ">="
48
- - !ruby/object:Gem::Version
49
- version: 1.3.5
50
- - - "<"
51
- - !ruby/object:Gem::Version
52
- version: '2.0'
53
- - !ruby/object:Gem::Dependency
54
- name: irb-power_assert
55
- requirement: !ruby/object:Gem::Requirement
56
- requirements:
57
- - - '='
58
- - !ruby/object:Gem::Version
59
- version: 0.0.2
60
- type: :development
61
- prerelease: false
62
- version_requirements: !ruby/object:Gem::Requirement
63
- requirements:
64
- - - '='
65
- - !ruby/object:Gem::Version
66
- version: 0.0.2
67
- - !ruby/object:Gem::Dependency
68
- name: warning
69
- requirement: !ruby/object:Gem::Requirement
70
- requirements:
71
- - - ">="
72
- - !ruby/object:Gem::Version
73
- version: 1.2.0
74
- - - "<"
75
- - !ruby/object:Gem::Version
76
- version: '2.0'
77
- type: :development
78
- prerelease: false
79
- version_requirements: !ruby/object:Gem::Requirement
80
- requirements:
81
- - - ">="
82
- - !ruby/object:Gem::Version
83
- version: 1.2.0
84
- - - "<"
85
- - !ruby/object:Gem::Version
86
- version: '2.0'
87
- - !ruby/object:Gem::Dependency
88
- name: rake
89
- requirement: !ruby/object:Gem::Requirement
90
- requirements:
91
- - - ">="
92
- - !ruby/object:Gem::Version
93
- version: 13.0.3
94
- - - "<"
95
- - !ruby/object:Gem::Version
96
- version: '20.0'
97
- type: :development
98
- prerelease: false
99
- version_requirements: !ruby/object:Gem::Requirement
100
- requirements:
101
- - - ">="
102
- - !ruby/object:Gem::Version
103
- version: 13.0.3
104
- - - "<"
105
- - !ruby/object:Gem::Version
106
- version: '20.0'
107
- - !ruby/object:Gem::Dependency
108
- name: yard
109
- requirement: !ruby/object:Gem::Requirement
110
- requirements:
111
- - - ">="
112
- - !ruby/object:Gem::Version
113
- version: 0.9.26
114
- - - "<"
115
- - !ruby/object:Gem::Version
116
- version: '2'
117
- type: :development
118
- prerelease: false
119
- version_requirements: !ruby/object:Gem::Requirement
120
- requirements:
121
- - - ">="
122
- - !ruby/object:Gem::Version
123
- version: 0.9.26
124
- - - "<"
125
- - !ruby/object:Gem::Version
126
- version: '2'
127
- - !ruby/object:Gem::Dependency
128
- name: rubocop
129
- requirement: !ruby/object:Gem::Requirement
130
- requirements:
131
- - - ">="
132
- - !ruby/object:Gem::Version
133
- version: 1.15.0
134
- - - "<"
135
- - !ruby/object:Gem::Version
136
- version: 1.16.0
137
- type: :development
138
- prerelease: false
139
- version_requirements: !ruby/object:Gem::Requirement
140
- requirements:
141
- - - ">="
142
- - !ruby/object:Gem::Version
143
- version: 1.15.0
144
- - - "<"
145
- - !ruby/object:Gem::Version
146
- version: 1.16.0
147
- - !ruby/object:Gem::Dependency
148
- name: rubocop-rake
149
- requirement: !ruby/object:Gem::Requirement
150
- requirements:
151
- - - ">="
152
- - !ruby/object:Gem::Version
153
- version: 0.5.1
154
- - - "<"
155
- - !ruby/object:Gem::Version
156
- version: 0.6.0
157
- type: :development
158
- prerelease: false
159
- version_requirements: !ruby/object:Gem::Requirement
160
- requirements:
161
- - - ">="
162
- - !ruby/object:Gem::Version
163
- version: 0.5.1
164
- - - "<"
165
- - !ruby/object:Gem::Version
166
- version: 0.6.0
167
- - !ruby/object:Gem::Dependency
168
- name: rubocop-performance
169
- requirement: !ruby/object:Gem::Requirement
170
- requirements:
171
- - - ">="
172
- - !ruby/object:Gem::Version
173
- version: 1.11.3
174
- - - "<"
175
- - !ruby/object:Gem::Version
176
- version: 1.12.0
177
- type: :development
178
- prerelease: false
179
- version_requirements: !ruby/object:Gem::Requirement
180
- requirements:
181
- - - ">="
182
- - !ruby/object:Gem::Version
183
- version: 1.11.3
184
- - - "<"
185
- - !ruby/object:Gem::Version
186
- version: 1.12.0
187
- - !ruby/object:Gem::Dependency
188
- name: rubocop-rubycw
189
- requirement: !ruby/object:Gem::Requirement
190
- requirements:
191
- - - ">="
192
- - !ruby/object:Gem::Version
193
- version: 0.1.6
194
- - - "<"
195
- - !ruby/object:Gem::Version
196
- version: 0.2.0
197
- type: :development
198
- prerelease: false
199
- version_requirements: !ruby/object:Gem::Requirement
200
- requirements:
201
- - - ">="
202
- - !ruby/object:Gem::Version
203
- version: 0.1.6
204
- - - "<"
205
- - !ruby/object:Gem::Version
206
- version: 0.2.0
207
- - !ruby/object:Gem::Dependency
208
- name: rubocop-md
209
- requirement: !ruby/object:Gem::Requirement
210
- requirements:
211
- - - ">="
212
- - !ruby/object:Gem::Version
213
- version: 1.0.1
214
- - - "<"
215
- - !ruby/object:Gem::Version
216
- version: 2.0.0
217
- type: :development
218
- prerelease: false
219
- version_requirements: !ruby/object:Gem::Requirement
220
- requirements:
221
- - - ">="
222
- - !ruby/object:Gem::Version
223
- version: 1.0.1
224
- - - "<"
225
- - !ruby/object:Gem::Version
226
- version: 2.0.0
11
+ date: 2021-06-02 00:00:00.000000000 Z
12
+ dependencies: []
227
13
  description: " A unit testing framework\n"
228
14
  email:
229
15
  - kachick1+ruby@gmail.com
@@ -256,7 +42,7 @@ required_ruby_version: !ruby/object:Gem::Requirement
256
42
  requirements:
257
43
  - - ">="
258
44
  - !ruby/object:Gem::Version
259
- version: 2.5.0
45
+ version: 2.6.0
260
46
  required_rubygems_version: !ruby/object:Gem::Requirement
261
47
  requirements:
262
48
  - - ">="