adjustn 0.0.3 → 0.1.0

Sign up to get free protection for your applications and to get access to all the features.
checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
  ---
2
- SHA1:
3
- metadata.gz: 2f7ac87d0d86eb25793e203392bc3b78577ac824
4
- data.tar.gz: 11940464cc98ad142886e271e720359e23d8e152
2
+ SHA256:
3
+ metadata.gz: 507c06ba52c377d7897ed740dc1d92733a9a5516228ba34fd087f1f13540e13b
4
+ data.tar.gz: b82ed949bf2af07ad8719fdd11be0ac64921147304f139a0ffc25ac62ff4eeb4
5
5
  SHA512:
6
- metadata.gz: 1331885cc1c8d3ac05803301abc1c4981fbe945a0355298d6a3a16293fca2de9a48d065ac226196a583f7434aeb2612147893788286484fd8b0a42e796791e05
7
- data.tar.gz: 216c660c4fe055008592020d923cb2de89c04bae95e7465f38d5b19abc24b9f38d9ab47a0d344ddc277e8a93ddb4a7cddf3b50846c5b65ad584341f9cc7aa2b6
6
+ metadata.gz: 532c9faa753a17ca9a703568af916abeef24c9b1bef8acccc80a6d79c0ab43900d888e18d0fe1956ac31ead2600ecc1612b759d22837262066d564ccc6a42706
7
+ data.tar.gz: 92101b2bbb87905e3d64f35d5b57469fd99e3f231086afbc9ca20e6dfdda8462da8ffeda42a3e92fb78244cfc946ba6d4b6ecdcf212f0b0f767402b9191038c0
@@ -2,18 +2,16 @@ language: ruby
2
2
 
3
3
  rvm:
4
4
  - ruby-head
5
- - 2.0.0
6
- - 1.9.3
7
- - rbx
5
+ - 2.6
6
+ - 2.5
7
+ - rbx-3
8
8
  - jruby-head
9
- - jruby-19mode
10
9
 
11
10
  matrix:
12
11
  allow_failures:
13
12
  - rvm: ruby-head
14
- - rvm: rbx
13
+ - rvm: rbx-3
15
14
  - rvm: jruby-head
16
- - rvm: jruby-19mode
17
15
 
18
16
  before_install:
19
17
  - gem install bundler
data/README.md CHANGED
@@ -27,7 +27,7 @@ $ adjustn LF path [*path]
27
27
  Requirements
28
28
  ------------
29
29
 
30
- * [Ruby 1.9.3 or later](http://travis-ci.org/#!/kachick/adjustn)
30
+ * [Ruby 2.5 or later](http://travis-ci.org/#!/kachick/adjustn)
31
31
 
32
32
  Install
33
33
  -------
@@ -41,7 +41,7 @@ Link
41
41
 
42
42
  * [code](https://github.com/kachick/adjustn)
43
43
  * [issues](https://github.com/kachick/adjustn/issues)
44
- * [CI](http://travis-ci.org/#!/kachick/adjustn
44
+ * [CI](http://travis-ci.org/#!/kachick/adjustn)
45
45
  * [gem](https://rubygems.org/gems/adjustn)
46
46
 
47
47
  License
@@ -11,12 +11,10 @@ Gem::Specification.new do |gem|
11
11
  gem.license = 'MIT'
12
12
  gem.version = AdjustN::VERSION.dup
13
13
 
14
- gem.required_ruby_version = '>= 1.9.3'
15
14
  gem.add_development_dependency 'test-declare', '~> 0.0.3'
16
- gem.add_development_dependency 'rspec', '>= 2.14.1', '< 3'
17
- gem.add_development_dependency 'yard', '>= 0.8.7.3', '< 0.9'
15
+ gem.add_development_dependency 'yard', '>= 0.9.20', '< 2'
18
16
  gem.add_development_dependency 'rake', '>= 10', '< 20'
19
- gem.add_development_dependency 'bundler', '>= 1.3.5', '< 2'
17
+ gem.add_development_dependency 'bundler', '>= 2', '< 3'
20
18
 
21
19
  if RUBY_ENGINE == 'rbx'
22
20
  gem.add_dependency 'rubysl', '~> 2.0'
@@ -2,6 +2,6 @@
2
2
 
3
3
  module AdjustN
4
4
 
5
- VERSION = '0.0.3'.freeze
5
+ VERSION = '0.1.0'.freeze
6
6
 
7
7
  end
metadata CHANGED
@@ -1,109 +1,89 @@
1
1
  --- !ruby/object:Gem::Specification
2
2
  name: adjustn
3
3
  version: !ruby/object:Gem::Version
4
- version: 0.0.3
4
+ version: 0.1.0
5
5
  platform: ruby
6
6
  authors:
7
7
  - Kenichi Kamiya
8
8
  autorequire:
9
9
  bindir: bin
10
10
  cert_chain: []
11
- date: 2013-12-15 00:00:00.000000000 Z
11
+ date: 2019-07-04 00:00:00.000000000 Z
12
12
  dependencies:
13
13
  - !ruby/object:Gem::Dependency
14
14
  name: test-declare
15
15
  requirement: !ruby/object:Gem::Requirement
16
16
  requirements:
17
- - - ~>
17
+ - - "~>"
18
18
  - !ruby/object:Gem::Version
19
19
  version: 0.0.3
20
20
  type: :development
21
21
  prerelease: false
22
22
  version_requirements: !ruby/object:Gem::Requirement
23
23
  requirements:
24
- - - ~>
24
+ - - "~>"
25
25
  - !ruby/object:Gem::Version
26
26
  version: 0.0.3
27
- - !ruby/object:Gem::Dependency
28
- name: rspec
29
- requirement: !ruby/object:Gem::Requirement
30
- requirements:
31
- - - '>='
32
- - !ruby/object:Gem::Version
33
- version: 2.14.1
34
- - - <
35
- - !ruby/object:Gem::Version
36
- version: '3'
37
- type: :development
38
- prerelease: false
39
- version_requirements: !ruby/object:Gem::Requirement
40
- requirements:
41
- - - '>='
42
- - !ruby/object:Gem::Version
43
- version: 2.14.1
44
- - - <
45
- - !ruby/object:Gem::Version
46
- version: '3'
47
27
  - !ruby/object:Gem::Dependency
48
28
  name: yard
49
29
  requirement: !ruby/object:Gem::Requirement
50
30
  requirements:
51
- - - '>='
31
+ - - ">="
52
32
  - !ruby/object:Gem::Version
53
- version: 0.8.7.3
54
- - - <
33
+ version: 0.9.20
34
+ - - "<"
55
35
  - !ruby/object:Gem::Version
56
- version: '0.9'
36
+ version: '2'
57
37
  type: :development
58
38
  prerelease: false
59
39
  version_requirements: !ruby/object:Gem::Requirement
60
40
  requirements:
61
- - - '>='
41
+ - - ">="
62
42
  - !ruby/object:Gem::Version
63
- version: 0.8.7.3
64
- - - <
43
+ version: 0.9.20
44
+ - - "<"
65
45
  - !ruby/object:Gem::Version
66
- version: '0.9'
46
+ version: '2'
67
47
  - !ruby/object:Gem::Dependency
68
48
  name: rake
69
49
  requirement: !ruby/object:Gem::Requirement
70
50
  requirements:
71
- - - '>='
51
+ - - ">="
72
52
  - !ruby/object:Gem::Version
73
53
  version: '10'
74
- - - <
54
+ - - "<"
75
55
  - !ruby/object:Gem::Version
76
56
  version: '20'
77
57
  type: :development
78
58
  prerelease: false
79
59
  version_requirements: !ruby/object:Gem::Requirement
80
60
  requirements:
81
- - - '>='
61
+ - - ">="
82
62
  - !ruby/object:Gem::Version
83
63
  version: '10'
84
- - - <
64
+ - - "<"
85
65
  - !ruby/object:Gem::Version
86
66
  version: '20'
87
67
  - !ruby/object:Gem::Dependency
88
68
  name: bundler
89
69
  requirement: !ruby/object:Gem::Requirement
90
70
  requirements:
91
- - - '>='
92
- - !ruby/object:Gem::Version
93
- version: 1.3.5
94
- - - <
71
+ - - ">="
95
72
  - !ruby/object:Gem::Version
96
73
  version: '2'
74
+ - - "<"
75
+ - !ruby/object:Gem::Version
76
+ version: '3'
97
77
  type: :development
98
78
  prerelease: false
99
79
  version_requirements: !ruby/object:Gem::Requirement
100
80
  requirements:
101
- - - '>='
102
- - !ruby/object:Gem::Version
103
- version: 1.3.5
104
- - - <
81
+ - - ">="
105
82
  - !ruby/object:Gem::Version
106
83
  version: '2'
84
+ - - "<"
85
+ - !ruby/object:Gem::Version
86
+ version: '3'
107
87
  description: A tiny text tool for adjusting new line characters
108
88
  email:
109
89
  - kachick1+ruby@gmail.com
@@ -112,8 +92,8 @@ executables:
112
92
  extensions: []
113
93
  extra_rdoc_files: []
114
94
  files:
115
- - .gitignore
116
- - .travis.yml
95
+ - ".gitignore"
96
+ - ".travis.yml"
117
97
  - Gemfile
118
98
  - MIT-LICENSE
119
99
  - README.md
@@ -135,20 +115,19 @@ require_paths:
135
115
  - lib
136
116
  required_ruby_version: !ruby/object:Gem::Requirement
137
117
  requirements:
138
- - - '>='
118
+ - - ">="
139
119
  - !ruby/object:Gem::Version
140
- version: 1.9.3
120
+ version: '0'
141
121
  required_rubygems_version: !ruby/object:Gem::Requirement
142
122
  requirements:
143
- - - '>='
123
+ - - ">="
144
124
  - !ruby/object:Gem::Version
145
125
  version: '0'
146
126
  requirements: []
147
127
  rubyforge_project:
148
- rubygems_version: 2.0.14
128
+ rubygems_version: 2.7.6
149
129
  signing_key:
150
130
  specification_version: 4
151
131
  summary: A tiny text tool for adjusting new line characters
152
132
  test_files:
153
133
  - test/test_lib.rb
154
- has_rdoc: