cannot be newer than the current version